Qué es Lumina y cómo instalarlo en Ubuntu

LuminaNo es la primera vez que lo comentamos, pero si hay algo en lo que los sistemas operativos basados en Linux son superiores a todos los demás es en su capacidad de personalización. Cambiar toda la imagen de un sistema operativo basado en Linux puede estar a tan sólo un comando de distancia y hoy os hablamos de Lumina, un entorno gráfico ligero diseñado para su uso en cualquier sistema operativo tipo Unix que se basa en el uso de plugins y que permite opciones como que cada usuario use su propia interfaz personalizada.

Tal y como leemos en su web oficial, “Lumina fue diseñado para requerir el menor número de dependencias del sistema y requisitos como sea posible“, lo que siempre viene bien cuando usamos un equipo con recursos limitados. Los desarrolladores de Lumina dicen que la mejor forma de probarlo es instalando el sistema operativo TrueOS, pero que también se puede instalar en Ubuntu y cualquier otro sistema operativo basado en Unix. En este artículo os enseñaremos cómo instalarlo en las distribuciones basadas en Debian.

Cómo instalar Lumina en Ubuntu

Aunque no puedo decir que la instalación de este entorno gráfico en Ubuntu sea un proceso complicado, sí que puedo decir que me gustaría más que se pudiera instalar como otros entornos gráficos como MATE que se pueden instalar con un comando corto o seleccionando un paquete del gestor de paquetes Synaptic. Los pasos a seguir para instalarlo son los siguientes:

  1. Para instalar Lumina en Ubuntu 14.04 o posterior o Debian 8 o posterior, abriremos un terminal y escribiremos el siguiente (largo) comando:
sudo apt-get update
sudo apt-get install build-essential git qt5-default libqt5gui5 qttools5-dev-tools qtmultimedia5-dev libqt5multimediawidgets5 libqt5network5 libqt5svg5-dev libqt5x11extras5-dev libxcb-icccm4-dev libxcb-ewmh dev libxcb-composite0-dev libxcb-damage0-dev libxcb-util0-dev libphonon-dev libxcomposite-dev libxdamage-dev dev libxrender libxcb-image0-dev libxcb-screensaver0-dev qtdeclarative5-dev fluxbox xscreensaver kde-estilo-oxígeno xbacklight alsa-utils acpi numlockx pavucontrol xterm sysstat
  1. A continuación, clonamos el código fuente de Lumina escribiendo lo siguiente en el terminal:
git clone https://github.com/trueos/lumina.git
  1. El siguiente paso es configurar y compilar el código escribiendo lo siguiente:
CD lumina
qmake
  1. Por último, escribimos lo siguiente en el terminal:
make
sudo make install

Para elegir Lumina como entorno gráfico, tendremos que cerrar sesión y volver a iniciarla seleccionando el nuevo entorno. Personalmente, no soy partidario de instalar entornos gráficos que puedan añadir paquetes innecesarios a un sistema operativo, por lo que yo también recomendaría usar TrueOS para probar esta interfaz de usuario. En cualquier caso y como siempre decimos, si lo instaláis en Ubuntu no dudéis en dejar vuestras experiencias en los comentarios.

 


Categorías

Ubuntu

Pablo Aparicio

Apasionado por todo tipo de tecnología, tanto del hardware como del software. Adicto a escuchar toda clase de música y a tocar (guitarra y bajo) la que mis límites me permiten. MTB es otro de mis hobbies: camino que veo, camino que cojo.

Un comentario

  1.   acevalgar dijo

    ¿Habrá otra forma de instalarlo?

    Ejecuté sudo apt-get update

    Luego

    sudo apt-get install build-essential git qt5-default libqt5gui5 qttools5-dev-tools qtmultimedia5-dev libqt5multimediawidgets5 libqt5network5 libqt5svg5-dev libqt5x11extras5-dev libxcb-icccm4-dev libxcb-ewmh dev libxcb-composite0-dev libxcb-damage0-dev libxcb-util0-dev libphonon-dev libxcomposite-dev libxdamage-dev dev libxrender libxcb-image0-dev libxcb-screensaver0-dev qtdeclarative5-dev fluxbox xscreensaver kde-estilo-oxígeno xbacklight alsa-utils acpi numlockx pavucontrol xterm sysstat
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se ha podido localizar el paquete libxcb-ewmh
    E: No se ha podido localizar el paquete dev
    E: No se ha podido localizar el paquete dev
    E: No se ha podido localizar el paquete libxrender
    E: No se ha podido localizar el paquete kde-estilo-oxígeno

    Y ahí quedó

    Por favor.

    Gracias

Escribe un comentario