Mozilla apuesta fuerte por Shumway en Firefox

Firefox y Shumway

La gente de Mozilla ha incluido Shumway en el código base de Firefox. Shumway representa «una manera de soportar la reproducción de [archivos] Flash sin Adobe Flash Player».

En Mozilla están convencidos de que esto permitirá reproducir archivos Flash (SWF) de una manera mucho más segura que utilizando el reproductor de Adobe. «Adobe Flash Player ha estado plagado de fallos, así que comenzar a reproducir Flash sin el reproductor normal es un gran paso adelante para la seguridad», escribió en su blog Henrik Gemal, contribuidor de Mozilla.

¿Y qué es Shumway?

De acuerdo al propio Gemal, se trata de una tecnología HTML5 experimental que busca crear un motor de renderizado fiel y eficiente para archivos en formato SWF. Shumway es dirigido por la comunidad y cuenta con el soporte y respaldo de Mozilla.

Aunque por ahora se trata de un experimento, si el comportamiento con Firefox demuestra ser correcto en un futuro podría ser incluido y activado por defecto en todas las instalaciones del navegador del panda rojo. De momento Shumway se puede probar en . Los chicos de Phoronix aseguran que Shumway puede con la mayoría de los archivos Flash que pululan por la red, aunque aún cojea en el área de aplicaciones comerciales.

Más información – Firefox implementará activación por sitio en los plug-ins
Fuente – Anuncio oficial, Phoronix


2 comentarios

  1.   Dseusyte dijo

    En la versión actual estable de Firefox para Linux, 30.0, Shumway no viene incluído, tampoco Flash. A priori no es gran problema pues al menos las grandes plataformas de vídeo como YouTube, Vimeo y Dailymotion ofrecen sus vídeos en HTML5, como debería hacer ya “todo el mundo”. Sin embargo, otras webs como Tu.tv, RTVE.es A la Carta, AtresPlayer y EiTB Televisión a la carta todavía siguen con Flash. Y ni instalando Shumway se pueden ver sus vídeos (parece que Shumway todavía no funciona bien -por algo no vendrá incluído en Firefox de serie-).

    Yo tengo intención de ponerme en contacto con RTVE, etc. para que ofrezcan sus vídeos también en HTML5 cuanto antes, recordándoles que hay leyes de interoperabilidad, que HTML5 es tecnología moderna a la vez que estándar, y que Flash es obsoleto, con fallos de seguridad, no estando presente en iOS ni en Android y habiéndose abandonado su actualización en Linux.

    Con suerte más gente toca la puerta de RTVE y demás y pronto conseguimos que se actualicen y ofrezcan sus vídeos a todos. ¿Te animas a escribirles, difundir el problema en tu blog, etc.?

    Gracias

    1.    Bultakoseg dijo

      Conviene aclarar algo sobre el asunto que se trata aquí:

      He estado mirando dentro de ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ y, tras descargar varios ficheros comprimidos con distintas versiones para Linux (desde las más antiguas pasando a las más recientes) y descomprimirlos, he visto que en ninguna de ellas viene (venía) el fichero libflashplayer.so (plugin de Adobe Flash). El enlace apunta a los repositorios oficiales de Mozilla, comunidad responsable de Firefox.

      Sin embargo, algunas distros de GNU/Linux que traían o traen de serie Firefox como su navegador web sí que lo traen de fábrica con el plugin de Flash (suelo usar el navegador que viene de serie, no lo suelo cambiar, aunque prefiero Firefox -por suerte las distros que uso suelen llevarlo de serie-; por tanto no sé decir si, caso de que FX no venga de serie, si al instalarlo desde los repositorios viene o no con Flash por defecto). Linux Mint traía de serie FX con Flash y lo sigue haciendo. Ubuntu no lo hacía por temas legales ( aunque luego se podía añadir fácilmente desde otros repositorios que Ubuntu mismo o su empresa responsable Canonical ofrecía; o desde la web de Adobe: http://get.adobe.com/es/flashplayer/ ). Supongo que el asunto seguirá igual en Ubuntu, que hace tiempo que no uso, pues a veces uso Lubuntu y en la versión con soporte de larga duración actual viene con FX de serie pero sin Flash (Lubuntu es derivado oficial de Ubuntu; mientras que Linux Mint, aunque se basa en Ubuntu -salvo LMDE, que se basa en Debian, base de Ubuntu y otros-, no está bajo el paraguas de Canonical sino el de otra comunidad). Puppy Linux Slacko 5.7 viene con Firefox de serie pero sin Flash. Otras versiones de Puppy que probé y recuerdo ahora venían con otro navegador web por defecto.

Escribe un comentario