Ya se pueden instalar paquetes .deb de terceros con GNOME Software de Ubuntu 16.04

GNOME Software

En lo que no parece ser una decisión acertada para todos los usuarios, Canonical decidió eliminar el (lento) Centro de Software de Ubuntu para dar paso a GNOME Software como gestor de paquetes por defecto de Ubuntu 16.04 LTS (Xenial Xerus). Posteriormente, Canonical le cambió el nombre a Ubuntu Software para facilitar las cosas a los nuevos usuarios. El problema es que había un fallo que impedía que se pudieran instalar paquetes .deb de terceros desde GNOME Software (o Ubuntu Software).

Una versión LTS como Ubuntu 16.04 no tendría que llegar con este tipo de problemas por dos razones: porque Ubuntu es uno de los sistemas operatigos GNU/Linux más usados del mundo y porque es una versión Long Term Support que es más importante que las versiones que se lanzan cada seis meses. El problema es que lo primero que hacen muchos usuarios nada más instalar un sistema es buscar los paquetes .deb de las aplicaciones que más usaban e instalarlas, algo que no podían hacer en Ubuntu 16.04 por el error mencionado.

Llega un parche para GNOME Software que corrige el problema

En estas dos semanas de vida que tiene Ubuntu 16.04 LTS, si se quería instalar un paquete .deb de terceros se podía instalar desde la terminal (con el comando sudo dpkg -i nombredelpaquete.deb) o usando otro tipo de gestores de paquetes, como el Gdebi que viene instalado en Ubuntu MATE (y razón por la que yo no había experimentado este problema).

Hay que reconocer que sorprende que Canonical haya lanzado una nueva versión LTS de Ubuntu con un fallo como este y que le haya costado una semana corregir el problema. Pero lo bueno es que la espera se ha terminado y la nueva versión ya está en los repositorios oficiales de Ubuntu. Para instalarla basta con que se ejecute la aplicación “Actualización de software” o se abra una terminal y se use el comando sudo apt update (sí, se puede sin “-get”).

¿Ha estado sufriendo el problema de GNOME Software que impedía instalar paquetes .deb de terceros?


Categorías

Ubuntu

Pablo Aparicio

Apasionado por todo tipo de tecnología, tanto del hardware como del software. Adicto a escuchar toda clase de música y a tocar (guitarra y bajo) la que mis límites me permiten. MTB es otro de mis hobbies: camino que veo, camino que cojo.

11 comentarios

  1.   Pepet Caneló dijo

    No sabía que esta bug furea oficial, en su momento me hizo perder la cabeza y es lo que me ha decantó a usar kubuntu en la versión 16.04.

  2.   David Villegas dijo

    Yo volví a la versión 14.04 ya que no podía resistir esa fallo que aun usando sudo dpkg -i algunos paquetes no los podía instalar, ahora que se que ya arreglaron el error, se pueden ir a la Chingada los de Ubuntu, me instalaré el 16.04 cuando salga la 16.04.1

  3.   Javier dijo

    Además al nuevo software center le faltan muchos paquetes, que aún estando en los repositorios no aparecen.

    1.    leillo1975 dijo

      Muy cierto, quizás eso es lo que más me molesta, ya que los paquetes de terceros es más raro instalarlos

    2.    Miguel Ángel Santamaría Rogado dijo

      ¿No hay ninguna opción para mostrar todos los paquetes? Al estilo de “Ver elementos técnicos” del antiguo Centro de Software.

      Saludos.

  4.   Martín dijo

    De terror Ubuntu 16.04 LTS, fallo tras fallo me corrió y me devolví a Ubuntu 14.04.3 porque la 14.04.4 también tiene problemas con algunas librerías que en la .3 no se presentan.

    Y como escribe un comentarista de éste hilo… a lavarse las patas los de Canónical con la 16.04, esperaré a la .1 y veré que tal….

  5.   marcus dijo

    DE TERROR!! Cada version nueva que sacan es peor que la anterior ¿que les pasa a los de canonical? no solo que no mejoran ,sino que empeoran………..el “bug” gravisimo de no poder instalar paquetes de terceros cuando es lo que hacemos todos hace que instales y desisntales mas rapido para poner alguna version anterior que soporte tus aplicaciones voy a renegar un poco mas con esta 16.04 y despues ,si no puedo solucionar los problemas que me afectan migrare lamentablemente a otra distribucion que siga siendo seria………

  6.   marcus dijo

    De nuevo….
    Lamento informarles que la “correccion del bug” aqui anunciada no funciona en ninguna de las 6(seis) maquinas en la que la he probado……..

  7.   marcus dijo

    sudo apt-get install software center
    …y despues instalan todas las aplicaciones desde el viejo centro de software,
    tambien funciona instalando el lubuntu software center
    el instalador del lubuntu esta en el nuevo instalacdor de software

  8.   Ruymán dijo

    Confirmado que FALLA como escopeta de feria. Sigue sin poder instalarse por defecto los paquetes de terceros.

    Estoy sobreviviendo con dpkg -i, a duras penas.

  9.   Ariel Gimenez dijo

    Encontre la solución provisoria,instalen el ubuntu software center desde ese gestor y luego lo instalan con el viejo centro de software de ubuntu,creo que tambien se puede hacer con el centro de software de lubuntu.yo estoy instalando los drivers intel siguiendo este tutorial.
    https://allanbogh.com/2016/01/05/ubuntu-16-04-installing-the-intel-graphics-drivers-using-the-intel-graphics-installer-for-linux/

Escribe un comentario