كيف تعرف إصدار Ubuntu الذي نستخدمه

أوبونتوأحد الأسئلة التي يطرحها المبتدئ دائمًا هو ما هو الإصدار الذي يجب أن أقوم بتثبيته أو استخدامه لجهاز الكمبيوتر الخاص بي؟ o كيف أعرف إصدار Ubuntu الذي أملكه؟ سؤالان مهمان للمبتدئين ولكنهما بالنسبة للخبير لديهما حل سهل لأن نفس المحطة ، من خلال أوامر معينة ، يمكنك إبلاغنا بهذه المعلومات.

ما هو الإصدار الذي يجب أن أقوم بتثبيته على جهاز الكمبيوتر الخاص بي؟

للإجابة على هذا السؤال يجب أن نعرف ما نوع الأجهزة التي يمتلكها جهاز الكمبيوتر الخاص بنا، على وجه التحديد ما هو المعالج الذي لديك. إذا كان لدينا جهاز كمبيوتر عمره بضع سنوات ، بنواة واحدة أو ذاكرة منخفضة، علينا التثبيت نظام التشغيل Ubuntu 32 بت، الإصدار الذي سيتم الإشارة إليه دائمًا باللقب i386 ، 32 بت أو ببساطة x86.

على العكس من ذلك ، إذا كان لدينا جهاز كمبيوتر بمعالج حالي ، به عدة أنوية أو ببساطة يحتوي على أكثر من 2 جيجا بايت من ذاكرة الوصول العشوائي، إذن سيكون إصدار Ubuntu الذي سيتعين علينا استخدامه أو تثبيته إصدار 64 بت أو الملقب أيضًا باسم x86_64 أو AMD64. هذا الإصدار هو الإصدار القياسي حاليًا حيث تدعم أحدث أجهزة الكمبيوتر هذا الإصدار.

ما هو إصدار Ubuntu الذي قمت بتثبيته على جهاز الكمبيوتر الخاص بي؟

لكن في بعض الأحيان يحدث أننا نشتري الكمبيوتر مع تضمين Ubuntu ولا نعرف ما هو الإصدار الذي قمنا بتثبيته ، لمعرفة ذلك علينا فقط فتح Terminal والكتابة:

lsb_release -a

مع هذا لن نعرف فقط إصدار Ubuntu ولكن أيضًا اسم التوزيع وفي حالة كونه LTS ، فإن إصدار هذا واحد. إذا أردنا معرفة ما إذا كان لدينا Ubuntu 32 بت أو Ubuntu 64 بت ، فبدلاً من كتابة الأمر السابق ، يتعين علينا كتابة ما يلي:

uname -m

سيظهر مثل هذا إذا كان لدينا Ubuntu 32 بت ، وفي هذه الحالة سيظهر "i386" أو "x86_64" لإصدار 64 بت. إذا كنا ، على العكس من ذلك ، نريد أن نعرف فقط إصدار النواة يجب أن نعرف ما إذا كان به خطأ أو إذا قمنا بتحديثه ، فعلينا كتابة الأمر التالي:

uname -a

اختتام

هذه الأوامر عملية نظرًا لأننا لا نمتلك دائمًا النسخة الرسومية في Ubuntu ، أحيانًا بسبب مشكلة عدم التوافق أو لأننا ببساطة ندير خادمًا ، فليس لدينا دائمًا هذه المعلومات في متناول اليد أو بيانياً ، ومن هنا تأتي أهمية معرفة هذا أو تعرف على الأقل مكان تحديد موقعه.


محتوى المقال يلتزم بمبادئنا أخلاقيات التحرير. للإبلاغ عن خطأ انقر فوق هنا.

7 تعليقات ، اترك لك

اترك تعليقك

لن يتم نشر عنوان بريدك الإلكتروني.

*

*

  1. المسؤول عن البيانات: ميغيل أنخيل جاتون
  2. الغرض من البيانات: التحكم في الرسائل الاقتحامية ، وإدارة التعليقات.
  3. الشرعية: موافقتك
  4. توصيل البيانات: لن يتم إرسال البيانات إلى أطراف ثالثة إلا بموجب التزام قانوني.
  5. تخزين البيانات: قاعدة البيانات التي تستضيفها شركة Occentus Networks (الاتحاد الأوروبي)
  6. الحقوق: يمكنك في أي وقت تقييد معلوماتك واستعادتها وحذفها.

  1.   عبدالمجيد .1982 قال

    الأمر الأول لا يعمل معي

    1.    عبدالمجيد .1982 قال

      آسف لقد نسيت _ الكالينجيون

      1.    ريتشارد قال

        franmmj1982 ، حتى لا يحدث لك هذا النوع من أخطاء الكتابة مرة أخرى ، يجب أن "ترسم" الأمر ونسخه (باستخدام Ctrl + C) ، عندما تذهب إلى الجهاز ، تقوم "بلصقه" هناك. لكن احذر من أنه في المحطة الطرفية لا يمكنك ببساطة اللصق باستخدام Ctrl + V ، ولكن عليك القيام بذلك Ctrl + Shift + V.

  2.   دعامة قال

    لقد قمت بتثبيت ubuntu لكنني لا أعرف ما هو الإصدار ، عندما أتبع تعليماتك أرى i686 ما هو الإصدار؟

    1.    | أو | أو | أو | قال

      إنه 32 بت.

  3.   خوان خوسيه ليندي قال

    شكرا على المقال !!

    إذا كان الأمر: lsb_release -a لا يعمل من أجلك ، فقم فقط بتثبيت الحزمة:

    sudo apt-get install lsb

    يظهر هنا: http://www.sysadmit.com/2017/11/linux-saber-version.html

  4.   إيدهر قال

    أحاول تحديث python3 ، لكني أحصل على أخطاء لا أعرف ما إذا كان نوعًا من التوافق.

    تحذير: الدليل '/home/y/.cache/pip/http' أو دليله الأصلي غير مملوك للمستخدم الحالي وتم تعطيل ذاكرة التخزين المؤقت. يرجى التحقق من الأذونات ومالك هذا الدليل. إذا كنت تنفذ النقطة باستخدام sudo ، فقد تحتاج إلى علامة sudo's -H.
    تحذير: الدليل '/home/y/.cache/pip' أو دليله الأصلي غير مملوك للمستخدم الحالي وتم تعطيل عجلات التخزين المؤقت. تحقق من أذونات ومالك هذا الدليل. إذا كنت تنفذ النقطة باستخدام sudo ، فقد تحتاج إلى علامة sudo's -H.
    البحث في الروابط: / tmpqo37vc51
    تم تحديث المتطلبات بالفعل: setuptools في /usr/local/lib/python3.8/site-packages (41.2.0)
    تم تحديث المتطلبات بالفعل: نقطة في /usr/local/lib/python3.8/site-packages (19.2.3)
    y @ y-Latitude-D0: ~ / Python-3.8.2 $ python3 –version
    بيثون 3.5.2
    y @ y-Latitude-D0: ~ / Python-3.8.2 $

منطقي (صحيح)