Com habilitar el suport per Flatpak en Ubuntu 20.04

Ubuntu 20.04 i Flatpak

Probablement ja hagueu llegit diversos articles sobre els paquets Snap en Ubuntu 20.04 LTS Focal Fossa. En un moviment polèmic, Canonical està pressionant perquè usem els seus paquets de nova generació, però als usuaris de Linux ens agrada controlar més el que fem servir i no ens agrada aquest comportament. A més, som molts els que preferim els paquets Flatpak, Entre altres coses, per ser més ràpid i més fàcil d'utilitzar.

Fa just un any publiquem un article en el qual us ensenyàvem com habilitar el suport per als paquets Flatpak en Ubuntu, però aquest sistema ja no funciona en Focal Fossa perquè han començat a fer servir una altra botiga de programari. Per tant, aquest article és una actualització de l'anterior o un en el qual expliquem els canvis que podem fer per seguir gaudint d'aquests paquets en l'última versió d'Ubuntu.

Ubuntu 20.04 i Flatpak: passos a seguir

El més important que hem de saber o tenir en compte és que el problema és el nou Ubuntu Software, que no és altra cosa que la Snap Store modificada i més restringida que han inclòs en Focal Fossa. Sabent això, els passos a seguir serien aquests:

  1. El primer que hem de fer és instal·lar el paquet «flatpak». Per a això, obrim un terminal i escrivim la següent comanda:
sudo apt install flatpak
  1. El paquet anterior no ens serveix de gaire sense una botiga compatible, de manera que instal·larem un. Podem instal·lar Discover (plasma-discover) i, des d'ell, buscar «flatpak» i instal·lar el motor necessari, però a l'ésser programari del KDE instal·larà moltes dependències i no quedarà tan bé com en Kubuntu, per exemple. Per tant, la millor opció és tornar enrere i instal·lar el «vell» GNOME Programari:
sudo apt install gnome-software
  1. A continuació, hem d'instal·lar el plugin perquè Programari GNOME sigui compatible amb els paquets Flatpak:
sudo apt install gnome-software-plugin-flatpak
  1. A partir d'aquí, el que hem de fer és el mateix que en Ubuntu 19.10 i anteriors, començant per afegir el repositori Flathub amb aquesta comanda:
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
  1. Finalment, reiniciem el sistema operatiu i ja estaria tot preparat per a instal·lar paquets Flatpak en Ubuntu 20.04.

Instal·lar el programari de Flathub en Ubuntu

Un cop habilitat el suport, el programari de Flathub apareixerà en el GNOME Software. L'única cosa en el que hem de fixar-nos és en la informació de el paquet, el apartat de la font en què apareixerà «flathub». Una altra opció és anar a flathub.org, Realitzar les recerques des d'allà, fer clic al botó blau que posa «INSTALL» i seguir les instruccions que apareixen en pantalla.

Si volem, també podem eliminar la «Snap Store» amb la comanda «suo snap remove snap-store» sense les cometes, però això ja ho deixo a gust de consumidor. Si fem tot això serem nosaltres qui decidirem què i d'on instal·lar, Pel que crec que val la pena.


Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Linez va dir

    Gràcies per l'aportació, un apunt: si has actualitzat des d'una versió anterior d'Ubuntu, com és el meu cas i on ja tenia habilitat flatpak, gnome-software apareix com instal · lat, però si ho llances t'obre la versió snap instal·lada per canonical.
    La solució és reinstal·lar gnome-software: sudo apt-get install -reinstall gnome-software

  2.   Rafa va dir

    Per aquestes coses deixi d'usar ubutnu, amb Mint és instal·lar el sistema, instal·lar les aplicacions que un necessita ia treballar. Ubuntu fa perdre molt de temps. El veig ideal per a persones que els agrada «cacharrear» amb l'ordinador, però no per al que pretén treballar amb ell.

    1.    Linez va dir

      A veure amic, això és opcional, el centre de programari porta milers d'aplicacions sense instal·lar el suport flatpak.
      No culpis a Ubuntu de la teva incompetència.

      1.    Armant Mendoza va dir

        Fals: això és una jugada bruta de canonical ... coses com aquestes, MAI es presenten en una distro acabada de publicar, es digui Debian, Arch, etc. però curiosament si passa en Ubuntu, i això és perquè canonical té deslligada una guerra bruta contra Red Hat (desenvolupadora dels paquets Flatpak), guerra que afecta la comunitat però potser aquesta guerra sigui l'inici de la finalitat d'Ubuntu

  3.   Mario Calderón va dir

    Encara sort em vaig alliberar de canonical i d'Ubuntu i les seves jugades brutes ...