Com solucionar els problemes de so en Ubuntu 18.04

Problemes de So amb Ubuntu

Ubuntu 18.04 és l'última versió d'Ubuntu LTS i possiblement la versió més compatible i potent de totes les versions d'Ubuntu. Però tot i això, sempre hi ha determinats problemes amb cert tipus de maquinari o amb algunes configuracions.

A continuació us explicarem una sèrie de passos que cal realitzar en cas de tenir problemes de so. Una qüestió habitual dins del món Gnu/Linux però que és fàcil de solucionar. Tot i que sembli una cosa òbvia, el primer pas que hem de fer és comprovar la configuració de la targeta de so. Per això anem a Ajustos de Sistema i en So ens fixem que dispositiu està marcat en «Sortida» i quin està marcat en «entrada».

Crear USB arrencable
Article relacionat:
Com crear un USB arrencable d'Ubuntu 16.10 fàcil i ràpidament

Un dels problemes més habituals és que en Sortida estigui marcat la presa HDMI i no la vulguem utilitzar. Amb seleccionar la targeta de so n'hi haurà prou per a solucionar tal problema. Potser hi hagi altres problemes i que a través d'aquest menú gràfic no ho puguem fer. Per a això obrim una terminal i executem el següent:

alsamixer

després d'això apareixerà la gestió de l'controlador Alsa que emet el so. Fent clic F6 podem canviar la targeta gràfica per defecte, això pot solucionar bastants problemes de so, però tot i així, hi ha situacions que no es solucionen així. En aquest cas, després de tot l'anterior realitzat i no funcionar, l'únic que ens queda és reiniciar o reinstal·lar Alsa i PulseAudio. Per a això executem a la terminal les ordres següents:

sudo alsa force-reload

I això reiniciarà el servei i executant les ordres següents reinstalaremos Alsa i PulseAudio:

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
samba linux windows
Article relacionat:
Com instal · lar i configurar Samba en Ubuntu 14.10

Si després de realitzar cadascun d'aquests passos i Amb tot, seguim tenint problemes de so, hauríem de buscar algun pegat específic o en cas extrem, canviar de distribució o de targeta de so. Són casos extrems que solen afectar un parell de casos o amb un maquinari extremadament específic. Si no, qualsevol mètode dels anteriors ens servirà per solucionar qualsevol dels problemes de so que tinguem amb Ubuntu.


Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Vladi Aoki va dir

    Probe aquesta comanda i el que va fer va ser fer-me mal el sistema operatiu en Mint, no ho recomano utilitzar.

  2.   Daniel Soria va dir

    hola sóc nou en aquest món, abans tenia linux mint, i he decidit provar amb kubuntu 18.04 per problemes de lentitud amb el navegador, encara que això persisteix igual, bo el problema és que no reprodueix cap so he seguit els passos a peu de la lletra i no funciona, a l'entrar a alsamixer i prémer f6, només surt - predeterminat
    0 HDA intel
    - introdueixi nom
    tinc un ACER TRAVELMATE 2490, es que és molt antic però no tinc res més ... .. jajajaja, no sé si necessites mes dades o on he de posar-me en contacte

  3.   Luis va dir

    No em va funcionar aquesta solució en el meu PC Llibreta exo cloud E15 .. és com que em reconeix la placa de so, em deixa pujar i baixar el volum però no s'escolta ni pels altaveus ni pels auriculars.
    Els driver a windows és Intel SST Audio Device (WDM) i ES8316AudCodec Device però no trobo la forma d'instal·lar-los i / o fer-los funcionar en Ubuntu 18.04.1 LTS

  4.   Ignacio López va dir

    Hola, jo instal Ubuntu 18.04.1 LTS perfecte i el so funcionava correcte. Instal programes normals i tot funcionava bé. Apagueu normal i a l'altre dia, vaig encendre i ja no apareixia el parlantecito a l'escriptori. Sense so i sense haver fet modificacions en la configuració. Vaig fer el que va suggerir però tot i així no funciona. Tinc una placa de so integrada que la reconeix com Realtek ALC887-VD. El meu mother és MSI H97 PCMate. Seguiré buscant a veure que trobo.

  5.   Joaquin Sanchez Morejon va dir

    Benvolgut Ignasi Lopez, estic semblant a Un. S'instal·li Ubuntu 18.04 en una acer chromebook 15 CB3-532. i no aconsegueixo terner cap so, porto dies investigant i fent proves i res, poguessin ajudar-me porfa, escriguin al meu correu, viu a Cuba i aca la internet no és gens fàcil, per endavant gràcies, per tenir aquest bloc ia la comunitat de linux a ajuden a tots a millorar el programari lliure. sense mes Joaquin, Cuba.

    1.    Oscar va dir

      em pas el mateix, el que a mi em va funcionar va ser desinstal·lar pulseaudio de la meva ubuntu 18.04.2 i llest, va tornar el so

  6.   jorge caldera va dir

    bona tader tinc un chromebook als seus c200 i muntanya ubuntu 18.14.1 i ise tot el que vas dir i res si us plau intenti instal·lar chtmax98090 en el sistema gràcia cordials

  7.   Ricardo Fernández va dir

    També tinc problemes de so, sense trobar solució després d'hores de buscar a internet i provar possibles solucions.
    Arribo a la conclusió que és un problema sense solució i que he de provar una altra distro, no basada en Ubuntu.

  8.   juan va dir

    Hola, la millor i més ràpida solució és connectar de nou l'HDMI o un altre i llavors anar a Ajustos de Sistema i en So posar el dispositiu que es vol reprodueixi i quedi marcat a "Sortida". Això em va servir a mi a Linux Mint 19

    1.    Bastian va dir

      Benvolgut, la teva solució em va ajudar moltíssim! gràcies!

      1.    Osmel DF va dir

        Hola. Tant fotre amb aquest pc, i la solució era aquesta, jajajaja, Gràcies friends. solucionat el so, que conte de alsa, reload, instal·lar, desinstal·lar, thank You.

  9.   Fran va dir

    Més aviat, el post és per crear-los. Si no voleu perdre el temps, ignorar aquest post.

  10.   Sinosé Mecallo va dir

    «Gràcies» per fer-me reinstal·lar el sistema. Si no voleu fastiguejar completament no escriviu res del que indica el post a la terminal. Algú amb coneixement hauria de filtrar els nyaps que escriu alguna gent en aquest bloc, en teoria, amb bona intenció.

  11.   Luis Manuel va dir

    Els següents paquets tenen dependències incomplides:
    pulseaudio: Depèn: libpulse0 (= 1: 4.0-0ubuntu11) però 1: 4.0-0ubuntu11.1 serà instal·lat
    Recomana: pulseaudio-module-x11 però no va a instal·lar-
    Recomana: gstreamer0.10-pulseaudio però no va a instal·lar-
    Recomana: pulseaudio-utils però no va a instal·lar-
    E: No s'han pogut corregir els problemes, vostè ha retingut paquets trencats ... .això em surt després de fer tot el que indica arriba..que puc fer per solucionar el problema ??? Gràcies

  12.   Luis Manuel va dir

    luis @ Luis-B: ~ $ sudo alsa force-reload
    [Sudo] password for luis:
    Terminating processes: 4557.
    Unloading ALSA sound driver modules: snd-hda-codec-hdmi snd-hda-codec-via snd-hda-codec-generic snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd- seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-via snd-hda-codec -generic snd-hda-codec snd-hwdep snd-pcm snd-timer).
    Loading ALSA sound driver modules: snd-hda-codec-hdmi snd-hda-codec-via snd-hda-codec-generic snd-hda-intel snd-hda-controller snd-hda-codec snd-hwdep snd-pcm snd- seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
    luis @ Luis-B: ~ $ sudo apt-get remove -purge alsa-base pulseaudio
    Llegint llista de paquets ... Fet
    S'està construint l'arbre de dependències
    Llegint la informació d'estat ... Fet
    Package 'pulseaudio' is not installed, sota not removed
    Els paquets indicats a continuació es van instal·lar de forma automàtica i ja no són necessaris.
    evolution-data-server-common libcamel-1.2-45 libebackend-1.2-7
    libebook-1.2-14 libebook-contacts-1.2-0 libedata-book-1.2-20
    libedataserver-1.2-18 libglademm-2.4-1c2a libpulsedsp libtelepathy-glib0
    libzeitgeist-1.0-1 libzeitgeist-2.0-0 nautilus-data python-zeitgeist
    zeitgeist zeitgeist-core zeitgeist-datahub
    Utilitza 'apt-get autoremove' to remove them.
    Els següents paquets es suprimiran:
    alsa-base *
    0 actualitzats, 0 s'instal·laran, 1 per eliminar i 0 no actualitzats.
    Es alliberaran 514 kB després d'aquesta operació.
    Voleu continuar? [S / n] s
    (S'està llegint la base de dades ... 174024 fitxers o directoris instal·lats actualment.)
    Desinstal·lant alsa-base (1.0.25 + DFSG-0ubuntu4) ...
    Purgant fitxers de configuració de alsa-base (1.0.25 + DFSG-0ubuntu4) ...
    luis @ Luis-B: ~ $ sudo apt-get install alsa-base pulseaudio
    Llegint llista de paquets ... Fet
    S'està construint l'arbre de dependències
    Llegint la informació d'estat ... Fet
    No s'han pogut instal·lar alguns paquets. Això pot significar que
    vostè va demanar una situació impossible o, si està usant la distribució
    inestable, que alguns paquets necessaris no han estat creats o han
    estat moguts fora de Incoming.
    La següent informació pot ajudar a resoldre la situació:

    Els següents paquets tenen dependències incomplides:
    pulseaudio: Depèn: libpulse0 (= 1: 4.0-0ubuntu11) però 1: 4.0-0ubuntu11.1 serà instal·lat
    Recomana: pulseaudio-module-x11 però no va a instal·lar-
    Recomana: gstreamer0.10-pulseaudio però no va a instal·lar-
    Recomana: pulseaudio-utils però no va a instal·lar-
    E: No s'han pogut corregir els problemes, vostè ha retingut paquets trencats.
    luis @ Luis-B: ~ $
    Aquí està tot el procediment ... Gràcies

  13.   Alvaro va dir

    Hola bona, el meu problema és que l'únic que no escolto és a través d'internet, la música a través del reproductor s'escolta bé però ni youtube ni res en li navegador es escucha.Si algú em pot ajudar li ho agrairia,
    gràcies

    1.    crift14 va dir

      Mentre reprodueixes alguna cosa a internet, entra a la configuració d'àudio i busca aquí un apartat que digui alguna cosa com aplicacions perquè tries el navegador i li indiquis que l'àudio de sortida ha de ser per no sé teus auriculars o els teus altaveus ..., si no ve un apartat d 'aplicacions busca una opció que digui «utilitzar com a predeterminat» i indica el dispositiu de sortida que vols, no et puc ajudar més sense saber que distribució o que entorn d'escriptori estàs utilitzant.
      Salutacions!

  14.   Yuspass32 va dir

    Gràcies! m'ha anat de luxe ia la primera!

  15.   Emerson va dir

    Cal aguantar,
    Diguin el que diguin aquests «setciències» si els fas cas el més possible és que hagis de reinstal·lar, el so és un desastre en linux, però des de sempre, no d'ara
    Acaben de treure l'última LTS, Bionic, i té els mateixos problemes de so que tenia ubuntu 8
    és el que hi ha, cal fotre. o tornar a windows
    Jo ja m'he resignat, he de tornar a executar alsa cada vegada que obro el sistema, (ja t'imaginaràs la gràcia que em fa,) el navegador es queda sense so a cada estona, (reiniciar i pregar a el cel) i bé, el dia que tingui pasta em comprare un Mac
    No us preocupeu, però fer-vos a la idea, si vas amb carro, no et queixis de l'olor de l'cavall.
    Jo del que em quejop és d'aquesta plèiade d'enginyers que enganyen a la gent

  16.   Emerson va dir

    i que vagi per davant, que res em faria més feliç que pogués fer amb linux el que faig amb windows, encara que fos semblant !!!!!
    en aquest últim mes he instal·lat mint i ubuntu, ... cinc vegades !!!! i si, a la fi ho normalet, (després de deu anys, ja sòl aconseguir que funcions, i si no reinici, i si no reinstal·lo, (quin remei)
    però fa temps que intento fer alguna cosa semblant al que faig en windows amb stereotools, voicemeeter potato, ((ull que aquest tb és gratis) de moment porto un mes i mig i cinc instalaciuones i no ho he aconseguit
    I això, que, per variar encontre un, -Per fi !!!! -, que t'explica més o menys comprensiblement, tot i que encara amb algunes fallades, el que cal fer i instal·lar
    Un exemple de l'desastre és aquest: instal Mint, i ho instal·lo perquè m'ho suggereix l'autor de l'tutories, (JoseGDF) després d'instal·lar la distro, actualitzar, els repositoris de KXStudio, els programes ....
    els connectors de Calf no hi van, de cap manera
    És clar altres quantes hores a google buscant algun miracle, ... i res, desinstal·lar
    i començar de nou
    amb ubunto 19, ja posats. i si, els de calf funcionaven, és a dir, s'obrien, però ... la distro no tenia so ... fins desinstal·lar
    Tornar a instal·lar ubuntum aquest cop la 188, per això que estarà millor, més estable. i per a aquells que estan pensant en perquè no s'instal·li directament Ubuntu studio, ja ho vaig fer, no va funcionar
    i això és un botonet. així que si entres a linux, ja saps, buscate una cadira còmoda per passar-te moooooooltes hores a google, la majoria de les vegades, ... per a res

  17.   Mario va dir

    Ús Kubuntu 18.04 LTS.
    El que jo vaig fer va ser solament canviar el perfil d'àudio de sortida

    1.    baphomet va dir

      Aquest va ser el comentari més encertat de tots els que llei:
      canviar el perfil d'Advanced Output Configuration
      Gràcies, Mario.

      PD: Et recomano Ricardo Fernández canviar-te a Windows i no hauràs de tornar a tocar el teu sistema operatiu, els altres seguirem estudiant l'enorme potencial del programari lliure.

      1.    baphomet va dir

        Si algú va perdre la «bocinita» del KDE en el procés, no es preocupi:
        1- sudo apt install plasma-pa
        2- suo reboot

  18.   Aitor va dir

    Bones, doncs jo en hp-stream notebook, amb ubuntu 18.04. L'equip de la meva filla, primer amb windows 8 fins que la meva filla es va cansar de que fos com una tortugueta. Ha funcionat amb Linux Mint correctament durant un temps i fa unes setmanes vaig instal·lar Ubuntu 18.04. No em vaig fixar en l'àudio però fa un parell de dies vam anar a reproduir una pel·lícula i l'àudio sonava trencat. Vaig comprovar amb arxius de música i el mateix. He seguit els passos d'aquest post des d'on diu que escrivim a la terminal:

    suo alsa force-reload

    ia mi m'ha solucionat el problema. Ara l'àudio se sent bé. Així que gràcies!

  19.   Walter va dir

    La solució a el tema de l'àudio en Ubuntu 18.04 és instal·lar:
    sudo apt-get install pavucontrol. Això després d'haver provats totes les anteriors suggeriments.
    De totes maneres moltes gràcies.

    Amb això es pot seleccionar la targeta i buscar la combinació a Configuració de «Control de volum que ara sí va a aparèixer en mostrarà aplicacions o executant en Terminal« pavucontrol »sense les cometes.

      1.    Jorge va dir

        Em va funcionar !!! te n'aniràs a cel !!!!

  20.   Joan va dir

    Hola. Tinc Lubuntu 18.04 LTS. El so em va bé. Les aplicacions d'àudio i vídeo, internet, tot bé. L'únic és que no reprodueix els sons de sistema, com quan baixes o pugeu el volum, buides la paperera, etc.
    Si algú té la solució, s'agraeix!

  21.   Roberto Alex va dir

    # Sudo apt-get remove TiMidity
    # Sudo shutdown now -r

    Hauria solucionar el problema en forma definitiva, si és que han fallat tots els passos anteriors. Salutacions des de Santiago de Xile.

    1.    Jhosiel va dir

      exelente

  22.   Jonatan va dir

    En el meu cas em va funcionar desinstal·lant l'aplicació Kodi, un reproductor multimèdia. El desinstal, reinicieu el servei d'àudio, reinicieu l'equip i llest!

  23.   Ferran Scavia va dir

    Va funcionar molt bé per Lubuntu 20.04, vaig actualitzar des consola i treure el so. Molt bon tutorial per solucionar.

    Moltes gràcies

  24.   Fernando va dir

    Moltes gràcies!
    No em funcionava un altaveu i les teves indicacions, tan clares, m'han resolt el problema.
    No sé programació i em vaig passar a Ubuntu, des de Windows, fa poc.

  25.   Miguel va dir

    No aconsegueixo que el meu Asus EEE PC Seashell emeti cap so, tego instal·lat Ubuntu 18.04 LTS Mate

  26.   deepjavero va dir

    Només s'escolta una sortida dels audiòfons

  27.   Jesús va dir

    Ho he provat i efectivament ... ara no em funciona res relacionat amb l'àudio.
    Algú sabria com podria recuperar l'estat anterior als comandaments publicats en el post?

    Gràcias

  28.   hfdhfd va dir

    A mi també se m'ha danyat Ubuntu, ha desaparegut la secció Configuració.

  29.   fdsfds va dir

    He hagut de reinstal·lar el panell de configuració:

    $ Gnome-control-center

    Ho tinc:

    Command 'gnome-control-center' not found, but can be installed with:

    suo apt install gnome-control-center

    Així que el vaig instal·lar usant:

    suo apt install gnome-control-center

    font: https://www.enmimaquinafunciona.com/pregunta/168437/-el-boton-de-configuracion-del-sistema-ha-desaparecido-en-ubuntu-1904-

  30.   Alexander Espinosa va dir

    Hola que tal tot, he fet tot el que especifiques però no passa res no s'escolta el micròfon de la pc, i primer s'escoltaven les dues botzines, ara només s'escolta un. Si us plau podrien recolzar-me en això? M'encanta ubuntu i no vull tornar a l'windows que per a mi és horrible. Però amb aquest sistema així m'és una mica difícil treballar. Doneu-me un cop de mà

  31.   André va dir

    Moltes gràcies! El reinstal·lar (alsa i pulseaudio) em va resoldre el problema de la manca de sortida de so. Ubuntu 18.04.6 LTS. Acer AOA150. Intel NM10/ICH7 Family High Def. Àudio Controller. Driver snd_hda_intel.