Cumu installà l'ultima versione di LibreOffice in Ubuntu

LibreOffice 7.1.1 nantu à Ubuntu

Ancu Ubuntu ùn hè micca Debian, ùn hè ancu Arch Linux. Ciò chì vogliu dì hè a frequenza è a velocità cù chì aghjunghjenu u software à i so repositori: Debian aghjusta solu un software chì hè bè pruvatu, chì si traduce in versioni assai vechje, mentre Ubuntu si mette à ghjornu più veloce, ma menu di distribuzioni Rolling Release cum'è Arch Linux o Manjaro . Per questa ragione, di solitu aghjusta una versione di LibreOffice chì ùn hè micca u più aghjurnatu.

Prima di cuntinuà, mi piacerebbe fà una cosa chjara: se Canonical sceglie di stà cù a versione raccomandata, hè per qualcosa. Hè simplicemente più testatu è hà menu bug. Ma hè ancu vera chì The Document Foundation migliora a cumpatibilità cù ogni nova versione, è da pocu sò stata surprisa di vede chì gran parte di ciò chì hè scrittu in Writer hè perfettamente cumpatibile cù WordPress, dunque pensu chì in casi cusì vale a pena aduprà l'ultima versione. Quì avemu da mustrà vi cumu.

A megliu opzione per avè sempre aghjurnatu LibreOffice: u vostru PPA

Per alcuni software, in realtà, di gran lunga una di e migliori opzioni hè di aduprà a versione Flatpak. Ma u fattu ch'elli sianu pacchetti isolati pò causà prublemi, hè per quessa chì, cum'è parechji altri, preferiscu sempre ciò chì chjamemu a "versione APT". S'ellu hè ciò chì ci interessa, tuttu ciò chì duvemu fà hè aghjunghje u repositoriu ufficiale:

  1. Apremu un terminal.
  2. Scrivemu i seguenti:
sudo add-apt-repository ppa:libreoffice
  1. Dopu, aghjurnemu pacchetti. Se avemu LibreOffice installatu, a nova versione apparerà cum'è un aghjurnamentu.

Versione Flatpak

A seconda megliu opzione per mè hè di installà u pacchettu flatpak. Pudemu fà questu da qualsiasi centru di software cumpatibile, sempre chì sia attivatu. In questu articulu vi spiegemu cumu fà da Ubuntu 20.04 in avanti. Se avemu una versione più vechja, u software GNOME era dighjà installatu per difettu, allora ùn ci hè bisognu di installallu. L'installazione di qualsiasi pacchettu di stu tippu hè simplice quant'è circallu, guardendu a sezione di e fonti, scegliendu "Flathub" è clicchendu "Installà".

Pudemu ancu installà a suite cum'è spiegata in u Pagina Flathub, chì hè cù un cumandamentu di terminal (flatpak installate flathub org.libreoffice.LibreOffice), ma perchè fà cusì sì parlemu di Ubuntu è pudemu fà cun Software GNOME? Inoltre, da u magazinu GNOME pudemu ancu circà pacchetti Flatpak.

Versione Snap

Questu aghju messu l'ultima di e trè migliori opzioni perchè preferiscu i pacchetti precedenti. Inoltre, parechji pacchetti Snap necessitanu tempu per aghjurnà, ancu s'ellu ùn pare micca esse u casu per LibreOffice. Installà a versione Snap di sta suite d'uffiziu in Ubuntu hè simplice quant'è circà "Libreoffice" in u magazinu predeterminatu di u sistema upirativu, postu chì ghjè in realtà un "Snap Store" chì ùn cunsigliu mancu, ma hè bonu per questu.

Se, cum'è mè, ùn vulete micca toccu à quellu magazinu, è se avete installatu u software GNOME, pudete ancu cercallu in questu magazinu è sceglite quellu chì dice in origine "snapcraft.io" in Ubuntu. È se ciò chì vulete hè di fà lu per mezu di u terminal, duverete scrive questu cumandamentu:

sudo snap install libreoffice

Cum'è l'aghju cummentatu, preferiscu fà lu cù u repositoriu ufficiale, è pensu chì ùn sò micca l'unicu, ma una di queste trè opzioni hè bona.


U cuntenutu di l'articulu aderisce à i nostri principii di etica edituriale. Per signalà un errore cliccate quì.

2 cumenti, lasciate i toi

Lasciate u vostru cummentariu

U vostru indirizzu email ùn esse publicatu. campi, nicissarii sò marcati cù *

*

*

  1. Responsabile di i dati: Miguel Ángel Gatón
  2. Scopu di i dati: Cuntrolla SPAM, gestione di cumenti.
  3. Legitimazione: U vostru accunsentu
  4. Cumunicazione di i dati: I dati ùn seranu micca cumunicati à terzi, eccettu per obbligazione legale.
  5. Archiviazione di dati: Base di dati ospitata da Occentus Networks (UE)
  6. Diritti: In ogni mumentu pudete limità, recuperà è cancellà e vostre informazioni.

  1.   Vascu dijo

    Ch'elli sianu pacchetti isolati ponu generà prublemi, serà chì nò, senza flatpak ùn averete mancu un solu prublema, ancu se ne aduprate solu unu in tuttu u sistema, chì tontu duvete vede.

    1.    Pablinux dijo

      Micca tuttu funziona listessu, ci sò estensioni chì ùn sò micca dispunibili, u cuncepimentu pò cambià ...

      Ié, hè una pussibilità.