Cómo instalar la última versión de LibreOffice en Ubuntu

LibreOffice 7.1.1 en Ubuntu

Aunque Ubuntu no es Debian, tampoco es Arch Linux. A lo que me refiero es a la frecuencia y velocidad con la que añaden el software a sus repositorios: Debian sólo añade software que está muy probado, lo que se traduce en versiones muy pasadas, mientras que Ubuntu actualiza más rápido, pero menos que distribuciones Rolling Release como Arch Linux o Manjaro. Por ese motivo, suele añadir una versión de LibreOffice que no es la más actualizada.

Antes de seguir, quisiera dejar clara una cosa: si Canonical elige quedarse en la versión recomendada es por algo. Sencillamente, está más probada y tiene menos bugs. Pero también es cierto que The Document Foundation mejora la compatibilidad con cada nuevo lanzamiento, y recientemente me he sorprendido al ver que mucho de lo escrito en Writer es perfectamente compatible con WordPress, por lo que creo que en casos como este merece la pena usar la última versión. Aquí te vamos a enseñar cómo.

La mejor opción de tener LibreOffice siempre actualizado: su PPA

Para algún software, de hecho, para mucho, una de las mejores opciones es usar la versión Flatpak. Pero que sean paquetes aislados puede generar problemas, motivo por el cual yo, como muchos otros, seguimos prefiriendo lo que llamamos «versión APT». Si es esto lo que nos interesa, lo único que tenemos que hacer es añadir el repositorio oficial:

  1. Abrimos un terminal.
  2. Escribimos lo siguiente:
sudo add-apt-repository ppa:libreoffice
  1. A continuación, actualizamos paquetes. Si tenemos LibreOffice instalado, nos aparecerá la nueva versión como actualización.

Versión Flatpak

La segunda mejor opción para mí es instalar el paquete Flatpak. Esto lo podemos hacer desde cualquier centro de software compatible, siempre y cuando esté habilitado. En este artículo explicamos cómo hacerlo de Ubuntu 20.04 en adelante. Si tenemos una versión anterior, GNOME Software ya estaba instalado por defecto, por lo que no hay que instalarlo. Instalar cualquier paquete de este tipo es tan sencillo como realizar la búsqueda del mismo, mirar el apartado de fuentes, elegir «Flathub» y hacer clic en «Instalar».

También podemos instalar la suite tal y como explican en la página de Flathub, que es con un comando del terminal (flatpak install flathub org.libreoffice.LibreOffice), pero ¿para qué hacerlo así si estamos hablando de Ubuntu y podemos hacerlo con GNOME Software? Además, desde la tienda de GNOME también podemos buscar paquetes Flatpak.

Versión Snap

Esta la pongo la última de las tres mejores opciones porque prefiero los paquetes anteriores. Además, muchos paquetes Snap tardan tiempo en actualizarse, aunque no parece ser el caso de LibreOffice. Instalar la versión Snap de esta suite de ofimática en Ubuntu es tan sencillo como buscar «libreoffice» en la tienda por defecto del sistema operativo, ya que en realidad es una «Snap Store» que no recomiendo para nada, pero nos vale para esto.

Si, como yo, no queréis tocar esa tienda para nada, y si habéis instalado GNOME Software, podéis buscarlo también en esta tienda y elegir la que en el origen Ubuntu ponga «snapcraft.io». Y si lo que queréis es hacerlo vía terminal, tendréis que escribir este comando:

sudo snap install libreoffice

Como he comentado, yo prefiero hacerlo con el repositorio oficial, y creo que no soy el único, pero cualquiera de estas tres opciones es buena.


El contenido del artículo se adhiere a nuestros principios de ética editorial. Para notificar un error pincha aquí.

2 comentarios, deja el tuyo

Deja tu comentario

Tu dirección de correo electrónico no será publicada.

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.

  1.   vaserqueno dijo

    Eso de que sean paquetes aislados puede generar problemas, va ser que no, con ningún flatpak vas a ni un solo problema, aunque uses solo uno en todo el sistema, vaya chorradas hay que ver.

    1.    Pablinux dijo

      No todo funciona igual, hay extensiones que no están disponibles, el diseño puede variar…

      Sí, es una posibilidad.