Závislosti nesplněny

Jak vyřešit nesplněné závislosti balíků v Ubuntu a derivátech

Máte problémy s nesplněné závislosti? Nejsi jediný.

Přináším vám téma, které nám dává problém čtenáře, který nám pomocí naší sekce Kontakt poslal svůj problém, což je poměrně častý problém v Ubuntu a Debian, který má částečné řešení, myslím vyřešit závislosti balíčku k instalaci. Dotaz zněl takto:

ahoj, mám problémy s instalací flash na můj lubuntu 13.10, mám netbook Sony vcpm120al, s 2 GB RAM a asi 250 GB pevného disku, když se pokusím nainstalovat plugin buď stažením, nebo softwarovým centrem lubuntu, které mě hodí chyba, ve výchozím nastavení nebyla nainstalována, protože si myslím, že měla přijít
při pokusu o instalaci balíčku mi říká, že tyto závislosti balíku nelze vyřešit

Tato chyba může být způsobena dalšími softwarovými balíčky, které chybí nebo nelze nainstalovat. Může to být také konflikt mezi softwarovými balíčky, které nelze nainstalovat společně, a podrobně Následující balíčky mají nesplněné závislosti:

flashplugin-installer: Závisí: libnspr4-0d, ale nebude nainstalován

předem děkuji, dodávám, že jsem právě opustil okna a opravdu nevím, jak používat lubuntu.

Co jsou nesplněné „závislosti“?

Když chceme nainstalovat balíček nebo program v Ubuntu a v Gnu / Linuxu, potřebujeme nejen balíček, ale potřebujeme také doplňkové soubory a balíčky, na kterých závisí program, který chceme nainstalovat. Mnohokrát tyto balíčky nejsou v našem systému nalezeny, takže nám dává tuto chybu. Abychom to vyřešili, musíme obvykle nainstalovat balíčky, na kterých program závisí, ale jak se to stane zde, někdy systém trvá na chybě nebo neprovádíme instalaci správně. Většinou to není kvůli tomu, ale že máme nefunkční balíček z nějaké jiné instalace, a proto nám dává chybu závislosti.

Řešení chyby nesplněných závislostí

Abychom to vyřešili, nejpraktičtější věcí je otevřít terminál a napsat následující

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get update

sudo apt-get -f nainstalovat

První příkazy způsobí, že systém vyčistí paměť balíčků a instalaci, a to efektivně, a vyčistí systém osiřelých balíčků, tj. Balíků, které byly najednou používány aplikací a již nejsou používány žádným programem. Třetí příkaz aktualizuje systém Apt a poslední příkaz řeší jakékoli poškozené závislosti, které v systému existují.

Poté lze instalaci provést správně. V tomto konkrétním případě bych doporučil otevřít terminál a napsat následující

sudo apt-get install lubuntu-limited-extras

Tím se nainstaluje řada programů, které jsou klasifikovány jako nezbytné doplňky pro začínající uživatele. Mezi nimi by byla zásilka, která měla v našem systému blikat. Pokud to nefunguje ani při použití blesku, nejpřímější a nejbezpečnější je napsat do terminálu

sudo apt-get install flashplugin-installer

S tím, pokud je instalace Lubuntu správná, bude stačit vyřešit problém Lukase, čtenáře, který nám napsal. Na závěr vám připomenout, že pokud máte jakékoli dotazy nebo požadavky, neváhejte nás kontaktovat. Pokud je to v našich silách, vyřešíme to.

Více informací - Rychlá a snadná instalace balíků DEB, Synaptic, debianitový manažer v Ubuntu,


61 komentářů, nechte svůj

Zanechte svůj komentář

Vaše e-mailová adresa nebude zveřejněna. Povinné položky jsou označeny *

*

*

  1. Odpovědný za údaje: Miguel Ángel Gatón
  2. Účel údajů: Ovládací SPAM, správa komentářů.
  3. Legitimace: Váš souhlas
  4. Sdělování údajů: Údaje nebudou sděleny třetím osobám, s výjimkou zákonných povinností.
  5. Úložiště dat: Databáze hostovaná společností Occentus Networks (EU)
  6. Práva: Vaše údaje můžete kdykoli omezit, obnovit a odstranit.

  1.   15400 řekl

    Díky, dostal jsem tu chybu a tím zmizel. pozdravy!

    1.    PEDRO řekl

      díky to fungovalo velmi dobře

      1.    Fabian řekl

        Velice vám děkuji.

  2.   jerson řekl

    dobrý Doufám, že mi pomůžete, uživatel desktopu "střední úroveň" Mám xubuntu 13.10 32b, chci vědět, jestli s těmito příkazy Chcete-li to vyřešit, nejpraktičtější věcí je otevřít terminál a napsat následující

    sudo apt-get autoremove

    sudo apt-get autoclean

    sudo apt-get update

    sudo apt-get -f nainstalovat
    může vyčistit úložiště, která již nepoužívám, a opustit systém bez poruch.

  3.   Carlos řekl

    Měl jsem Ubuntu 13.11 a vyřešil jsem to

    sudo apt-get autoclean a pak sudo install -f a poté restart mě vyděsil, když jsem to zapnul, vše vyřešeno = D
    Doufám, že vám bude sloužit salu2

  4.   xinai řekl

    Děkuji vám!

  5.   Nový linerobot řekl

    Velmi dobrý partner, tady je skript, který za vás udělá vše, od partnera je program čističe systému, který také odstraní tento typ problému, pouze pokud apt-get install -f přetrvává http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ velmi doporučuji pozdravit kolegy 🙂

  6.   Hector Munoz řekl

    Chci nainstalovat program, který je pro nás užitečný, elektronika se nazývá piklab, ale pokaždé, když se pokusím, dostanu chybu s těmi věcmi závislosti na deseria pomozte mi děkuji

    1.    david259 řekl

      http://ubuntuforums.org/showthread.php?t=123481 zkusili jste to pro piklab 🙂 doufám, že to funguje pro vás

  7.   Pedro řekl

    Nainstalujte openoffice namísto libreoffice a nyní mám problém nesplněných závislostí, které mi nedovolí nic nainstalovat. Nějaké řešení? dík

    1.    FenixPlays_YT řekl

      Ach příteli, totéž se mi stane, kdykoli chci něco nainstalovat buď přes správce balíčků, nebo mi obchod dá chybu nesplněných závislostí a řekne mi, že mám 1 poškozený balíček a nevím, jak to opravit; (

  8.   Jose Carlos RG řekl

    Je to dobré vysvětlení pro začínající uživatele. Pozdravy.

  9.   felipe řekl

    Díky za info. Pozdravy

  10.   Dreicomp řekl

    Stále mám stejný problém, myslím, že se jedná o závislost, která si sama říká

  11.   Alvaro řekl

    Dobrý den, dobře, měl jsem podobnou chybu při instalaci Java na server ubuntu 14.04.
    Sledoval jsem následující proces:

    sudo apt-get nainstalovat výchozí-jre

    A dostal jsem něco delšího, ale podobného, ​​toto vychází po první chybě při dalším pokusu.

    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    Možná budete chtít spustit „apt-get -f install“, abyste to opravili:
    Následující balíčky mají nesplněné závislosti:
    ca-certificates-java: Závisí: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) nebo
    java6-runtime-bezhlavý
    default-jre: Závisí: default-jre-headless (= 2: 1.7-51)
    Závisí: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: Závisí: libtiff5 (> = 4.0.3), ale nebude se instalovat
    E: Závislosti nebyly splněny. Zkuste „apt-get -f install“ bez balíčků (nebo zadejte řešení).

    Co jsem se tedy pokusil, je postupovat podle uvedených kroků, ale když zadám následující instrukci, zobrazí se následující chyba:

    sudo apt-get autoremove

    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    Možná budete chtít spustit „apt-get -f install“, abyste to opravili.
    Následující balíčky mají nesplněné závislosti:
    ca-certificates-java: Závisí: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) nebo
    java6-runtime-bezhlavý
    libgdk-pixbuf2.0-0: Závisí: libtiff5 (> = 4.0.3), ale není nainstalován
    E: Závislosti nejsou splněny. Zkuste to znovu pomocí -f.

    Jsem docela nováček v linuxu, mohl byste mi pomoci, abych věděl, jak to vyřešit? Díky

    1.    finger jazyk řekl

      Dobrý den, zobrazí se mi chyba podobná Alvarovi, nevím, jestli nám můžete pomoci, opravdu bych ji ocenil.

  12.   mateus mateus řekl

    díky i v ubuntu 15.04 to funguje

  13.   Leonardo R. řekl

    Skvělý! Díky moc!

  14.   Mariano řekl

    Velice vám děkuji, hodně mi to pomohlo. Chtěl jsem nainstalovat 4k youtube mp3 pomocí terminálu a nemohl jsem, protože mi to udělalo chybu, pak jsem si to stáhl a nainstaloval a to mi dalo závislost na rozbitých balíčcích. Vaše linky problém vyřešily za mě. Zdá se, že v ubuntu je to velmi běžné.

  15.   Luis řekl

    Zdravím kolegy, na které se pokouším nainstalovat cinnemon, by měl pískat a dostanu chybu. Následující balíčky mají nevyplněné závislosti a na konci se píše .. Nelze opravit problémy, ponechali jste si poškozené balíčky.
    Doufám a pomůžu mi tento problém napravit

  16.   liriccombene řekl

    díky Grosooo studujeme na viedma univ de Comahue Argentina a bylo to řešení

  17.   Dyango vtz řekl

    ahoj, vím, že to v tuto chvíli není relevantní, ale při instalaci mám chybu v aplikaci, už ji mám funkční, ale ve stavovém řádku se mi zobrazuje tato chyba: «E: Balíček wps-office: i386 potřebuje být znovu nainstalován, ale soubor pro něj nelze najít. " Už jsem se to pokusil odinstalovat, abych to mohl správně přeinstalovat, ale to mi to nedovolí a už mi chybí nápady.

  18.   Gabriel řekl

    Děkuji moc

  19.   diov3rov3r řekl

    Díky: D

  20.   racer5 řekl

    Díky, bylo to perfektní řešení !!

  21.   Anděl Alegre řekl

    Moje chyba je kvůli vínu

    angel @ alienware: ~ $ sudo apt-get install wine1.7
    [sudo] heslo pro anděla:
    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    Nelze nainstalovat nějaký balíček. To může znamenat, že
    požádali jste o nemožnou situaci nebo, pokud používáte distribuci
    nestabilní, že některé potřebné balíčky nebyly vytvořeny nebo mají
    byl přesunut z Příchozí.
    Situaci mohou pomoci vyřešit následující informace:

    Následující balíčky mají nesplněné závislosti:
    wine1.7: Závisí: wine1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

    1.    Thomas Castelli řekl

      to samé se stalo mně! Nevím, jak to vyřešit, pokud víte, jak mi dejte vědět, že to musím vyřešit

  22.   Juan Pablo Rivera Quinzacara řekl

    děkuji, hodně mi to pomohlo, už jsem neměl problém.

  23.   max řekl

    dobré, chci aktualizovat ubuntu 15.10 na 16.04, ale dostanu tuto chybu

    Při inicializaci informací o balíčku došlo k problému, který nelze opravit.

    Nahlaste to prosím jako chybu v balíčku „update-manager“ a uveďte následující chybovou zprávu:
    E: Chyba, pkgProblemResolver :: Vyřešit generované výpadky, může to být způsobeno zadrženými balíčky.

    pokud mi můžete pomoci, díky

  24.   Jorge Rios-Gomez řekl

    Děkuji moc, nemohl jsem nainstalovat hardinfo na můj Ubuntu 16 a s vaší pomocí vše funguje dobře.

    Moc vám děkuji ze srdce a pozdravů.

  25.   Felipe D. řekl

    Děkuji, sloužilo mi to úžasně, opravuji mnoho chyb, které jsem měl

  26.   Ann řekl

    Ahoj, snažil jsem se, ale stále dostávám chybu s libappindicator1, například takto:
    Chybovat http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 nebyl nalezen
    E: Nelze získat http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 nebyl nalezen

    E: Nemohl jsem získat nějaké soubory, možná bych měl spustit „apt-get update“ nebo to zkusit znovu s –fix-missing?

    Snažím se s možnostmi, které mi terminál dává, a nic…. Nějaké nápady?
    Děkuji vám!

  27.   Ann řekl

    Poznámka: vše začíná takto:
    Následující balíčky mají poškozené závislosti: google-chrome-stable: Depends: libappindicator1 but not installed

  28.   Mily řekl

    Dobrý den, mám problém. Chci nainstalovat Lightworks (Video Editor) Stáhnu si deb a když ho otevřu, načte mě, ale nedovolí mi jej nainstalovat, jak říká:

    Chyba: Nelze uspokojit závislost: libc6 (> = 2.17)

    Už jsem se snažil dělat všechno, co jsi řekl, a nefunguje to pro mě.

  29.   allodir řekl

    Výborně, moc děkuji!

  30.   Sergio Cabral řekl

    Ahoj, mám Ubuntu 14.04, při pokusu o stažení vína mám mnoho chyb

    Následující balíčky mají nesplněné závislosti:
    wine1.6: Závisí: wine1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Závisí: wine1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

    Říká mi, že když se pokusím stáhnout víno 1.6, které je nutné mít víno, a také mi to řekne, když se pokusím stáhnout víno 1.8 přes terminál a vstoupím do správce synaptických balíčků a zkusím to tam a řekne mi to tento

    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.
    E: Chyba, pkgProblemResolver :: Vyřešit generované výpadky, mohlo to být způsobeno zadrženými pakety.
    E: Nelze opravit závislosti
    E: Chyba, pkgProblemResolver :: Vyřešit generované výpadky, mohlo to být způsobeno zadrženými pakety.
    E: Nelze opravit závislosti

    A vyzkoušel jsem 1000 různých věcí. Co mohu dělat? Pomoc

  31.   Sebastian řekl

    Ahoj! Jak se máte? Můžu se tě na něco zeptat?

    Dělám to a stále mám problémy s instalací Qgis, mohl byste mi pomoci?

    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    Nelze nainstalovat nějaký balíček. To může znamenat, že
    požádali jste o nemožnou situaci nebo, pokud používáte distribuci
    nestabilní, že některé požadované balíčky ještě nebyly vytvořeny nebo jsou
    Vzali z „Příchozí“.
    Situaci mohou pomoci vyřešit následující informace:

    Následující balíčky mají nesplněné závislosti:
    python-qgis: Závisí: python3-psycopg2, ale nenainstaluje se
    Doporučení: liblwgeom-dev, ale nenainstaluje se
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

    Zdravím!

  32.   Raphael Benito řekl

    ~ $ sudo apt-get -f instalace
    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    0 aktualizováno, 0 nových bude nainstalováno, 0 odebráno a 167 neaktualizováno

    Chápu to a stále mi to dělá problém při instalaci comodo.
    Proč? prosím pomozte

  33.   Carlos řekl

    Dobrý den, používám ubuntu 18.04.02 LTS, situace je taková, že se snažím nainstalovat Oracle Database 11g Express Edition, to znamená, že při stahování souboru je tento soubor rpm, samozřejmě ho chci převést. deb, ale v době instalace alien mám nějaké problémy se závislostmi v balíčcích debhelper a dpkg-dev.
    jakékoli řešení, budu velmi vděčný.

  34.   Manuel Beltran řekl

    Perfektní, tady s Peppermint 10 vše dobré
    Děkujeme za sdílení řešení

  35.   tunel69 řekl

    Dobře.
    Pokaždé, když jdu do terminálu, dostanu tuto chybu, když vložím sudo, a nevím, co mám dělat.
    E: položka 49 je nesprávně zadána v souboru seznamu /etc/apt/sources.list (analýza URI)
    E: Seznamy písem nelze přečíst.

  36.   Juanan řekl

    linux je kurva hovno. Po celá léta jsem se uchýlil k různým distribucím, abych údajně využil zastaralé vybavení a vždy stejný příběh, ty zatracené závislosti, které neumožňují instalovat prakticky nic. Pak musím slyšet, že Ubuntu, kubuntu, lubuntu ... používá to i moje babička ... koule. Kdykoli vstanu, skončím frustrovaný. Normální, že to jde lépe a více logero ... neumožňuje nic instalovat.

  37.   Mariana řekl

    Ahoj, mám problém s instalací Haguichi, dostanu následující:

    Následující balíčky mají nesplněné závislosti:
    haguichi: Záleží: libglib2.0-0 (> = 2.48), ale bude nainstalován 2.32.4-0ubuntu1 + 12.04ac5
    Závisí: libglib2.0-bin (> = 2.48)
    Závisí: libgtk-3-0 (> = 3.18), ale bude nainstalován 3.4.2-0ubuntu0.9
    Závisí: libnotify4 (> = 0.7.6), ale bude nainstalována 0.7.5-1
    Doporučení: dconf-cli, ale nelze nainstalovat
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

    Nevím, jak to vyřešit, pokud někdo ví, prosím, pomozte mi, děkuji.

  38.   Daniela řekl

    Děkuji moc, nakonec jsem to vyřešil, jste geni @

  39.   hernan řekl

    Ahoj, mám ubuntu 18.04 a dává mi následující chybu při pokusu o instalaci npm, mám nainstalován nodejs 14.04; Už jsem vyzkoušel řešení, které navrhují, ale stále dává stejnou chybu, díky!

    sudo apt install npm build-essential
    Čtení seznamu balíků ... Hotovo
    Vytváření stromu závislostí
    Čtení informací o stavu ... Hotovo
    build-essential je již ve své nejnovější verzi (12.4ubuntu1).
    Nelze nainstalovat nějaký balíček. To může znamenat, že
    požádali jste o nemožnou situaci nebo, pokud používáte distribuci
    nestabilní, že některé požadované balíčky ještě nebyly vytvořeny nebo jsou
    Vzali z „Příchozí“.
    Situaci mohou pomoci vyřešit následující informace:

    Následující balíčky mají nesplněné závislosti:
    npm: Závisí: nodejs, ale nenainstaluje se
    Závisí: node-abbrev (> = 1.0.4), ale nebude se instalovat
    Závisí: node-ansi (> = 0.3.0-2), ale nebude se instalovat
    Závisí: node-ansi-color-table, ale nebude se instalovat
    Závisí to: node-archy, ale nebude se instalovat
    Závisí to: node-block-stream, ale nebude se instalovat
    Závisí: node-fstream (> = 0.1.22), ale nebude se instalovat
    Závisí: node-fstream-ignore, ale nebude se instalovat
    Závisí to: node-github-url-from-git, ale nebude se instalovat
    Závisí: node-glob (> = 3.1.21), ale nebude se instalovat
    Závisí: node-graceful-fs (> = 2.0.0), ale nebude se instalovat
    Závisí: node-inherits, ale nebude se instalovat
    Závisí: node-ini (> = 1.1.0), ale nebude se instalovat
    Závisí to: node-lockfile, ale nenainstaluje se
    Závisí to: node-lru-cache (> = 2.3.0), ale nebude se instalovat
    Závisí: uzel-minimatch (> = 0.2.11), ale nebude se instalovat
    Závisí to: node-mkdirp (> = 0.3.3), ale nebude se instalovat
    Závisí to: node-gyp (> = 0.10.9), ale nebude se instalovat
    Závisí: node-nopt (> = 3.0.1), ale nebude se instalovat
    Závisí: node-npmlog, ale nenainstaluje se
    Závisí: uzel jednou, ale nebude se instalovat
    Závisí to: node-osenv, ale nenainstaluje se
    Závisí: čtení uzlů, ale nebude se instalovat
    Závisí: node-read-package-json (> = 1.1.0), ale nebude se instalovat
    Závisí: požadavek na uzel (> = 2.25.0), ale nebude se instalovat
    Závisí: opakování uzlu, ale nebude se instalovat
    Závisí to: node-rimraf (> = 2.2.2), ale nebude se instalovat
    Závisí: node-semver (> = 2.1.0), ale nebude se instalovat
    Závisí to: node-sha, ale nenainstaluje se
    Závisí: snímek uzlu, ale nenainstaluje se
    Závisí to: node-tar (> = 0.1.18), ale nebude se instalovat
    Závisí: podtržítko uzlu, ale nebude se instalovat
    Závisí: node-which, ale nenainstaluje se
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

  40.   Sergio řekl

    Díky moc! Byl jsem měsíce, aniž bych kvůli těmto chybám mohl nainstalovat program, unavilo mě hledání ve fórech a dnes jsem našel tento. Pozdravy!

  41.   Xavier řekl

    ahoj dobře, jsem trochu / docela nováček s ubuntu a mám následující problém, nevím, jestli je to správné místo, ale pokud ne, prosím, veď mě.
    Mám nainstalovaný elementární os 5.1.7 Zkoušel jsem mnoha způsoby instalovat víno, sledovat návody, bez úspěchu instalovat repozitáře, snažil jsem se vše smazat, jak jsi uvedl v tomto příspěvku, a teď se to snažím nainstalovat z aplikačního centra a stále mi říká totéž «nesplněné závislosti» konkrétně

    W: Chyba GPG: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Následující podpisy nelze ověřit, protože veřejný klíč není k dispozici: NO_PUBKEY DFA175A75104960E
    E: Úložiště „https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease“ není podepsáno.
    W: Z takového úložiště nemůžete bezpečně aktualizovat, a proto je ve výchozím nastavení zakázán.
    W: Podrobnosti o vytváření úložišť a konfiguraci uživatelů najdete na manuálové stránce apt-secure (8).
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease není (zatím) k dispozici (Následující podpisy nelze ověřit, protože veřejný klíč není k dispozici: NO_PUBKEY DFA175A75104960E)

    Doufám, že mi pomůžete, díky předem.

  42.   Jorge řekl

    Dobrý den, při instalaci editoru pro Latex (texmaker) mi dává následující chybu a nemohu ji odstranit:
    Nelze uspokojit závislost libc6 (> = 2.29)

    díky

  43.   ian řekl

    Ahoj, při natáčení došlo k chybě při instalaci komunitního serveru mongodb:

    "Sudo apt-get install -y mongodb-org"

    a dává mi následující chybu:

    Následující balíčky mají nesplněné závislosti:
    mongodb-org: Závisí: mongodb-org-server, ale nenainstaluje se
    E: Problémy se nepodařilo opravit, ponechali jste si poškozené balíčky.

    ale nic nevyřešilo, abych odstranil zastaralé závislosti

  44.   Cristian řekl

    vynikající !!

  45.   Miguel López řekl

    Vynikající informace a fungovalo to perfektně. Moc děkuji

  46.   Federico řekl

    Můžete přímo přejít do složek /etc/apt/sources.list.dy s vyhledáváním ls, které jim způsobí chybu, a poté je smazat pomocí sudo rm název souboru a zadat ...

  47.   Mario řekl

    Dík ! Dík!

  48.   Alexander cardozo řekl

    Nenechávám si pořád stejnou chybu

  49.   Doktor Strange řekl

    Jinde velmi dobré vysvětlení, nenašel jsem řešení tak jednoduché jako to vaše, gratuluji, pokud vás mohu pozvat na kávu, vložte odkaz do svých publikací.

  50.   Mary řekl

    Nápověda Chci nainstalovat steam do lubuntu
    nejprve dám "sudo apt install steam-installer", pak mi to řekne, že musím dát steam, zkusím to a skončím s rozbitými balíčky
    (po vyzkoušení výše uvedeného kromě samozřejmě toho blesku, protože ho mám)
    Skočí mi to:
    Nelze nainstalovat nějaký balíček. To může znamenat, že
    požádali jste o nemožnou situaci nebo, pokud používáte distribuci
    nestabilní, že některé požadované balíčky ještě nebyly vytvořeny nebo jsou
    Vzali z „Příchozí“.
    Situaci mohou pomoci vyřešit následující informace:

    Následující balíčky mají nesplněné závislosti:
    steam: i386: Záleží: libgl1-mesa-dri: i386 (> = 17.3), ale nenainstaluje se nebo
    libtxc-dxtn0: i386, ale nelze jej nainstalovat
    Záleží: libgl1-mesa-glx: i386, ale nenainstaluje se
    Záleží: libgpg-error0: i386 (> = 1.10), ale nenainstaluje se
    Záleží: libudev1: i386, ale nenainstaluje se
    Záleží: libxcb-dri3-0: i386 (> = 1.11.1), ale nenainstaluje se
    Záleží: libxinerama1: i386 (> = 2: 1.1.1), ale nenainstaluje se
    Závisí to: libc6: i386 (> = 2.15), ale nebude se instalovat
    Závisí: libstdc ++ 6: i386 (> = 4.8), ale nebude se instalovat
    Závisí to: libx11-6: i386, ale nebude se instalovat
    Doporučujeme: libxss1: i386, ale nenainstaluje se
    Doporučit: mesa-vulkan-drivers: i386, ale nenainstaluje se
    E: Problémy nelze opravit, zachovali jste poškozené balíky
    Co mám dělat, prosím?

  51.   Mario Barcenilla řekl

    V poslední době mám mnoho problémů s Ubuntu, řeším je ve videu na mém kanálu SABIASCOMO, takže při přeinstalaci Ubuntu 14.04 LTS na 32bitový PC a následné aktualizaci mě napadla kuriozita, protože před aktualizací jsem instaloval z Centrum softwaru Ubuntu, QtCreator a já jej při aktualizaci odebereme, pokus o instalaci vrátí chybu „Závislosti balíčků nelze vyřešit“ a v části Podrobnosti následující:
    Následující balíčky mají nesplněné závislosti:

    qtcreator: Závisí: libqt5concurrent5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5designercomponents5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 není nainstalován
    Závisí: libqt5help5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 není nainstalován
    Závisí: libqt5printsupport5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5script5 (> = 5.0.2), ale 5.2.1 + dfsg-1ubuntu1 není nainstalován
    Závisí: libqt5svg5 (> = 5.0.2), ale 5.5.1-2build1 ~ ppa1404 + 1 není nainstalováno
    Závisí: libqt5xml5 (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libgcc1 (> = 1: 4.1.1), ale 1: 4.9.3-0ubuntu4 není nainstalován
    Závisí: libqt5core5a (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5designer5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 není nainstalován
    Závisí: libqt5gui5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5network5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5qml5 (> = 5.2.0 ~ beta1), ale 5.5.1-2ubuntu6 ~ ppa1404 + 2 není nainstalován
    Závisí: libqt5quick5 (> = 5.1.0), ale 5.5.1-2ubuntu6 ~ ppa1404 + 2 není nainstalováno
    Závisí: libqt5sql5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libqt5widgets5 (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 není nainstalována
    Závisí: libstdc ++ 6 (> = 4.6), ale 4.8.4-2ubuntu1 ~ 14.04.4 není nainstalováno
    Závisí: qtbase-abi-5-2-1, ale je to virtuální balíček
    Závisí: qtdeclarative-abi-5-2-1, ale je to virtuální balíček
    Pokud by byl někdo tak laskav a informoval mě, co mohu dělat, byl bych mu nesmírně vděčný.

  52.   Alex řekl

    A v případě debianu 11? byl by to stejný postup?

  53.   Mateo řekl

    Zobrazuje se mi chyba závislosti pro tento balíček vína, protože je údajně rozbitý, už jsem udělal vše, co mi stránka řekla, a nevím, co mi doporučují udělat
    zde je instalační balíček:
    Nelze nainstalovat nějaký balíček. To může znamenat, že
    požádali jste o nemožnou situaci nebo, pokud používáte distribuci
    nestabilní, že některé požadované balíčky ještě nebyly vytvořeny nebo jsou
    Vzali z „Příchozí“.
    Situaci mohou pomoci vyřešit následující informace:

    Následující balíčky mají nesplněné závislosti:
    winehq-stable: Závisí: stabilní na víno (= 7.0.0.0 ~ bionic-1)
    E: Problémy nelze opravit, zachovali jste poškozené balíky

    Nevím co mám dělat můžete mi prosím pomoci

  54.   Červenec řekl

    Skvělé, umožnilo mi to nainstalovat další programy, díky

  55.   streggonne řekl

    fantastický příspěvek