Sådan installeres Wine på Ubuntu 18.04 LTS?

Vin

Vin er en populær gratis og open source-software der giver brugerne mulighed for at køre Windows-applikationer på Linux og andre Unix-lignende operativsystemer. For at være lidt mere teknisk, Vin det er et kompatibilitetslag; oversætter systemopkald fra Windows til Linux og det bruger nogle Windows-biblioteker i form af .dll-filer.

For de mennesker, der migrerer fra Linux, har de muligvis brug for noget Windows-software eller spil, der ikke er tilgængeligt eller ikke har nogen tilsvarende i Linux. Vin gør det muligt at køre disse Windows-programmer og spil på dit Linux-skrivebord.

Vin det er en af ​​de bedste måder at køre Windows-applikationer på Linux på. Derudover Vin samfund den har en meget detaljeret applikationsdatabase, vi finder den som AppDB den indeholder mere end 25,000 programmer og spil, sorteret efter deres kompatibilitet med Wine:

  • Platin applikationer- Installerer og kører jævnt i en klar til brug vininstallation
  • Guld applikationer- arbejde fejlfrit med nogle specielle indstillinger som DLL-tilsidesættelser, andre indstillinger eller med tredjepartssoftware
  • Sølv applikationer- De kører med mindre problemer, der ikke påvirker typisk brug, for eksempel kan et spil køre i en enkelt spiller, men ikke i multiplayer.
  • Bronze applikationer- Disse apps fungerer, men har mærkbare problemer, selv til regelmæssig brug. De kan være langsommere, end de burde være, have UI-problemer eller mangler specifikke funktioner.
  • Uønskede apps- Fællesskabet har vist, at disse apps ikke kan bruges med vin. De installerer muligvis ikke, starter muligvis ikke eller starter med så mange fejl, at det er umuligt at bruge.

Inden du installerer vin, vi skal beslutte, om vi vil have den seneste stabile version eller udviklingsversionen.

Den stabile version har færre fejl og højere stabilitet, men det understøtter færre Windows-applikationer. Det udviklingsversion giver bedre kompatibilitet, men har flere uløste fejl.

Hvis du ønsker at have den nyeste version af den stabile vinserie, har vi for øjeblikket version 3.0.

Installation af vin på Ubuntu 18.04

 

For at installere det i vores system de skal åbne en terminal ved at trykke på 'CTRL + ALT + T' eller fra skrivebordet og kør følgende kommandoer for at installere det.

Det første trin vil være at aktivere 32-bit arkitektur, at selvom vores system er 64 bits, sparer vi mange problemer, der normalt opstår, når vi udfører dette trin, for dette skriver vi på terminalen:

sudo dpkg --add-architecture i386

Nu vi skal importere nøglerne og føje dem til systemet med denne kommando:

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key

Færdiggjort dette nu vi vil tilføje følgende lager til systemetI øjeblikket er der ikke noget lager til Ubuntu 18.04 LTS, men vi kan bruge lageret fra den tidligere version, der fungerer perfekt, for dette skriver vi i terminalen:

sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ artful main'

Endelig Vi skal bare skrive følgende kommando for at installere Wine på vores computere, dette er for at installere den stabile version af Wine 3.0:

sudo apt-get install --install-recommends winehq-stable

Nu vi har også adgang til vinudviklingsgrenen, som indeholder mange flere funktioner og forbedringer end 3.0, problemet med at være en udviklingsversion er, at vi løber risikoen for at få nogle fejl med udførelsen.

Flash- og Linux-logoer
relateret artikel:
Afhængigheder uopfyldte

Pero hvis du vil installere det, som i øjeblikket er i gang, er Wine 3.7-versionen til installation du skal bare løbe:

sudo apt-get install --install-recommends winehq-devel

Udført installationen Du skal bare køre denne kommando for at kontrollere, at den blev installeret med succes og ved, hvilken version du har installeret:

wine --version

Hvor det var den stabile version, får du et svar som dette:

wine-3.0

Sådan afinstalleres Wine fra Ubuntu 18.04 LTS?

Hvis du vil afinstallere Wine fra dit system af en eller anden grund, sDu skal bare køre følgende kommandoer.

Afinstaller den stabile version:

sudo apt purge winehq-stable

sudo apt-get remove wine-stable

sudo apt-get autoremove

Afinstaller udviklingsversionen:

sudo apt purge winehq-devel

sudo apt-get remove wine-devel

sudo apt-get autoremove

Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

43 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort.

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Jorge Ariel Utello sagde han

    Den eneste applikation, jeg vil have fra Windows, eller understøtter vin ...

  2.   jesus sagde han

    i det andet trin får jeg syntaktisk fejl nær det uventede element `newline 'hvordan løser jeg det? tak skal du have

  3.   juli sagde han

    afklaringspunkt, kommandoen «sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/»Kan ikke bruges i 18.04, da adressen mangler en Bionic-mappe, for at kommandoen sudo« apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ kunstnerisk hoved '», der erstatter det.
    Jeg prøvede den første kommando, og den producerede en permanent repository-fejl, som jeg skulle fjerne manuelt fra software og opdateringer

    1.    Daniel Perez sagde han

      Det skete for mig det samme som juli, og jeg fik dette i Ubuntu 18.04:

      daniel @ daniel-X45C: ~ $ sudo apt-get opdatering

      Tænding: 1 http://dl.google.com/linux/chrome/deb stabil InRelease
      Des: 2 http://dl.google.com/linux/chrome/deb stabil frigivelse [1 189 B]
      Des: 3 http://dl.google.com/linux/chrome/deb stabil Release.gpg [819 B]
      Des: 4 http://security.ubuntu.com/ubuntu bionisk sikkerhed InRelease [83.2 kB]
      Objekt: 5 http://mx.archive.ubuntu.com/ubuntu bionisk InRelease
      Tænding: 6 https://dl.winehq.org/wine-builds/ubuntu bionisk InRelease
      Des: 7 http://mx.archive.ubuntu.com/ubuntu bioniske opdateringer InRelease [83.2 kB]
      Des: 8 https://dl.winehq.org/wine-builds/ubuntu kunstnerisk InRelease [4 701 B]
      Des: 9 http://dl.google.com/linux/chrome/deb stabile / main amd64-pakker [1 370 B]
      FEJL: 10 https://dl.winehq.org/wine-builds/ubuntu bionisk frigivelse
      404 blev ikke fundet [IP: 151.101.196.69 443]
      FEJL: 8 https://dl.winehq.org/wine-builds/ubuntu kunstnerisk InRelease
      Følgende underskrifter kunne ikke bekræftes, fordi deres offentlige nøgle ikke er tilgængelig: NO_PUBKEY 818A435C5FCBF54A
      Objekt: 11 http://mx.archive.ubuntu.com/ubuntu bionic-backports InRelease
      Des: 12 http://security.ubuntu.com/ubuntu bionisk sikkerhed / main amd64 DEP-11 Metadata [204 B]
      Des: 13 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main i386-pakker [58.8 kB]
      Des: 14 http://security.ubuntu.com/ubuntu bionic-security / universe amd64 DEP-11 Metadata [2 B]
      Des: 15 http://security.ubuntu.com/ubuntu bionisk sikkerhed / univers DEP-11 64 × 64 ikoner [29 B]
      Des: 16 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main amd64-pakker [59.3 kB]
      Des: 17 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main Translation-da [21.6 kB]
      Des: 18 http://mx.archive.ubuntu.com/ubuntu bioniske opdateringer / main amd64 DEP-11 Metadata [9 092 B]
      Des: 19 http://mx.archive.ubuntu.com/ubuntu bioniske opdateringer / vigtigste DEP-11 64 × 64 ikoner [8 689 B]
      Des: 20 http://mx.archive.ubuntu.com/ubuntu bionic-updates / universe i386-pakker [28.2 kB]
      Des: 21 http://mx.archive.ubuntu.com/ubuntu bionic-updates / universe amd64-pakker [28.2 kB]
      Des: 22 http://mx.archive.ubuntu.com/ubuntu bionic-updates / universe amd64 DEP-11 Metadata [5 716 B]
      Des: 23 http://mx.archive.ubuntu.com/ubuntu bioniske opdateringer / univers DEP-11 64 × 64 ikoner [14.8 kB]
      Læsepakke liste ... Udført
      E: Depotet "https://dl.winehq.org/wine-builds/ubuntu bionic Release" har ikke en Publish-fil.
      N: Du kan ikke opdatere fra et lager som dette sikkert, og det er derfor deaktiveret som standard.
      N: Se apt-secure (8) man-siden for detaljer om oprettelse af opbevaringssteder og konfiguration af brugere.
      W: GPG-fejl: https://dl.winehq.org/wine-builds/ubuntu artful InRelease: Følgende signaturer kunne ikke bekræftes, fordi deres offentlige nøgle ikke er tilgængelig: NO_PUBKEY 818A435C5FCBF54A
      E: Depotet "https://dl.winehq.org/wine-builds/ubuntu artful InRelease" er ikke underskrevet.
      N: Du kan ikke opdatere fra et lager som dette sikkert, og det er derfor deaktiveret som standard.
      N: Se apt-secure (8) man-siden for detaljer om oprettelse af opbevaringssteder og konfiguration af brugere.
      daniel @ daniel-X45C: ~ $

  4.   Swamp sagde han

    Mener du, at det andet arkiv fungerer? Det samme skete for mig, jeg var nødt til at fjerne lageret manuelt, fordi det ikke lod mig foretage opdateringer, det eneste jeg ikke kunne gøre var at fjerne WineHQ-pakkerudbyderen i Software og opdateringer i "Authentication". Ved du det hvordan kan jeg fjerne det?

  5.   Aioros sagde han

    Tak for dataene, sandheden hjalp mig meget

  6.   David mansilla sagde han

    Hej, jeg har fulgt alle trin, og Vin vises ikke på listen over installerede programmer, men hvis jeg sætter $ vin –version
    så ja det ser ud

    vin-3.13
    Så jeg ved ikke, hvad problemet er, jeg prøvede først den stabile version, derefter denne, og jeg kan ikke se

  7.   Pipo sagde han

    se at jeg ledte efter hjælp til kali linux ikke til ubuntu>: v atte el pipo: v

  8.   Alfonso sagde han

    Grace comrade @, men for Windos-programmet, som jeg har brug for, spørger det mig .NET Framework

    du har endnu et es på ærmet, 😉

    Tak.

  9.   Guillermo Velazquez Vargas sagde han

    Tak for bidraget, jeg er ny på Linux, vær venlig at hjælpe mig, se, installer vinen som du nævner, og den blev installeret .. kun da den var gennem terminalen blev der ikke oprettet nogen direkte adgang, jeg fandt den allerede med find men jeg vil have direkte adgang, du hjælper mig med tjeneste

  10.   Diego sagde han

    Mange tak, det har hjulpet mig meget. Hilsner fra Uruguay

  11.   GIGY sagde han

    HELLO: MEGET TAK, AMI TJENEDE MIG I ALT, JEG INSTALLEREDE ALLE TAK.

  12.   Matias sagde han

    Hej, godt at spørge, om nogen er sket med ham, at når vi kører en win2-software, og vi vil trække og slippe en fil, er det ikke muligt, jeg forklarer: Jeg har allerede programmet installeret, det er en musikafspiller (radioboss ) med vin, jeg har musikken på diskene, og jeg vil finde den, trække den og slippe den på afspilleren, og den lader mig ikke. Hvis nogen kender løsningen, takker jeg dig.

    Og hilsner fra Mendoza, Argentina.

  13.   Manuel Beltran sagde han

    når jeg vil installere et Windows-program i vin, får jeg følgende meddelelse;

    fatale fejl
    installationen sluttede for tidligt på grund af en fejl

    Er der noget, jeg gjorde forkert, da jeg installerede vin, eller hvilken fejl vil det være?

  14.   snowyshadows322 sagde han

    Dette hjalp mig tak

  15.   Jose Vega sagde han

    godnat

    Jeg udførte hele proceduren, men når du giver den koden til at installere, er resultatet:

    * følgende pakker har brudte afhængigheder:
    winehq-stable: Afhænger af: wine-stable (= 5.0.0 bionic)
    E: Problemer kunne ikke rettes, du har bevaret ødelagte pakker.

    1.    Diego sagde han

      José, hvordan går det? Jeg har haft det samme problem. Er det lykkedes at ordne det?

  16.   samfurted sagde han

    HVAD E OPNÅDE YEHHHHHHHH YOLO # XD 🙂 😉

    1.    Jenia PS sagde han

      Hvordan klarede du det endelig?

  17.   Tomás sagde han

    Efter at have udført alle processerne siger den sidste kommandolinje:

    vin: kan ikke finde L »C: \\ windows \\ system32 \\ PROGRAM.exe»

    Og vin ser ikke ud til at være installeret. Hvilket kan være?

  18.   kenshura sagde han

    sudo dpkg – tilføj-arkitektur i386
    sudo apt opdatering
    sudo apt-add-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionisk hoved '
    wget -nv https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key -O Slip.tasten
    sudo apt-key tilføj - <Release.key
    sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./ '
    sudo apt-get update
    sudo apt install –install-anbefaler winehq-stable

    fast til LUBUNTU 18.04 LTS
    Kilde: https://askubuntu.com/questions/1205550/cant-install-wine-on-ubuntu-actually-lubuntu-18-04

  19.   paul sagde han

    Læsepakke liste ... Udført
    Oprettelse af afhængighedstræ
    Læsning af statusoplysninger ... Udført
    Kan ikke installere en pakke. Dette kan betyde det
    du bad om en umulig situation, eller hvis du bruger distributionen
    ustabil, at nogle nødvendige pakker endnu ikke er oprettet eller er
    De har taget fra "indgående."
    Følgende oplysninger kan hjælpe med at løse situationen:

    Følgende pakker har uopfyldte afhængigheder:
    winehq-stable: Afhænger af: wine-stable (= 5.0.0 ~ bionic)
    E: Problemer kunne ikke rettes, du har bevaret ødelagte pakker.
    hvorfor får jeg det?

    1.    daniel sagde han

      Det samme sker med mig, har du været i stand til at løse det?

    2.    Paul sagde han

      Præcis det samme skete med mig, jeg giver dig løsningen

      hvis du ikke har aptitude, skal du installere det med sudo apt-get aptitude og derefter sudo apt-get update

      endelig installer vin:

      sudo aptitude installere winehq-stable

      kør derefter denne guide

      https://help.ubuntu.com/community/Wine - winecfg

  20.   shimmy sagde han

    Hej, jeg har ubuntu mate 18.04, og jeg kan ikke installere vin, jeg får dette:

    shimmy @ shimmy-Aspire-A315-33: ~ $ sudo apt-key tilføj winehq.key
    OK
    shimmy @ shimmy-Aspire-A315-33: ~ $ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionisk hoved '
    Objekt: 1 http://es.archive.ubuntu.com/ubuntu bionisk InRelease
    Objekt: 2 http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu bionisk InRelease
    Objekt: 3 http://es.archive.ubuntu.com/ubuntu bioniske opdateringer InRelease
    Tænding: 4 https://dl.winehq.org/wine-builds/ubuntu stor InRelease
    Objekt: 5 https://brave-browser-apt-release.s3.brave.com bionisk InRelease
    Objekt: 6 https://dl.winehq.org/wine-builds/ubuntu eoan InRelease
    Objekt: 7 http://es.archive.ubuntu.com/ubuntu bionic-backports InRelease
    Objekt: 8 http://security.ubuntu.com/ubuntu bionisk sikkerhed InRelease
    Objekt: 9 https://dl.winehq.org/wine-builds/ubuntu bionisk InRelease
    Objekt: 10 https://dl.winehq.org/wine-builds/ubuntu kunstnerisk InRelease
    Objekt: 11 http://ppa.launchpad.net/lah7/ubuntu-mate-colours/ubuntu bionisk InRelease
    FEJL: 12 https://dl.winehq.org/wine-builds/ubuntu stor frigivelse
    404 blev ikke fundet [IP: 151.101.134.217 443]
    Objekt: 13 http://repository.spotify.com stabil InRelease
    Læsepakke liste ... Udført
    E: Depotet "https://dl.winehq.org/wine-builds/ubuntu great Release" har ikke en Publish-fil.
    N: Du kan ikke opdatere fra et lager som dette sikkert, og det er derfor deaktiveret som standard.
    N: Se apt-secure (8) man-siden for detaljer om oprettelse af opbevaringssteder og konfiguration af brugere.

    Hvordan løser jeg det?
    Tak!

    1.    muflus sagde han

      Hej! løste du det ??
      det samme sker for mig ...

  21.   KaffeRobot sagde han

    Hvilken kommando har jeg brug for for at åbne vin fra terminalen? Jeg havde brugt den før, men jeg husker den ikke længere, og den er ikke registreret i terminalen. hvis nogen kender kommandoen, kan du hjælpe mig?

  22.   ophøre sagde han

    yusmar @ yusmar-Intel-powered-classmate-PC: ~ $ sudo apt-get install –install-anbefaler winehq-stabil
    Læsepakke liste ... Udført
    Oprettelse af afhængighedstræ
    Læsning af statusoplysninger ... Udført
    Kan ikke installere en pakke. Dette kan betyde det
    du bad om en umulig situation, eller hvis du bruger distributionen
    ustabil, at nogle nødvendige pakker endnu ikke er oprettet eller er
    De har taget fra "indgående."
    Følgende oplysninger kan hjælpe med at løse situationen:

    Følgende pakker har uopfyldte afhængigheder:
    winehq-stable: Afhænger af: wine-stable (= 5.0.1 ~ bionic)
    E: Problemer kunne ikke rettes, du har bevaret ødelagte pakker.

    Hvordan kan jeg rette det?

    1.    Roberto sagde han

      Hej, jeg prøvede 3 gange og nævner altid E: Kunne ikke løse problemer, du har bevaret ødelagte pakker. Jeg installerede Synaptic, så jeg kan fjerne dem, men det gør det ikke korrekt. Hvis du kender noget til at løse problemet, vil jeg sætte pris på det.

  23.   JSTB sagde han

    Er der et problem med at installere Vin fra ubuntu-softwaren? undskyld uvidenhed, jeg er ny på linux.

  24.   Salgado. Officiel sagde han

    Tak <3
    Jeg brugte din metode i 2020, og den fungerede perfekt for mig

  25.   Golden sagde han

    Jeg gjorde alt det samme, og jeg sprang over fejlen og fortsatte den samme, og mange ting downloades til mig.
    Jeg håber, det er slet ikke ondsindet.

    1.    Lykos sagde han

      Bruger du lts-versionen? hvis du har fluerne installeret den 18.10, skal du gå til 18.04 lts, ​​den har langsigtet support.
      Vin gav mig en masse drama, da jeg var 18.10, jeg gik til 18.04 lts, ​​og det er en perle

  26.   Lucas Levaggi sagde han

    men jeg ser dette på E: dpkg-udførelse blev afbrudt, du skal manuelt udføre "sudo dpkg –configure -a" for at rette problemet

  27.   JOSE sagde han

    TAKK

  28.   spøgelsesspiller sagde han

    Jeg kunne virkelig godt lide det, jeg installerede det, og jeg spiller fnaf på grund af det, bro, tak

  29.   enzym sagde han

    Jeg får dette Følgende pakker har uopfyldte afhængigheder:
    winehq-stable: Afhænger af: wine-stable (= 6.0.0 ~ bionic-1)
    E: Problemer kunne ikke rettes, du har bevaret ødelagte pakker.

  30.   Paul sagde han

    Hej, jeg har endelig været i stand til at installere Wine på min linux ubuntu 18.04

    Jeg fik fejlen afhænger af bionic osv., Når jeg forsøgte at installere, så jeg var nødt til at installere den gennem aptitude med kommandoen

    sudo aptitude installere winehq-stable

    og det fungerede for mig 😀

    følg derefter trinene i denne vejledning

    https://help.ubuntu.com/community/Wine

    Det var da jeg løb winecfg i terminalen, at jeg var lettet over at kunne endelig nyde den.

    Alligevel ville jeg bare bidrage med denne viden, hilsner

  31.   Juan Pablo sagde han

    Jeg får vin 6.0 og i app-baren får jeg ikke vin

    1.    Benjamin sagde han

      Du skal højreklikke, åbne med en anden applikation og vælge vin 😀

  32.   RafaCG sagde han

    Det er rigtigt, at Wine ikke er perfekt, men det hjælper mig med at køre de programmer, jeg arbejder med på Windows her på Linux.

  33.   Benjamin sagde han

    har brug for mange ting for at fungere, og du spiser opbevaring ...

  34.   hhhehehwh sagde han

    ja jeg har vin på min windors pc