Abhängigkeiten unerfüllt

So lösen Sie unerfüllte Paketabhängigkeiten in Ubuntu und Derivaten

Haben Sie Probleme mit unerfüllte Abhängigkeiten? Du bist nicht der einzige.

Ich bringe Ihnen ein Thema, das uns von einem Leserproblem gegeben wird. Er hat unseren Kontaktbereich verwendet, um uns sein Problem zu senden, ein ziemlich häufiges Problem in Ubuntu und Debian, das eine Teillösung hat, meine ich Lösen Sie die Abhängigkeiten eines zu installierenden Pakets. Die Abfrage lautete wie folgt:

hallo, ich habe probleme bei der installation von flash auf meinem lubuntu 13.10, ich habe ein sony vcpm120al netbook mit 2 gb ram und ca. 250 gb festplatte, wenn ich versuche, das plugin entweder per download oder über das lubuntu software center zu installieren, auf das es mich wirft Ein Fehler, es wurde nicht standardmäßig installiert, da ich denke, dass es hätte kommen sollen
Wenn ich versuche, das Paket zu installieren, wird mir mitgeteilt, dass diese Paketabhängigkeiten nicht aufgelöst werden können

Dieser Fehler kann auf zusätzliche Softwarepakete zurückzuführen sein, die fehlen oder nicht installiert werden können. Es kann sich auch um einen Konflikt zwischen Softwarepaketen handeln, die nicht zusammen installiert werden können. Im Detail Die folgenden Pakete weisen unerfüllte Abhängigkeiten auf:

flashplugin-installer: Abhängig von: libnspr4-0d, aber es wird nicht installiert

Vielen Dank im Voraus, ich füge hinzu, dass ich gerade Fenster verlassen habe und nicht wirklich weiß, wie man Lubuntu benutzt.

Was sind unerfüllte "Abhängigkeiten"?

Wenn wir ein Paket oder ein Programm in Ubuntu und Gnu / Linux installieren möchten, benötigen wir nicht nur das Paket, sondern auch ergänzende Dateien und Pakete, von denen das zu installierende Programm abhängt. Oft werden diese Pakete nicht in unserem System gefunden, daher gibt es diesen Fehler. Um dies zu lösen, müssen wir normalerweise die Pakete installieren, von denen das Programm abhängt, aber wie es hier passiert, besteht das System manchmal darauf, einen Fehler zu geben, oder wir führen die Installation nicht korrekt durch. Meistens liegt es nicht daran, aber wir haben ein kaputtes Paket von einer anderen Installation und deshalb gibt es uns den Abhängigkeitsfehler.

Lösung für den Fehler unerfüllter Abhängigkeiten

Um dies zu lösen, ist es am praktischsten, das Terminal zu öffnen und Folgendes zu schreiben

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get update

sudo apt-get -f installieren

Die ersten Befehle veranlassen das System, den Speicher von Paketen und die Installation zu bereinigen, sowohl das System von verwaisten Paketen, dh von Paketen, die zu einem Zeitpunkt von einer Anwendung verwendet wurden und von keinem Programm mehr verwendet werden. Der dritte Befehl aktualisiert das Apt-System. Der letzte Befehl behebt alle defekten Abhängigkeiten, die auf dem System vorhanden sind.

Danach kann die Installation korrekt durchgeführt werden. In diesem speziellen Fall würde ich empfehlen, das Terminal zu öffnen und Folgendes einzugeben

sudo apt-get install lubuntu-beschränkte-Extras

Dadurch wird eine Reihe von Programmen installiert, die als notwendige Extras für Anfänger klassifiziert sind. Unter ihnen wäre das Paket, um Flash in unserem System zu haben. Wenn dies auch nicht funktioniert, um Flash zu haben, ist es am direktesten und sichersten, in das Terminal zu schreiben

sudo apt-get installieren flashplugin-installer

Wenn die Installation von Lubuntu korrekt ist, reicht dies aus, um das Problem von Lukas, dem Leser, der uns geschrieben hat, zu lösen. Erinnern Sie uns abschließend daran, dass Sie uns bei Fragen oder Wünschen jederzeit kontaktieren können. Wenn es in unserer Macht steht, werden wir es lösen.

Mehr Informationen - DEB-Pakete schnell und einfach installieren, Synaptic, ein Debianite-Manager in Ubuntu,


Der Inhalt des Artikels entspricht unseren Grundsätzen von redaktionelle Ethik. Um einen Fehler zu melden, klicken Sie auf hier.

61 Kommentare, hinterlasse deine

Hinterlasse einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert mit *

*

*

  1. Verantwortlich für die Daten: Miguel Ángel Gatón
  2. Zweck der Daten: Kontrolle von SPAM, Kommentarverwaltung.
  3. Legitimation: Ihre Zustimmung
  4. Übermittlung der Daten: Die Daten werden nur durch gesetzliche Verpflichtung an Dritte weitergegeben.
  5. Datenspeicherung: Von Occentus Networks (EU) gehostete Datenbank
  6. Rechte: Sie können Ihre Informationen jederzeit einschränken, wiederherstellen und löschen.

  1.   15400 sagte

    Danke, ich habe diesen Fehler bekommen und damit ist er verschwunden. Grüße!

    1.    PEDRO sagte

      danke es hat sehr gut funktioniert

      1.    Fabian sagte

        Vielen Dank, sehr hilfreich.

  2.   jerson sagte

    gut Ich hoffe, Sie können mir helfen, Desktop-Benutzer "Medium Level" Ich habe xubuntu 13.10 32b, ich möchte wissen, ob mit diesen Befehlen Um dies zu lösen, ist es am praktischsten, das Terminal zu öffnen und Folgendes zu schreiben

    sudo apt-get autoremove

    sudo apt-get autoclean

    sudo apt-get update

    sudo apt-get -f installieren
    Es kann die Repositorys von denen bereinigen, die ich nicht mehr benutze, und das System ohne Fehler verlassen.

  3.   carlos sagte

    Nun, ich hatte Ubuntu 13.11 und habe es damit gelöst

    sudo apt-get autoclean und dann sudo install -f und dann neustart erschreckten mich, als ich es einschaltete alles gelöst = D.
    Ich hoffe es dient dir salu2

  4.   Xinai sagte

    ich danke Ihnen!

  5.   Neuer Linerobotic sagte

    Sehr guter Partner, hier ist ein Skript, das alles für Sie erledigt. Ein Partner ist ein Systembereinigungsprogramm, das diese Art von Problem nur dann beseitigt, wenn apt-get install -f weiterhin besteht http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ sehr empfehlenswerte grüße kollegen 🙂

  6.   Hector munoz sagte

    Ich möchte ein Programm installieren, das für uns Elektronik nützlich ist. Es heißt piklab, aber jedes Mal, wenn ich es versuche, erhalte ich einen Fehler mit diesen Dingen der Abhängigkeit von Deseria. Hilf mir, danke

    1.    david259 sagte

      http://ubuntuforums.org/showthread.php?t=123481 Sie haben dies für Piklab versucht. Ich hoffe, es funktioniert für Sie

  7.   pedro sagte

    installiere openoffice anstelle von libreoffice, und jetzt habe ich ein Problem mit unerfüllten Abhängigkeiten, bei denen ich nichts installieren kann. Irgendeine Lösung?. Vielen Dank

    1.    FenixPlays_YT sagte

      Oh Freund, das gleiche passiert mir, wenn ich etwas entweder über den Paketmanager oder den Store installieren möchte, was mir den Fehler unerfüllter Abhängigkeiten gibt und mir sagt, dass ich 1 kaputtes Paket habe und nicht weiß, wie ich es reparieren soll. ((

  8.   Jose Carlos RG sagte

    Dies ist eine gute Erklärung für Anfänger. Schöne Grüße.

  9.   Felipe sagte

    Danke für die Info. Gruß

  10.   Dreikomp sagte

    Ich habe immer noch das gleiche Problem, ich denke, es ist eine Abhängigkeit, die sich selbst nennt

  11.   Alvaro sagte

    Hallo, gut, ich hatte einen ähnlichen Fehler bei der Installation von Java auf einem Ubuntu 14.04-Server.
    Ich habe den folgenden Prozess befolgt:

    sudo apt-get installieren default-jre

    Und ich habe etwas längeres, aber ähnliches, das kommt nach dem ersten Fehler heraus, wenn ich es erneut versuche.

    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    Möglicherweise möchten Sie "apt-get -f install" ausführen, um dies zu korrigieren:
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    ca-certificates-java: Abhängig von: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) oder
    Java6-Laufzeit-Headless
    default-jre: Abhängig von: default-jre-headless (= 2: 1.7-51)
    Abhängig von: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: Abhängig von: libtiff5 (> = 4.0.3), wird jedoch nicht installiert
    E: Abhängigkeiten nicht erfüllt. Versuchen Sie "apt-get -f install" ohne Pakete (oder geben Sie eine Lösung an).

    Ich habe also versucht, die angegebenen Schritte auszuführen, aber wenn ich die folgende Anweisung eingebe, wird folgende Fehlermeldung angezeigt:

    sudo apt-get autoremove

    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    Möglicherweise möchten Sie "apt-get -f install" ausführen, um dies zu korrigieren.
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    ca-certificates-java: Abhängig von: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) oder
    Java6-Laufzeit-Headless
    libgdk-pixbuf2.0-0: Abhängig von: libtiff5 (> = 4.0.3), aber nicht installiert
    E: Abhängigkeiten nicht erfüllt. Versuchen Sie es erneut mit -f.

    Ich bin ein ziemlicher Neuling in Linux. Könnten Sie mir helfen, um zu wissen, wie man das löst? Danke

    1.    Fingersprache sagte

      Hallo, ich erhalte einen ähnlichen Fehler wie Alvaro. Ich weiß nicht, ob Sie uns helfen können. Ich würde mich sehr darüber freuen.

  12.   Mateus Mateus sagte

    danke auch in ubuntu 15.04 funktioniert es

  13.   Leonardo R. sagte

    Großartig! Vielen Dank!

  14.   Mariano sagte

    Vielen Dank, es hat mir sehr geholfen. Ich wollte 4k youtube mp3 per Terminal installieren und konnte es nicht, weil es mir einen Fehler gab. Dann habe ich es heruntergeladen, um es zu installieren, und es gab mir Abhängigkeit von kaputten Paketen. Ihre Zeilen haben das Problem für mich gelöst. Es scheint, dass dies in Ubuntu sehr häufig ist.

  15.   Luis sagte

    Grüße Kollegen, auf denen ich Cinnemon installieren möchte, sollten keuchen und ich erhalte eine Fehlermeldung. Die folgenden Pakete haben unerfüllte Abhängigkeiten und am Ende heißt es .. Probleme konnten nicht behoben werden, Sie haben defekte Pakete gehalten.
    Ich hoffe und kann mir helfen, dieses Problem zu beheben

  16.   liriccombene sagte

    danke Grosooo wir studieren an der viedma univ de Comahue Argentina und es war die Lösung

  17.   Dyango vtz sagte

    Hallo, ich weiß, dass dies im Moment nicht relevant ist, aber ich habe einen Fehler mit einer Anwendung bei der Installation. Ich habe sie bereits ausgeführt, aber in der Statusleiste wird folgende Fehlermeldung angezeigt: «E: Das wps-office-Paket: i386 muss neu installiert werden, aber die Datei dafür kann nicht gefunden werden. " Ich habe bereits versucht, es zu deinstallieren, um es ordnungsgemäß neu installieren zu können, aber es lässt mich nicht und mir gehen die Ideen aus.

  18.   Armin sagte

    Vielen Dank

  19.   diov3rov3r sagte

    Danke: D

  20.   racer5 sagte

    Danke, es war die perfekte Lösung !!

  21.   Engel Alegre sagte

    Mein Fehler ist wegen des Weins

    angel @ alienware: ~ $ sudo apt-get install wine1.7
    [sudo] Passwort für Engel:
    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    Kann keine Packung installieren. Dies kann bedeuten, dass
    Sie haben nach einer unmöglichen Situation gefragt oder wenn Sie die Distribution verwenden
    instabil, dass einige notwendige Pakete nicht erstellt wurden oder haben
    wurde aus Incoming entfernt.
    Die folgenden Informationen können zur Lösung der Situation beitragen:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    Wein1.7: Abhängig von: Wein1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

    1.    Thomas Castelli sagte

      das gleiche passiert mir! Ich weiß nicht, wie ich es lösen soll, wenn Sie wissen, wie ich es wissen lassen muss, dass ich es lösen muss

  22.   Juan Pablo Rivera Quinzacara sagte

    danke, es hat mir sehr geholfen, ich hatte das problem nicht mehr.

  23.   max sagte

    Gut, ich möchte Ubuntu 15.10 auf 16.04 aktualisieren, aber ich erhalte diesen Fehler

    Bei der Initialisierung der Paketinformationen trat ein Problem auf, das nicht behoben werden konnte.

    Bitte melden Sie dies als Fehler im "Update-Manager" -Paket und geben Sie die folgende Fehlermeldung an:
    E: Fehler, pkgProblemResolver :: Generierte Ausfälle beheben, dies kann an gehaltenen Paketen liegen.

    wenn du mir helfen kannst danke

  24.   Jorge Rios-Gomez sagte

    Vielen Dank, ich konnte Hardinfo nicht auf meinem Ubuntu 16 installieren und mit Ihrer Hilfe funktioniert alles in Ordnung.

    Vielen Dank von Herzen und Grüße.

  25.   Felipe D sagte

    Danke, es hat mir wunderbar gedient, ich behebe viele Fehler, die ich hatte

  26.   Ana sagte

    Hallo, ich habe es versucht, aber ich bekomme immer wieder einen Fehler mit libappindicator1, wie folgt:
    Fehlgehen http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 nicht gefunden
    E: Unmöglich zu bekommen http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 nicht gefunden

    I: Einige Dateien konnten nicht abgerufen werden. Vielleicht sollte ich "apt-get update" ausführen oder es erneut mit –fix-fehlen versuchen.

    Ich versuche es mit den Optionen, die mir das Terminal bietet und nichts…. Irgendwelche Ideen?
    Thanks!

  27.   Ana sagte

    Hinweis: Alles beginnt so:
    Die folgenden Pakete haben defekte Abhängigkeiten: google-chrome-stabile: Abhängig von: libappindicator1, aber nicht installiert

  28.   Mily sagte

    Hallo ich habe ein problem Ich möchte Lightworks (Video Editor) installieren. Ich lade das Deb herunter und wenn ich es öffne, lädt es mich, aber ich kann es nicht so installieren, wie es heißt:

    Fehler: Abhängigkeit kann nicht erfüllt werden: libc6 (> = 2.17)

    Ich habe bereits versucht, alles zu tun, was Sie gesagt haben, und es funktioniert bei mir nicht.

  29.   Allodir sagte

    Ausgezeichnet! Vielen Dank !.

  30.   Sergio Cabral sagte

    Hallo, ich habe ein Ubuntu 14.04. Ich bekomme viele Fehler, wenn ich versuche, Wein herunterzuladen

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    Wein1.6: Abhängig von: Wein1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Abhängig von: wine1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

    Es sagt mir, dass wenn ich versuche, Wein 1.6 herunterzuladen, der benötigt wird, um Wein zu haben, und es sagt mir dasselbe, wenn ich versuche, Wein 1.8 über das Terminal herunterzuladen und ich den synaptischen Paketmanager aufrufe und es dort versuche und es sagt mir Dies

    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.
    E: Fehler, pkgProblemResolver :: Behebung generierter Ausfälle, die möglicherweise durch gehaltene Pakete verursacht wurden.
    E: Abhängigkeiten können nicht behoben werden
    E: Fehler, pkgProblemResolver :: Behebung generierter Ausfälle, die möglicherweise durch gehaltene Pakete verursacht wurden.
    E: Abhängigkeiten können nicht behoben werden

    Und ich habe 1000 verschiedene Dinge ausprobiert. Was kann ich tun? Hilfe

  31.   Sebastian sagte

    Hallo! Wie geht es dir? Kann ich dir eine Frage stellen?

    Ich mache das und habe immer noch Probleme bei der Installation von Qgis. Können Sie mir helfen?

    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    Kann keine Packung installieren. Dies kann bedeuten, dass
    Sie haben nach einer unmöglichen Situation gefragt oder wenn Sie die Distribution verwenden
    instabil, dass einige erforderliche Pakete noch nicht erstellt wurden oder werden
    Sie haben aus "Incoming" genommen.
    Die folgenden Informationen können zur Lösung der Situation beitragen:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    python-qgis: Abhängig von: python3-psycopg2, aber es wird nicht installiert
    Empfehlen: liblwgeom-dev, aber es wird nicht installiert
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

    Viele Grüße!

  32.   Raffael Benito sagte

    ~ $ sudo apt-get -f installieren
    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    0 aktualisiert, 0 neu installiert, 0 entfernt und 167 nicht aktualisiert

    Ich bekomme das und es gibt mir immer wieder das Problem bei der Installation von Comodo.
    Warum? Bitte helfen Sie

  33.   Carlos sagte

    Hallo gut, ich verwende Ubuntu 18.04.02 LTS. Die Situation ist, dass ich versuche, Oracle Database 11g Express Edition zu installieren, das heißt, wenn ich die Datei herunterlade, ist diese Datei RPM, offensichtlich möchte ich sie konvertieren. deb, aber zum Zeitpunkt der Installation von alien bekomme ich einige Abhängigkeitsprobleme in den Paketen debhelper und dpkg-dev.
    Für jede Lösung werde ich sehr dankbar sein.

  34.   Manuel Beltran sagte

    Perfekt, alles gut hier mit Peppermint 10
    Vielen Dank, dass Sie die Lösung geteilt haben

  35.   Tunnel69 sagte

    Gut.
    Jedes Mal, wenn ich zum Terminal gehe, erhalte ich diesen Fehler, wenn ich sudo einsetze, und ich weiß nicht, was ich tun soll.
    E: Eintrag 49 in Listendatei /etc/apt/sources.list falsch angegeben (URI-Analyse)
    E: Die Schriftartenlisten konnten nicht gelesen werden.

  36.   Juanan sagte

    Linux ist verdammt Scheiße. Seit Jahren greife ich auf verschiedene Distributionen zurück, um angeblich veraltete Geräte und immer die gleiche Geschichte zu verwenden, die verdammten Abhängigkeiten, die es nicht erlauben, praktisch alles zu installieren. Dann muss ich hören, dass Ubuntu, Kubuntu, Lubuntu ... sogar meine Großmutter benutzt es ... die Bälle. Immer wenn ich aufstehe, bin ich frustriert. Normal, dass es besser geht und mehr logero ... es erlaubt nichts zu installieren.

  37.   Mariana sagte

    Hallo, ich habe ein Problem bei der Installation von Haguichi. Ich erhalte Folgendes:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    haguichi: Es kommt darauf an: libglib2.0-0 (> = 2.48), aber 2.32.4-0ubuntu1 + 12.04ac5 wird installiert
    Abhängig von: libglib2.0-bin (> = 2.48)
    Hängt davon ab: libgtk-3-0 (> = 3.18), aber 3.4.2-0ubuntu0.9 wird installiert
    Abhängig von: libnotify4 (> = 0.7.6), aber 0.7.5-1 wird installiert
    Empfehlen: dconf-cli aber nicht installierbar
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

    Ich weiß nicht, wie ich es lösen soll. Wenn jemand weiß, bitte helfen Sie mir, danke.

  38.   daniela sagte

    Vielen Dank, am Ende habe ich es gelöst, du bist geni @

  39.   hernan sagte

    Hallo, ich habe Ubuntu 18.04 und es gibt mir den folgenden Fehler beim Versuch, npm zu installieren, ich habe NodeJS 14.04 installiert; Ich habe es bereits mit der von ihnen vorgeschlagenen Lösung versucht, aber es gibt immer wieder den gleichen Fehler, danke!

    Sudo apt install npm build-essential
    Paketliste lesen ... Fertig
    Abhängigkeitsbaum erstellen
    Statusinformationen lesen ... Fertig
    build-essential ist bereits in der neuesten Version (12.4ubuntu1).
    Kann keine Packung installieren. Dies kann bedeuten, dass
    Sie haben nach einer unmöglichen Situation gefragt oder wenn Sie die Distribution verwenden
    instabil, dass einige erforderliche Pakete noch nicht erstellt wurden oder werden
    Sie haben aus "Incoming" genommen.
    Die folgenden Informationen können zur Lösung der Situation beitragen:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    npm: Abhängig von: nodejs, aber es wird nicht installiert
    Abhängig von: node-abbrev (> = 1.0.4), aber es wird nicht installiert
    Hängt davon ab: node-ansi (> = 0.3.0-2), wird aber nicht installiert
    Hängt davon ab: Node-Ansi-Color-Table, wird aber nicht installiert
    Abhängig von: Node-Archy, aber es wird nicht installiert
    Hängt davon ab: Node-Block-Stream, wird aber nicht installiert
    Hängt davon ab: node-fstream (> = 0.1.22), wird aber nicht installiert
    Hängt davon ab: node-fstream-ignore, aber es wird nicht installiert
    Hängt davon ab: node-github-url-from-git, wird aber nicht installiert
    Hängt davon ab: node-glob (> = 3.1.21), wird aber nicht installiert
    Hängt davon ab: node-graceful-fs (> = 2.0.0), wird jedoch nicht installiert
    Hängt davon ab: Knoten erbt, wird aber nicht installiert
    Abhängig von: node-ini (> = 1.1.0), aber es wird nicht installiert
    Hängt davon ab: Node-Lockfile, wird aber nicht installiert
    Hängt davon ab: node-lru-cache (> = 2.3.0), wird aber nicht installiert
    Abhängig von: Node-Minimatch (> = 0.2.11), wird jedoch nicht installiert
    Abhängig von: node-mkdirp (> = 0.3.3), aber es wird nicht installiert
    Hängt davon ab: node-gyp (> = 0.10.9), wird aber nicht installiert
    Hängt davon ab: node-nopt (> = 3.0.1), wird aber nicht installiert
    Abhängig von: node-npmlog, aber es wird nicht installiert
    Hängt davon ab: einmal Knoten, aber es wird nicht installiert
    Hängt davon ab: node-osenv wird aber nicht installiert
    Hängt davon ab: Knoten lesen, aber es wird nicht installiert
    Abhängig von: node-read-package-json (> = 1.1.0), wird jedoch nicht installiert
    Hängt davon ab: Node-Request (> = 2.25.0), wird aber nicht installiert
    Hängt davon ab: Knoten erneut versuchen, aber es wird nicht installiert
    Abhängig von: Node-Rimraf (> = 2.2.2), aber es wird nicht installiert
    Abhängig von: Node-Semver (> = 2.1.0), aber es wird nicht installiert
    Hängt davon ab: node-sha wird aber nicht installiert
    Hängt davon ab: Node-Slide, wird aber nicht installiert
    Abhängig von: Node-Tar (> = 0.1.18), aber es wird nicht installiert
    Hängt davon ab: Knoten-Unterstrich, aber es wird nicht installiert
    Hängt davon ab: Knoten, der aber nicht installiert wird
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

  40.   sergio sagte

    Danke vielmals! Aufgrund dieser Fehler war ich monatelang nicht in der Lage, ein Programm zu installieren. Ich hatte es satt, in Foren zu suchen, und heute habe ich dieses gefunden. Schöne Grüße!

  41.   Xavier sagte

    Hallo gut, ich bin ein bisschen / ziemlich neu in Ubuntu und ich habe das folgende Problem. Ich weiß nicht, ob es der richtige Ort ist, aber wenn nicht, führe mich bitte
    Ich habe Elementary OS 5.1.7 installiert. Ich habe auf viele Arten versucht, Wine zu installieren. Nach Tutorials habe ich Repositorys installiert, ohne Erfolg. Ich habe versucht, alles zu löschen, auch wenn Sie diesen Beitrag geschrieben haben, und jetzt versuche ich, es aus dem Application Center zu installieren und es sagt mir immer wieder dasselbe «unerfüllte Abhängigkeiten»

    W: GPG-Fehler: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Die folgenden Signaturen konnten nicht überprüft werden, da der öffentliche Schlüssel nicht verfügbar ist: NO_PUBKEY DFA175A75104960E
    E: Das Repository "https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease" ist nicht signiert.
    W: Sie können nicht sicher von einem solchen Repository aus aktualisieren. Daher ist es standardmäßig deaktiviert.
    W: Weitere Informationen zum Erstellen von Repositorys und zum Konfigurieren von Benutzern finden Sie in der Manpage apt-Secure (8).
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease ist (noch) nicht verfügbar (Die folgenden Signaturen konnten nicht überprüft werden, da der öffentliche Schlüssel nicht verfügbar ist: NO_PUBKEY DFA175A75104960E)

    Ich hoffe, Sie können mir helfen, danke im Voraus.

  42.   Jorge sagte

    Hallo, wenn ich einen Editor für Latex (Texmaker) installiere, erhalte ich den folgenden Fehler und kann ihn nicht beseitigen:
    Libc6-Abhängigkeit kann nicht erfüllt werden (> = 2.29)

    dank

  43.   Januar sagte

    Hallo, ich habe einen Fehler beim Installieren des Mongodb Community Servers, wenn ich fotografiere:

    "Sudo apt-get install -y mongodb-org"

    und es gibt mir den folgenden Fehler:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    mongodb-org: Hängt davon ab: mongodb-org-server, wird aber nicht installiert
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete behalten.

    aber es hat nichts für mich gelöst veraltete Abhängigkeiten zu entfernen

  44.   cristian sagte

    Ausgezeichnet !!

  45.   Miguel Lopez sagte

    Hervorragende Informationen und es hat perfekt funktioniert. Vielen Dank

  46.   Federico sagte

    Sie können direkt zu den Ordnern /etc/apt/sources.list.dy mit einer ls-Suche gehen, für die eine Fehlermeldung angezeigt wird, und diese dann mit dem Dateinamen sudo rm löschen und ...

  47.   Mario sagte

    Vielen Dank ! Vielen Dank!

  48.   Alexander Cardozo sagte

    Ich lasse mich nicht den gleichen Fehler bekommen

  49.   Doctor Strange sagte

    Sehr gute Erklärung an anderer Stelle Ich habe keine so einfache Lösung wie deine gefunden, herzlichen Glückwunsch, wenn ich dich zu einem Kaffee einladen darf, füge den Link in deine Veröffentlichungen ein.

  50.   Maria sagte

    Hilfe Ich möchte Dampf in lubuntu installieren
    zuerst setze ich "sudo apt install steam-installer", dann sagt es mir, dass ich Steam installieren muss, ich versuche und ende mit kaputten Paketen
    (nachdem ich das obige ausprobiert habe, außer natürlich, dass der Blitz da ist, weil ich ihn habe)
    Es springt mir an:
    Kann keine Packung installieren. Dies kann bedeuten, dass
    Sie haben nach einer unmöglichen Situation gefragt oder wenn Sie die Distribution verwenden
    instabil, dass einige erforderliche Pakete noch nicht erstellt wurden oder werden
    Sie haben aus "Incoming" genommen.
    Die folgenden Informationen können zur Lösung der Situation beitragen:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    steam: i386: Hängt ab von: libgl1-mesa-dri: i386 (> = 17.3) aber es wird nicht installiert oder
    libtxc-dxtn0: i386 aber nicht installierbar
    Hängt davon ab: libgl1-mesa-glx: i386, aber es wird nicht installiert
    Hängt davon ab: libgpg-error0: i386 (> = 1.10) aber es wird nicht installiert
    Hängt davon ab: libudev1: i386, aber es wird nicht installiert
    Hängt davon ab: libxcb-dri3-0: i386 (> = 1.11.1) aber es wird nicht installiert
    Hängt davon ab: libxinerama1: i386 (> = 2: 1.1.1) aber es wird nicht installiert
    Abhängig von: libc6: i386 (> = 2.15), aber es wird nicht installiert
    Abhängig von: libstdc ++ 6: i386 (> = 4.8), aber es wird nicht installiert
    Abhängig von: libx11-6: i386, aber es wird nicht installiert
    Empfiehlt: libxss1: i386 wird aber nicht installiert
    Empfehlen: mesa-vulkan-drivers: i386 wird aber nicht installiert
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete zurückbehalten
    Was soll ich bitte tun?

  51.   Mario Barcenilla sagte

    In letzter Zeit habe ich viele Probleme mit Ubuntu, die ich in einem Video auf meinem SABIASCOMO-Kanal behandle Center of Ubuntu-Software, QtCreator, und ich entfernen es beim Aktualisieren, versuchen, es zu installieren, geben einen Fehler zurück "Paketabhängigkeiten können nicht aufgelöst werden" und in den Details Folgendes:
    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

    qtcreator: Abhängig von: libqt5concurrent5 (> = 5.0.2) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5designercomponents5 (> = 5.0.2) aber 5.5.1-3build1 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5help5 (> = 5.0.2) aber 5.5.1-3build1 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5printsupport5 (> = 5.0.2) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5script5 (> = 5.0.2) aber 5.2.1 + dfsg-1ubuntu1 ist nicht installiert
    Hängt davon ab: libqt5svg5 (> = 5.0.2) aber 5.5.1-2build1 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5xml5 (> = 5.2.0) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libgcc1 (> = 1: 4.1.1) aber 1: 4.9.3-0ubuntu4 ist nicht installiert
    Hängt davon ab: libqt5core5a (> = 5.2.0) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5designer5 (> = 5.0.2) aber 5.5.1-3build1 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5gui5 (> = 5.0.2) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5network5 (> = 5.0.2) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5qml5 (> = 5.2.0 ~ beta1) aber 5.5.1-2ubuntu6 ~ ppa1404 + 2 ist nicht installiert
    Hängt davon ab: libqt5quick5 (> = 5.1.0) aber 5.5.1-2ubuntu6 ~ ppa1404 + 2 ist nicht installiert
    Hängt davon ab: libqt5sql5 (> = 5.0.2) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libqt5widgets5 (> = 5.2.0) aber 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 ist nicht installiert
    Hängt davon ab: libstdc ++ 6 (> = 4.6) aber 4.8.4-2ubuntu1 ~ 14.04.4 ist nicht installiert
    Hängt davon ab: qtbase-abi-5-2-1 aber es ist ein virtuelles Paket
    Hängt davon ab: qtdeclarative-abi-5-2-1 aber es ist ein virtuelles Paket
    Wenn mir jemand so freundlich wäre, mir mitzuteilen, was ich tun kann, wäre ich sehr dankbar.

  52.   Alex sagte

    Und im Fall von Debian 11? wäre es das gleiche Verfahren?

  53.   Mateo sagte

    Ich erhalte einen Abhängigkeitsfehler für dieses Weinpaket, weil es angeblich kaputt ist, ich habe bereits alles getan, was die Seite mir gesagt hat, und ich weiß nicht, was sie mir empfehlen
    hier ist das Installationspaket:
    Kann keine Packung installieren. Dies kann bedeuten, dass
    Sie haben nach einer unmöglichen Situation gefragt oder wenn Sie die Distribution verwenden
    instabil, dass einige erforderliche Pakete noch nicht erstellt wurden oder werden
    Sie haben aus "Incoming" genommen.
    Die folgenden Informationen können zur Lösung der Situation beitragen:

    Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
    Winehq-Stable: Abhängig von: Wine-Stable (= 7.0.0.0 ~ Bionic-1)
    E: Probleme konnten nicht behoben werden, Sie haben defekte Pakete zurückbehalten

    ich weiß nicht was ich machen soll könnt ihr mir bitte helfen

  54.   Juli sagte

    Ausgezeichnet, es hat mir erlaubt, andere Programme zu installieren, danke

  55.   Streggonne sagte

    fantastischer Beitrag