How to download an older version of a package (downgrade) in Ubuntu with a few clicks

Download previous version of a package in Ubuntu

Although there is usually software in the official Ubuntu repositories that is already well tested, there is always the possibility that we update a package and it may not work as well as we expected. It may also be that they introduce changes that we do not like, so it may be a good idea to reinstall the previous package. Can this be done in Ubuntu? Yes, and in this article we are going to show you how download an older version using the option with graphical interface.

But before continuing we have to advise that not all packages can downgrade and that it can only be downloaded to versions that are still available in the official repositories; when a certain time passes and they eliminate a version, it will no longer be possible to download as we are going to explain here. And what software is that that will allow us to make these changes without going through the terminal? The package manager Synaptic.

Synaptic allows us to download an older version of a package

The first thing we will have to do, if we do not have it installed already, is to install Synaptic. To do this, just open the software center, search for "synaptic" and install the package or a terminal and type "sudo apt install synaptic" without the quotes. Once installed, the next step is to open the package manager. A window will appear with information that we will have to accept; If we check the box, the warning will appear again the next time we open the package manager.

With Synaptic open, we click on the magnifying glass and search for a package, such as Firefox of the example. Now, we go to the "Package" menu and choose "Force version ...".

Synaptics

A window will open like the following one where we have to choose the version you want. As you can see, at the time of writing this article we can choose between Firefox 95, the most updated, or the 93 with which Impish Indri came at the time of its launch. Firefox 94 is no longer in the repositories, so it cannot be installed with this method.

Synaptics, choose package version

To finish we will have to click on «Apply». But there is also an optional step that we must take if we do not want the package to be updated in the future: we return to the "Package" menu and choose "Lock version". With this we will avoid negative surprises in the future, but we will also be left without future news.

And this is how we can download an older version of a package in Ubuntu. Is simple and easy to remember, and it can save us headaches.


The content of the article adheres to our principles of editorial ethics. To report an error click here!.

Be the first to comment

Leave a Comment

Your email address will not be published.

*

*

  1. Responsible for the data: Miguel Ángel Gatón
  2. Purpose of the data: Control SPAM, comment management.
  3. Legitimation: Your consent
  4. Communication of the data: The data will not be communicated to third parties except by legal obligation.
  5. Data storage: Database hosted by Occentus Networks (EU)
  6. Rights: At any time you can limit, recover and delete your information.