Sõltuvused on täitmata

Kuidas lahendada täitmata paketisõltuvus Ubuntu ja derivaatidega

Kas teil on probleeme täitmata sõltuvused? Sa pole ainus.

Toon teile teema, mille meile annab lugeja probleem, ta on meie jaotise Kontakt abil saatnud meile oma probleemi, Ubuntu ja Debiani üsna levinud probleemi, millel on osaline lahendus, ma mõtlen lahendada installitava paketi sõltuvused. Päring kõlas järgmiselt:

tere, mul on probleeme lubjatu 13.10 flashi installimisega, mul on sony vcpm120al netbook, 2 gb ram ja umbes 250gb kõvakettaga, kui proovin pistikprogrammi installida kas allalaadimise või lubuntu tarkvarakeskuse kaudu, kuhu see mind viskab Viga, see ei tulnud vaikimisi installitud, kuna arvan, et see oleks pidanud tulema
kui proovin paketti installida, ütleb see mulle, et paketi sõltuvusi ei saa lahendada

See tõrge võib olla tingitud täiendavatest tarkvarapakettidest, mis puuduvad või pole installitavad. See võib olla ka konflikt tarkvarapakettide vahel, mida ei saa koos installida, ja üksikasjades. Järgmistel pakettidel on täitmata sõltuvused:

flashplugin-installer: Sõltub: libnspr4-0d, kuid seda ei installita

Tänan juba ette, lisan, et jätsin just aknad maha ja ma ei oska õieti lubuntu kasutada.

Mis on täitmata "sõltuvused"?

Kui soovime installida paketi või programmi Ubuntu ja Gnu / Linuxi, ei vaja me mitte ainult paketti, vaid ka täiendavaid faile ja pakette, millest sõltub installitav programm. Mitu korda ei leia neid pakette meie süsteemist, nii et see annab meile selle vea. Selle lahendamiseks peame tavaliselt installima paketid, millest programm sõltub, kuid nagu siin juhtub, nõuab süsteem mõnikord vea andmist või me ei tee installimist õigesti. Enamasti pole see tingitud sellest, kuid meil on mõne muu installi pakett purunenud ja seetõttu annab see meile sõltuvusvea.

Lahendus täitmata sõltuvuste veale

Selle lahendamiseks on kõige otstarbekam avada terminal ja kirjutada järgmine

sudo apt-get autoremove

Sudo Apt-Get Autoclean

sudo apt-get update

sudo apt -get -f install

Esimeste käskude tulemusel puhastatakse süsteem pakettide ja installimälust, nii tõhus kui ka puhas süsteem orvudeta pakettidest, see tähendab pakettidest, mida rakendus korraga kasutas ja mida ükski programm enam ei kasuta. Kolmas käsk värskendab Apt-süsteemi. Ja viimane käsk kõrvaldab kõik süsteemis esinevad katkised sõltuvused.

Pärast seda saab installi õigesti teha. Sel konkreetsel juhul soovitaksin terminali avada ja tippida järgmised

sudo apt-get install lubuntu-limited-extras

See installib rea programme, mis on klassifitseeritud algajate jaoks vajalikeks lisadeks. Nende hulgas oleks ka pakk, millel oleks meie süsteemis välk. Kui ka see ei toimi välgu olemasolu korral, on kõige otsesem ja ohutum kirjutada terminali

sudo apt-get install flashplugin-installer

Sellega, kui Lubuntu installimine on õige, piisab meile kirjutanud lugeja Lukase probleemi lahendamisest. Lõpuks tuletame teile meelde, et kui teil on küsimusi või taotlusi, võtke meiega kindlasti ühendust. Kui see on meie võimuses, siis lahendame selle.

Rohkem informatsiooni - DEB-pakettide kiire ja lihtne installimine, Synaptic, Debianite'i haldur Ubuntu,


Artikli sisu järgib meie põhimõtteid toimetuse eetika. Veast teatamiseks klõpsake nuppu siin.

61 kommentaari, jätke oma

Jäta oma kommentaar

Sinu e-postiaadressi ei avaldata.

*

*

  1. Andmete eest vastutab: Miguel Ángel Gatón
  2. Andmete eesmärk: Rämpsposti kontrollimine, kommentaaride haldamine.
  3. Seadustamine: teie nõusolek
  4. Andmete edastamine: andmeid ei edastata kolmandatele isikutele, välja arvatud juriidilise kohustuse alusel.
  5. Andmete salvestamine: andmebaas, mida haldab Occentus Networks (EL)
  6. Õigused: igal ajal saate oma teavet piirata, taastada ja kustutada.

  1.   15400 DIJO

    Tänan, et sain selle vea ja sellega see kadus. lugupidamisega!

    1.    PEDRO DIJO

      aitäh, see töötas väga hästi

      1.    Fabian DIJO

        Suur aitäh väga abivalmis.

  2.   kherson DIJO

    hea, ma loodan, et saate mind aidata, töölaua kasutaja "keskmine tase". Mul on xubuntu 13.10 32b, ma tahan teada, kas nende käskudega on selle lahendamiseks kõige otstarbekam avada terminal ja kirjutada järgmine

    sudo apt-get autoremove

    Sudo Apt-Get Autoclean

    sudo apt-get update

    sudo apt -get -f install
    see võib puhastada hoidlad nendest, mida ma enam ei kasuta, ja lahkuda süsteemist tõrgeteta.

  3.   carlos DIJO

    Mul oli ubuntu 13.11 ja ma lahendasin selle

    sudo apt-get autoclean ja seejärel sudo install -f ja seejärel taaskäivitamine hirmutas mind, kui lülitasin selle sisse kõik lahendatud = D
    Loodan, et see pakub teile salu2

  4.   xinai DIJO

    Aitäh !

  5.   Uus Linerobotic DIJO

    Väga hea partner, siin on skript, mis teeb kõik teie eest, partnerilt on see süsteemipuhasti programm, mis eemaldab seda tüüpi probleemid ainult juhul, kui apt-get install -f püsib http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ soojalt soovitatud kolleegid 🙂

  6.   hektor munoz DIJO

    Ma tahan installida meile elektroonika jaoks kasuliku programmi nimega piklab, kuid iga kord, kui proovin, saan vea nende deseriast sõltuvate asjadega, aidake mind tänada

    1.    david259 DIJO

      http://ubuntuforums.org/showthread.php?t=123481 proovisite seda piklabi jaoks 🙂 loodan, et see töötab teie jaoks

  7.   Pedro DIJO

    Paigaldasin libreoffice'i asemel openoffice'i ja nüüd on mul täitmata sõltuvuste probleem, mis ei lase mul midagi installida. Kas mõni lahendus? Aitäh

    1.    FenixPlays_YT DIJO

      Oh sõber, sama juhtub minuga alati, kui tahan midagi installida kas pakendihalduri kaudu või pood annab mulle täitmata sõltuvuste vea ja ütleb mulle, et mul on 1 katki pakett ja ma ei tea, kuidas seda parandada; (

  8.   Jose Carlos RG DIJO

    See on hea selgitus algajatele kasutajatele. Tervitused.

  9.   Felipe DIJO

    Tänan info eest. Tervitused

  10.   Dreicomp DIJO

    Mul on endiselt sama probleem, ma arvan, et see on sõltuvus, mis ennast kutsub

  11.   Alvaro DIJO

    Tere, hea, mul oli sarnane viga Java installimisel ubuntu 14.04 serverisse.
    Ma järgisin järgmist protsessi:

    sudo apt-get install default-jre

    Ja ma sain midagi pikemat, kuid sellega sarnast, see tuleb välja pärast esimest viga uuesti proovimisel.

    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    Selle parandamiseks võite käivitada "apt-get -f install":
    Järgmistel pakettidel on täitmata sõltuvused:
    ca-sertifikaadid-java: sõltub: openjdk-7-jre-peata (> = 7 ~ u3-2.1.1 ~ pre1-1) või
    java6-runtime-peata
    default-jre: sõltub: default-jre-headless (= 2: 1.7-51)
    Sõltub: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: sõltub: libtiff5 (> = 4.0.3), kuid ei installi
    E: sõltuvused pole täidetud. Proovige "apt-get -f install" ilma pakettideta (või määrake lahendus).

    Nii et proovisin järgida näidatud samme, kuid järgmise juhise sisestamisel kuvatakse järgmine tõrge:

    sudo apt-get autoremove

    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    Selle parandamiseks võiksite käivitada "apt-get -f install".
    Järgmistel pakettidel on täitmata sõltuvused:
    ca-sertifikaadid-java: sõltub: openjdk-7-jre-peata (> = 7 ~ u3-2.1.1 ~ pre1-1) või
    java6-runtime-peata
    libgdk-pixbuf2.0-0: sõltub: libtiff5 (> = 4.0.3), kuid pole installitud
    E: sõltuvused pole täidetud. Proovige uuesti, kasutades klahvi -f.

    Ma olen linuxis üsna uus. Kas saaksite mind aidata, kuidas seda lahendada? Tänan

    1.    sõrme keel DIJO

      Tere, mul on Alvaro veaga sarnane viga, ma ei tea, kas saate meid aidata, ma hindaksin seda väga

  12.   mateus mateus DIJO

    aitäh isegi ubuntus 15.04 see töötab

  13.   Leonardo R. DIJO

    Suurepärane! Tänud!

  14.   Mariano DIJO

    Suur aitäh, see teenis mulle palju. Tahtsin installida 4k youtube mp3 terminali kaudu ja ma ei saanud seda teha, kuna see andis mulle vea, siis laadisin selle installimiseks alla ja see andis mulle sõltuvust katkistest pakettidest. Teie read lahendasid minu jaoks probleemi. Tundub, et see on ubuntus väga levinud.

  15.   Luis DIJO

    Tervitused, kolleegid, kellele üritan kaneeli installida, peaksid vilistama ja saan vea. Järgmistel pakettidel on täitmata sõltuvused ja lõpus on kirjas .. Probleeme ei õnnestunud lahendada, teil on katkised paketid alles.
    Loodan ja saan aidata seda probleemi lahendada

  16.   liriccombene DIJO

    aitäh, Grosooo, mida me õpime Argentinas, Cmahue linnas, ja see oli lahendus

  17.   Dyango vtz DIJO

    tere, ma tean, et see pole praegu asjakohane, kuid mul on rakendusega installimisel viga, mul on see juba töötav, kuid olekuribal kuvatakse see viga: «E: pakett wps-office: i386 peab uuesti installida, kuid selle faili ei õnnestu leida. " Olen seda juba proovinud desinstallida, et saaksin seda korralikult uuesti installida, kuid see ei lase mul ja ideed on otsas.

  18.   Gabriel DIJO

    tänan väga

  19.   diov3rov3r DIJO

    Aitäh; D

  20.   racer5 DIJO

    Aitäh, see oli ideaalne lahendus !!

  21.   Ingel Alegre DIJO

    Minu viga on veini pärast

    ingel @ alienware: ~ $ sudo apt-get install vein1.7
    [sudo] ingli parool:
    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    Ei saa mõnda pakki installida. See võib seda tähendada
    küsisite võimatut olukorda või kui kasutate levitamist
    ebastabiilne, et mõnda vajalikku paketti pole loodud või on
    teisaldati sissetulevast.
    Järgmine teave aitab olukorda lahendada:

    Järgmistel pakettidel on täitmata sõltuvused:
    vein1.7: sõltub: vein1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

    1.    Thomas Castelli DIJO

      sama juhtub ka minuga! Ma ei tea, kuidas seda lahendada, kui teate, kuidas mulle teada anda, et ma pean selle lahendama

  22.   Juan Pablo Rivera Quinzacara DIJO

    aitäh, see aitas mind palju, mul polnud enam probleemi.

  23.   max DIJO

    hea, ma tahan uuendada Ubuntu 15.10 versioonile 16.04, kuid saan selle vea

    Paketi teabe lähtestamisel ilmnes võimatu parandada probleem.

    Palun teatage sellest paketis "update-manager" veast ja lisage järgmine tõrketeade:
    E: Viga, pkgProblemResolver :: Lahendage loodud katkestused, see võib olla tingitud ootel pakettidest.

    kui saate mind aidata, aitäh

  24.   Jorge Rios-Gomez DIJO

    Suur aitäh, ma ei saanud oma Ubuntu 16 oma hardinfot installida ja teie abiga töötab kõik korras.

    Tänan teid südamest ja tervitades.

  25.   Philip D DIJO

    Aitäh, see teenis mind suurepäraselt, parandasin palju vigu, mis mul olid

  26.   Ana DIJO

    Tere, olen proovinud, kuid mul on libappindicator1-ga pidevalt viga, näiteks:
    Viga http://co.archive.ubuntu.com/ubuntu/ utoopilised värskendused / peamine libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 ei leitud
    E: võimatu saada http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 ei leitud

    E: Mõnda faili ei õnnestunud hankida, võib-olla peaksin käivitama "apt-get update" või proovima uuesti failiga –fix-missing?

    Proovin terminali pakutavate võimalustega ja mitte midagi ... Ideid?
    Aitäh!

  27.   Ana DIJO

    Märkus: kõik algab järgmiselt:
    Järgmistel pakettidel on katkised sõltuvused: google-chrome-stabiilne: sõltub: libappindicator1, kuid pole installitud

  28.   mily DIJO

    Tere, mul on probleem. Ma tahan installida Lightworks (Video Editor), laadin alla deb ja laadin selle avades alla, kuid see ei lase mul seda installida nagu öeldud:

    Viga: ei saa rahuldada sõltuvust: libc6 (> = 2.17)

    Olen juba proovinud teha kõike, mida ütlesite, ja see ei tööta minu jaoks.

  29.   allodir DIJO

    Suurepärane, suur aitäh!

  30.   Sergio Cabral DIJO

    Tere, mul on Ubuntu 14.04. Veini allalaadimisel proovin palju vigu

    Järgmistel pakettidel on täitmata sõltuvused:
    vein1.6: sõltub: vein1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Oleneb: vein1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

    See ütleb mulle, et kui proovin alla laadida veini 1.6, mis on vajalik veini saamiseks, ja see ütleb mulle ka sama, kui proovin terminali kaudu alla laadida veini 1.8 ja sisenen sünaptiliste pakettide haldurisse ja proovin seal ning see ütleb mulle seda

    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.
    E: Viga, pkgProblemResolver :: Lahendage loodud katkestused, selle põhjuseks võivad olla ootel olevad paketid.
    E: sõltuvusi ei õnnestu parandada
    E: Viga, pkgProblemResolver :: Lahendage loodud katkestused, selle põhjuseks võivad olla ootel olevad paketid.
    E: sõltuvusi ei õnnestu parandada

    Ja ma olen proovinud 1000 erinevat asja. Mida ma saan teha? abi

  31.   Sebastian DIJO

    Tere! Kuidas sul läheb? Kas ma võin sinult midagi küsida?

    Ma teen seda ja mul on endiselt probleeme Qgise installimisega. Kas saaksite mind aidata?

    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    Ei saa mõnda pakki installida. See võib seda tähendada
    küsisite võimatut olukorda või kui kasutate levitamist
    ebastabiilne, et mõnda vajalikku paketti pole veel loodud või need on
    Nad on võtnud "Saabuvatest".
    Järgmine teave aitab olukorda lahendada:

    Järgmistel pakettidel on täitmata sõltuvused:
    python-qgis: sõltub: python3-psycopg2, kuid seda ei installita
    Soovitage: liblwgeom-dev, kuid seda ei installita
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

    Tervitused!

  32.   Raphael Benito DIJO

    ~ $ sudo apt-get -f install
    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    0 värskendatud, 0 uut installitakse, 0 eemaldamiseks ja 167 värskendamata

    Ma saan selle aru ja see tekitab mulle pidevalt probleemi Comodo installimisel.
    Miks? Palun aidake

  33.   Carlos DIJO

    Tere, hea, kasutan ubuntu 18.04.02 LTS-i. Olukord on see, et proovin installida oracle andmebaasi 11g express edition, st faili allalaadimisel on see fail rpm, ilmselt tahan selle teisendada .deb-ks, kuid hetkel on välismaalase installimisel tekkinud pakettides debhelper ja dpkg-dev mõned sõltuvuse probleemid.
    mis tahes lahendus, olen väga tänulik.

  34.   Manuel Beltran DIJO

    Ideaalne, kõik hea siin Piparmündi 10 abil
    Täname lahenduse jagamise eest

  35.   Tunnel69 DIJO

    Väga hea.
    Iga kord, kui terminali lähen, ilmub sudo panemisel see viga ja ma ei tea, mida teha.
    E: loendifailis /etc/apt/sources.list on valesti määratud kirje 49 (URI sõelumine)
    E: Fondiloendeid ei õnnestunud lugeda.

  36.   Juanan DIJO

    linux on kuradima pask. Olen aastaid kasutanud erinevaid levitusi, et väidetavalt kasutada vananenud seadmeid ja alati ühte ja sama lugu, neetud sõltuvusi, mis ei võimalda praktiliselt midagi installida. Siis pean kuulma, et Ubuntu, kubuntu, lubuntu ... isegi mu vanaema kasutab seda ... pallid. Alati, kui ma vaimustun, olen pettunud. Normaalne, et see läheb paremini ja logero ... see ei võimalda midagi installida.

  37.   Mariana DIJO

    Tere, mul on Haguichi installimisel probleem, saan järgmise:

    Järgmistel pakettidel on täitmata sõltuvused:
    haguichi: See sõltub: libglib2.0-0 (> = 2.48), kuid installitakse 2.32.4-0ubuntu1 + 12.04ac5
    Sõltub: libglib2.0-bin (> = 2.48)
    Oleneb: libgtk-3-0 (> = 3.18), kuid installitakse 3.4.2-0ubuntu0.9
    Sõltub: libnotify4 (> = 0.7.6), kuid installitakse 0.7.5-1
    Soovitage: dconf-cli, kuid pole installitav
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

    Ma ei tea, kuidas seda lahendada, kui keegi teab, palun aidake mind, aitäh.

  38.   Daniela DIJO

    Suur aitäh, lõpuks lahendasin selle ära, sa oled geni @

  39.   Hernan DIJO

    Tere, mul on ubuntu 18.04 ja see annab mulle npm installimisel järgmise tõrke, mul on installitud nodejs 14.04; Proovisin juba nende pakutavat lahendust, kuid see annab sama vea, aitäh!

    sudo apt install npm build-essential
    Pakettide loendi lugemine ... Valmis
    Sõltuvuspuu loomine
    Olekuteabe lugemine ... Valmis
    build-essential on juba oma uusimas versioonis (12.4ubuntu1).
    Ei saa mõnda pakki installida. See võib seda tähendada
    küsisite võimatut olukorda või kui kasutate levitamist
    ebastabiilne, et mõnda vajalikku paketti pole veel loodud või need on
    Nad on võtnud "Saabuvatest".
    Järgmine teave aitab olukorda lahendada:

    Järgmistel pakettidel on täitmata sõltuvused:
    npm: sõltub: nodejs, kuid seda ei installita
    Sõltub: node-short (> = 1.0.4), kuid seda ei installita
    Sõltub: node-ansi (> = 0.3.0-2), kuid seda ei installita
    Sõltub: node-ansi-color-table, kuid seda ei installita
    Oleneb: node-archy, kuid seda ei installita
    Sõltub: node-block-stream, kuid seda ei installita
    Sõltub: node-fstream (> = 0.1.22), kuid seda ei installita
    Sõltub: node-fstream-ignore, kuid seda ei installita
    Sõltub: node-github-url-from-git, kuid seda ei installita
    Sõltub: node-glob (> = 3.1.21), kuid seda ei installita
    Sõltub: node-graceful-fs (> = 2.0.0), kuid seda ei installita
    Sõltub: sõlm pärib, kuid seda ei installita
    Sõltub: node-ini (> = 1.1.0), kuid seda ei installita
    Sõltub: node-lockfile, kuid seda ei installita
    Sõltub: node-lru-cache (> = 2.3.0), kuid seda ei installita
    Sõltub: node-minimatch (> = 0.2.11), kuid seda ei installita
    Sõltub: node-mkdirp (> = 0.3.3), kuid seda ei installita
    Sõltub: node-gyp (> = 0.10.9), kuid seda ei installita
    Sõltub: node-nopt (> = 3.0.1), kuid seda ei installita
    Sõltub: node-npmlog, kuid seda ei installita
    Sõltub: üks kord sõlme, kuid seda ei installita
    Sõltub: node-osenv, kuid seda ei installita
    Oleneb: sõlme loe, kuid seda ei installita
    Sõltub: node-read-package-json (> = 1.1.0), kuid seda ei installita
    Sõltub: sõlm-taotlus (> = 2.25.0), kuid seda ei installita
    Sõltub: proovige uuesti, kuid seda ei installita
    Sõltub: node-rimraf (> = 2.2.2), kuid seda ei installita
    Sõltub: node-semver (> = 2.1.0), kuid seda ei installita
    Sõltub: node-sha, kuid seda ei installita
    Sõltub: node-slide, kuid seda ei installita
    Sõltub: node-tar (> = 0.1.18), kuid seda ei installita
    Sõltub: sõlme-alakriips, kuid seda ei installita
    Sõltub: sõlm-mis, kuid ei installi
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

  40.   sergio DIJO

    Tänud! Olin mitu kuud, ilma et oleksin saanud nende vigade tõttu programmi installida, väsisin foorumitest otsimisest ja leidsin täna selle üles. Tervitused!

  41.   Javier DIJO

    tere, hea, ma olen ubuntuga natuke / üsna algaja ja mul on järgmine probleem, ma ei tea, kas see on õige koht, aga kui ei, siis palun juhendage mind.
    Mul on installitud elementaarsete versioonide 5.1.7. Olen proovinud mitmel viisil veini installida, järgides õpetusi, paigaldades edutult hoidlaid, proovisin kõik kustutada isegi nii, nagu te sellesse postitusse panite, ja proovin nüüd rakenduskeskusest installida ja see ütleb mulle pidevalt sama "täitmata sõltuvused"

    W: GPG viga: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Järgmisi allkirju ei õnnestunud kontrollida, kuna avalik võti pole saadaval: NO_PUBKEY DFA175A75104960E
    E: hoidla "https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease" pole alla kirjutatud.
    W: Sellisest hoidlast ei saa ohutult värskendada ja seetõttu on see vaikimisi keelatud.
    W: Hoidlate loomise ja kasutajate konfigureerimise kohta leiate üksikasju manuslehelt apt-secure (8).
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease pole (veel) saadaval (järgmisi allkirju ei õnnestunud kontrollida, kuna avalik võti pole saadaval: NO_PUBKEY DFA175A75104960E)

    Loodan, et saate mind aidata, aitäh juba ette.

  42.   Jorge DIJO

    Tere! Latexi (texmaker) redaktori installimisel annab see järgmise tõrke ja ma ei saa seda kõrvaldada:
    Ei saa rahuldada libc6 sõltuvust (> = 2.29)

    tänan

  43.   Ian DIJO

    Tere, mul on viga mongodb-kogukonnaserveri installimisel, kui ma pildistan:

    "Sudo apt-get install -y mongodb-org"

    ja see annab mulle järgmise vea:

    Järgmistel pakettidel on täitmata sõltuvused:
    mongodb-org: sõltub: mongodb-org-server, kuid seda ei installita
    E: Probleeme ei õnnestunud parandada, teil on katkised pakid alles.

    kuid see pole minu jaoks midagi lahendanud, eemaldan iganenud sõltuvused

  44.   Cristian DIJO

    suurepärane !!

  45.   miguel lopez DIJO

    Suurepärane teave ja see toimis suurepäraselt. Suur aitäh

  46.   Federico DIJO

    Võite otse minna kaustadesse /etc/apt/sources.list.dy, otsides ls, mis neist annab vea, ja seejärel kustutada see sudo rm-i failinimega ja sisestada ...

  47.   Mario DIJO

    Aitäh! Aitäh!

  48.   Aleksander kardozo DIJO

    Ma ei lase endal sama viga saada

  49.   doktor Strange DIJO

    Väga hea seletus mujal, ma ei suutnud leida nii lihtsat lahendust kui teie oma, palju õnne, kui saan teid kohvile kutsuda, pange link oma väljaannetesse.

  50.   Maarja DIJO

    Abi Soovin lubuntusse auru installida
    esiteks panin "sudo apt install steam-installer", siis ütleb mulle, et pean auru panema, proovin lõpuks katkiseid pakette
    (pärast ülaltoodud proovimist, välja arvatud muidugi see välk, sest mul on see olemas)
    See hüppab mulle:
    Ei saa mõnda pakki installida. See võib seda tähendada
    küsisite võimatut olukorda või kui kasutate levitamist
    ebastabiilne, et mõnda vajalikku paketti pole veel loodud või need on
    Nad on võtnud "Saabuvatest".
    Järgmine teave aitab olukorda lahendada:

    Järgmistel pakettidel on täitmata sõltuvused:
    steam: i386: sõltub: libgl1-mesa-dri: i386 (> = 17.3), kuid seda ei installita ega
    libtxc-dxtn0: i386, kuid pole installitav
    Sõltub: libgl1-mesa-glx: i386, kuid seda ei installita
    Sõltub: libgpg-error0: i386 (> = 1.10), kuid seda ei installita
    Sõltub: libudev1: i386, kuid seda ei installita
    Sõltub: libxcb-dri3-0: i386 (> = 1.11.1), kuid seda ei installita
    Sõltub: libxinerama1: i386 (> = 2: 1.1.1), kuid seda ei installita
    Sõltub: libc6: i386 (> = 2.15), kuid seda ei installita
    Sõltub: libstdc ++ 6: i386 (> = 4.8), kuid seda ei installita
    Sõltub: libx11-6: i386, kuid seda ei installita
    Soovitage: libxss1: i386, kuid seda ei installita
    Soovitage: mesa-vulkan-draiverid: i386, kuid ei installita
    E: Probleeme ei õnnestunud parandada, olete säilitanud katkised pakendid
    Mida ma teen, palun?

  51.   Mario Barcenilla DIJO

    Viimasel ajal on mul Ubuntuga palju probleeme, käsitlen neid oma SABIASCOMO kanalis olevas videos, nii et Ubuntu 14.04 LTS-i uuesti installimisel 32-bitisele arvutile ja seejärel värskendamisel tekkis uudishimu, sest enne värskendamist installisin ma Ubuntu tarkvara keskus, QtCreator ja ma eemaldame selle värskendamisel, selle installimine tagastab tõrketeate "Paketisõltuvusi ei saa lahendada" ja jaotises Üksikasjad järgmist:
    Järgmistel pakettidel on täitmata sõltuvused:

    qtcreator: oleneb: libqt5concurrent5 (> = 5.0.2), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Sõltub: libqt5designercomponents5 (> = 5.0.2), kuid 5.5.1-3build1 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5help5 (> = 5.0.2), kuid 5.5.1-3build1 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5printsupport5 (> = 5.0.2), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5script5 (> = 5.0.2), kuid 5.2.1 + dfsg-1ubuntu1 pole installitud
    Oleneb: libqt5svg5 (> = 5.0.2), kuid 5.5.1-2build1 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5xml5 (> = 5.2.0), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Sõltub: libgcc1 (> = 1: 4.1.1), kuid 1: 4.9.3-0ubuntu4 pole installitud
    Oleneb: libqt5core5a (> = 5.2.0), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5designer5 (> = 5.0.2), kuid 5.5.1-3build1 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5gui5 (> = 5.0.2), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5network5 (> = 5.0.2), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5qml5 (> = 5.2.0 ~ beeta1), kuid 5.5.1-2ubuntu6 ~ ppa1404 + 2 pole installitud
    Oleneb: libqt5quick5 (> = 5.1.0), kuid 5.5.1-2ubuntu6 ~ ppa1404 + 2 pole installitud
    Oleneb: libqt5sql5 (> = 5.0.2), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libqt5widgets5 (> = 5.2.0), kuid 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 pole installitud
    Oleneb: libstdc ++ 6 (> = 4.6), kuid 4.8.4-2ubuntu1 ~ 14.04.4 pole installitud
    Oleneb: qtbase-abi-5-2-1, kuid see on virtuaalne pakett
    Oleneb: qtdeclarative-abi-5-2-1, kuid see on virtuaalne pakett
    Kui keegi oleks nii lahke ja annaks mulle teada, mida ma teha saan, oleksin väga tänulik.

  52.   Alex DIJO

    Ja debian 11 puhul? kas see oleks sama protseduur?

  53.   Mateo DIJO

    Saan selle veinipaketi puhul sõltuvuse vea, kuna see väidetavalt on katki, tegin juba kõik, mida leht mulle ütles ja ma ei tea, mida nad soovitavad mul teha
    siin on installipakett:
    Ei saa mõnda pakki installida. See võib seda tähendada
    küsisite võimatut olukorda või kui kasutate levitamist
    ebastabiilne, et mõnda vajalikku paketti pole veel loodud või need on
    Nad on võtnud "Saabuvatest".
    Järgmine teave aitab olukorda lahendada:

    Järgmistel pakettidel on täitmata sõltuvused:
    veinikvaliteetne: sõltub: veinistabiilne (= 7.0.0.0 ~ bioonne-1)
    E: Probleeme ei õnnestunud parandada, olete säilitanud katkised pakendid

    Ma ei tea, mida teha, kas saate mind aidata

  54.   Juuli DIJO

    Suurepärane see võimaldas mul installida muid programme, aitäh

  55.   streggonne DIJO

    fantastiline panus