Hankige oma 32-bitises Linuxis uuesti Google Chrome'i tugi

kroom ubuntul

Nagu Google detsembris teatas, Google Chrome'i tugi 32-bitistel Linuxi süsteemidel on lõppenud samal kuul. Kõigil kasutajatel, kes jätkavad selle rakenduse kasutamist, soovitatakse see enam loobuda, sest kuigi nad saavad seda ka edaspidi käitada, ei saa nad enam värskendusi, sealhulgas vajalikke turvapaiku.

Teiselt poolt rakendus Tundub, et endiselt toetatakse Chromiumi 32-bitise jaoks Linuxi süsteemides ja seda võib pidada tekkiva olukorra alternatiiviks. Kuna aga ametlikku Google Chrome'i 32-bitiste pakettide hoidlat enam pole, saavad kasutajad, kellel on 64-bitine süsteem, ja kes kasutavad seda rakenduse versiooni paketi värskendamisel saavad nad tõrketeate. Õnneks on sellel lihtne lahendus.

Kui kasutate 32-bitist Chrome'i Ubuntu x64 süsteemi all, saate selle rakenduse paketi värskendamise proovimisel järgmise teate:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release
Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file) Some index files failed to download. They have been ignored, or old ones used instead.

Parandage see väike viga Ubuntus on see väga lihtne ja peate failis muutma ainult väikest rida /etc/apt/sources.list.d/google-chrome.list. Lisage lihtsalt jaotise "deb" järele tekst "[arch = amd64]" või kasutage järgmist käsku:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

Eelmine fail taastatakse iga värskendusega mis tuleb teha programmiga, nii et kui te ei soovi minna samade toimingutega nagu varem, soovitame teil selleks lisada faili atribuut + i muutumatu. Selleks täitke sellel järgmine juhis:

</p>
<p class="source-code">sudo chattr -i /etc/apt/sources.list.d/google-chrome.list</p>
<p class="source-code">

Artikli sisu järgib meie põhimõtteid toimetuse eetika. Veast teatamiseks klõpsake nuppu siin.

5 kommentaari, jätke oma

Jäta oma kommentaar

Sinu e-postiaadressi ei avaldata.

*

*

  1. Andmete eest vastutab: Miguel Ángel Gatón
  2. Andmete eesmärk: Rämpsposti kontrollimine, kommentaaride haldamine.
  3. Seadustamine: teie nõusolek
  4. Andmete edastamine: andmeid ei edastata kolmandatele isikutele, välja arvatud juriidilise kohustuse alusel.
  5. Andmete salvestamine: andmebaas, mida haldab Occentus Networks (EL)
  6. Õigused: igal ajal saate oma teavet piirata, taastada ja kustutada.

  1.   rztv23 DIJO

    oi nii hea: v

  2.   Libahunt DIJO

    Aitäh

  3.   Oswaldo Hernandez DIJO

    Ok, artikkel on väga hea, kuid need, kes kasutavad 32-bitist arhitektuuri, kuidas me 64-bitise kroomi installime, kuna see viskab järgmise tõrke:
    # dpkg -i google-chrome-stabil_current_amd64.deb
    dpkg: viga faili google-chrome-stabil_current_amd64.deb (–install) töötlemisel:
    paketi arhitektuur (amd64) ei vasta süsteemi (i386) arhitektuurile
    Töötlemisel ilmnesid vead:
    google-chrome-stabil_current_amd64.deb

    1.    Jorge DIJO

      Võib-olla pole see kommentaar vanale ajaveebile kasulik, küll aga sellele, kes seda loeb.
      32-bitised süsteemid ei toeta 64-bitisi programme, mistõttu neid isegi ei installita (võimaluse korral tagurpidi, 64-bitised süsteemid toetavad 32-bitiseid programme).
      seoses

  4.   Ali Gonzalez DIJO

    Artikli sisu ei ole pealkirjaga kooskõlas. Asi on selles, et teil on 32-bitine Ubuntu süsteem ja soovite Chrome'i installida 32-bitise jaoks, isegi kui seda enam ei toetata. Teil pole 64-bitist süsteemi.