وابستگی های انجام نشده

چگونه می توان وابستگی بسته انجام نشده در اوبونتو و مشتقات را حل کرد

آیا شما با مشکل روبرو هستید وابستگی های انجام نشده؟ شما تنها فرد نیستید.

موضوعی را برای شما آورده ام که توسط یک مشکل خواننده به ما داده شده است ، وی از بخش تماس ما برای ارسال مشکل خود استفاده کرده است ، منظور من وابستگی های یک بسته برای نصب را برطرف کنید. پرس و جو اینگونه خوانده می شود:

سلام ، من در نصب فلش روی lubuntu 13.10 مشکلی دارم ، من یک نت بوک sony vcpm120al دارم ، با 2 گیگابایت رم و حدود 250 گیگابایت هارد دیسک ، وقتی که می خواهم پلاگین را یا با بارگیری یا با مرکز نرم افزار lubuntu نصب کنم ، مرا به این سمت سوق می دهد یک خطا ، به طور پیش فرض نصب نشده است ، همانطور که فکر می کنم باید اتفاق می افتاد
هنگامی که من سعی می کنم بسته را نصب کنم به من می گوید که این وابستگی های بسته قابل حل نیست

این خطا می تواند به دلیل بسته های نرم افزاری اضافی باشد که مفقود شده اند یا قابل نصب نیستند. همچنین ممکن است تعارضی بین بسته های نرم افزاری باشد که نمی توانند با هم نصب شوند. و جزئیات این بسته های زیر وابستگی های نامشخصی دارند:

flashplugin-installer: بستگی دارد: libnspr4-0d اما نصب نمی شود

پیشاپیش از شما متشکرم ، من اضافه می کنم که من فقط پنجره ها را ترک کردم و واقعا نمی دانم چگونه از lubuntu استفاده کنم.

"وابستگی" های انجام نشده چیست؟

وقتی می خواهیم یک بسته یا برنامه را در اوبونتو و در Gnu / Linux نصب کنیم ، نه تنها به بسته نیاز داریم بلکه به پرونده ها و بسته های مکمل نیز نیاز داریم ، برنامه ای که می خواهیم نصب کنیم به آنها بستگی دارد. بسیاری از اوقات این بسته ها در سیستم ما یافت نمی شوند ، بنابراین این خطا را به ما می دهد. برای حل این مسئله ما معمولاً باید بسته هایی را نصب کنیم که برنامه به آنها بستگی دارد ، اما همانطور که در اینجا اتفاق می افتد ، گاهی اوقات سیستم اصرار دارد که خطایی بدهد یا ما نصب را به درستی انجام نمی دهیم. بیشتر اوقات به این دلیل نیست بلکه ما یک بسته خراب از نصب دیگری داریم و به همین دلیل خطای وابستگی را به ما می دهد.

راه حل خطای وابستگی های انجام نشده

برای حل این ، عملی ترین کار باز کردن ترمینال و نوشتن موارد زیر است

sudo apt-get حرکت خودکار

sudo apt-get autoclean

کنید: sudo apt-get برای بروز رسانی

sudo apt-get -f نصب کنید

اولین دستورات باعث می شود که سیستم حافظه بسته ها و نصب آنها تمیز شود ، هم سیستم موثر و هم سیستم را از بسته های یتیم تمیز کند ، یعنی بسته هایی که در یک زمان توسط برنامه ای استفاده می شدند و دیگر هیچ برنامه ای از آنها استفاده نمی کند. دستور سوم سیستم Apt را به روز می کند و آخرین دستور ، وابستگی های شکسته شده در سیستم را برطرف می کند.

پس از این ، نصب می تواند به درستی انجام شود. در این حالت خاص ، توصیه می کنم پایانه را باز کرده و موارد زیر را تایپ کنید

sudo apt-get موارد اضافی با محدودیت lubuntu را نصب کنید

با این کار مجموعه ای از برنامه ها نصب می شوند که به عنوان موارد اضافی ضروری برای کاربران تازه کار طبقه بندی می شوند. از جمله آنها بسته ای است که فلش در سیستم ما وجود دارد. اگر این کار برای داشتن فلش هم جواب نداد ، مستقیم ترین و مطمئن ترین کار نوشتن در ترمینال است

sudo apt-get نصب flashplugin-installer

با این کار ، اگر نصب Lubuntu درست باشد ، برای حل مشکل لوکاس ، خواننده ای که برای ما نامه نوشته است ، کافی است. در پایان به شما یادآوری می کنیم که در صورت داشتن هرگونه سوال یا درخواست ، در تماس با ما دریغ نکنید. اگر در توان ما باشد ، آن را حل خواهیم کرد.

اطلاعات بیشتر - نصب بسته های DEB به سرعت و به راحتی, Synaptic ، یک مدیر دبیانیت در اوبونتو,


محتوای مقاله به اصول ما پیوست اخلاق تحریریه. برای گزارش یک خطا کلیک کنید اینجا.

60 نظر ، نظر خود را بگذارید

نظر خود را بگذارید

نشانی ایمیل شما منتشر نخواهد شد.

*

*

  1. مسئول داده ها: میگل آنخل گاتون
  2. هدف از داده ها: کنترل هرزنامه ، مدیریت نظرات.
  3. مشروعیت: رضایت شما
  4. ارتباط داده ها: داده ها به اشخاص ثالث منتقل نمی شوند مگر با تعهد قانونی.
  5. ذخیره سازی داده ها: پایگاه داده به میزبانی شبکه های Occentus (EU)
  6. حقوق: در هر زمان می توانید اطلاعات خود را محدود ، بازیابی و حذف کنید.

  1.   15400 dijo

    متشکرم که آن خطا را دریافت کردم و با این کار ناپدید شد. با احترام!

    1.    PEDRO dijo

      با تشکر بسیار خوب کار کرد

      1.    فابیان dijo

        با تشکر بسیار بسیار مفید.

  2.   خرسون dijo

    خوب امیدوارم که بتوانید به من کمک کنید ، کاربر دسک تاپ "سطح متوسط" من xubuntu 13.10 32b دارم ، می خواهم بدانم با این دستورات برای حل این ، عملی ترین کار باز کردن ترمینال و نوشتن موارد زیر است

    sudo apt-get حرکت خودکار

    sudo apt-get autoclean

    کنید: sudo apt-get برای بروز رسانی

    sudo apt-get -f نصب کنید
    این می تواند مخازن آنهایی را که دیگر استفاده نمی کنم تمیز کرده و بدون خرابی از سیستم خارج شود.

  3.   کارلوس dijo

    خوب من اوبونتو 13.11 داشتم و با این حل کردم

    sudo apt-get autoclean و سپس sudo install -f و سپس راه اندازی مجدد من را ترساند وقتی آن را روشن کردم همه چیز حل شد = D
    امیدوارم در خدمت شما باشه salu2

  4.   زینایی dijo

    متشکرم !

  5.   Linerobotic جدید dijo

    شریک بسیار خوب ، در اینجا اسکریپتی وجود دارد که همه کارها را برای شما انجام می دهد ، از یک شریک این یک برنامه تمیز کننده سیستم است که فقط در صورت ادامه نصب apt-get نصب -f نیز این نوع مشکلات را برطرف می کند http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ سلام بسیار توصیه می شود همکاران

  6.   هکتور مونوز dijo

    من می خواهم برنامه ای را نصب کنم که برای ما مفید باشد الکترونیکی به نام piklab نامیده می شود اما هر وقت سعی می کنم خطایی در مورد موارد وابستگی به deseria به من کمک کن تشکر

    1.    david259 dijo

      http://ubuntuforums.org/showthread.php?t=123481 شما این مورد را برای piklab امتحان کرده اید ... امیدوارم که برای شما مفید باشد

  7.   پدرو dijo

    من openoffice را به جای libreoffice نصب کردم و اکنون با مشکل عدم وابستگی روبرو شده ام که به من اجازه نصب چیزی نمی دهد. هر راه حلی؟. با تشکر

    1.    FenixPlays_YT dijo

      اوه دوست ، هر وقت بخواهم چیزی را نصب کنم یا از طریق مدیر بسته یا فروشگاه خطای وابستگی های برآورده نشده را به من می دهد و به من می گوید که من یک بسته خراب دارم و نمی دانم چگونه آن را برطرف کنم ، همین اتفاق برای من می افتد. (

  8.   خوزه کارلوس RG dijo

    این یک توضیح خوب برای کاربران تازه کار است. با درود.

  9.   فیلیپه dijo

    سپاس گذارم برای اطلاعات. با درود

  10.   Dreicomp dijo

    من هنوز هم همین مشکل را دارم ، فکر می کنم این یک وابستگی است که خودش را صدا می زند

  11.   آلوارو dijo

    سلام ، خوب من هنگام نصب java روی سرور ubuntu 14.04 یک خطای مشابه داشتم.
    من روند زیر را دنبال کردم:

    sudo apt-get install default-jre

    و من چیزی طولانی تر دارم اما شبیه به این ، این پس از اولین خطا هنگام دوباره امتحان کردن ظاهر می شود.

    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    برای اصلاح آن ممکن است بخواهید "apt-get -f install" را اجرا کنید:
    بسته های زیر وابستگی های برآورده نشده ای دارند:
    ca-certificates-java: بستگی دارد: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) یا
    java6-runtime-freeless
    default-jre: بستگی دارد: default-jre-headless (= 2: 1.7-51)
    بستگی دارد: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: بستگی دارد: libtiff5 (> = 4.0.3) اما نصب نمی شود
    ه: وابستگی ها برآورده نشده است. "apt-get -f install" را بدون بسته امتحان کنید (یا راه حل مشخص کنید).

    بنابراین آنچه که من سعی کردم این است که مراحل مشخص شده را دنبال کنم ، اما وقتی دستورالعمل زیر را وارد می کنم خطای زیر را دریافت می کنم:

    sudo apt-get حرکت خودکار

    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    برای اصلاح آن ممکن است بخواهید "apt-get -f install" را اجرا کنید.
    بسته های زیر وابستگی های برآورده نشده ای دارند:
    ca-certificates-java: بستگی دارد: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) یا
    java6-runtime-freeless
    libgdk-pixbuf2.0-0: بستگی دارد: libtiff5 (> = 4.0.3) اما نصب نشده است
    ه: وابستگی ها انجام نشده است. دوباره با استفاده از -f امتحان کنید.

    من کاملاً تازه کار linux هستم ، می توانید دستی به من بدهید تا بدانم چگونه این مشکل را حل کنم؟ متشکرم

    1.    میگی dijo

      سلام ، من خطایی مشابه آلوارو پیدا کردم ، نمی دانم می توانید به ما کمک کنید ، واقعاً ممنون می شوم

  12.   ماتئوس ماتئوس dijo

    با تشکر حتی در اوبونتو 15.04 کار می کند

  13.   لئوناردو آر dijo

    عالی! خیلی ممنون!

  14.   ماریانو dijo

    خیلی ممنونم خیلی به من کمک کرد. من می خواستم 4k یوتیوب mp3 را با ترمینال نصب کنم و نتوانستم چون خطایی به من وارد کرد ، سپس آن را بارگیری کردم تا نصب شود و به بسته های خراب وابستگی داد. خطوط شما مشکل را برای من حل کرد. به نظر می رسد که این مورد در اوبونتو بسیار رایج است.

  15.   لوئیس dijo

    با سلام به همکاران من سعی می کنم دارچین را روی wheezy نصب کنم و خطایی پیدا کردم. بسته های زیر وابستگی های برآورده نشده ای دارند و در پایان می گوید .. مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.
    امیدوارم و می تواند به من کمک کند تا این مشکل را برطرف کنم

  16.   لریک کامبن dijo

    با تشکر از Grosooo ما در حال مطالعه در viedma univ de Comahue آرژانتین هستیم و این راه حل بود

  17.   دیانگو vtz dijo

    سلام ، من می دانم که در حال حاضر مربوط نیست ، اما هنگام نصب خطایی در برنامه وجود دارد ، من قبلاً آن را فعال کرده ام اما در نوار وضعیت این خطا را مشاهده می کنم: «E: بسته wps-office: i386 نیاز به دوباره نصب شود ، اما پرونده مربوط به آن یافت نمی شود. " من قبلاً سعی کردم آن را حذف نصب کنم تا بتوانم به درستی آن را دوباره نصب کنم ، اما به من اجازه نمی دهد و من فکر نمی کنم.

  18.   جبرئيل dijo

    خیلی از شما متشکرم

  19.   diov3rov3r dijo

    متشکرم

  20.   racer5 dijo

    با تشکر ، این راه حل عالی بود !!

  21.   آنجل الگر dijo

    اشتباه من بخاطر شراب است

    angel @ alienware: ~ $ sudo apt-get install wine 1.7
    رمز عبور [sudo] برای فرشته:
    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    نمی توان برخی از بسته ها را نصب کرد. این ممکن است به این معنی باشد
    شما یک وضعیت غیرممکن را خواسته اید یا اگر از توزیع استفاده می کنید
    ناپایدار است ، که برخی از بسته های لازم ایجاد نشده است یا وجود ندارد
    از ورودی منتقل شده است.
    اطلاعات زیر می تواند به حل وضعیت کمک کند:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    wine1.7: بستگی دارد: wine1.7-i386 (= 1: 1.7.55-0ubuntu1)
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

    1.    توماس کاستلی dijo

      برای من هم همین اتفاق می افتد! من نمی دانم چگونه آن را حل کنم ، اگر می دانید چگونه به من اطلاع دهید که باید آن را حل کنم

  22.   خوان پابلو ریورا کوینزاکارا dijo

    ممنون ، خیلی به من کمک کرد ، دیگر مشکلی نداشتم.

  23.   حداکثر dijo

    خوب من می خواهم اوبونتو 15.10 را به 16.04 به روز کنم اما این خطا را دریافت کردم

    هنگام مقدمه سازی اطلاعات بسته ، مشکلی غیر قابل اصلاح وجود داشت.

    لطفاً این را به عنوان یک اشکال در بسته "مدیر-بروزرسانی" گزارش دهید و پیام خطای زیر را وارد کنید:
    E: Error، pkgProblemResolver :: مشکلات قطع تولید را برطرف کنید ، این ممکن است به دلیل بسته های نگهداری شده باشد.

    اگر می توانید به من کمک کنید ممنون

  24.   خورخه ریوس گومز dijo

    بسیار متشکرم ، من نتوانستم hardinfo را روی اوبونتو 16 خود نصب کنم و با کمک شما همه چیز درست است.

    از صمیم قلب و سلام شما بسیار سپاسگزارم.

  25.   فیلیپه دی dijo

    متشکرم ، به طرز شگفت انگیزی به من پاسخ داد ، بسیاری از خطاهایی که داشتم را برطرف می کنم

  26.   آنا dijo

    سلام ، من سعی کردم اما مرتباً با libappindicator1 خطا می کنم ، مانند این:
    اشتباه http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0-4.2untuXNUMX
    404 پیدا نشد
    ه: بدست آوردن غیرممکن است http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 پیدا نشد

    E: برخی از پرونده ها به دست نمی آیند ، شاید من باید "apt-get update" را اجرا کنم یا دوباره با -fix-lost دوباره امتحان کنم؟

    من با گزینه هایی که ترمینال به من می دهد سعی می کنم و هیچ چیز ... هر ایده؟
    با تشکر از شما

  27.   آنا dijo

    توجه: همه چیز به این ترتیب شروع می شود:
    بسته های زیر وابستگی های خراب دارند: google-chrome-կայուն: بستگی دارد: libappindicator1 اما نصب نشده است

  28.   Mily dijo

    سلام من مشکلی دارم من می خواهم Lightworks (Video Editor) را نصب کنم ، من deb را بارگیری می کنم و وقتی آن را باز می کنم بار من را می گیرد ، اما به من اجازه نمی دهد همانطور که می گوید آن را نصب کنم:

    خطا: نمی توان وابستگی را برآورده کرد: libc6 (> = 2.17)

    من قبلاً سعی کردم هر آنچه شما گفتید را انجام دهم و به درد من نمی خورد.

  29.   الودیر dijo

    عالی ، بسیار متشکرم!

  30.   سرجیو کابرال dijo

    سلام ، من یک اوبونتو 14.04 دارم که هنگام بارگیری شراب خطاهای زیادی پیدا می کنم

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    wine1.6: بستگی دارد: wine1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    بستگی دارد: wine1.6-i386 (= 1: 1.6.2-0ubuntu4)
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

    این به من می گوید اگر من سعی کنم شراب 1.6 مورد نیاز برای شراب را بارگیری کنم و همچنین هنگامی که می خواهم شراب 1.8 را از طریق ترمینال بارگیری کنم و وارد مدیر بسته سیناپسی شوم و آنجا را امتحان کنم همین را به من می گوید این

    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.
    E: Error، pkgProblemResolver :: مشکلات قطعی تولید شده را برطرف کنید ، این ممکن است به دلیل بسته های نگهداری شده باشد.
    ه: رفع وابستگی ها امکان پذیر نیست
    E: Error، pkgProblemResolver :: مشکلات قطعی تولید شده را برطرف کنید ، این ممکن است به دلیل بسته های نگهداری شده باشد.
    ه: رفع وابستگی ها امکان پذیر نیست

    و من 1000 چیز مختلف را امتحان کرده ام. چه کاری می توانم انجام دهم؟ کمک

  31.   سباستین dijo

    سلام! چطور هستید؟ آیا می توانم از شما سوالی بپرسم؟

    من این کار را می کنم و هنوز هم در نصب Qgis مشکل دارم ، می توانید به من کمک کنید؟

    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    نمی توان برخی از بسته ها را نصب کرد. این ممکن است به این معنی باشد
    شما یک وضعیت غیرممکن را خواسته اید یا اگر از توزیع استفاده می کنید
    ناپایدار ، که برخی از بسته های مورد نیاز هنوز ایجاد نشده اند یا هستند
    آنها از "ورودی" گرفته اند.
    اطلاعات زیر می تواند به حل وضعیت کمک کند:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    python-qgis: بستگی دارد: python3-psycopg2 اما نصب نمی شود
    پیشنهاد: liblwgeom-dev اما نصب نمی شود
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

    سلام!

  32.   رافائل بنیتو dijo

    s $ sudo apt-get -f نصب کنید
    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    0 به روز شده ، 0 جدید نصب می شود ، 0 برای حذف و 167 به روز نمی شود

    من این را دریافت کردم و مدام هنگام نصب comodo به من مشکل می دهد.
    چرا؟ لطفا کمک کنید

  33.   کارلوس dijo

    سلام خوب ، من از ubuntu 18.04.02 LTS استفاده می کنم ، وضعیت این است که من در تلاش هستم تا پایگاه داده اوراکل 11g express edition را نصب کنم ، یعنی اینکه هنگام بارگیری فایل ، این فایل rpm است ، بدیهی است که می خواهم آن را تبدیل کنم. deb ، اما در زمان نصب alien ، برخی از مشکلات وابستگی در بسته های debhelper و dpkg-dev وجود دارد.
    هر راه حلی ، من بسیار سپاسگزار خواهم بود

  34.   مانوئل بلتران dijo

    عالی ، همه چیز خوب اینجا با Peppermint 10 است
    با تشکر از شما برای به اشتراک گذاشتن راه حل

  35.   69. تونل dijo

    خوب است.
    هر بار که به ترمینال می روم وقتی sudo می گذارم این خطا پیدا می شود و نمی دانم چه کاری باید انجام دهم.
    E: ورودی 49 به اشتباه در پرونده لیست /etc/apt/sources.list (تجزیه و تحلیل URI) مشخص شده است
    ه: لیست های قلم خوانده نمی شوند.

  36.   خوانان dijo

    لینوکس لعنتی است سالها است که من به توزیع های مختلف متوسل شده ام تا ظاهراً از تجهیزات منسوخ شده و همیشه همان داستان استفاده کنم ، وابستگی های لعنتی که اجازه نصب تقریباً هر چیزی را نمی دهند. سپس باید بشنوید که اوبونتو ، کوبونتو ، لوبونتو ... حتی مادربزرگ من از آن استفاده می کند ... توپ ها. هر وقت بلند می شوم ناامید می شوم. طبیعی است که بهتر و بیشتر نرم تر می شود ... اجازه نصب هر چیزی را نمی دهد.

  37.   ماریانا dijo

    سلام ، من با نصب Haguichi مشکلی دارم ، موارد زیر را دریافت می کنم:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    haguichi: بستگی دارد: libglib2.0-0 (> = 2.48) اما 2.32.4-0ubuntu1 + 12.04ac5 قرار است نصب شود
    بستگی دارد: libglib2.0-bin (> = 2.48)
    بستگی دارد: libgtk-3-0 (> = 3.18) اما 3.4.2-0ubuntu0.9 نصب می شود
    بستگی دارد: libnotify4 (> = 0.7.6) اما 0.7.5-1 نصب خواهد شد
    پیشنهاد: dconf-cli اما قابل نصب نیست
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

    من نمی دانم چگونه آن را حل کنم ، اگر کسی می داند لطفا به من کمک کنید ، متشکرم.

  38.   دانیلا dijo

    خیلی ممنون ، آخر من حلش کردم ، شما نابغه هستید

  39.   هرن dijo

    سلام من اوبونتو 18.04 دارم و هنگام تلاش برای نصب npm خطای زیر را به من می دهد: من nodejs 14.04 را نصب کردم. من قبلاً راه حل پیشنهادی آنها را امتحان کردم اما متشکرم همان خطا را ارائه می دهد!

    sudo apt نصب npm ساخت ضروری است
    خواندن لیست بسته ... انجام شد
    ایجاد درخت وابستگی
    خواندن اطلاعات وضعیت ... انجام شد
    build-basic در آخرین نسخه خود (12.4ubuntu1) موجود است.
    نمی توان برخی از بسته ها را نصب کرد. این ممکن است به این معنی باشد
    شما یک وضعیت غیرممکن را خواسته اید یا اگر از توزیع استفاده می کنید
    ناپایدار ، که برخی از بسته های مورد نیاز هنوز ایجاد نشده اند یا هستند
    آنها از "ورودی" گرفته اند.
    اطلاعات زیر می تواند به حل وضعیت کمک کند:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    npm: بستگی دارد: nodejs اما نصب نمی شود
    بستگی دارد: node-Brief (> = 1.0.4) اما نصب نمی شود
    بستگی دارد: node-ansi (> = 0.3.0-2) اما نصب نمی شود
    بستگی دارد: node-ansi-color-table اما نصب نمی شود
    بستگی دارد: node-archy اما نصب نمی شود
    بستگی دارد: node-block-stream اما نصب نمی شود
    بستگی دارد: node-fstream (> = 0.1.22) اما نصب نمی شود
    بستگی دارد: node-fstream- نادیده بگیرید اما نصب نمی شود
    بستگی دارد: node-github-url-from-git اما نصب نمی شود
    بستگی دارد: node-glob (> = 3.1.21) اما نصب نمی شود
    بستگی دارد: node-graceful-fs (> = 2.0.0) اما نصب نمی شود
    بستگی دارد: گره ارث می برد اما نصب نمی شود
    بستگی دارد: node-ini (> = 1.1.0) اما نصب نمی شود
    بستگی دارد: node-lockfile اما نصب نمی شود
    بستگی دارد: node-lru-cache (> = 2.3.0) اما نصب نمی شود
    بستگی دارد: node-minimatch (> = 0.2.11) اما نصب نمی شود
    بستگی دارد: node-mkdirp (> = 0.3.3) اما نصب نمی شود
    بستگی دارد: node-gyp (> = 0.10.9) اما نصب نمی شود
    بستگی دارد: node-nopt (> = 3.0.1) اما نصب نمی شود
    بستگی دارد: node-npmlog اما نصب نمی شود
    بستگی دارد: گره یکبار انجام می شود اما نصب نمی شود
    بستگی دارد: node-osenv اما نصب نمی شود
    بستگی دارد: خواندن گره اما نصب نمی شود
    بستگی دارد: node-read-package-json (> = 1.1.0) اما نصب نمی شود
    بستگی دارد: node-request (> = 2.25.0) اما نصب نمی شود
    بستگی دارد: سعی مجدد در گره اما نصب نمی شود
    بستگی دارد: node-rimraf (> = 2.2.2) اما نصب نمی شود
    بستگی دارد: node-semver (> = 2.1.0) اما نصب نمی شود
    بستگی دارد: node-sha اما نصب نمی شود
    بستگی دارد: node-slide اما نصب نمی شود
    بستگی دارد: node-tar (> = 0.1.18) اما نصب نمی شود
    بستگی دارد: گره-زیر خط بزنید اما نصب نمی شود
    بستگی دارد: گره ای که نصب نمی شود
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

  40.   سرجیو dijo

    خیلی ممنون! ماهها بود که به دلیل این خطاها قادر به نصب برنامه نبودم ، از جستجو در انجمن ها خسته شدم و امروز این یکی را پیدا کردم. با درود!

  41.   خاویر dijo

    سلام خوب من کمی / کاملاً تازه وارد با اوبونتو هستم و مشکل زیر را دارم ، نمی دانم مکان درستی است اما اگر نه ، لطفا مرا راهنمایی کنید.
    من سیستم عامل ابتدایی 5.1.7 را نصب کرده ام. من به روشهای مختلفی سعی در نصب شراب ، آموزش های بعدی ، نصب مخازن بدون موفقیت داشته ام ، سعی کردم همه چیز را حذف کنم حتی همانطور که در این پست قرار داده اید ، و اکنون سعی می کنم آن را از مرکز برنامه نصب کنم و مدام همان "وابستگی های انجام نشده" را به طور خاص به من می گوید

    W: خطای GPG: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: امضای زیر قابل تأیید نیست زیرا کلید عمومی در دسترس نیست: NO_PUBKEY DFA175A75104960E
    E: مخزن "https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease" امضا نشده است.
    W: شما نمی توانید از مخزنی مانند این با خیال راحت به روز کنید و بنابراین به طور پیش فرض غیرفعال است.
    W: برای جزئیات ایجاد مخازن و پیکربندی کاربران به صفحه apt-safe (8) man مراجعه کنید.
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease (هنوز) در دسترس نیست (امضای زیر را نمی توان تأیید کرد زیرا کلید عمومی در دسترس نیست: NO_PUBKEY DFA175A75104960E)

    امیدوارم بتوانید به من کمک کنید ، پیشاپیش متشکرم

  42.   خورخه dijo

    سلام ، هنگام نصب ویرایشگر برای لاتکس (texmaker) خطای زیر را به من می دهد و نمی توانم آن را برطرف کنم:
    تأمین وابستگی libc6 امکان پذیر نیست (> 2.29/XNUMX =)

    تشکر

  43.   ایان dijo

    سلام من هنگام نصب عکس سرور جامعه mongodb خطایی داشتم:

    "Sudo apt-get install -y mongodb-org"

    و خطای زیر را به من می دهد:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    mongodb-org: بستگی دارد: mongodb-org-server اما نصب نمی شود
    ه: مشکلات برطرف نشد ، بسته های خراب را حفظ کرده اید.

    اما هیچ مشکلی برای من حل نشده است که وابستگی های منسوخ را حذف کند

  44.   کریستین dijo

    عالیه !!

  45.   میگل لوپز dijo

    اطلاعات عالی و کاملاً کار آمد بسیار ممنون

  46.   فدریکو dijo

    با جستجوی ls می توانید مستقیماً به پوشه های /etc/apt/sources.list.dy بروید که یکی از آنها به آنها خطا می دهد و سپس آن را با نام پرونده sudo rm حذف کرده و وارد کنید ...

  47.   ماریو dijo

    با تشکر ! با تشکر!

  48.   الکساندر کاردوزو dijo

    من اجازه نمی دهم همان خطا را داشته باشم

  49.   دکتر استرنج dijo

    توضیحات بسیار خوبی در جاهای دیگر من راه حلی به سادگی شما پیدا نکردم ، تبریک می گویم ، اگر می توانم شما را به قهوه دعوت کنم ، پیوند را در نشریات خود قرار دهید.

  50.   مريم dijo

    راهنما من می خواهم بخار را در lubuntu نصب کنم
    ابتدا "sudo apt install steam-installer" را قرار می دهم ، سپس به من می گوید که باید بخار بگذارم ، سعی می کنم بسته های شکسته را تمام کنم
    (بعد از امتحان موارد بالا بجز البته فلش چون من آن را دارم)
    به سمت من می پرد:
    نمی توان برخی از بسته ها را نصب کرد. این ممکن است به این معنی باشد
    شما یک وضعیت غیرممکن را خواسته اید یا اگر از توزیع استفاده می کنید
    ناپایدار ، که برخی از بسته های مورد نیاز هنوز ایجاد نشده اند یا هستند
    آنها از "ورودی" گرفته اند.
    اطلاعات زیر می تواند به حل وضعیت کمک کند:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    بخار: i386: بستگی دارد: libgl1-mesa-dri: i386 (> = 17.3) اما نصب نمی شود یا
    libtxc-dxtn0: i386 اما قابل نصب نیست
    بستگی دارد: libgl1-mesa-glx: i386 اما نصب نمی شود
    بستگی دارد: libgpg-error0: i386 (> = 1.10) اما نصب نمی شود
    بستگی دارد: libudev1: i386 اما نصب نمی شود
    بستگی دارد: libxcb-dri3-0: i386 (> = 1.11.1) اما نصب نمی شود
    بستگی دارد: libxinerama1: i386 (> = 2: 1.1.1) اما نصب نمی شود
    بستگی دارد: libc6: i386 (> = 2.15) اما نصب نمی شود
    بستگی دارد: libstdc ++ 6: i386 (> = 4.8) اما نصب نمی شود
    بستگی دارد: libx11-6: i386 اما نصب نمی شود
    توصیه می شود: libxss1: i386 اما نصب نمی شود
    توصیه کنید: mesa-vulkan-drivers: i386 اما نصب نمی شود
    ه: مشکلات قابل اصلاح نیستند ، شما بسته های شکسته را حفظ کرده اید
    چیکار کنم لطفا؟

  51.   ماریو بارسنیلا dijo

    اخیراً من با اوبونتو مشکلات زیادی دارم، در یک ویدیو در کانال SABIASCOMO خود با آنها برخورد می کنم، بنابراین هنگام نصب مجدد اوبونتو 14.04 LTS روی رایانه شخصی 32 بیتی و سپس به روز رسانی آن، یک کنجکاوی برای من ایجاد شد، زیرا قبل از به روز رسانی از طریق برنامه نصب کردم. مرکز نرم‌افزار اوبونتو، QtCreator، و هنگام به‌روزرسانی آن را حذف می‌کنم، تلاش برای نصب آن، خطای «وابستگی‌های بسته را نمی‌توان حل کرد» و در جزئیات زیر را برمی‌گرداند:
    بسته های زیر وابستگی های برآورده نشده ای دارند:

    qtcreator: بستگی دارد: libqt5concurrent5 (> = 5.0.2) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5designercomponents5 (> = 5.0.2) اما 5.5.1-3build1 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5help5 (> = 5.0.2) اما 5.5.1-3build1 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5printsupport5 (> = 5.0.2) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5script5 (> = 5.0.2) اما 5.2.1 + dfsg-1ubuntu1 نصب نشده است
    بستگی دارد: libqt5svg5 (> = 5.0.2) اما 5.5.1-2build1 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5xml5 (> = 5.2.0) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libgcc1 (> = 1: 4.1.1) اما 1: 4.9.3-0ubuntu4 نصب نشده است
    بستگی دارد: libqt5core5a (> = 5.2.0) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5designer5 (> = 5.0.2) اما 5.5.1-3build1 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5gui5 (> = 5.0.2) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5network5 (> = 5.0.2) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5qml5 (> = 5.2.0 ~ beta1) اما 5.5.1-2ubuntu6 ~ ppa1404 + 2 نصب نشده است
    بستگی دارد: libqt5quick5 (> = 5.1.0) اما 5.5.1-2ubuntu6 ~ ppa1404 + 2 نصب نشده است
    بستگی دارد: libqt5sql5 (> = 5.0.2) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libqt5widgets5 (> = 5.2.0) اما 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 نصب نشده است
    بستگی دارد: libstdc ++ 6 (> = 4.6) اما 4.8.4-2ubuntu1 ~ 14.04.4 نصب نشده است
    بستگی دارد: qtbase-abi-5-2-1 اما یک بسته مجازی است
    بستگی دارد: qtdeclarative-abi-5-2-1 اما یک بسته مجازی است
    اگر کسی آنقدر مهربان باشد که به من اطلاع دهد که چه کاری می توانم انجام دهم، بسیار سپاسگزار خواهم بود.

  52.   الکس dijo

    و در مورد دبیان 11؟ آیا همین رویه خواهد بود؟

  53.   ماته dijo

    من یک خطای وابستگی برای این بسته شراب دریافت می کنم زیرا ظاهراً خراب است، من قبلاً هر کاری را که صفحه به من گفته بود انجام دادم و نمی دانم آنها به من توصیه می کنند چه کار کنم
    در اینجا بسته نصب است:
    نمی توان برخی از بسته ها را نصب کرد. این ممکن است به این معنی باشد
    شما یک وضعیت غیرممکن را خواسته اید یا اگر از توزیع استفاده می کنید
    ناپایدار ، که برخی از بسته های مورد نیاز هنوز ایجاد نشده اند یا هستند
    آنها از "ورودی" گرفته اند.
    اطلاعات زیر می تواند به حل وضعیت کمک کند:

    بسته های زیر وابستگی های برآورده نشده ای دارند:
    winehq-կայուն: بستگی دارد: شراب پایدار (= 7.0.0.0 ~ bionic-1)
    ه: مشکلات قابل اصلاح نیستند ، شما بسته های شکسته را حفظ کرده اید

    نمیدونم چیکار کنم میشه لطفا کمکم کنید

  54.   جولای dijo

    عالی به من اجازه داد برنامه های دیگر را نصب کنم با تشکر