Dépendances non satisfaites

Comment résoudre les dépendances de package non satisfaites dans Ubuntu et ses dérivés

Avez-vous des problèmes avec dépendances non satisfaites? Tu n'est pas le seul.

Je vous apporte un sujet qui nous est donné par un problème de lecteur, il a utilisé notre section Contact pour nous envoyer son problème, un problème assez courant dans Ubuntu et Debian qui a une solution partielle, je veux dire résoudre les dépendances d'un package à installer. La requête se lisait comme suit:

bonjour, j'ai des problèmes pour installer le flash sur mon lubuntu 13.10, j'ai un netbook sony vcpm120al, avec 2gb de ram et environ 250gb de disque dur, quand j'essaye d'installer le plugin soit par téléchargement, soit par le centre logiciel lubuntu ça me jette à Une erreur, il n'est pas venu installé par défaut car je pense qu'il aurait dû venir
lorsque j'essaye d'installer le package, cela me dit que les dépendances du package ne peuvent pas être résolues

Cette erreur peut être due à des progiciels supplémentaires manquants ou non installables. Il peut également s'agir d'un conflit entre des packages logiciels qui ne peuvent pas être installés ensemble., Et en détail Les packages suivants ont des dépendances non satisfaites:

flashplugin-installer: dépend de: libnspr4-0d mais il ne sera pas installé

Merci d'avance, j'ajoute que je viens de quitter windows et que je ne sais pas vraiment comment utiliser lubuntu.

Que sont les «dépendances» non satisfaites?

Lorsque nous voulons installer un package ou un programme dans Ubuntu et sous Gnu / Linux, nous avons non seulement besoin du package, mais nous avons également besoin de fichiers et de packages complémentaires, dont dépend le programme que nous voulons installer. Plusieurs fois, ces packages ne sont pas trouvés dans notre système, ce qui nous donne cette erreur. Pour résoudre ce problème, nous devons généralement installer les packages dont dépend le programme, mais comme cela se produit ici, parfois le système insiste pour donner une erreur ou nous ne faisons pas l'installation correctement. La plupart du temps, ce n'est pas à cause de cela, mais nous avons un package cassé d'une autre installation et c'est pourquoi cela nous donne l'erreur de dépendance.

Solution à l'erreur des dépendances non satisfaites

Pour résoudre ce problème, le plus pratique est d'ouvrir le terminal et d'écrire ce qui suit

sudo apt-get autoremove

sudo apt-get nettoyage automatique

sudo apt-get update

sudo apt-get -f installer

Les premières commandes amènent le système à nettoyer la mémoire des packages et à installer, à la fois efficaces et à nettoyer le système des packages orphelins, c'est-à-dire des packages qui à un moment donné étaient utilisés par une application et ne sont plus utilisés par aucun programme. La troisième commande met à jour le système Apt. Et la dernière commande résout toutes les dépendances rompues qui existent sur le système.

Après cela, l'installation peut être effectuée correctement. Dans ce cas précis, je recommanderais d'ouvrir le terminal et de taper ce qui suit

sudo apt-get install lubuntu-restricted-extras

Cela installera une série de programmes qui sont classés comme des extras nécessaires pour les utilisateurs novices. Parmi eux, il y aurait le colis à avoir flash dans notre système. Si cela ne fonctionne pas non plus pour avoir du flash, la chose la plus directe et la plus sûre est d'écrire dans le terminal

sudo apt-get install flashplugin-installer

Avec cela, si l'installation de Lubuntu est correcte, il suffira de résoudre le problème de Lukas, le lecteur qui nous a écrit. Rappelez-vous enfin que si vous avez des questions ou des demandes, n'hésitez pas à nous contacter. Si c'est en notre pouvoir, nous le résoudrons.

Plus d'informations - Installer les packages DEB rapidement et facilement, Synaptic, un gestionnaire Debianite dans Ubuntu,


61 commentaires, laissez le vôtre

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont marqués avec *

*

*

  1. Responsable des données: Miguel Ángel Gatón
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   15400 dit

    Merci, j'ai eu cette erreur et avec cela, elle a disparu. Cordialement!

    1.    PEDRO dit

      merci ça a très bien fonctionné

      1.    Fabien dit

        Merci beaucoup très utile.

  2.   jerson dit

    bon j'espère que vous pourrez m'aider, utilisateur de bureau "niveau moyen" J'ai xubuntu 13.10 32b, je veux savoir si avec ces commandes Pour résoudre ce problème, le plus pratique est d'ouvrir le terminal et d'écrire ce qui suit

    sudo apt-get autoremove

    sudo apt-get nettoyage automatique

    sudo apt-get update

    sudo apt-get -f installer
    il peut nettoyer les référentiels de ceux que je n'utilise plus et me laisser le système sans échec.

  3.   carlos dit

    Eh bien, j'avais ubuntu 13.11 et j'ai résolu avec ça

    sudo apt-get autoclean puis sudo install -f puis redémarrer m'ont fait peur quand je l'ai allumé tout résolu = D
    J'espère que ça vous sert salu2

  4.   Xinai dit

    gracias!

  5.   Nouveau Linerobotic dit

    Très bon partenaire, voici un script qui fait tout pour vous, d'un partenaire est un programme de nettoyage du système qui supprime également ce type de problème uniquement si apt-get install -f persiste http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ Salutations hautement recommandées collègues 🙂

  6.   Hector Munoz dit

    Je veux installer un programme qui est utile pour nous l'électronique s'appelle piklab mais chaque fois que j'essaye, j'obtiens une erreur avec ces choses de dépendance à deseria aidez-moi merci

    1.    david259 dit

      http://ubuntuforums.org/showthread.php?t=123481 vous avez essayé cela pour piklab, j'espère que cela fonctionnera pour vous

  7.   pedro dit

    installez openoffice au lieu de libreoffice, et maintenant j'ai un problème de dépendances non satisfaites, ce qui ne me permettra pas d'installer quoi que ce soit. Une solution quelconque?. Merci

    1.    FenixPlays_YT dit

      Oh ami, la même chose m'arrive chaque fois que je veux installer quelque chose via le gestionnaire de paquets ou le magasin me donne l'erreur de dépendances non remplies et me dit que j'ai 1 paquet cassé et que je ne sais pas comment le réparer; (

  8.   José Carlos RG dit

    C'est une bonne explication pour les utilisateurs novices. Les salutations.

  9.   felipe dit

    Merci pour l'info. Les salutations

  10.   Dreicomp dit

    J'ai toujours le même problème, je pense que c'est une dépendance qui s'appelle

  11.   Alvaro dit

    Bonjour, bien, j'ai eu une erreur similaire lors de l'installation de java sur un serveur ubuntu 14.04.
    J'ai suivi le processus suivant:

    sudo apt-get installer default-jre

    Et j'ai quelque chose de plus long mais similaire à celui-ci, cela sort après la première erreur en réessayant.

    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    Vous pouvez exécuter "apt-get -f install" pour le corriger:
    Les packages suivants ont des dépendances non satisfaites:
    ca-certificate-java: dépend de: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) ou
    java6-runtime-sans tête
    default-jre: Dépend: default-jre-headless (= 2: 1.7-51)
    Dépend: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: dépend de: libtiff5 (> = 4.0.3) mais ne s'installe pas
    E: Dépendances non satisfaites. Essayez "apt-get -f install" sans paquet (ou spécifiez une solution).

    Donc, ce que j'ai essayé, c'est de suivre les étapes indiquées, mais lorsque j'entre l'instruction suivante, j'obtiens l'erreur suivante:

    sudo apt-get autoremove

    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    Vous pouvez exécuter "apt-get -f install" pour le corriger.
    Les packages suivants ont des dépendances non satisfaites:
    ca-certificate-java: dépend de: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) ou
    java6-runtime-sans tête
    libgdk-pixbuf2.0-0: dépend de: libtiff5 (> = 4.0.3) mais pas installé
    E: Dépendances non remplies. Essayez à nouveau en utilisant -f.

    Je suis assez novice en Linux, pouvez-vous me donner un coup de main pour savoir comment résoudre ce problème? Merci

    1.    langue doigt dit

      Bonjour, j'obtiens une erreur similaire à celle d'Alvaro, je ne sais pas si vous pouvez nous aider, je l'apprécierais beaucoup

  12.   mateus mateus dit

    merci même dans ubuntu 15.04 ça marche

  13.   Léonard R dit

    Brillant! Merci beaucoup!

  14.   Mariano dit

    Merci beaucoup cela m'a beaucoup aidé. Je voulais installer un mp4 youtube 3k par terminal et je ne pouvais pas car cela me donnait une erreur, puis je l'ai téléchargé pour l'installer et cela m'a donné une dépendance sur les paquets cassés. Vos lignes ont résolu le problème pour moi. Il semble que cela soit très courant dans ubuntu.

  15.   Luis dit

    Salutations, les collègues sur lesquels j'essaie d'installer cinnemon devraient siffler et j'obtiens une erreur. Les packages suivants ont des dépendances non remplies et à la fin, il est indiqué .. Impossible de résoudre les problèmes, vous avez conservé des packages cassés.
    J'espère et je peux m'aider à corriger ce problème

  16.   lriccombène dit

    merci Grosooo nous étudions à viedma univ de Comahue Argentina et c'était la solution

  17.   Dyango vtz dit

    bonjour, je sais que ce n'est pas pertinent pour le moment, mais j'ai une erreur avec une application lors de l'installation, je la fais déjà fonctionner mais dans la barre d'état j'obtiens cette erreur: «E: Le paquet wps-office: i386 doit être réinstallé, mais le fichier correspondant est introuvable. " J'ai déjà essayé de le désinstaller pour pouvoir le réinstaller correctement mais cela ne me laissera pas et je suis à court d'idées.

  18.   Gabriel dit

    Merci beaucoup

  19.   diov3rov3r dit

    Merci: D

  20.   racer5 dit

    Merci, c'était la solution parfaite !!

  21.   Ange Alegre dit

    Mon erreur est à cause du vin

    angel @ alienware: ~ $ sudo apt-get install wine1.7
    [sudo] mot de passe pour angel:
    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    Ne peut pas installer un pack. Cela peut signifier que
    vous avez demandé une situation impossible ou, si vous utilisez la distribution
    instable, que certains packages nécessaires n'ont pas été créés ou
    a été déplacé hors de Incoming.
    Les informations suivantes peuvent aider à résoudre la situation:

    Les packages suivants ont des dépendances non satisfaites:
    wine1.7: Dépend: wine1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

    1.    Thomas Castelli dit

      Je ressens la même! Je ne sais pas comment le résoudre si vous savez comment me faire savoir que j'ai besoin de le résoudre

  22.   Juan Pablo Rivera Quinzacara dit

    merci, ça m'a beaucoup aidé, je n'avais plus de problème.

  23.   max dit

    bon je veux mettre à jour ubuntu 15.10 à 16.04 mais j'obtiens cette erreur

    Un problème impossible à corriger s'est produit lors de l'initialisation des informations sur le package.

    Veuillez signaler cela comme un bogue dans le package "update-manager" et inclure le message d'erreur suivant:
    E: Erreur, pkgProblemResolver :: Résoudre les pannes générées, cela peut être dû à des packages en attente.

    si tu peux m'aider merci

  24.   Jorge Ríos Gómez dit

    Merci beaucoup, je n'ai pas pu installer hardinfo sur mon Ubuntu 16 et avec votre aide tout fonctionne bien.

    Merci beaucoup du cœur et des salutations.

  25.   Philippe D dit

    Merci, cela m'a servi à merveille, je corrige de nombreuses erreurs que j'ai eues

  26.   Ana dit

    Salut, j'ai essayé mais j'obtiens toujours une erreur avec libappindicator1, comme ceci:
    Err http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 introuvable
    E: impossible d'obtenir http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 introuvable

    E: Certains fichiers n'ont pas pu être obtenus, peut-être que je devrais lancer "apt-get update" ou réessayer avec –fix-missing?

    J'essaye avec les options que le terminal me donne et rien…. Une idée?
    Merci!

  27.   Ana dit

    Remarque: tout commence comme ceci:
    Les packages suivants ont des dépendances cassées: google-chrome-stable: Dépend: libappindicator1 mais pas installé

  28.   Mily dit

    Bonjour j'ai un problème. Je veux installer Lightworks (Video Editor), je télécharge le deb et quand je l'ouvre, il me charge, mais il ne me laisse pas l'installer comme il le dit:

    Erreur: impossible de satisfaire la dépendance: libc6 (> = 2.17)

    J'ai déjà essayé de faire tout ce que vous avez dit et cela ne fonctionne pas pour moi.

  29.   allodir dit

    Excellent! Merci beaucoup !.

  30.   Sergio Cabral dit

    Salut, j'ai un Ubuntu 14.04 J'obtiens de nombreuses erreurs lorsque j'essaye de télécharger du vin

    Les packages suivants ont des dépendances non satisfaites:
    wine1.6: dépend de: wine1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Dépend: wine1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

    Cela me dit que si j'essaie de télécharger wine 1.6, il est nécessaire d'avoir wine et cela me dit aussi la même chose quand j'essaye de télécharger wine 1.8 via le terminal et que j'entre dans le gestionnaire de paquets synaptiques et j'essaye là et ça me dit ce

    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.
    E: Erreur, pkgProblemResolver :: Résoudre les pannes générées, cela peut avoir été causé par des packages en attente.
    E: Impossible de corriger les dépendances
    E: Erreur, pkgProblemResolver :: Résoudre les pannes générées, cela peut avoir été causé par des packages en attente.
    E: Impossible de corriger les dépendances

    Et j'ai essayé 1000 choses différentes. Que puis-je faire? aider

  31.   Sebastian dit

    Salut! Comment ça va? Puis-je vous poser une question?

    Je fais cela et j'ai toujours des problèmes pour installer Qgis, pouvez-vous m'aider?

    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    Ne peut pas installer un pack. Cela peut signifier que
    vous avez demandé une situation impossible ou, si vous utilisez la distribution
    instable, que certains packages requis n'ont pas encore été créés ou sont
    Ils ont pris de "Incoming".
    Les informations suivantes peuvent aider à résoudre la situation:

    Les packages suivants ont des dépendances non satisfaites:
    python-qgis: dépend de: python3-psycopg2 mais il ne s'installe pas
    Recommander: liblwgeom-dev mais il ne s'installe pas
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

    Salutations!

  32.   Raphaël Benito dit

    ~ $ sudo apt-get -f installer
    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    0 mis à jour, 0 nouveau sera installé, 0 à supprimer et 167 non mis à jour

    Je comprends cela et cela me pose toujours le problème lors de l'installation de comodo.
    Parce que? Aidez-moi, s'il vous plaît

  33.   Carlos dit

    Bonjour bien, j'utilise ubuntu 18.04.02 LTS, la situation est que j'essaie d'installer oracle database 11g express edition, c'est-à-dire que lors du téléchargement du fichier, ledit fichier est rpm, évidemment je veux le convertir en. deb, mais au moment de l'installation d'alien, j'ai des problèmes de dépendance dans les paquets debhelper et dpkg-dev.
    toute solution, je serai très reconnaissant.

  34.   Manuel Beltrán dit

    Parfait, tout va bien ici avec la menthe poivrée 10
    Merci d'avoir partagé la solution

  35.   Tunnel69 dit

    Bon.
    Chaque fois que je vais au terminal, j'obtiens cette erreur lorsque je mets sudo, et je ne sais pas quoi faire.
    E: entrée 49 mal spécifiée dans le fichier de liste /etc/apt/sources.list (analyse d'URI)
    E: Les listes de polices n'ont pas pu être lues.

  36.   Juanan dit

    linux est de la merde. Depuis des années, j'ai eu recours à différentes distributions pour soi-disant utiliser des équipements obsolètes et toujours la même histoire, ces foutues dépendances qui ne permettent pratiquement rien d'installer. Puis avoir à entendre que Ubuntu, kubuntu, lubuntu ... même ma grand-mère l'utilise ... les boules. Chaque fois que je me lève, je finis par être frustré. Normal que ça se passe mieux et plus logero ... ça ne permet rien d'installer.

  37.   Mariana dit

    Salut, j'ai un problème pour installer Haguichi, j'obtiens ce qui suit:

    Les packages suivants ont des dépendances non satisfaites:
    haguichi: Cela dépend: libglib2.0-0 (> = 2.48) mais 2.32.4-0ubuntu1 + 12.04ac5 va être installé
    Dépend: libglib2.0-bin (> = 2.48)
    Dépend: libgtk-3-0 (> = 3.18) mais 3.4.2-0ubuntu0.9 va être installé
    Dépend: libnotify4 (> = 0.7.6) mais 0.7.5-1 sera installé
    Recommander: dconf-cli mais pas installable
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

    Je ne sais pas comment le résoudre, si quelqu'un sait s'il vous plaît aidez-moi, merci.

  38.   daniela dit

    Merci beaucoup, à la fin je l'ai résolu, vous êtes géni @

  39.   hernan dit

    Salut, j'ai ubuntu 18.04 et cela me donne l'erreur suivante en essayant d'installer npm, j'ai nodejs 14.04 installé; J'ai déjà essayé avec la solution qu'ils proposent mais ça continue de donner la même erreur, merci!

    sudo apt installer npm build-essential
    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    build-essential est déjà dans sa dernière version (12.4ubuntu1).
    Ne peut pas installer un pack. Cela peut signifier que
    vous avez demandé une situation impossible ou, si vous utilisez la distribution
    instable, que certains packages requis n'ont pas encore été créés ou sont
    Ils ont pris de "Incoming".
    Les informations suivantes peuvent aider à résoudre la situation:

    Les packages suivants ont des dépendances non satisfaites:
    npm: dépend de: nodejs mais il ne s'installe pas
    Dépend: node-abbrev (> = 1.0.4) mais il ne s'installe pas
    Dépend: node-ansi (> = 0.3.0-2) mais il ne s'installe pas
    Dépend: node-ansi-color-table mais il ne s'installe pas
    Dépend: node-archy mais il ne s'installe pas
    Dépend: node-block-stream mais il ne s'installe pas
    Dépend: node-fstream (> = 0.1.22) mais il ne s'installe pas
    Dépend: node-fstream-ignore mais il ne s'installe pas
    Dépend: node-github-url-from-git mais il ne s'installe pas
    Dépend: node-glob (> = 3.1.21) mais il ne s'installe pas
    Dépend: node-graceful-fs (> = 2.0.0) mais il ne s'installe pas
    Dépend: le nœud hérite mais il ne s'installe pas
    Dépend: node-ini (> = 1.1.0) mais il ne s'installe pas
    Dépend: node-lockfile mais il ne s'installe pas
    Dépend: node-lru-cache (> = 2.3.0) mais il ne sera pas installé
    Dépend: node-minimatch (> = 0.2.11) mais il ne sera pas installé
    Dépend: node-mkdirp (> = 0.3.3) mais il ne s'installe pas
    Dépend: node-gyp (> = 0.10.9) mais il ne s'installe pas
    Dépend: node-nopt (> = 3.0.1) mais il ne s'installe pas
    Dépend: node-npmlog mais il ne s'installe pas
    Dépend: node-once mais il ne s'installe pas
    Dépend: node-osenv mais il ne s'installe pas
    Dépend: lecture du nœud mais ne s'installe pas
    Dépend: node-read-package-json (> = 1.1.0) mais il ne s'installe pas
    Dépend: node-request (> = 2.25.0) mais il ne s'installe pas
    Dépend: relance du nœud mais ne s'installe pas
    Dépend: node-rimraf (> = 2.2.2) mais il ne s'installe pas
    Dépend: node-semver (> = 2.1.0) mais il ne sera pas installé
    Dépend: node-sha mais il ne s'installe pas
    Dépend: node-slide mais il ne s'installe pas
    Dépend: node-tar (> = 0.1.18) mais il ne s'installe pas
    Dépend: node-underscore mais il ne s'installe pas
    Dépend: nœud-qui, mais ne sera pas installé
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

  40.   sergio dit

    Merci beaucoup! J'étais des mois sans pouvoir installer un programme à cause de ces erreurs, j'en avais marre de chercher dans les forums et aujourd'hui j'ai trouvé celui-ci. Les salutations!

  41.   Javier dit

    bonjour bon je suis un peu / assez débutant avec ubuntu et j'ai le problème suivant, je ne sais pas si c'est le bon endroit mais sinon, s'il vous plaît, guidez-moi.
    J'ai installé le système d'exploitation élémentaire 5.1.7.J'ai essayé de nombreuses façons d'installer wine, en suivant des tutoriels, en installant des référentiels sans succès, j'ai essayé de tout supprimer même lorsque vous l'avez mis dans cet article, et maintenant j'essaye de l'installer à partir du centre d'application et il ne cesse de me dire la même chose «dépendances non remplies» spécifiquement

    W: erreur GPG: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible: NO_PUBKEY DFA175A75104960E
    E: Le référentiel "https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease" n'est pas signé.
    W: Vous ne pouvez pas mettre à jour à partir d'un référentiel comme celui-ci en toute sécurité et il est donc désactivé par défaut.
    W: Consultez la page de manuel apt-secure (8) pour plus de détails sur la création de référentiels et la configuration des utilisateurs.
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease n'est pas (encore) disponible (les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible: NO_PUBKEY DFA175A75104960E)

    J'espère que vous pourrez m'aider, merci d'avance.

  42.   Jorge dit

    Bonjour, lors de l'installation d'un éditeur pour Latex (texmaker) cela me donne l'erreur suivante et je ne peux pas l'éliminer:
    Impossible de satisfaire la dépendance libc6 (> = 2.29)

    merci

  43.   Janvier dit

    Salut, j'ai une erreur lors de l'installation du serveur de communauté mongodb lorsque je tire:

    "Sudo apt-get install -y mongodb-org"

    et cela me donne l'erreur suivante:

    Les packages suivants ont des dépendances non satisfaites:
    mongodb-org: dépend de: mongodb-org-server mais il ne s'installe pas
    E: Les problèmes n'ont pas pu être corrigés, vous avez conservé des paquets cassés.

    mais cela n'a rien résolu pour moi supprimer les dépendances obsolètes

  44.   cristian dit

    excellent !!

  45.   Miguel Lopez dit

    Excellente information et cela a parfaitement fonctionné. Merci beaucoup

  46.   Federico dit

    Vous pouvez aller directement dans les dossiers /etc/apt/sources.list.dy avec une recherche ls dont on leur donne une erreur puis le supprimer avec le nom de fichier sudo rm et entrer ...

  47.   Mario dit

    Merci ! Merci!

  48.   Alexandre cardozo dit

    Je ne me laisse pas avoir la même erreur

  49.   Doctor Strange dit

    Très bonne explication d'ailleurs, je n'ai pas trouvé de solution aussi simple que la tienne, bravo, si je peux t'inviter à un café, mets le lien dans tes publications.

  50.   Marie dit

    Aide Je veux installer steam dans lubuntu
    d'abord je mets "sudo apt install steam-installer", puis il me dit que je dois mettre steam, j'essaye de me retrouver avec des paquets cassés
    (après avoir essayé ce qui précède sauf bien sur ce flash car je l'ai)
    ça me saute aux yeux :
    Ne peut pas installer un pack. Cela peut signifier que
    vous avez demandé une situation impossible ou, si vous utilisez la distribution
    instable, que certains packages requis n'ont pas encore été créés ou sont
    Ils ont pris de "Incoming".
    Les informations suivantes peuvent aider à résoudre la situation:

    Les packages suivants ont des dépendances non satisfaites:
    steam : i386 : Dépend : libgl1-mesa-dri : i386 (> = 17.3) mais il ne s'installera pas ou
    libtxc-dxtn0 : i386 mais non installable
    Dépend : libgl1-mesa-glx : i386 mais il ne s'installera pas
    Dépend : libgpg-error0 : i386 (> = 1.10) mais il ne s'installera pas
    Dépend : libudev1 : i386 mais il ne s'installera pas
    Dépend : libxcb-dri3-0 : i386 (> = 1.11.1) mais il ne s'installera pas
    Dépend: libxinerama1: i386 (> = 2: 1.1.1) mais il ne s'installera pas
    Dépend: libc6: i386 (> = 2.15) mais il ne s'installe pas
    Dépend: libstdc ++ 6: i386 (> = 4.8) mais il ne s'installe pas
    Dépend: libx11-6: i386 mais il ne s'installe pas
    Recommande : libxss1 : i386 mais ne s'installera pas
    Recommander : mesa-vulkan-drivers : i386 mais ne s'installera pas
    E : Les problèmes n'ont pas pu être corrigés, vous avez conservé des colis cassés
    Que dois-je faire, s'il vous plaît?

  51.   Mario Barcenilla dit

    Dernièrement, j'ai de nombreux problèmes avec Ubuntu, je les traite dans une vidéo sur ma chaîne SABIASCOMO, donc lors de la réinstallation d'Ubuntu 14.04 LTS sur un PC 32 bits, puis de sa mise à jour, une curiosité m'est venue, car avant la mise à jour, j'ai installé à partir du Le logiciel Center of Ubuntu, QtCreator, et je le supprime lors de la mise à jour, essayer de l'installer renvoie une erreur "Les dépendances des packages ne peuvent pas être résolues" et dans les détails les éléments suivants :
    Les packages suivants ont des dépendances non satisfaites:

    qtcreator : Dépend : libqt5concurrent5 (> = 5.0.2) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5designercomponents5 (> = 5.0.2) mais 5.5.1-3build1 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5help5 (> = 5.0.2) mais 5.5.1-3build1 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5printsupport5 (> = 5.0.2) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5script5 (> = 5.0.2) mais 5.2.1 + dfsg-1ubuntu1 n'est pas installé
    Dépend : libqt5svg5 (> = 5.0.2) mais 5.5.1-2build1 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5xml5 (> = 5.2.0) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libgcc1 (> = 1 : 4.1.1) mais 1 : 4.9.3-0ubuntu4 n'est pas installé
    Dépend : libqt5core5a (> = 5.2.0) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5designer5 (> = 5.0.2) mais 5.5.1-3build1 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5gui5 (> = 5.0.2) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5network5 (> = 5.0.2) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5qml5 (> = 5.2.0 ~ beta1) mais 5.5.1-2ubuntu6 ~ ppa1404 + 2 n'est pas installé
    Dépend : libqt5quick5 (> = 5.1.0) mais 5.5.1-2ubuntu6 ~ ppa1404 + 2 n'est pas installé
    Dépend : libqt5sql5 (> = 5.0.2) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libqt5widgets5 (> = 5.2.0) mais 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 n'est pas installé
    Dépend : libstdc ++ 6 (> = 4.6) mais 4.8.4-2ubuntu1 ~ 14.04.4 n'est pas installé
    Dépend : qtbase-abi-5-2-1 mais c'est un paquet virtuel
    Dépend : qtdeclarative-abi-5-2-1 mais c'est un paquet virtuel
    Si quelqu'un avait la gentillesse de m'informer de ce que je peux faire, je lui en serais extrêmement reconnaissant.

  52.   Alex dit

    Et dans le cas de debian 11 ? serait-ce la même procédure ?

  53.   mateo dit

    Je reçois une erreur de dépendance sur ce package de vin car il est censé être cassé, j'ai déjà fait tout ce que la page m'a dit et je ne suis pas sûr de ce que vous me recommandez de faire
    voici le package d'installation :
    Ne peut pas installer un pack. Cela peut signifier que
    vous avez demandé une situation impossible ou, si vous utilisez la distribution
    instable, que certains packages requis n'ont pas encore été créés ou sont
    Ils ont pris de "Incoming".
    Les informations suivantes peuvent aider à résoudre la situation:

    Les packages suivants ont des dépendances non satisfaites:
    winehq-stable: dépend de: wine-stable (= 7.0.0.0 ~ bionic-1)
    E : Les problèmes n'ont pas pu être corrigés, vous avez conservé des colis cassés

    je ne sais pas quoi faire pouvez vous m'aider svp

  54.   Juillet dit

    Excellent ça m'a permis d'installer d'autres programmes merci

  55.   stéggonne dit

    contribution fantastique