Vratite podršku za Google Chrome na 32-bitnom Linuxu

krom na ubuntuu

Kao što je Google najavio u prosincu, Prestala je podržavati Google Chrome na 32-bitnim Linux sustavima ovog istog mjeseca. Svim korisnicima koji nastavljaju koristiti ovu aplikaciju preporučeno je da to prestanu jer, iako će je i dalje moći pokretati, više neće primati ažuriranja, uključujući potrebne sigurnosne zakrpe.

S druge strane, aplikacija Čini se da je Chromium za 32-bit još uvijek podržan na Linux sustavima i moglo bi se smatrati alternativom ovoj situaciji koja se javlja. No, kako službeno spremište za Google Chrome za 32-bitne pakete više ne postoji, korisnici sa 64-bitnim sustavom i koji koriste tu verziju aplikacije dobit će poruku o pogrešci prilikom pokušaja ažuriranja paketa. Srećom, ima jednostavno rješenje.

Ako koristite 32-bitni Chrome pod Ubuntu x64 sustavom, sljedeća će biti poruka kada pokušate ažurirati paket ove aplikacije:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release
Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file) Some index files failed to download. They have been ignored, or old ones used instead.

Popravi ovo malo pogreška u Ubuntuu je vrlo jednostavno a u datoteci ćete morati urediti samo mali redak /etc/apt/sources.list.d/google-chrome.list. Samo dodajte tekst "[arch = amd64]" nakon odjeljka "deb" ili upotrijebite sljedeću naredbu:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

Prethodna se datoteka obnavlja sa svakim ažuriranjem da biste završili s programom, pa ako se ne želite vraćati istim koracima kao i prije, preporučujemo da datoteci dodate atribut + i nepromjenjiv. Da biste to učinili, izvršite na njemu slijedeće upute:

</p>
<p class="source-code">sudo chattr -i /etc/apt/sources.list.d/google-chrome.list</p>
<p class="source-code">

Sadržaj članka pridržava se naših načela urednička etika. Da biste prijavili pogrešku, kliknite ovdje.

5 komentara, ostavi svoj

Ostavite svoj komentar

Vaša email adresa neće biti objavljen.

*

*

  1. Za podatke odgovoran: Miguel Ángel Gatón
  2. Svrha podataka: Kontrola neželjene pošte, upravljanje komentarima.
  3. Legitimacija: Vaš pristanak
  4. Komunikacija podataka: Podaci se neće dostavljati trećim stranama, osim po zakonskoj obvezi.
  5. Pohrana podataka: Baza podataka koju hostira Occentus Networks (EU)
  6. Prava: U bilo kojem trenutku možete ograničiti, oporaviti i izbrisati svoje podatke.

  1.   rztv23 dijo

    o tako dobro: v

  2.   vukodlak dijo

    Hvala ti

  3.   Oswaldo Hernandez dijo

    Ok, članak je vrlo dobar, ali oni koji koriste 32-bitnu arhitekturu, kako to učiniti da instaliramo 64-bitni krom, budući da baca sljedeću pogrešku:
    # dpkg -i google-chrome-stable_current_amd64.deb
    dpkg: pogreška u obradi datoteke google-chrome-stable_current_amd64.deb (–install):
    arhitektura paketa (amd64) ne odgovara arhitekturi sustava (i386)
    Tijekom obrade naišle su na pogreške:
    google-chrome-stable_current_amd64.deb

    1.    Jorge dijo

      Možda ovaj komentar neće biti koristan za stari blog, ali bit će za onoga tko ga pročita.
      32-bitni sustavi ne podržavaju 64-bitne programe, pa neće biti ni instalirani (obrnuto, ako je moguće, 64-bitni sustavi podržavaju 32-bitne programe).
      pozdravi

  4.   Ali Gonzalez dijo

    Sadržaj članka nije u skladu s naslovom. Poanta je u tome što imate 32-bitni Ubuntu sustav i želite instalirati Chrome za 32-bitni, čak i ako više nije podržan. Nemate 64-bitni sustav.