Töltse vissza a Google Chrome támogatást 32 bites Linux rendszerén

króm az ubuntuban

Amint a Google decemberben bejelentette, A 32 bites Linux rendszereken a Google Chrome támogatása megszűnt ugyanabban a hónapban. Mindazoknak a felhasználóknak, akik továbbra is használják ezt az alkalmazást, javasoljuk, hogy hagyják abba ezt, mert bár továbbra is képesek lesznek futtatni, nem kapnak több frissítést, beleértve a szükséges biztonsági javításokat is.

Másrészt az alkalmazás Úgy tűnik, hogy a 32 bites Chromium továbbra is támogatott Linux rendszereken, és a felmerülő helyzet alternatívájának tekinthető. Mivel azonban a 32 bites csomagok hivatalos Google Chrome adattára már nem létezik, a 64 bites rendszerrel rendelkező felhasználók, akik az alkalmazás ezen verzióját használják hibaüzenetet kap, amikor megpróbálja frissíteni a csomagot. Szerencsére van egy egyszerű megoldása.

Ha 32 bites Chrome-ot használ Ubuntu x64 rendszer alatt, akkor az üzenet a következő üzenetet kapja, amikor megpróbálja frissíteni az alkalmazás csomagját:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release
Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file) Some index files failed to download. They have been ignored, or old ones used instead.

Javítsd ki ezt a keveset hiba az Ubuntuban nagyon egyszerű és csak egy kis sort kell szerkesztenie a fájlban /etc/apt/sources.list.d/google-chrome.list. Csak adja hozzá az "[arch = amd64]" szöveget a "deb" szakasz után, vagy használja a következő parancsot:

sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

Az előző fájl minden egyes frissítéssel visszaáll a programmal kell elvégezni, ezért ha nem akarja, hogy ugyanazokkal a lépésekkel lépjen vissza, mint korábban, javasoljuk, hogy ehhez tegye hozzá a + i attribútumot a fájlhoz változhatatlan. Ehhez hajtsa végre a következő utasítást:

</p>
<p class="source-code">sudo chattr -i /etc/apt/sources.list.d/google-chrome.list</p>
<p class="source-code">

A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

5 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra.

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   rztv23 dijo

    hát olyan jó: v

  2.   vérfarkas dijo

    Köszönöm

  3.   Oswaldo Hernandez dijo

    Ok, a cikk nagyon jó, de azok, akik 32 bites architektúrát használnak, hogyan tegyük a 64 bites krómot, mivel a következő hibát dobja:
    # dpkg -i google-chrome-stabil_current_amd64.deb
    dpkg: hiba a google-chrome-stabil_current_amd64.deb (–install) fájl feldolgozásakor:
    a csomag architektúrája (amd64) nem felel meg a rendszer architektúrájának (i386)
    A feldolgozás során hibák léptek fel:
    google-chrome-stabil_current_amd64.deb

    1.    Jorge dijo

      Talán ez a megjegyzés nem lesz hasznos a régi blog számára, de annak, aki elolvassa.
      A 32 bites rendszerek nem támogatják a 64 bites programokat, így azokat még nem is telepítik (ha lehetséges, fordítva, a 64 bites rendszerek támogatják a 32 bites programokat).
      Üdvözlet

  4.   Ali Gonzalez dijo

    A cikk tartalma nincs összhangban a címmel. A lényeg az, hogy 32 bites Ubuntu rendszered van, és a Chrome-ot 32 bitesre szeretnéd csatlakoztatni, még akkor is, ha már nem támogatott. Nincs 64 bites rendszere.

bool (igaz)