Hogyan telepítsük az AMD / ATI illesztőprogramokat az Ubuntu 18.04-be?

AMD Radeon

En az előző cikk megosztottam néhány módszert a telepítés végrehajtására Az Nvidia video-illesztőprogramok a rendszerünkönNos, most az AMD illesztőprogramokkal rendelkezőkön a sor.

A lapkakészlet video-illesztőprogramjainak telepítése Tudnunk kell a videoképeink modelljét, ez magában foglalja az AMD processzorokat is amelyek régóta integrált grafikával vannak együtt.

Érdemes megemlíteni, hogy ez a cikk újoncoknak szól, mivel ez a téma általában nagyon gyakran feltett kérdés.

A Privative AMD illesztőprogramok telepítése az Ubuntuban

Nekünk kell nyisson meg egy terminált, és futtassa a következő parancsot:

lspci | grep VGA

Tehát valami ilyesmit fog mutatni:

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] [Radeon R5 (PCIE)]

Esetemben AMD processzorom van, integrált Radeon R5 GPU-val.

Ezekkel az információkkal folytatjuk a rendszerünknek megfelelő illesztőprogram letöltését.

Az illesztőprogram letöltéséhez az AMD hivatalos oldalára kell mennünk megfelel a videokártyánknak. A link ez.

Kész a letöltés ki kell csomagolnunk a most kapott fájlt, a terminálban azon a mappán helyezkedünk el, ahová a fájlt mentjük és végrehajtjuk:

tar -xJvf amdgpu-pro _ *. tar.xz

Létrejön egy könyvtár, amely tartalmazza az összes szükséges illesztőprogram-csomagot. Belépünk a könyvtárba:

cd amdgpu-pro-XX.XX-XXXXXX

Telepítés előtt hozzá kell adnunk a 32 bites architektúra támogatását:

sudo dpkg --add-architecture i386

sudo apt update

És most futtassuk a telepítő szkriptet. A terminálba beírjuk:

./amdgpu-pro-install -y

Az esettől függően a következő érveket használhatják.

--px  PX platform support

--online    Force installation from an online repository

--version=VERSION      Install the specified driver VERSION

--pro        Install "pro" support (legacy OpenGL and Vulkan)

--opencl=legacy    Install legacy OpenCL support

--opencl=rocm      Install ROCm OpenCL support

--opencl=legacy,rocm       Install both legacy and ROCm OpenCL support

--headless    Headless installation (only OpenCL support)

--compute     (DEPRECATED) Equal to --opencl=legacy –headless

A gördülékeny telepítés ajánlott argumentuma a -px.

A telepítés végén csak újra kell indítania a számítógépet hogy az új illesztőprogramok az indításkor betöltődjenek, és használatukkal elindíthassa a rendszert.

Como érdekes alternatívákat telepíthet:

./amdgpu-pro-install --opencl=rocm

Hogyan lehet eltávolítani a Radeon illesztőprogramokat az Ubuntu 18.04-ben?

Most az egyik leggyakrabban előforduló probléma az, hogy a számítógép újraindításakor a képernyő elsötétül, és nem mutatja meg az asztali környezetet.

Miért A változtatások visszaállításához csak TTY-t kell megnyitnia a Ctrl + Alt + F1 billentyűkombinációval és beleírod:

amdgpu-pro-uninstall

Megpróbálhat néhány telepítési argumentummal arra az esetre, ha az előző nem működne az Ön számára.

Egy másik megoldás a grub szerkesztése, a következő sort kell szerkesztenünk, ehhez végrehajtjuk:

sudo nano /etc/default/grub

Hozzáteszik amdgpu.vm_fragment_size = 9 a következő sorban így néz ki:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.vm_fragment_size=9"

A nyílt forráskódú ATI / AMD illesztőprogramok telepítése az Ubuntu 18.04-re

alapértelmezés szerint Az Ubuntu 18.04 már telepítette a nyílt forráskódú AMD illesztőprogramokat. Beépülnek a Mesába és a Linux kernelbe.

Bár igen gyorsabb frissítéseket akarnak, Mivel a hivatalos Ubuntu adattárak csomagjai nem mindig naprakészek, támaszkodhatunk egy adattárra.

Ez a PPA friss, ingyenes grafikus illesztőprogramokat biztosít X (2D) és táblázat (3D). A frissítési csomagok a következőket tartalmazzák:

  • Vulkan 1.1+
  •  OpenGL 4.5+ támogatás és új OpenGL kiterjesztések
  • OpenCL támogatás libclc támogatással
  • Gallium-kilenc frissítve
  • VDPAU és VAAPI Gallium3D gyorsított videóillesztők

A PPA hozzáadásához a rendszerünkhöz szükséges, hogy a Ctrl + Alt + T és a billentyűkkel nyissunk meg egy terminált kivégezzük a következő parancsokat:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

És telepítjük:

sudo apt install xserver-xorg-video-amdgpu

Y ha telepíteni szeretné a Vulkan támogatását:

sudo apt install mesa-vulkan-drivers

Egy másik módszer a rendszer számára az illesztőprogramok telepítésére:

sudo apt update && sudo apt -y upgrade

A végén újra kell indítanunk a számítógépünket, és a változtatások a rendszer indításakor betöltődnek.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

8 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Roberto dijo

    Ez a cikkben idézett parancs NEM működik: sudo add-apt-repository ppa: oibaf / graphics-drivers.
    A jelszó megadása után a következő üzenetet adja: Hiba: argumentumként csak egy adattárra van szükség.

  2.   Éjszakai vámpír dijo

    Vegye el a tereket, hogy működjön:

    sudo add-apt-repository ppa: oibaf / graphics-drivers

  3.   Petrificator dijo

    Szia, követtem a cikk lépéseit, és most fekete képernyőt kapok, amikor a mesát telepítem az Ubuntu 18.04-be. van ötleted hogyan lehetne kijavítani? Minden jót

  4.   Emilio dijo

    Nem működik, én közvetlenül az amd oldalon letöltöm az illesztőprogramot .deb formátumban, ők biztosítanak egy ritkot az összes függőséggel, és attól függően, hogy milyen gpu van, telepítenie kell őket a kért sorrendben, majd A képernyő fekete volt, és a logó elhagyása után nem indítottam el a rendszert ... Felejtsen el bármilyen módszert, nem lehet, és pontozhat

  5.   Oscar dijo

    Szia, köszönöm a bejegyzést.

    Egy kérdés, megértem, hogy a vulkan mind a nyílt forráskódú meghajtók verziójában van, akár a tulajdonosoknál.

    Ma melyik nyújtana jobb teljesítményt?

  6.   Paco dijo

    Helló, nagyon köszönöm a bemutatót. Nagy segítség volt számomra!

  7.   xawics dijo

    Az Ubuntu 18.04 használatával, miután elhanyagoltuk a saját illesztőprogramok telepítését a következő paraméterrel:
    Remélem szolgálnak

  8.   Valentin dijo

    Segítségre van szükségem, órák óta próbálom telepíteni az illesztőprogramokat, és ezt a megjegyzést végső megoldásként használom.

    erre a parancsra válaszul: tar -xJvf amdgpu-pro _ *. tar.xz
    Az ubuntu eldob:

    tar (gyermek): amdgpu-pro: Nem lehet megnyitni: Fájl vagy könyvtár nem létezik
    tar (gyermek): A hiba nem állítható helyre: kilépés most
    kátrány: A gyermek visszatért státusza
    tar: A hiba nem állítható helyre: kilépés most

    amit nem értek, az az oka, mert minden lépést megtettem a levélig (5 vagy 6 alkalommal)