A Java 9 telepítése az Ubuntura

java logó

 

Valamivel ezelőtt beszéltünk hogyan kell telepíteni a Java 8-ot az Ubuntu-ra, és most, hogy a Java 9 verziója van Korai hozzáférés, és a közösségen belül sok felhasználó szerette volna tudni, hogyan kell telepíteni, el fogjuk mondani, hogy miként érheti el gyorsan a Java új verzióját az Ubuntuban.

Mielőtt folytatnánk, tisztázzunk egyet: Csak akkor telepítse a Java 9-et, ha kifejezetten szüksége van rá, mivel ez egy verzió Korai hozzáférés olyan termék, amely 2016-ban látja majd a fényt. A mai napig biztos, hogy van még néhány bogarak és több mint valószínű, hogy nincsenek megfelelő biztonsági javításai, azon kívül, hogy egyes opciók eltávolítása a JDK9-ben problémákhoz vezethet bizonyos Java-alkalmazások használatakor.

A PPA-t, amelyet felajánlunk Önnek, a WebUpd8 hozta létre, és nem tartalmaz egyetlen Oracle bináris dokumentumot sem, mert a vállalat nem engedélyezi ezt a licencében. Emiatt a PPA tartalmazza a telepítő, amely automatikusan letölti a Java 9 programot vagy ami ugyanaz, JDK9 és Java 9 verzióban csatlakoztat böngészőkhöz, és ez mindent konfigurál az Ön számára. A Java telepítő alfa verziónak minősül, és garancia nélkül kínálják, így annak használata saját felelősségére és költségére történik.

Érdemes ezt megemlíteni a letöltés kissé lassú lesz az Oracle szerverek miatt, függetlenül attól, hogy milyen gyors a kapcsolat, amelyen keresztül letölti.

Mindenesetre a Java 9 telepítése az Ubuntu-ra PPA használatával a következő parancsokat használjuk terminálban:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java9-installer

A következő lesz környezeti változók beállítása automatikusan. Ehhez ezt a parancsot használjuk:

sudo apt-get install oracle-java9-set-default

A környezeti változók bármelyik régebbi változataAz e verzió eltávolításra kerül az új verzió telepítésekor.

És eddig a kis útmutatónk a Java 9 telepítéséhez, reméljük, hogy hasznosnak találja, és még egyszer javasoljuk, hogy ne használja, ha ez nem feltétlenül szükséges verziójának jellegét figyelembe véve Korai hozzáférés.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

4 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra.

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Gower dijo

    Nagyon hasznos azok számára, akik a Jdevelopert használjuk.

  2.   Emmanuel Velasquez dijo

    Nézd, te egy elegáns anyahéj vagy, a sorete nem működik nálam, hagyd abba a szarok feltöltését a kurva miatt, aki téged szült, azt mondja nekem, hogy ez nem található meg egységben, nem tudom, hogy sorete, ta to jakiado

  3.   tétlen dijo

    az új java 9 nagyon jó

  4.   GLORIA dijo

    ez nem engedi meg, a parancsok feltétele végén a "The package" oracle-java9-installer "fájl nem jelenik meg telepítésre.

bool (igaz)