Hogyan lehet újra engedélyezni a Zárképernyő szerkesztése opciót az Ubuntu 18.04-ben?

redőny-szerkesztés letiltva

Ahogy telnek a napok számos hiba nyilvánvalóvá vált hogy a Canonical srácainak még javítaniuk kellett az Ubuntu 18.04 új kiadásában, és mivel nem tudom, hogy elmulasztották-e a Gnome Shell kiterjesztések telepítésének integrációját, az érintőpad gomb többek között le volt tiltva.

Nos, ezúttal, ha nem Rájött egy apró hibára, amelyet a Zárképernyő képernyőkép tartalmaz, ha az az alkalmazás, amelyet a rendszer képernyőképeihez használnak, amellyel lehetővé teszi számunkra ezek gyors kiadását.

Az Ubuntu 18.04-ben az Exponáló képernyő képernyőképnél nincs engedélyezve a szerkesztés gomb, amelyet akkor vehet észre, amikor megnyitja az eszközt képernyőkép készítésekor.

És nemcsak ezt, hanem Hiányzik a felső panel kisalkalmazásának jelzője is, ez megakadályozza, hogy a képszerkesztő funkciókat működtessük. Ez azt jelenti, hogy olyan funkciók vannak, mint a szöveg elmosása, a kép kivágása, vonalak, nyilak, szöveg stb. hozzáadása, alapértelmezés szerint nem működnek.

Ez a hiba annak a ténynek tudható be, hogy könyvtárat nem vettek fel a rendszerbe, mivel ez nem szerepel a hivatalos Ubuntu 18.04 adattárakban.

A könyvesbolt az libgoo-canvas-perl, de ne aggódjon, használhatjuk azt, amely a korábbi "Ubuntu 17.10" verzió tárházaiban elérhető.

redőny-rajzoló eszköz

Hogyan lehet kijavítani a problémát az Exponáló képernyőfotóval?

Manuálisan letölthetik a deb csomagot egy oldalról Ne felejtse el letölteni a függőségeit sem.

Letöltés libgoocanvas-közönséges a kapcsolat ez azAhhoz, hogy libgoocanvas3 a kapcsolat ez az, és a libgoo-canvas-perl a kapcsolat ez az.

A letöltések befejezése után a választott csomagkezelővel telepítheti a letöltött fájlokat.

Vagy ha úgy tetszik, használhat terminált (Ctrl + Alt + T) a csomagok telepítéséhez, helyezkedjenek el abban a mappában, ahová a fájlokat letöltötték, és futtassák:

sudo dpkg -i libgoocanvas*deb

sudo apt-get -f telepítés

Ezután telepítjük a libgoo-canvas-perl fájlt

sudo dpkg -i libgoo-canvas-perl*.deb

sudo apt-get -f install

Vagy ha inkább futtathatja az alábbi parancsokat, amelyek letöltik a libgoo-canvas-perl és annak függőségeit mi azt tesszük, hogy elmentjük őket a saját könyvtárába, és telepítjük ezeket a deb fájlokat.

32 bites Ubuntu származékok esetén:

mkdir ~/libgoo-canvas-perl && cd ~/libgoo-canvas-perl

wget http://archive.ubuntu.com/ubuntu/pool/universe/libg/libgoo-canvas-perl/libgoo-canvas-perl_0.06-2ubuntu3_i386.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/libe/libextutils-depends-perl/libextutils-depends-perl_0.405-1_all.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/libe/libextutils-pkgconfig-perl/libextutils-pkgconfig-perl_1.15-1_all.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/g/goocanvas/libgoocanvas3_1.0.0-1_i386.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/g/goocanvas/libgoocanvas-common_1.0.0-1_all.deb

sudo dpkg -i *.deb

sudo apt install -f

Ubuntu és 64 bites származékok esetén:

mkdir ~/libgoo-canvas-perl && cd ~/libgoo-canvas-perl

wget http://archive.ubuntu.com/ubuntu/pool/universe/libg/libgoo-canvas-perl/libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/libe/libextutils-depends-perl/libextutils-depends-perl_0.405-1_all.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/libe/libextutils-pkgconfig-perl/libextutils-pkgconfig-perl_1.15-1_all.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/g/goocanvas/libgoocanvas3_1.0.0-1_amd64.deb && wget http://archive.ubuntu.com/ubuntu/pool/universe/g/goocanvas/libgoocanvas-common_1.0.0-1_all.deb

sudo dpkg -i *.deb

sudo apt install -f

Ha megvan telepítette az összes szükséges függőséget, újra kell indítania a redőnyt.

Ezt úgy tehetik meg, hogy megnyitnak egy terminált és futtatják a következő parancsot, hogy megöljék az összes futó Shutter példányt.

sudo killall shutter

Hogyan lehet engedélyezni a Shutter kisalkalmazást?

zár

Mint korábban említettük, az Exponáló prompt kisalkalmazása nem jelent meg a rendszer tálcáján.

Ez az alkalmazás mutatója lehetővé tette számunkra a gyors hozzáférést az összes redőny funkcióhoz Bár ez nem kötelező funkció, kiváló hozzáférést biztosít minden funkciójához.

Ha dEsean engedélyezze újra ezt az kisalkalmazást, a következő lépéseket kell végrehajtanunk az alkalmazásjelző engedélyezéséhez.

Először meg kell nyisson meg egy terminált, és futtassa a következő parancsot az indikátor telepítéséhez:

sudo apt install libappindicator-dev

Most kész folytatni fogjuk a Pearl modul telepítését a rendszerünkbe, ehhez végrehajtjuk:

sudo cpan -i Gtk2::AppIndicator

Csak a végén A Shuttert újra kell indítanunk a következő paranccsal:

sudo killall shutter

És ezzel már látnunk kell az applet indikátort az Ubuntu 18.04 felső paneljén.

Személyes megjegyzésként hozzáfűzhetem, hogy nem tudom, mi történt az Ubuntu fejlesztőkkel, mert nem értem, hogy az ilyen alapvető funkciók hogyan jelenthetnek problémákat, bár esetleg más funkciókra összpontosítottak, elfelejtve áttekinteni a legalapvetőbbeket.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

2 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra.

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Charles Rock dijo

    Miután megpróbálta telepíteni a megadott könyvtárakat:
    libgoocanvas3_1.0.0-1_amd64.deb
    libgoocanvas-common_1.0.0-1_all.deb
    libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb

    Az én esetemben a következő könyvtárakat kellett telepítenem:
    libextutils-pkgconfig-perl_1.15-1_all.deb
    libextutils-depend-perl_0.405-1_all.deb

    Maga a dpkg jelezte ezen függőségek hiányát.

    Nagyon köszönöm a hozzászólást.

    Talán túlságosan rohanunk az új verzióra ugrani, a végén ezeknek a kis problémáknak a megoldása túl sok időt vesz igénybe, hogy megspóroljuk magunkat, csak várva egy kicsit.

  2.   Toni dijo

    Nekem jól sikerült, köszönöm.