A Flatpak támogatás engedélyezése az Ubuntu 20.04-ben

Ubuntu 20.04 és Flatpak

Valószínűleg már több cikket olvasott az Snap csomagokról az Ubuntu 20.04 LTS Focal Fossa alkalmazásban. Ellentmondásos lépésként a Canonical arra törekszik, hogy használjuk a következő generációs csomagjaikat, de a Linux-felhasználók szeretik ellenőrizni, hogy mit használunk többet, és nem szeretik ezt a viselkedést. Ezen kívül sokan vagyunk, akik inkább flatpak csomagoktöbbek között azért, hogy gyorsabb és könnyebben használható legyen.

Csak egy éve kiadjuk egy cikk, amelyben bemutattuk, hogyan lehet engedélyezni a Flatpak csomagok támogatását az Ubuntuban, de ezt a rendszert már nem működik a Focal Fossa-ban, mert elkezdtek egy másik szoftverboltot használni. Ezért ez a cikk az előző vagy az egyik frissítése, amelyben elmagyarázzuk azokat a változtatásokat, amelyeket megtehetünk annak érdekében, hogy továbbra is élvezhessük ezeket a csomagokat az Ubuntu legújabb verziójában.

Ubuntu 20.04 és Flatpak: követendő lépések

A legfontosabb, amit tudnunk kell vagy figyelembe kell vennünk, hogy a probléma az új Ubuntu szoftver, amely nem más, mint a Módosított Snap Store és korlátozottabban, amelyeket felvettek a Focal Fossa-ba. Ennek tudatában a következő lépéseket kell követni:

  1. Az első dolog, amit tennünk kell, a "flatpak" csomag telepítése. Ehhez megnyitunk egy terminált, és beírjuk a következő parancsot:
sudo apt install flatpak
  1. A fenti csomag kompatibilis bolt nélkül nem sok hasznunkra válik, ezért telepíteni fogjuk. Telepíthetjük a Discovert (plazma-felfedezés), és ebből megkereshetjük a "flatpak" szót, és telepíthetjük a szükséges motort, de KDE szoftverként sok függőséget telepít, és nem lesz olyan jó, mint például a Kubuntuban. Ezért a legjobb megoldás az, ha visszalép és telepíti a "régi" GNOME szoftvert:
sudo apt install gnome-software
  1. Ezután telepítenünk kell a bővítményt úgy GNOME szoftver kompatibilis legyen a Flatpak csomagokkal:
sudo apt install gnome-software-plugin-flatpak
  1. Innentől kezdve az ugyanaz, mint az Ubuntu 19.10-ben és a korábbi verziókban, kezdve a Flathub-tárház hozzáadásával ezzel a paranccsal:
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
  1. Végül újraindítjuk az operációs rendszert, és minden készen áll a Flatpak csomagok telepítésére az Ubuntu 20.04-ben.

A Flathub szoftver telepítése az Ubuntura

A támogatás engedélyezése után a Flathub szoftver megjelenik a GNOME szoftverben. Az egyetlen dolog, amit meg kell vizsgálnunk, az a csomag információ, a a forrás azon része, amelyben a "flathub" megjelenik. Egy másik lehetőség az, hogy megy flathub.org, hajtsa végre a kereséseket onnan, kattintson a kék gombra, amely azt írja, hogy "TELEPÍT", és kövesse a képernyőn megjelenő utasításokat.

Ha akarjuk, akkor a "sudo snap remove snap-store" paranccsal idézőjelek nélkül is eltávolíthatjuk a "Snap Store" -t, de ezt a fogyasztó ízlésére bízom. Ha a fentieket megtesszük mi fogjuk eldönteni, hogy mit és hova telepítsünk, úgyhogy szerintem megéri.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

5 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Linez dijo

    Köszönöm a közreműködést, egy megjegyzés: ha az Ubuntu egy korábbi verziójáról frissített, mint az én esetemben, és ahol már engedélyeztem a Flatpak használatát, akkor a gnome-szoftver telepítve jelenik meg, de ha elindítja, akkor megnyitja a telepített snap verziót kanonikusan.
    A megoldás a gnome-software újratelepítése: sudo apt-get install –reinstall gnome-software

  2.   Rafa dijo

    Ezeknél a dolgoknál hagyja abba az ubutnu használatát, a Mint alkalmazással a rendszer telepítése, a szükséges alkalmazások telepítése és a munka. Az Ubuntu sok időt pazarol. Ideálisnak tartom azok számára, akik szeretnek "bütykölni" a számítógéppel, de nem azok számára, akik dolgozni akarnak vele.

    1.    Linez dijo

      Lássuk barátom, ez opcionális, a szoftverközpont több ezer alkalmazást hoz létre a Flatpak támogatás telepítése nélkül.
      Ne hibáztasd az Ubuntut alkalmatlanságodért.

      1.    Armando Mendoza helyőrző kép dijo

        Hamis: ez egy piszkos kanonikus lépés ... az ilyen dolgok SOHA nem szerepelnek egy újonnan megjelent disztróban, nevezzük Debiannak, Arch-nak stb. de furcsa módon, ha ez az Ubuntuban történik, és ez azért van, mert a Canonical piszkos háborút indított el a Red Hat (a Flatpak csomagok fejlesztője) ellen, amely háború a közösséget érinti, de talán ez a háború az Ubuntu végének kezdete

  3.   Mario Calderon dijo

    Hála istennek, megszabadultam a kanoniktól, az Ubuntutól és annak piszkos játékaitól ...