Hogyan lehet frissíteni az Ubuntu 17.10-re egy korábbi verzióról

Ubuntu 17.10

A tegnapi nap folyamán ismertük az Ubuntu új verzióját, a közismertet Ubuntu 17.10 Művészi Aardvack. Ez a verzió új gépekre telepíthető, de azoknak, akiknek az Ubuntu régebbi verziója van, várniuk kell.

Sokan valószínűleg most kapják meg a frissítési üzenetet, de másoknak várniuk kell. A frissítési folyamat felgyorsítása Számos módszert javasolunk a gyors frissítéshez, biztonságos és egyszerű.

Az első dolog, amit meg kell tennünk, az összes fontos adat biztonsági másolatának létrehozása. Ez a folyamat meglehetősen veszélyes, és egy internet- vagy áramkimaradás ronthatja a frissítést. Miután elkészítettük a biztonsági másolatot, meg kell nyitnunk a terminált.

Most kétféleképpen végezhetjük el a frissítést: vagy grafikusan írással csináljuk,

sudo apt-get update && update-manager

Ez frissíti az operációs rendszert, majd futtatja a grafikus frissítő eszközt. De létezik a leggyorsabb és leghatékonyabb terminálopció (Nekem személy szerint jobban tetszik), ez a folyamat a következő parancsokból áll:

sudo apt-get update && upgrade

sudo do-release-upgrade

Ezzel a terminálon keresztül indul az operációs rendszer frissítése. Ahogy a grafikus módon, úgy nekünk is legyen figyelmes a frissítés által nekünk feltett kérdésekre és kérésekre.

Ha LTS verziót használunk, függetlenül attól, hogy mennyire hajtjuk végre a fenti parancsokat, az Ubuntu 17.10-re történő frissítés módja nem fog működni. Ahhoz, hogy ez működjön, először el kell mennünk a „Szoftver és frissítések”, majd a „Frissítések” fülre. Ebben megváltoztatjuk a legördülő opciót "bármilyen új verzióra", majd megnyomjuk a bezárás gombot, majd folytatjuk az előző lépéseket. Most a frissítési folyamat működik.

Mint látható, a frissítési folyamat meglehetősen egyszerű, és a meglévő internetkapcsolattól függően gyors lesz. De ne feledje Ezt a frissítést fontos megtenni, mivel a következő verziókban megtalálható lesz a Wayland és a Gnome, sok könyvtárat és fájlt igénylő programok.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

4 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Károly dijo

    Felejtsd el a frissítést közvetlenül az Ubuntu 17.04-ről, ha régi grafikád van. Az Ubuntu 17.10 a gnome-3.26-tal és különösen a mesa 17.2-vel (> = mesa 17.1) már nem kompatibilis a régi grafikus kártyákkal (ugyanez a Fedorával stb. Stb.).

    Ehhez azt tanácsolom, hogy a közvetlen frissítés előtt töltsön le egy "live-cd" fájlt, és tesztelje, hogy ez jól működik-e az Ön számára, és ha nem, kövesse az általam jelzett következő lépéseket (megtartja a mesa és az xserver-xorg csomagokat az Ubuntu 17.04-ből ).

    # Megtartjuk a tábla csomag frissítését és az xserver-xorg fájlt
    sudo apt-mark hold libegl1-table
    sudo apt-mark hold libgl1-table-dri
    sudo apt-mark hold libgl1-table-glx
    sudo apt-mark hold libglapi-table
    sudo apt-mark hold libgles2-table
    sudo apt-mark hold libglu1-table
    sudo apt-mark hold libtxc-dxtn-s2tc
    sudo apt-mark hold libwayland-egl1-table
    sudo apt-mark hold table-utils
    sudo apt-mark hold table-va-meghajtók
    sudo apt-mark hold table-vdpau-meghajtók

    sudo apt-mark hold xorg
    sudo apt-mark tartsa xorg-docs-core
    sudo apt-mark hold xserver-xorg
    sudo apt-mark hold xserver-xorg-core
    sudo apt-mark hold xserver-xorg-input-libinput
    sudo apt-mark hold xserver-xorg-legacy
    sudo apt-mark hold xserver-xorg-video-all
    sudo apt-mark hold xserver-xorg-video-amdgpu
    sudo apt-mark hold xserver-xorg-video-ati
    sudo apt-mark hold xserver-xorg-video-fbdev
    sudo apt-mark hold xserver-xorg-video-intel
    sudo apt-mark hold xserver-xorg-video-nouveau
    sudo apt-mark hold xserver-xorg-video-qxl
    sudo apt-mark hold xserver-xorg-video-radeon
    sudo apt-mark hold xserver-xorg-video-vesa
    sudo apt-mark hold xserver-xorg-video-vmware

    #A rendszer frissül
    sudo apt-get update && upgrade
    sudo do-release-upgrade

  2.   Tomas Cortes Berisso dijo

    Gyenge az általa kínált szoftverek mennyisége, a 16.04-ben az alkalmazásopciók nagyon kiterjedtek voltak. Másrészt folyamatosan frissítenem kell, hogy megfelel a TLS-nek ... Kicsit eltévedtem!

  3.   Juan Martinez dijo

    17.04-es verzióm van, és nem kaptam meg a frissítést 17.10-re, bár mindkét módszert kipróbáltam.
    Láttam, hogy ha a "get" -t már nem használják

  4.   Fernando dijo

    Mi van, ha az Ubuntu 9.04-et használom?