Hogyan lehet visszaszerezni az NVIDIA Optimus támogatását az Ubuntu 14.04-ben

NVIDIA Optimus

Általában a frissítések általában mindenféle fejlesztést hoz, a teljesítmény vagy a biztonság valamint a felület vagy a kialakítás, és el kell mondani, hogy ez általában olyan feladat, amelynek a felhasználók megtanultak engedni az idő múlásával. És ez az, hogy az elején sokan inkább félretették őket, és így kitették csapataikat biztonsági kérdések és a stabilitás, de el kell mondani, hogy részben ez a hibás azokért a rossz tapasztalatokért, amelyeket korábban a frissítés során szereztünk (különösen a Windows 98 vagy a Windows XP napjaiban).

Szerencsére a dolgok megváltoztak, és most ezeket a feladatokat a felhasználók gyakran hajtják végre, de időről időre nemkívánatos helyzeteknek tesszük ki magunkat, amelyek közül néhányat a fejlesztők előzetes tesztelésével el lehet kerülni. frissítések. De ilyen ez a frenetikus világ, amelyben az alkalmazások és szolgáltatások gyors és majdnem beteg fejlesztési ciklusban vannak (valószínűleg a Google szabta meg a böngészőjével) króm amely hathetente ad ki új stabil verziókat).

A lényeg az a legfrissebb Ubuntu 14.04 frissítés „megszakította” az NVIDIA Optimus alapú rendszerek sok felhasználójának támogatásáthát lássuk hogyan lehet megoldani ezt a problémát. Valami, ami szerencsére nem túl bonyolult, és csak néhány lépést igényel, amelyeket megpróbálunk a lehető legjobban részletezni, hogy bármely, egy kis bátorsággal rendelkező felhasználó meg merje tenni, de előtte röviden kommentáljuk, miről van szó. NVIDIA Optimus.

Ez egy olyan technológia, amely NVIDIA két grafikus chipkel rendelkező laptopok számára fejlesztette ki, amely lehetővé teszi, hogy átlátható módon és igény szerint váltson a állítsa be a teljesítményt és az akkumulátor élettartamát a beállítások szerint és a felhasználói igények. Kezdetben csak a Windows alatt támogatta, de hamarosan elkezdte támogatni a Linuxot is, és mellette van még az úgynevezett nyílt opció is Bumblebee, amit sok disztró alapértelmezés szerint beépít.

Nyilvánvalóan a legfrissebb Ubuntu 14.04 frissítés esetén Az ubuntu-drivers-common csomag olyan problémát hozott, amely kiküszöbölte a berendezés kompatibilitását ezzel az NVIDIA technológiával, megakadályozva az olyan grafikus környezetek végrehajtását, mint az Unity, a GNOME 2D, stb, és jelenleg nincs hivatalos megoldás, bár valószínűleg nem tart sokáig, de a probléma nagyon egyszerűen megoldható a NVIDIA illesztőprogramok, vagyis az, amelyet néhány órával ezelőtt telepítettek az Ubuntu frissítése előtt.

Ez nagyon egyszerű, és csak meg kell nyitnunk egy terminált (ne felejtsük el, hogy nem vagyunk semmilyen grafikus környezetben), amit kombinálva érünk el Ctrl+Alt+F1. Ezután beírjuk a felhasználói adatainkat, majd végre tudjuk hajtani a következő parancsot:

sudo apt-get install ubuntu-drivers-common = 1: 0.2.91.4 nvidia-common = 1: 0.2.91.4

Várjuk a telepítés befejezését, amellyel számunkra maradhat nvidia-drivers-common 2.91.6 (vagy 2.91.7, ha az Ubuntu által javasolt tárakat használjuk), majd futtatjuk:

sudo újraindítás

Most megvárjuk, amíg csapatunk újraindul, és a problémát meg kellett volna oldani, megmutatva a bejelentkezési ablakot, amelyet megszoktunk, és amelyet már a legfrissebb Ubuntu 14.04 frissítés letöltése és telepítése előtt is használhatunk.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

Legyen Ön az első hozzászóló

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra.

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.