Katoolin, telepítse az összes Kali Linux eszközt az Ubuntura

katolikus

Katoolin főmenü

Katoolin volt Pythonban fejlesztették ki és szabadon elérhető a Githubon az Ubuntu vagy a Linux Mint számára. A Kali linux eszközök telepítése mellett a Katoolin lehetővé teszi a tárolók, a menü és a klasszikus menü telepítését is a Unity felhasználói számára.

Sok felhasználó keresi a Kali Linux eszközök telepítésének legjobb módját, amelyekre mindenkinek egyszerű módon és a terjesztés telepítése nélkül szüksége van. Mint napi operációs rendszer, véleményem szerint sok kívánnivalót hagy maga után. És véletlenül rábukkantam katolikus.

Sokan töltik le a Kali linuxot, és nem használják az eszközeinek felét, miért nem telepíti csak a szükséges eszközöket? A Katoolin egy telepítési szkript készítette Lionsec. Ez kategóriák szerint sorolja fel az eszközöket, és lehetővé teszi számunkra, hogy egyszerű módon kiválasszuk, melyiket telepítjük a rendszerünkbe. Ahogy az várható volt, ez lehetővé teszi számunkra, hogy elkerüljük az egyesével történő összeállítást, mivel ez túl fáradságos munka.

Mi az a Kali Linux?

Azok számára, akik még nem tudják, a Kali Linux a Debian GNU / Linux-on alapuló disztribúció, amelyet elsősorban a audit és általában a számítógépes biztonság. Ezt a disztribúciót az Offensive Security Ltd. tartja fenn. Ez a csapat a BackTrack átírása alapján fejlesztette a disztribúciót. A Kali Linux elődjének tekinthetjük.

A Kali Linux nagy előnye, hogy hozza előre telepített több mint 600 program beleértve: Nmap (portolvasó), Wireshark (szippantó), Ripper János (jelszófeltöltő) és az Aircrack-ng csomag (szoftver vezeték nélküli hálózatok biztonsági tesztjeihez).

A Kali Linux használható Live CD-ről, live-usb-ről, és fő operációs rendszerként is telepíthető, bár mint már mondtam, ez nagyon nem tanácsos.

Telepítse a Katoolint

A Katoolin telepítéséhez a GitHub csapatából csak meg kell nyitnunk a terminált, és hozzá kell adnunk a következő szkriptet:

sudo su
git clone https://github.com/LionSec/katoolin.git && cp katoolin/katoolin.py /usr/bin/katoolin
chmod +x /usr/bin/katoolin
sudo katoolin

A telepítés után elindítjuk a parancsfájlt a következő paranccsal:

sudo katoolin

Miután elindította az alkalmazást, megjelenik egy 5 lehetőség listája. De a Kali Linux eszközeinek Ubuntu telepítéséhez csak az első kettőt fogjuk használni.

  1. Adja hozzá a Kali Linux adattárakat, és frissítse a tárak listáját.
  2. Lásd az eszközkategóriákat.
  3. Telepítse a "classicmenu indikátort".
  4. Telepítse a Kali linux menüt.
  5. Megmutatja azokat a parancsokat, amelyeket a szkript végrehajtása során használhatunk.

Telepítse a Kali Linux Tools alkalmazást

A Kali linux eszközök telepítéséhez először hozzá kell adni a tárakat. A lerakat frissítésének folytatása előtt ajánlatos megnézni a sources.list listát, hogy elkerüljük a duplikációt, ami problémát okoz a frissítés során.

Katoolin adattár opciók

Katoolin adattár opciók

Miután megbizonyosodtunk arról, hogy nincs duplikált tárhely, az "1" opcióval kezdjük. Ezen belül vannak további lehetőségek, amelyek lehetővé teszik számunkra, hogy a Kali Linux adattárakat hozzáadjuk a Sourcers.listához. A következő képernyőn ismét az 1. lehetőséget választjuk.

A telepítést a rendszer opcióinak frissítésével folytatjuk a 2. opció kiválasztásával, amely néhány szóval elvégzi a „sudo apt-get frissítést”. Meglátjuk a konzolon, hogyan frissítik az adattárakat.

Ha minden jól megy, akkor a "vissza" szót írjuk vissza az előző képernyőre. Ebben a "2" opciót választjuk, hogy megmutassuk az elérhető eszközök kategóriáit.

Ha itt van, a "0" megnyomásával telepíthetjük az összes kategóriába tartozó eszközt. Vagy kiválaszthatunk egy kategóriát, majd kiválaszthatjuk a telepíteni kívánt eszközöket.

Katoolin kategóriái

Katoolin kategóriái

Egy kategórián belül megnyomhatjuk a "0" gombot a kiválasztott kategóriába tartozó összes eszköz telepítéséhez. Felírhatjuk annak az eszköznek a számát is, amelyet érdekel a telepítés.

A műveletek befejezése után csak ki kell lépnünk a szkriptből. Most láthatjuk, hogy már megvan a Kali Linux eszközök az Ubuntuban.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

18 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Chus M-dh dijo

    Visszatértem a 17.04-re a telepítéshez, de először voltak problémáim. Később még több volt, és visszatértem a 16.04 LTS-re (gondoltam, hogy megbízhatóbb lesz), mit jelent, az első dolog az történt, hogy eltűnt a kereső, az ikonok, az indítóban. Aztán folyamatosan azt mondta: "Sajnálom, hogy az Ubuntu belső hibát tapasztalt", és belső hibák jelentkeznek. A rendszer teljesen meghibásodott, és hosszú idő után el kellett hagynom, mint lehetetlent. A Linux instabil operációs rendszer, mindig a böngészőben kell megoldásokat keresni, mindig frissítésekkel. Sok disztró van, sok változat, ha valami működik, akkor eltávolítják és nem működő dolgokat helyeznek el. Ez egy katasztrófa. Mindig a rendszerért dolgozol, és nem fordítva, ahogy annak lennie kell. Meglátjuk, sikerül-e valaha stabilnak lenni. Vagy telepítse újra.

    1.    Daniel salinas dijo

      Megértem, hogy az összes operációs rendszer frissül

      1.    ChocopandaAvngr dijo

        A végfelhasználóknak szánt rendszerek, amelyek a Linux kernelt implementálták, általában nagyon stabilak és stabilak, de a felhasználó az, aki instabillá teszi azáltal, hogy hülyeségeket művel, amelyeket az interneten olvasnak (például a güinbug $ -nál).

    2.    Aragorn-Seiya Miyazaki dijo

      Lehet, hogy hiba történt a telepítés során, vagy olyan dolgokat helyezett át, amelyeket nem kellett volna, az ikonok vagy a kereső nem tűnnek el így. Közel 3 éve vagyok az Ubuntuban, és soha nem okozott nekem komoly hibát, a megjelenő apró hibák olyanok, amelyeket bármely más operációs rendszer ad, csak másokban, mint a Windows, néha nem is figyelmeztetnek: másrészt úgy gondolom, hogy ha Linuxot akarsz használni, akkor igen, tölts egy kis időt a használatának megtanulásával, de úgy gondolom, hogy érdemes megtenni.

    3.    Rodrigo Heredia dijo

      12.04-től frissítettem, ma 16.04 van, és nincsenek stabilitási problémáim, és túlhúzom a processzort.

    4.    Josinux dijo

      Az a tény, hogy nem tetszik, vagy hogy nem megy jól, még nem jelenti azt, hogy rossz operációs rendszerről van szó, és maximálisan beszélek egy lts-ről, nekem van az xubuntu 16.04-es verzióm, amióta kijött, és a számítógép közvetlenül repít és soha nem volt egyetlen problémám, és ismerek egy Linux-felhasználót, aki nem kevesebb, mint 2012 óta telepítette az xubuntut a pc-jére, neki 14.04-je van, ami szintén lts, ​​és 2012 óta soha nem mondják jól, egyetlen problémája sem volt , Azt hiszem, inkább fogalmad sincs, és elrontod.

  2.   Inukaze dijo

    Remélhetőleg és ezeknek a blogoknak a szerzői abbahagyják a címek elhelyezését, amelyek a végfelhasználókat elhitetik velük, hogy a disztribúciók teljesen különböző operációs rendszerek.

    Bármely Liñux eszközt telepíthetünk bármely Liñux disztribúcióra.

    Ha tudod, hogy mit csinálsz, akár az apt és a pacman alkalmazást is telepítheted a Fedorába, és kényelmetlenség nélkül használhatod, vagy használhatod az "AppStore" -ot a "Deepin" -re a Slackware vagy az OpenSuSE programban.

    De amúgy a kézi fordítás mindig jobb, mint az előre lefordított, hacsak a kézi fordítás nem sikerül.

    Mert még egy DOSBox 0.74-et is megoszthatok veled, amely a Slackware 11.0-ban fordít, és bármilyen disztribúcióban működik, még akkor is, ha "Élő" módban van, amíg grafikus környezettel rendelkezik, még akkor is, ha minimalista.

    1.    Damian Amoedo dijo

      Ha valaki úgy gondolta, hogy a disztribúciók teljesen különböző operációs rendszerek, akkor nem olvasta el a cikk többi részét. Az első nagyobb hiba.

      Nyilvánvaló, hogy bármely felhasználó türelemmel telepíthet egy eszközt bármely Linux disztribúcióra (egyes esetekben fellázadhat). De ne felejtsd el, hogy "nem mindenki tanultnak születik". Nem minden felhasználó rendelkezik ezzel a tudással, így egy ilyen, előre lefordított alkalmazásokkal rendelkező szkript segítségével több laikus kipróbálhatja bizonyos alkalmazásokat, amelyeknek előnyeit kihasználhatják. És ha szeretik őket, akkor mindig lesz idejük tanulni. Minden idő kérdése, hogy megszerezzük a dolgokat, bár nem mindenkinek van meg. A teljes cikkek elolvasása a vélemény kialakítása előtt jó kiindulópont.

      Be kell vallanom, hogy ha van valami, amiben egyetértek veled. Az alkalmazások kézi összeállítása a legjobb megoldás egy installációra az igazság pillanatában, de ez már mindenki ízlésének kérdése.

      Üdvözlet.

  3.   Elphist0n dijo

    Jó reggelt, van egy kérdésem.
    Miért nem tanácsos Kalit használni elsődleges operációs rendszerként?

    1.    Damian Amoedo dijo

      Amit mondok, nem tanácsos, mert az én ízlésemnek megfelelően, és miután számítógépen használtam, mint fő operációs rendszert, kissé instabilnak tűnt. De ez személyes megbecsülés, próbáld ki és vond le saját következtetéseidet. Üdvözlet.

  4.   Melléklet dijo

    A probléma a tárakkal kapcsolatos, a tárak hozzáadásával az operációs rendszer Kali verzióra frissül, és konfliktusok keletkeznek, csak ne adja hozzá a tárakat, és megfelelően fog működni, csak az Ubuntu 17.04-ben teszteltem

    1.    Emmanuel dijo

      Könnyű: Ha már nem használja a Kali eszközöket, deaktiválja a tárakat úgy, hogy kommentálja a megfelelő sort a nano /etc/apt/sources.list oldalon, és ily módon a rendszer nem ütközik az apt-get frissítés során.

      Üdvözlet.

  5.   forteszk dijo

    a 2. install parancs végrehajtásakor ezt kapom: bash: szintaktikai hiba a váratlan elem közelében;

    1.    Damien Amoedo dijo

      Szia. Próbáljon beírni: git clone https://github.com/LionSec/katoolin.git && cp katoolin/katoolin.py /usr/bin/katoolin

  6.   Miguel dijo

    Hiányzik az> apt install git, ha nincs telepítve a git.

  7.   Oscar dijo

    Helló,

    Megpróbáltam telepíteni az eszközöket a tárak hozzáadása és frissítése után, és ez elég sok hibát ad nekem:

    Csomaglista olvasása ... Kész
    Függőségfa létrehozása
    Az állapotinformációk olvasása ... Kész
    A gqrx csomag nem érhető el, de néhány más csomag hivatkozás
    hoz. Ez azt jelentheti, hogy a csomag hiányzik, elavult vagy csak
    más forrásból elérhető
    A következő csomagok azonban felváltják:
    gqrx-sdr: i386 gqrx-sdr

    E: Az acccheck csomag nem található
    E: Az automater csomag nem található
    E: A dnmap csomag nem található
    E: A ghost-phisher csomag nem található
    E: A maltego-teeth csomag nem található
    E: A miranda csomag nem található
    E: Az sslcaudit csomag nem található
    E: A wol-e csomag nem található
    E: A hexorbáz csomag nem található
    E: A powerfuzzer csomag nem található
    E: A ghost-phisher csomag nem található
    E: A giskismet csomag nem található
    E: A "gqrx" csomagnak nincs telepítési jelöltje
    E: A wifitap csomag nem található
    E: A blindelephant csomag nem található
    E: A lerobbant csomag nem található
    E: A fimap csomag nem található
    E: A fogócsomagot nem sikerült megtalálni
    E: A maltego-teeth csomag nem található
    E: A powerfuzzer csomag nem található
    E: A proxystrike csomag nem található
    E: Az ua-tester csomag nem található
    E: A vega csomag nem található
    E: A http-alagút csomagja nem található
    E: A kereszteződő csomag nem található
    E: Az u3-pwn csomag nem található
    E: A magictree csomag nem található
    E: A maltego-teeth csomag nem található
    E: Az iphone-backup-analyzer csomag nem található
    E: A pdgmail csomag nem található
    E: Az acccheck csomag nem található
    E: A creddump csomag nem található
    E: A findmyhash csomag nem található
    E: A hexorbáz csomag nem található
    E: A keimpx csomag nem található
    E: A maltego-teeth csomag nem található
    E: A jad csomag nem található

    Van valami tipp a folytatásra? Megpróbáltam frissíteni a csomagokat, megtisztítani, regenerálni a source.list ... sikertelenül.

    Köszönöm.

  8.   NÉVTELEN dijo

    hol tárolják?

  9.   Torres Messiás dijo

    Az EU ESTOU 3 NAPJA TÖBB VERÓIÓT TESTE DO KALI LINUXBÓL ÉS ESTALAÇÓ NEM RENDSZERBŐL NÁO ACHA A VERÇÃO, HOGY VAN TESTES ÉLŐ ÉLŐ RENDSZERE A TESTE -TŐL, hogy ez nem függ attól, hogy ITT ESTALAR VAGY KALI LINUX RENDSZER TESTE E SE GOSTARMOS FAZER ESTALÇAO DIRETO DO SISTEMA NA MACHINA, DEVE TER UMA FACILITAÇÃO DE ESTALAÇÃO DO SISTEMA