Miért érdemes visszamenni a GNOME szoftverhez, és elfelejteni az Ubuntu szoftvert az Ubuntu 20.04-ből ... legalábbis egyelőre

Ubuntu szoftver és Ubuntu szoftver, két üzlet az Ubuntu 20.04-en

Számomra ez az évek egyik legrosszabb kanonikus mozdulata. Megértem, hogy meg akarják szorítani a Snap csomagok használatát és motiválni a fejlesztőket és a felhasználókat, de ez nem így van. Nem azért, mert zavaró, a kevésbé tapasztalatlan felhasználók nem találnak néhány lehetőséget, a fejlettebbek pedig a szabadság hiányát érzik ... hacsak nem telepítjük a régit GNOME szoftver és élvezzük tovább mindent, mint korábban.

És ez az, hogy legalábbis ma A Focal Fossa Ubuntu szoftvere nem támogatja a Flatpak csomagokat, például. Ezenkívül, ahogy a Discover akár egy szoftver három verzióját is képes megjeleníteni (APT, Snap és Flatpak, ha engedélyezzük a támogatást), az új Ubuntu 20.04 áruház csak egyet mutat, a Snapcraft-ot, arra kényszerítve minket, hogy telepítsük a Snap csomagot Az APT verzió elérhető a hivatalos adattárakból ... hacsak nincs Snap csomag, amely akkor kínálja az APT verziót. Mint korábban mondtam, zavaros.

A GNOME szoftver támogatja a Snap és a Flatpak szolgáltatásokat

Amint elmagyarázzuk ezt a cikket arról, hogyan lehet engedélyezni a Flatpak csomagok támogatását az Ubuntuban, az Ubuntu 20.04-ig megjeleníthetjük az Ubuntu szoftverboltot Flathub eredmények ha telepítettük a "gnome-software-plugin-flatpak" csomagot, de az írás idején nincs semmi hasonló az új Ubuntu szoftverhez, és kétlem, hogy a Canonical megengedi a jövőben.

Akkor miért kell használnunk az új szoftverboltot? Milyen előnyöket kínál számunkra? Most, hogy mélyen, egymás mellett tesztelhettem a kettőt, úgy gondolom, hogy igen, a Canonicalnak meg kell próbálnia javítani a csomagjaik támogatását, de nem azon az áron, hogy MINDKET összezavarják és SOKKAL károsítják a felhasználókat. Mindaddig, amíg valami nem változik, például a módszerek enyhítése a Snap tovább népszerűsítésével, de az APT verzióinak megjelenítése még akkor is, ha rejtve van, meggyőződésem, hogy a legjobb az telepítse a "gnome-software" csomagot és folytassuk a szoftverek telepítését, mint az Eoan Ermine-ig.

Kicsit tetszett a változás az Unity-re, olyan kevéssé, hogy átálltam Ubuntu MATE amennyire csak tudtam, de ez ízlés kérdése volt, és nem volt olyan rossz az erős felszereléseknél. A boltváltás szerintem rossz minden felhasználó számára, és tudom, hogy sokan ugyanazt gondolják. Reméljük, hogy a Canonical visszalép, és ha nem, akkor mindig más lehetőségeket is telepíthetünk.


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

17 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Rafa dijo

    Ezekért a dolgokért az MInt-hez mentem ... hogy megkerüljem Mark kényszerét. Nem én fogom tagadni, hogy a nap folyamán jó munkát végzett, és hogy az Ubuntu jó. De ettől kezdve bármi olyan kiszabásához, ami a fején megy keresztül, mintha a világ legjobbjai lennének, mert felmerült benne. Hát nem. Így nem megyek át, és még egy vagyok, aki örökre eltűnt. A pénzverde ubuntu továbbfejlesztett és Mark paranoiája nélkül.

    Snap szar az appimage-hez és a flatpak-hoz képest. És hogy ne terjesszem ki magam itt jobban, otthagyom. De sok tesztet elvégeztem különféle alkalmazásokkal, és ha a jövőben a linux-ot egyetlen lehetőségként alkalmazzák, akkor visszatérek a Windows-hoz to, mert lejtős.

  2.   Daniel dijo

    Igazad van, hogy teszteltem a snap-ot és nagyon rosszul. Közülük sok, szinte mindegyik csak a rendszeren belül működik, és nem képes például szövegszerkesztőkre, zenelejátszókra, más partíciókon vagy külső meghajtókon található fájlok olvasására (a vlc kivételével). Ha azt mondom, hogy a Flatpak sokkal jobban megdolgozott, nagyon jól működik, és az alkalmazás több problémából is kijutott, nagyon hasznos. Megtalálom azt az okot, amiért a szoftverközpont valóban zavaró, figyelni kell arra, hogy mit telepít. Másrészt szembetűnő, hogy egyes tárházalkalmazások nem naprakészek, de be vannak csapva. A veszély abban rejlik, hogy az alkalmazásokat örökre eldobjuk a tárolókból, és a felhasználót a snap csomagba kényszerítjük, ami a kanonikus számára a jövő. Üdvözlettel.

    1.    Nasher_87 (ARG) dijo

      Daniel, ezek az engedélyek le vannak tiltva, különben az aktívak soha nem fogják olvasni a külső partíciókat

      1.    Raphael Romero dijo

        Megpróbálta engedélyeket adni neki? Szerintem nem, mert a Snaps nagyon jól működik.

    2.    Rafa dijo

      Jómagam a Gimp-ben, hogy tudjak ecseteket, színátmeneteket és harmadik féltől származó plugineket rakni, micsoda fejfájás ... azonban a flatpak-szal nem kellett semmit sem tennem, automatikusan felismerte őket az otthoni mappából.

      Ezután a teljesítmény egy pillanat alatt, sokkal alacsonyabb, de sokkal alacsonyabb, mint a flatpak. És nem is beszélve a nyitvatartásról, a legeredetibb Microsoft stílusban, duplán kattintva az ikonra, és elmegyünk kávézni.

      1.    Daniel dijo

        Kösz haver, fogalmam sem volt az engedélyekről. Értékelik.

        1.    Pelayo dijo

          Igazad van. Pontosan ugyanez történik a GIMP-vel és a harmadik féltől származó beépülő modulokkal. A Flat-rel megoldottam paracetamol szedése nélkül.

    3.    Raphael Romero dijo

      Az az igazság, hogy amióta többek között az Ubuntut és annak származékait használom, mint például a POP_OS, a Mint, soha nem nyúltam hozzá a Gnome szoftverbolthoz (eddig tudom, hogy így hívják). Először mindig a parancsablakba megyek, és a mindig megbízható APT-t használom, letöltöm a közvetlen DEB-ket vagy lefordítom a forráskódból ... másfél évvel ezelőttig az első dolgom a "sudo apt install snapd" snap-store ". Az az igazság, hogy nem a Gnome áruházat használom, mert legtöbbször elavult dolgokat hoz, és ha eltávolították a szokásos Store-ot, nem hinném, hogy azért, mert sokat használják, és nem azért, mert kiszabták, vagy mert a paranoia nem tudom, ki. Ha nem olvastam volna ezt a cikket, soha nem vettem volna észre ilyen hiányt. Ne vegyen fel az ebben a cikkben említett "többségbe", vizuális tapasztalatból tudom, hogy ezt az üzletet nem használják, legalábbis a Linux baráti körömben nem.

  3.   Alberto dijo

    Ha igazi gnómot szeretnél az Ubuntuban, használd a Pop! _Os-t (amely már 20.04-es bétaverzióval rendelkezik). Ez minden, aminek az Ubuntu-nak lennie kell

  4.   Nick0bre dijo

    Pablinux, egyetértek veled a pontatlan Canonical vállalatnál, hogy ezeket a snap csomagokat valamilyen módon előírja, és nem adja meg a Linux operációs rendszerek elvárt minőségét. Mások, akik a Debian, a RedHat, az AppImage, a Flatpak és az Arch Linux csomagolására szánják el magukat, kiemelten kezelik a minőséget a klasszikus Linux rendszerekkel szemben. A Canonical a korábbi Snappy-vel (egyesek emlékeznek arra, hogy 2016-ban ezeknek a csomagoknak az volt a célja, hogy Ubuntu Touch) vizet készítsen. használat.

  5.   Antonio dijo

    Több mint 10 évvel ezelőtt kezdtem az utamat Linux alatt az Ubuntuval. Amikor ilyen cikkeket olvasok, egyre kényelmesebbnek érzem magam, amikor Manjaro-ra váltottam. Az AUR adattárral egyetlen szoftverrel rendelkezik egyetlen kattintással.

    1.    Miguel dijo

      Teljesen egyetért Antonio, a manjaróval és az aurval nincs semmi, ami nem található meg, és ami nincs megoldva. Belefáradtam az egyik verzió és a másik közötti frissítés hibáiba, ami soha nem fordul elő manjaro-ban, és minden naprakész.

  6.   Sok a dijo

    Azon a napon, amikor nem tudom telepíteni a nem-snap szoftvert, kilépek az Ubuntuból ... Nos, egy ideje megpróbáltam telepíteni a freeBSD-t.

    Az én pillanatomra ez baromság, és nem fogom csökkenteni a normáimat csak a "kényelem" vagy a kényszerítés érdekében.

  7.   tetelx dijo

    A "http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu focal Release" tárolóban nincs kiadási fájl

    Err: 9 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu gócos kiadás
    404 nem található [IP: ——————————-

    És most mit csináljak ?????

    1.    pablinux dijo

      Működnie kell. Ha nem, akkor telepíthet egy valamivel régebbi "flatpak" csomagot, amely a hivatalos adattárakban található és ugyanolyan jó neked.

      A köszöntés.

  8.   Diego Abdali dijo

    Azt hiszem, ugyanaz a barátom, most telepítettem az Ubuntut erre a laptopra, és azt tervezem, hogy eltávolítom a snap boltot és telepítem a Gnome szoftvert

    1.    pablinux dijo

      Szia Diego. Ne tedd. Vagyis ne távolítsa el. Az Ubuntuban a Snap Store a snapdhoz van kötve, és ha Snaps csomagokat szeretne használni, akkor rendelkeznie kell vele. Javasoljuk, hogy telepítse a GNOME szoftvert, hagyja azt a boltot a dokkolóban, és felejtse el a Snap Store-ot, mintha ott sem lett volna.

      A köszöntés.