Miért vesztem el a reményt a Snap csomagokkal kapcsolatban [vélemény]

lenyűgöző logó

Az Ubuntu 16.04 LTS egyik legkiemelkedőbb új funkciója az snap csomagok. Az ilyen típusú csomagok mind előnyöket jelentenek: azt mondták: a frissítések leküldésesek, ami azt jelenti, hogy azonnali lesz magából a programból. Az összes függőséget a csomag tartalmazza. Sok operációs rendszerrel kompatibilisek. De vajon tényleg ennyire jó?

Három év telt el, és nem. Vagy még nem. Három év lehet rövid vagy hosszú, az Ön nézőpontjától függően, de jelenleg úgy gondolom, hogy ezek a csomagok, mint a Flatpak, nem olyan tökéletesek, mint várták. Ragaszkodom: még nem. Ebben a bejegyzésben fontos egyértelművé tenni, hogy az Véleményem, Elmagyarázom, miért vagyok ilyen pesszimista 2019 márciusában, ami reményeim szerint megváltozik a nem túl távoli jövőben.

A Snap csomagok nem épülnek be olyan jól, mint az APT-k

Ahogy el lehet képzelni, Linux blogszerkesztőként sok szoftvert tesztelek, sokféle módon. Az első dolog, amit észrevettem, nem egy cikk írása volt, hanem a választásom: eltávolítottam a Firefoxot az APT verzió telepítéséhez, és azonnal az indítás után Rájöttem, hogy nem volt annyira integrálva az operációs rendszerbe ahogy az APT verzió is. Ha őszintének kell lennem, most már nem emlékszem, mi, talán valami a kezelőfelületéről, de valami rosszabbra hívta fel a figyelmemet, és arra gondoltam: a programok Snap verziójában, ha létezik ».

Ezt az integrációt az Ubunlog olvasói kommentálták: a dolgok a Snap verzióban nem ugyanazok, mint az APT-ben. És ez bosszantó. Egy dolgot megszoktunk, és ők változtatják meg helyettünk. De nemcsak ezek az apró változtatások, hanem ha például használjuk a KDE-t és telepítünk egy GNOME-alapú csomagot, akkor a kép nem fog olyan jól kinézni a rendszeren, mint a "hivatalos" verzió. És ami még ennél is rosszabb: van olyan szoftver, amely nem veszi figyelembe a változásokat, például a bal oldali gombokat, így végül különböző ablakelrendezésekkel rendelkezünk. Természetesen el kell ismerni, hogy ez nem kizárólag a Snap verziókra vonatkozik, de gyakoribb. A Flatpak verzióiban is előfordul.

Hol vannak az azonnali frissítések a Snapból?

Ezen a héten azt kérdezte tőlem: „Mikor frissül? Firefox Snap verziójában? ». Nos, az elmélet azt mondja, hogy automatikusan történik, de nem. Feltételezzük, hogy amint elindítja a programot, megjelenik egy értesítés arról, hogy van új verzió. Valójában, a letöltésnek automatikusnak kell lennie, de nem. Ha a «Firefoxról» «Segítségre» megyünk, ahol új verzió létezik, megjelenik egy üzenet, ahonnan letölthetjük a böngésző kódját. A fájlok kézi másolása? Micsoda kellemetlenség! Erre jobb várni egy kicsit, mivel a Firefox 66 alig 48 órával a hivatalos indítása után jutott el az APT-tárházakba.

Igen, a jövőben jobb lesz. Nem igazán értem, hogy a Mozilla-hoz hasonló cégek miért készítik elő a megfelelőt a Windows és a macOS rendszerben, és miért hagyják maguk mögött a Linux-felhasználókat. Azért, mert mindannyiunknak lehetősége van a tárakra? Bármi is legyen, túl sok pasotizmust és ígéretet látok, amelyeket 2016-ban tettek nekünk az azonnali frissítések nem teljesülnek.

Váratlan bezárások

Ennek köze lehet az integrációhoz. Menetrend egyszer most 42 operációs rendszer ennek lehetnek következményei. 42 operációs rendszer sok, és ez a szám sokszorozható, ha figyelembe vesszük a különböző grafikus környezeteket. Láttam, hogy két program, az egyik a Flatpakon keresztül, a másik pedig a Snap verziójában, váratlanul bezárt. Linux felhasználóként pedig hülye arcom van. Hányszor láttam 14 év alatt? Azt hiszem, egy kéz ujján meg lehet őket számolni, és ezek közül kettő az ilyen típusú csomagokra és az idei évre vonatkozik. Ami a Flatpak verziót illeti, néha még a programot sem nyitották meg számomra, ami arra kényszerített, hogy telepítsem az APT verziót.

Minden nincs elveszve

Személyesen, Szerintem a Canonicalnak kellene egy kicsit nyomulnia sokkal inkább, hogy a fejlesztőket arra ösztönözzék, hogy javítsák szoftvereik Snap változatát. Ami nem érkezett meg, az az, hogy a Firefox még mindig a Snap verziójában a 65.x verziót használja, amikor a 66.0.1 verzió már elérhető az APT-tárházakban, és hamarosan elérhetővé válik a Firefox 66.0.2, amely kijavít két biztonsági hibát, amelyeket a Mozilla felcímkézett mint komoly. Az ilyen típusú csomagok egyik oka az a biztonság, amelyet az azonnali frissítések adnak nekünk, de nincs biztonság, ha nincs frissítés. Számomra a felelősség egy részét Mark Shuttleworth és csapata viseli.

Természetesen minden nincs elveszve. A korszerűbb csomagrendszer első éveiben vagyunk. A jövőben a frissítések jobbak lesznek, akárcsak a Windows és a macOS verziók. A váratlan bezárásokat az általunk küldött jelentésekkel rögzítjük. Kicsit nehezebb lesz, ha a tervezés tökéletes lesz az összes operációs rendszeren, de szinte az összes modern rendszer meglehetősen lapos felépítésű és némi hasonlóságot mutat.

Mi a véleményed a Snap csomagokról?

Kapcsolódó cikk:
Már havonta több mint 3 millió Snaps-ot telepítünk

A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

7 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Juan Carlos dijo

    Hogy őszinte legyek, amikor először telepítettem egy bepattintást, az a VLC programnak szólt, és mekkora meglepetés volt, mindezt angolul, win 98 interfésszel, és onnan mondtam; "Soha ne telepítsem újra", és a mai napig nem tettem meg (pár éve), megtartom a .deb csomagokat.

  2.   Paco dijo

    Néhány napja telepítettem a Photoscape-et snap-ra, és szar volt, nem volt rá mód, eltávolítottam, bort telepítettem, mint korábban, és Windows exe-ként futtattam, és problémamentesen kell működnie, egyetértek, az eredmény nem csiszoltak és problémákat okoznak a működésben.

    1.    pablinux dijo

      Helló Paco. Ellenőriztem most, és igen, nem is nyílik meg előttem, sok hibát ad. Az egyetlen dolog, amit elmondanék neked, hogy a Photoscape a Windows és a MacOS számára készült, ezért egy "portról" beszélünk, amely megpróbálja a fő és emulációs szoftvert ugyanabba a csomagba tenni.

      Az biztos, hogy amint elképzelem, hogy ez történik veled, úgy gondolom, hogy nem szabad csomagot indítaniuk, ha még nem próbálták ki eléggé, legalábbis egy ilyet.

      Mivel sok mindent ki kell próbálnom, igyekszem tovább. Jelenleg a GIMP Snap verziója van, mert az APT verzió problémákat okozott nekem .. Ó, az történik, hogy az én esetemben maradnak olyan telepítésekből származó maradványok, amelyeket nem akarok keresni. Amikor a következő hónapban formázom, maradok az összes fontos dolog APT változatánál. Szerintem túl korai a Flatpak és a Snap csomagrendszerek esetében.

      A köszöntés.

    2.    Gaston dijo

      Egyetértek, az SNAP verzió lassú és nem mindig működik, jobb egy APPImage?

  3.   Linuxero 1998 óta dijo

    Az év elején kipróbáltam a Freecad alkalmazást, és rákattintottam a Debian 9-re, ezt lehetetlennek kellett hagynom. Ugyanazok a problémák, amelyeket Juan Carlos megjegyez, és váratlan eltérések a programtól. Vissza a Freecad 0.16-hoz, amely elérhető a jelenlegi adattárakban.

  4.   Sergio dijo

    Kipróbáltam a LibreOffice snap verzióját, és ez problémákat okozott nekem. Az elmúlt 10 napban a programok több verzióját teszteltem snap-al, és többé-kevésbé ugyanúgy működtek, mint mindig, de az az igazság, hogy nem jelentenek különbséget a jobb oldalon, és a LibreOffice esetében ez közvetlenül rosszabb nekem csattanóval.
    A héten tiszta telepítést kell végeznem az Ubuntu-val, és mindent visszaadok az apt-re és gyorsabban frissítem a ppa-val, ha vannak ilyenek.

  5.   Andreale Dicam dijo

    El sem tudod képzelni, milyen kárt okozol magadnak, amikor törölsz üzeneteket tőlünk, olvasóktól, ha nem tetszik nekik ... akkor tiltsd le a megjegyzés rovatát. hogy megszűrjen minket.