Ubuntu18.04にHPプリンタードライバーをインストールする方法

HPプリンター

スキャンで2Dプリンターを使用することはますますまれになっていますが、スキャンできない、またはスキャンすべきでないドキュメントを印刷するために、優れたプリンターを使用する必要がある多くの領域とセクターがあります。

最も有名で人気のあるプリンタブランドのXNUMXつは、HPまたはHewlett-Packardです。 これらのプリンターは世界中にあり、世界中の卸売メーカーであるため、確かに複数のプリンターが使用されています。 UbuntuコンピューターにHPプリンターをインストールする必要性。 次に、Ubuntu18.04でそれを行う方法を説明します。現在、UbuntuにHPプリンターをインストールするにはXNUMXつの方法があります。 それらのXNUMXつは HPプリンターの基本機能を使用する汎用ドライバーでそれを行います、このインストールはに行くことによって達成されます [構成]-> [デバイス]-> [プリンター]をクリックし、パネルで[プリンターの追加]ボタンを押します。; これにより、構成ウィザードが起動し、選択したHPプリンター用の汎用ドライバーがインストールされます。 しかし、HPは何年にもわたって自由ソフトウェアと協力しており、 ずっと前に、Gnu / LinuxとUbuntu専用のドライバー。 これはHPLIPとして知られています.

プリンターデバイス

まず、 このドライバーをダウンロードする。 ダウンロードしたら、それが存在するフォルダーでターミナルを開き、次のように記述します。

chmod +x hplip-3.18.04.run && ./hplip-3.18.04.run

これにより、UbuntuシステムへのHPプリンターのインストールが開始されます。 インストール中に、「はい」の場合はY、「いいえ」の場合はNで回答する必要がある質問が表示されます。 ¡おじょ! hpliplaという単語に続く番号付け ダウンロードしたパッケージに合わせる必要があります そうでなければ、それは機能しません。

これで、HPプリンターがUbuntuにインストールされます。つまり、Ubuntuで編集または作成したドキュメントを印刷するために使用できます。


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

13コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   フェルナンドロベルトフェルナンデス

    このソフトウェアには、カートリッジ内のインクレベルに関する情報を提供する「HPTOOLBOX」と呼ばれる非常に便利な拡張機能が含まれています。 強くお勧めします。

  2.   私はニッチに行きます

    Ubuntu 18と言えば、32ビットバージョンがないのはどれほど不幸なことでしょうか。

  3.   チャーリー

    18.04ビットバージョンを使用している場合はubuntumate 32

  4.   ホルヘ・ガルシア

    完璧です。汎用ドライバーを使用すると、Ubuntu16.04からUbuntu18.04に移行し、hplip-3.19.1を使用すると、プリンターが機能しなくなりました。
    https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
    私はそれを取り戻しました。

  5.   エドガー・ウィリアムズ

    私はhpノートブックを持っていますが、Wi-Fiドライバーをインストールできません。正直なところ、10バージョンは18.4で実行されています。 誰か助けてもらえますか?

  6.   アンソニー

    ターミナルでchmod + x hplip-3.18.04.run && ./hplip-3.18.04.runと入力すると、ファイルが存在しないことが通知されます。

    marina @ marina-X550WAK:〜/ダウンロード$ chmod + x hplip-3.18.04.run && ./hplip-3.18.04.run
    chmod: 'hplip-3.18.04.run'にアクセスできません:ファイルまたはディレクトリが存在しません

    マリーナ@マリーナ-X550WAK:〜/ダウンロード$

    1.    ヘラルド

      こんにちはアントニオ、あなたはテキストで調整する必要があります、あなたがダウンロードしたhplipのバージョン、私は今リンクからダウンロードします、そしてバージョンは3.16.7です

  7.   ルイス·ゴンザレス

    それが言うようにそれをインストールするとき、それは私にスーパーユーザーのパスワードを要求します、私は私のものを入力します、そしてそれはそれを受け入れません。 それは何の鍵ですか?

  8.   カルロス・ルイス・ヴィラロボス

    Ubuntu 18.04を使用していて、hplip-3.16.7ドライバーをダウンロードしましたが、Ubuntu16.04ディストリビューションを要求されます。

  9.   アンドレス・ヒラルド

    素晴らしい。 あなたは私を狭い場所から追い出しました。 これまでのところ、私はLinuxから始めましたが、Windowsのようにいくつかの設定を行うのは簡単ではありませんでした。
    必要なものを少しグーグルで検索し、インストールしたディストリビューションに応じて、カスタム、忍耐、経験がありますが、私の場合はubuntu20.04でhpphotosmartc3.20.5プリンターを構成するためにhplip4780を見つけました。

  10.   ディエゴC

    ドライバをダウンロードするためのリンクが変更されました。 https://sourceforge.net/projects/hplip/
    ポストをありがとう

  11.   ゲイビー

    コメントします。 hp Laser 107aプリンターを購入し、次のドライバー「HP Laser Ns 18.04、hpcups 1020」を使用してubuntu 3.19.6にインストールできましたが、hplipを更新する前ではなく、バージョン「3.19.6」からの偶然です。 "、hplipから、私が購入したプリンターと互換性のあるこのドライバーを見つけることができます。 hpの製造元は、Linuxで使用できるこのドライバーを持っていません。これは、HPの会社と連携して動作するhplipによって処理されます。
    hpが行う重要なことは、バージョンを確認し、hplipの各バージョンに追加されたプリンターを確認するためにHplipに送信することです...すべてが魔法のように、Linux Ubuntu 19.10の時点で、このプリンターはマシンのhplipにあります。 つまり、Ubuntu 19.10より前のバージョンがある場合は、上記のコンパニオンが教えているように、新しいバージョンを手動でダウンロードする必要があります。
    このプリンターのお役に立てば幸いです。 以下に「.run」を残します。
    https://sourceforge.net/projects/hplip/files/hplip/3.19.6/hplip-3.19.6.run/download

  12.   ANA

    こんにちは、コマンドのコピー、ドライバパッケージの数の変更など...ファイルが存在しないことを教えてくれます。私はこれを何日も使っているので少し必死です。 HP Laserjet Pro M15aを使用していて、コンピューターはUbuntu16.04です。

    助けてください! 前もって感謝します