Norėdami kovoti su „Meltdown“, įdiekite branduolį 4.14.13

Linux Kernel

su naujausi saugumo klausimai sukurta pastarosiomis savaitėmis su dėl „Meltdown“ ir „Spectre“ atakų, didelės programinės įrangos kompanijos įdėjo daug darbo, kad tai surastų ir išspręstų.

Tuo tarpu „Linux“ sistemoje mes jau turime pirmuosius taisymus, kurie pašalina šiuos rimtus saugumo trūkumus, todėl turime sau užduotį atnaujinti saugotinos sistemos branduolį.

En šią naują versiją „Linux“ branduolio priežiūra Įspūdingiausias de esto Jie yra lopai, kurie sustabdo „Meltdown“ ir „Spectre“ atakaskita vertus, jie stengėsi išvengti atminties perpildymo problemų ir atminties paskirstymo.

Kaip įdiegti „Linux“ branduolio 4.14.13 priežiūros versiją „Ubuntu 17.10“?

Be daugiau vienintelio dalyko, kurį galiu pasakyti yra tai, kad ši versija yra nepaprastai svarbi norint ją turėti mūsų sistemoje, nes tai yra šiuo metu kylančių saugumo problemų sprendimas.

Verta tai paminėti čia aprašytas procesas galioja ne tik „Ubuntu“, mes taip pat galime tai padaryti Linux Mint, Elementary OS, Zorin OS ir bet kuri kita iš „Ubuntu“ išvestos sistemos.

32 bitų versijoms Atidarome terminalą ir vykdome:

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413_4.14.13-041413.201801101001_all.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413-generic_4.14.13-041413.201801101001_i386.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_i386.deb

Tai jau padarė, tMes įdiegiame paketus prieš atsisiųsdami toliau nurodytus veiksmus:

sudo dpkg -i linux-headers-4.14.13*.deb linux-image-4.14.13*.deb

Dabar 64 bitų sistemoms, atsisiunčiame šiuos paketus:

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413_4.14.13-041413.201801101001_all.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

Y mes pagaliau įdiegėme šią komandą:

sudo dpkg -i linux-headers-4.14.13*.deb linux-image-4.14.13*.deb

Pagaliau Kad pakeitimai įsigaliotų, teks iš naujo paleisti kompiuterį o kai esame „Grub“, turime įsitikinti, kad sistema prasideda nuo naujo branduolio.

Dabar, jei esate naujokas, galite to nedaryti rankiniu būdu, galite naudoti šį įrankį, kuris gali padėti tai padaryti už jus, nuoroda tai.


Palikite komentarą

Jūsų elektroninio pašto adresas nebus skelbiamas. Privalomi laukai yra pažymėti *

*

*

  1. Atsakingas už duomenis: Miguel Ángel Gatón
  2. Duomenų paskirtis: kontroliuoti šlamštą, komentarų valdymą.
  3. Įteisinimas: jūsų sutikimas
  4. Duomenų perdavimas: Duomenys nebus perduoti trečiosioms šalims, išskyrus teisinius įsipareigojimus.
  5. Duomenų saugojimas: „Occentus Networks“ (ES) talpinama duomenų bazė
  6. Teisės: bet kuriuo metu galite apriboti, atkurti ir ištrinti savo informaciją.

  1.   Giovanni gapp sakė

    Ir bios klaida, kai jie ją taisys, ar paprasčiausiai mums pasakys, kad nėra sprendimo, ir nusipraus rankas?

    1.    Davidas yeshaelis sakė

      Klaida jau ištaisyta

      1.    Hektoras Moreau sakė

        Labas popiet Deividas.

        Jūs minite, kad klaida jau buvo ištaisyta, bet jie turėtų įgalinti atsisiuntimą 11/01, bet iki šiol nieko. Taip pat nepateiktas joks paaiškinimas ubunlog, net ne GMO! Ubuntu!, nei oficialiame Ubuntu puslapyje.

  2.   Josepas Pujadas-Jubany sakė

    Ši branduolio versija pakabina visus nešiojamus kompiuterius mūsų institute. Turėjome išjungti „Lubuntu 16.04 LTS“ 64 bitų atnaujinimus.
    Namuose, mano darbalaukyje, tai veikia. Bet kompiuteris pakimba, kai atidarau savo seną virtualizuotą „Windows XP“ su „VirtualBox“. Daugiau informacijos:
    https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1742626

    1.    Josepas Pujadas-Jubany sakė

      Siaubas!
      Tą dieną aš kalbėjau apie 4.13.0 LTS HWE 26-16.04 (naujausias pareigūnas). Ir dabar matau, kad straipsnyje sakyta 4.14.13.
      Atsiprašau!
      https://insights.ubuntu.com/2018/01/12/meltdown-and-spectre-status-update/

  3.   Saito sakė

    Aš esu su „Kubuntu 16.04.3“ ir 4.13.0–26 branduoliu, viskas pataisyta ir veikia puikiai (be didelių klaidų ar klaidų), tačiau turiu pasakyti, kad aš turiu tas pačias problemas kaip ir visi, turintys „VirtualBox“: nors man tai nemiršta sistema, tiesiog procesoriaus suvartojimas siekia daugiau nei 75%, o po poros minučių nustoja veikti tik „VirtualBox“ ir ne visada.

  4.   ingemaras sakė

    Gaunu šį pranešimą: bash: sintaksinė klaida šalia netikėto elemento „newline“, aukščiau nurodyto, kai įvedu pirmą paketą, atitinkantį 64 bitų sistemas. Kaip tai pataisyti, norint įdiegti paketus į „Ubuntu 17.10“? Sveikinimai!

    1.    Josepas Pujadas-Jubany sakė
  5.   Gonzalo sakė

    Tikrai jie turės atnaujinti „VirtualBox“, kad tilptų šis branduolio atnaujinimas

  6.   Hektoras Moreau sakė

    Kas vyksta su „Canonical“ ir „Ubuntu“?

    Kadangi „ubuntu 17.10“ negalima naudoti, jis grįžo į „ubuntu“ 16.04.03. Bet, be kita ko, įdiegus ir atnaujinus, branduolys buvo atnaujintas nuo 4.10 iki 4.13. Perkraunant kompiuterį, negalėjau ieškoti programų, nes užstrigo „Ubuntu“ paleidimas, o spustelėjus jį, ekranas buvo paleistas iš naujo ir nebuvo galimybės normaliai dirbti. Kitaip tariant, visas dokas sugedo, jis galėjo veikti tik kiekvienam terminalui.

    „Mano užrašinė“ yra „HP Pavilion DV5-2247la“. 5 GHz „Intel Core i480-2,66M“ procesorius, 3 MB „L3“ talpykla, 2 x 3 GB DDR8 DIMM moduliai, „Intel HD Graphics“ su iki 1696 MB bendros grafikos atminties, 640 GB kietuoju disku (5400 RPM).

    1.    Josepas Pujadas-Jubany sakė

      Jei esate su 16.04 LTS HWE (16.04.03), naujausias oficialus branduolys yra 4.13.0-31. Mano darbe jis gerai dirba komandose, kurios yra vyresnės nei 2 metų. Naujesniuose turime problemų su IRQ priskyrimu.

      https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1742626
      https://bugzilla.kernel.org/show_bug.cgi?id=194945#c84

      Grub meniu išplėstinės parinktys galite pradėti nuo 4.10. Tada galite įdiegti „grub-customizer“, kad įkrovos nustatymas būtų 4.10.

      http://ubuntuhandbook.org/index.php/2016/04/install-grub-customizer-ubuntu-16-04-lts/

      Turime komandas su 4.10 (tai yra pirmasis matas, kurį imamės), o nuo vakar komandos, turinčios 4.14.15, http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.15/

      «Kas vyksta su„ Canonical “ir„ Ubuntu “?

      Tai nėra jų problema. Tai yra bendra problema, turinti įtakos visoms operacinėms sistemoms. Mūsų aparatūros pardavėjas prieš porą dienų man pasakė, kad jis turi daug ne „Linux“ kompiuterių, kurie nebus paleisti atnaujinus.

      Sėkmės!

  7.   Pjeras Aribautas sakė

    Sveiki, ar branduolį 4.14.13 galima naudoti su „Linux Mint 18.3“?

    1.    Josepas Pujadas-Jubany sakė

      Tureciau eiti. Tai „Ubuntu Xenial“ (16.04), https://linuxmint.com/download_all.php