Как повторно активировать поддержку Snaps в Linux Mint 20 ... на случай, если вам интересно

Linux Mint 20 со снапами

Если вы пришли сюда, думая, что эта статья не имеет смысла, позвольте мне сказать вам, что частично я согласен с вами. Для многих одна из самых важных достопримечательностей Linux Mint 20 именно он избавится от пакетов Canonical Snap, которые не нравятся так сильно, как Flatpak. Но, честно говоря, вполне вероятно, что мы найдем что-то, чей разработчик предлагает нам это только в snapcraft.io (например, Chromium) или в неофициальном репозитории, который, помимо того, что не так безопасен (хотя обычно они так и есть), установит зависимости, которые мы предпочли бы не устанавливать. В этом случае, если нам понадобится это конкретное программное обеспечение и в пакете, когда будет стоить следовать этому руководству.

Но, как я уже сказал в другой статье, один из вариантов - не следовать этим инструкциям и выбрать дистрибутив, который поддерживает привязки, если мы действительно этого хотим, как любой из официальных вариантов Ubuntu. То, что здесь объясняется, предназначено для тех пользователей, которые хотят продолжать пользоваться Linux Mint и предпочитать иметь доступ к пакетам Snap. Идея опубликовать его подал мне Джоуи Снеддон, который сделал то же самое в другом очень известном специализированном носителе Ubuntu.

Установка и активация snapd в Linux Mint 20

Linux Mint 20 был выпущен сегодня в бета-форме, и где лучше, чем в пробной версии, для тестирования подобных вещей. Что мы собираемся сделать, так это установить несколько пакетов и внести некоторые изменения, но я хотел бы настоять на том, чтобы Я бы не стал их делать, если бы я не зависел от приложения, похожего только на Snap. и я не хочу прекращать использование Linux Mint, когда он запускает свою Lysia. Если вам все еще интересно следовать этому руководству, а если нет, не критикуйте меня слишком сильно за то, что я поделился этой информацией, вам нужно сделать следующее:

  1. Открываем приложение-терминал.
  2. Мы написали:
sudo rm /etc/apt/preferences.d/nosnap.pref
  1. Затем мы устанавливаем пакет с помощью следующей команды:
sudo apt install snapd

Вышеуказанное необходимо, потому что, как сообщает Лео Чавес, пакет "snapd" нельзя установить обычным способом, потому что Linux Mint 20 его блокирует; показывает ошибку, что у вас нет кандидата на установку. С помощью того, что было объяснено выше, эта проблема должна быть исправлена. Linux Mint 20 включает файл конфигурации с именем nosnap.pref который включает в себя следующее сообщение:

«Linux Mint больше не поддерживает Ubuntu Store, которому принадлежит клиент snapd с открытым исходным кодом, к которому он подключается».

С помощью этого небольшого трюка мы уже должны иметь возможность установить Chromium на Linux Mint 20. Сделаете ли вы это или вы бы предпочли оставить Linux Mint 20 с новой философией Лефевра и его команды?


8 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   линуксминтусер сказал

    Я НЕ БУДУ ДЕЛАТЬ ЭТО.

  2.   Чарли сказал

    Заявление в блоге linux mint о snap (d) и chrome как snap имеет смысл, это издевательство.

    Будущее Linux Mint находится в базе Debian, которая намного лучше, чем в базе Ubuntu.

  3.   User12 сказал

    Они хотели бы, чтобы Mint скомпилировал свой собственный пакет Chromium (используя, например, тот, который поддерживается Debian), потому что то, что они намереваются сделать, чтобы отправить пользователей для загрузки пакета непосредственно с веб-сайта Chrome, несерьезно (и риск для пользователь, который не будет получать обновления программы).

  4.   Чарли сказал

    Я не думаю, что это будет необходимо. Linux Mint реализуется намного лучше, чем Ubuntu, я надеюсь, что со временем они смогут перейти на Debian в качестве основы.

    1.    яд сказал

      Проблема в том, что если ubuntu сделает это с дополнительным программным обеспечением ... mint придется их компилировать. Лучше сразу сократить убытки.

  5.   растягивание сказал

    Я установлю оснастку, чтобы посмотреть, работает ли она.
    Flatpak доставляет мне МНОГО проблем при установке, подзарядке и т. д.
    Кроме того, я хочу протестировать анбокс, который не работает в версии репозитория LM

  6.   Тулий сказал

    Очень обригадо !!!! наконец установите essa bagaça. Линукс очень сложно mexer mds, он отклонился от windows, стоит msm.

  7.   Дайо сказал

    друг, через два года я скажу тебе, что люблю тебя, спасибо!