Se lanza una corrección de último momento a la actualización de Ubuntu 14.04

Hace poco el equipo de desarrollo de Canonical lanzo una de las actualizaciones periódicas que suelen recibir sus versiones LTS, en este caso en específico para Ubuntu 14.04 LTS Trusty Tahr.

Estas actualizaciones contenían correcciones de errores y sobre todo los parches de seguridad para el Kernel del sistema.

Canonical ha lanzado nueva corrección y se disculpó por los problemas anteriores que se generaron para algunos usuarios de una de sus versiones LTS de Ubuntu.

Recientemente se ha descubierto nuevos defectos similares Specter que a su vez afectan a los procesadores x86 de Intel. Se les llama Fallo del terminal F1 (L1TF) o Foreshadow.

Sobre los fallos detectados

La actualización de seguridad para el Kernel resuelve dos vulnerabilidades de la cual una de ellas es el fallo del terminal F1, así como otros dos fallos de seguridad (CVE-2018-5390 y CVE-2018-5391) descubiertas por Juha-Matti Tilli en las implementaciones de TCP e IP del núcleo Linux, lo que podría permitir a atacantes provocar una denegación de servicio.

En el comunicado por parte de canonical se compartió lo siguiente:

Se descubrió que la memoria presente en la caché de datos L1 de una CPU Intel puede estar expuesta a un proceso malicioso que se está ejecutando en la CPU.

Esta vulnerabilidad también se conoce como error de Terminal L1 (L1TF). En el cual un atacante local en una máquina virtual invitada podría usar esto para exponer información (memoria de otros huéspedes o el sistema operativo anfitrión). (CVE-2.018 a 3.646)

Juha-Matti Tilli descubrió que la aplicación IP en el kernel de Linux realizado operaciones en algunas situaciones en el manejo de fragmentos de paquete entrantes. Un atacante remoto podría usar esto para causar una denegación de servicio. (CVE-2.018 hasta 5391)

Como vendría a ser normalmente, estas correcciones de fallos de seguridad vendrían a ser solucionados con el lanzamiento de los parches de seguridad para estos.

Por desgracia, en los sistemas de Ubuntu 14.04 LTS (Trusty Tahr), los usuarios informaron que las correcciones han introducido también una regresión en los paquetes del núcleo de Linux, lo que podría causar el famoso “Kernel Panic” para algunos usuarios al inicializar el sistema operativo en ciertos entornos de escritorio.

“Desafortunadamente, la actualización introdujo regresiones que causaron los accidentes en el núcleo durante el arranque en algunos entornos, y evitar que se iniciaron las aplicaciones java. esta actualización corrige los problemas nos disculpamos por las molestias “.

Ante estos comentarios por parte de los usuarios de esta versión de Ubuntu 14.04 LTS, Canonical tuvo que tomar cartas en el asunto y tener que resolver el problema de manera inmediata.

Con lo cual se lanzó una nueva versión corregida del Kernel de Linux, para los usuarios de Ubuntu 14.04 LTS Trusty Tahr, pidiendo a todos los usuarios a actualizar sus instalaciones tan pronto como sea posible.

Pueden consultar el comunicado, en el siguiente enlace.

Actualización de Ubuntu 14.04 LTS

Como se comentó, este fallo afecta directamente a los que sean usuarios de Ubuntu 14.04 LTS por lo que es sumamente necesario que realicen una actualización de manera inmediata, esto con el fin de evitar que estos fallos afecten al sistema.

La actualizacion la pueden hacer una manera bastante sencilla.

Pueden hacerlo desde la terminal ejecutando los siguientes comandos:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist upgrade

Hecho esto deberá el sistema a comenzar a actualizar los paquetes, así como el Kernel del sistema, descargando e instalado la corrección que lanzo canonical.

De igual manera pueden hacer esto de manera gráfica, tecleando en la terminal:

update-manager

Y este les mostrara las actualizaciones correspondientes y solamente deberán de aceptar e instalar.

Después de una actualización del kernel estándar, se recomienda que los usuarios reiniciar sus máquinas y, si es necesario, volver a compilar todos los módulos del núcleo que se pueden instalar, si han desinstalado manualmente el núcleo.

De igual manera puedes consultar las instrucciones que brinda Canonical para poder realizar una actualización sencilla y segura desde tu sistema.

El enlace es este.


Categorías

Noticias

Soy Estudiante de Ingeniería en Computación en la Universidad Autónoma Metropolitana (México), me considero aun un usuario medio en Linux , tengo pasión por las nuevas tecnologías , gamer y linuxero de corazón dispuesto a apoyar en lo que pueda.

2 comentarios

  1.   zeba_Zorin dijo

    Gracias!! Voy a actualizar!
    Te hago una pregunta..
    cuando instale en su momento xubuntu 16 el escritorio me andaba unas horas y luego el cursor del mouse se congelaba. pasaban 5 o 7 segundos y volvia a andar y al cabo de otros 5 segundos se congelaba y asi indefinidamente. Sabés a que se debió? si fue por el kernel al ser mi pc de 32 bits o que?
    Gracias otra vez!

  2.   David Naranjo dijo

    Son varios factores, desde los controladores de video, la version del Kernel e incluso problemas de compatibilidad del Xorg.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.