Prečo by ste sa mali vrátiť k softvéru GNOME a zabudnúť na softvér Ubuntu z Ubuntu 20.04 ... aspoň zatiaľ

Softvér Ubuntu a Ubuntu Software, dva obchody na Ubuntu 20.04

Pre mňa je to jeden z najhorších kanonických krokov za posledné roky. Chápem, že chcú presadiť použitie balíkov Snap a motivovať vývojárov a používateľov, ale to nie je cesta. Nie je to preto, že je to mätúce, tým menej neskúsení používatelia nenájdu niektoré možnosti a tí pokročilejší pocítia nedostatok slobody ... pokiaľ nenainštalujeme starú Softvér GNOME a ďalej si všetko užívajme ako predtým.

A je to tak, minimálne dnes Softvér Ubuntu od Focal Fossa nepodporuje balíčky Flatpak, napríklad. Rovnako ako Discover môže zobraziť až tri verzie softvéru (APT, Snap a Flatpak, ak povolíme podporu), nový obchod Ubuntu 20.04 zobrazuje iba jednu, Snapcraft, ktorá nás núti inštalovať balíček Snap, aj keď máme Verzia APT dostupná z oficiálnych archívov ... pokiaľ nie je k dispozícii balíček Snap, ktorý potom ponúka verziu APT. Ako som už povedal predtým, mätúce.

Softvér GNOME podporuje Snap a Flatpak

Ako vysvetľujeme v tento článok o tom, ako povoliť podporu balíkov Flatpak v Ubuntu, až do Ubuntu 20.04 by sme mohli predviesť softvérový obchod Ubuntu Výsledky Flathub ak by sme nainštalovali balík „gnome-software-plugin-flatpak“, ale v čase písania tohto článku už nič podobné pre nový softvér Ubuntu neexistuje a pochybujem, že to Canonical v budúcnosti povolí.

Prečo teda musíme používať nový obchod so softvérom? Aké výhody nám ponúka? Teraz, keď som bol schopný podrobne otestovať bok po boku, myslím, že áno, že by sa Canonical mal pokúsiť vylepšiť podporu svojich balíkov, ale nie za cenu toho, že OBOJTO zmätie a TEN ublíži svojim používateľom. Pokiaľ sa niečo nezmení, napríklad uvoľnenie metód tým, že budete viac propagovať Snap, ale ukážete verzie APT, aj keď sú skryté, som presvedčený, že najlepšie je nainštalujte si balík „gnome-software“ a pokračujte v inštalácii softvéru tak, ako sme to robili až do Eoan Ermine.

Zmena na Jednotu sa mi páčila málo, tak málo, že som prešla na Ubuntu MATE koľko som mohol, ale bola to vec vkusu a vo výkonnej výbave to nebolo také zlé. The zmena obchodu myslím, že je to zlé pre všetkých používateľov a viem, že mnohí z vás si myslia to isté. Dúfajme, že Canonical ustúpi, a ak nie, môžeme si kedykoľvek nainštalovať ďalšie možnosti.


Obsah článku je v súlade s našimi zásadami redakčná etika. Ak chcete nahlásiť chybu, kliknite na ikonu tu.

17 komentáre, nechajte svoj

Zanechajte svoj komentár

Vaša e-mailová adresa nebude zverejnená.

*

*

  1. Zodpovedný za údaje: Miguel Ángel Gatón
  2. Účel údajov: Kontrolný SPAM, správa komentárov.
  3. Legitimácia: Váš súhlas
  4. Oznamovanie údajov: Údaje nebudú poskytnuté tretím stranám, iba ak to vyplýva zo zákona.
  5. Ukladanie dát: Databáza hostená spoločnosťou Occentus Networks (EU)
  6. Práva: Svoje údaje môžete kedykoľvek obmedziť, obnoviť a vymazať.

  1.   Rafa dijo

    Kvôli týmto veciam som išiel na MInt ... aby som obišiel Markove povinnosti. Nebudem popierať, že ste odvtedy odviedli dobrú prácu a že Ubuntu je dobrý. Ale od toho až po vnucovanie všetkého, čo mu prejde hlavou, akoby to bolo najlepšie na svete, pretože mu to došlo. No nie. Takto neprejdem a som ďalší, ktorý je navždy preč. Mincovňa je vylepšená na ubuntu a bez Markovej paranoje.

    Snap sucks v porovnaní s appimage a flatpak. A aby som tu viac nerozšíril, nechávam to. Ale urobil som veľa testov s niekoľkými aplikáciami a ak bude v budúcnosti linuxový snap uložený ako jediná možnosť, vrátim sa späť do Windows 🙂, pretože je to odfláknuté.

  2.   daniel dijo

    Máte pravdu, že som testoval okamih a naozaj zle. Mnohé z nich, takmer všetky, fungujú iba v systéme a nie sú schopné, napríklad textové editory, hudobné prehrávače, čítanie súborov na iných oddieloch alebo externé disky (okrem vlc). Povedať, že Flatpak je oveľa prepracovanejší, funguje naozaj dobre a apimage ma dostal z viac ako jedného problému, veľmi užitočného. Zdá sa mi dôvod, prečo je softvérové ​​centrum skutočne neprehľadné, musíte dávať pozor na to, čo inštalujete. Na druhej strane je zarážajúce, že niektoré aplikácie úložiska nie sú aktualizované, ale sú prehľadné. Nebezpečenstvo spočíva v tom, že aplikácie budú z úložísk navždy vyhodené a budú nútení používateľa používať balíček snap, ktorý je pre kanonický budúcnosť. S pozdravom.

    1.    Nasher_87 (ARG) dijo

      Daniel, majú tieto povolenia zakázané, inak tie aktívne nikdy nebudú čítať externé oddiely

      1.    Raphael Romero dijo

        Skúšali ste mu dať povolenie? Myslím, že nie, pretože Snaps funguje veľmi dobre.

    2.    Rafa dijo

      Ja sám v Gimpe dokážem dať štetce, prechody a doplnky tretích strán, čo ma bolí hlava ... avšak s flatpakom som nemusel nič robiť, automaticky ich rozpoznal z domáceho priečinka.

      Potom je výkon rýchly, oveľa nižší, ale oveľa nižší ako flatpak. A nehovoriac o otváracích dobách v najoriginálnejšom štýle spoločnosti Microsoft, dvakrát kliknite na ikonu a choďte na kávu.

      1.    daniel dijo

        Ďakujem kámo, o povoleniach som vôbec netušil. To sa cení.

        1.    Pelayo dijo

          Máš pravdu. Presne to isté sa deje s GIMP a doplnkami tretích strán. S Flat som to vyriešil bez užívania paracetamolu.

    3.    Raphael Romero dijo

      Pravda, pretože používam Ubuntu a jeho deriváty, ako napríklad POP_OS, Mint, som sa nikdy nedotkol obchodu Gnome Software (až doteraz viem, že sa tak volá). Prvá vec, ktorú vždy urobím, je ísť do príkazového okna a použiť vždy spoľahlivý APT, stiahnuť priame DEB alebo kompilovať zo zdrojového kódu ... až pred rokom a pol prvá vec, ktorú urobím, je „sudo apt install snapd snap-store “. Pravdou je, že nepoužívam obchod Gnome, pretože väčšinou prináša zastarané veci a ak odstránili obvyklý obchod, nemyslím si, že to bolo preto, že ho veľa používajú, ani preto, že ho zaviedli, alebo preto, paranoje nie neviem koho. Keby som nečítal tento článok, nikdy by som si takúto absenciu nevšimol. Nezahŕňajte ma do „väčšiny“ spomenutej v tomto článku, z vizuálnych skúseností viem, že tento obchod sa nevyužíva, aspoň nie medzi mojím okruhom priateľov Linuxu.

  3.   Alberto dijo

    Ak chcete v systéme Ubuntu skutočného GNOME, použite program Pop! _Os (ktorý je už v beta verzii k 20.04). Je to všetko, čo by Ubuntu malo byť

  4.   Nick0bre dijo

    Pablinux, súhlasím s vami v nepresnej kanonickej spoločnosti, aby nejakým spôsobom uložil tieto balíčky snap, pričom nepredstavuje očakávanú kvalitu v operačných systémoch Linux. Ostatné, ktoré sa zaoberajú balením, Debian, RedHat, AppImage, Flatpak a Arch Linux vynikajú tým, že uprednostňujú kvalitu pred klasickými systémami Linux. Canonical vyrába vodu pomocou svojho bývalého Snappy (niektorí si pamätajú, že v roku 2016 mali tieto balíčky účel Ubuntu Touch), ktorý použitie.

  5.   Anthony dijo

    Svoju cestu v Linuxe som začal s Ubuntu pred viac ako 10 rokmi. Keď čítam takéto články, cítim sa čoraz pohodlnejšie, keď som prešla na Manjaro. S úložiskom AUR máte všetok softvér na jedno kliknutie.

    1.    Miguel dijo

      Naprosto súhlasím, Antonio, s manjarom a aurom nie je nič, čo sa nenájde a čo sa nevyrieši. Unavili ma zlyhania v aktualizácii medzi jednou verziou a druhou, niečo, čo sa v manjaro nikdy nestane a všetko je aktuálne.

  6.   Monet dijo

    V deň, keď si nebudem môcť nainštalovať softvér bez prerušenia, skončím s Ubuntu ... no už nejaký čas sa pokúšam nainštalovať freeBSD.

    Z môjho pohľadu je to svinstvo a nebudem znižovať svoje štandardy len kvôli „pohodliu“ alebo vynúteniu.

  7.   tetelx dijo

    Úložisko „http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu ohniskové vydanie“ nemá súbor vydania

    Chyba: 9 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu ohniskové uvoľnenie
    404 Nenašiel sa [IP: ——————————-

    A teraz čo mám robiť ?????

    1.    pablinux dijo

      Malo by to fungovať. Ak nie, môžete si nainštalovať o niečo starší balíček „flatpak“, ktorý je v oficiálnych úložiskách a je pre vás rovnako dobrý.

      Pozdrav.

  8.   Diego Abdali dijo

    Myslím, že ten istý priateľ, práve som nainštaloval Ubuntu na tento laptop a plánujem odinštalovať obchod snap a nainštalovať softvér Gnome

    1.    pablinux dijo

      Ahoj diego. Nerob to. To znamená, že ho neodinštalujte. V Ubuntu je Snap Store viazaný na snapd, a ak chcete používať balíčky Snap, musíte ho mať. Odporúča sa nainštalovať softvér GNOME, nechať tento obchod v doku a zabudnúť na Snap Store, akoby tam nebol.

      Pozdrav.