Závislosti nenaplnené

Ako vyriešiť nesplnené závislosti balíkov v Ubuntu a derivátoch

Máte problémy s nesplnené závislosti? Nie si jediný.

Prinášam vám tému, ktorú nám dáva problém čitateľa, on nám prostredníctvom našej sekcie Kontakt poslal svoj problém, pomerne častý problém v Ubuntu a Debiane, ktorý má čiastočné riešenie, myslím vyriešiť závislosti balíka, ktorý sa má nainštalovať. Dotaz znel takto:

ahoj, mám problémy s inštaláciou flash na môj lubuntu 13.10, mám netbook sony vcpm120al, s 2 GB RAM a asi 250 GB pevného disku, keď sa pokúsim nainštalovať doplnok buď stiahnutím alebo softvérovým centrom lubuntu, na ktoré ma vrhne chyba, štandardne sa nenainštalovala, pretože si myslím, že mala prísť
pri pokuse o inštaláciu balíka mi hovorí, že tieto závislosti balíka nie je možné vyriešiť

Táto chyba môže byť spôsobená ďalšími softvérovými balíkmi, ktoré chýbajú alebo sa nedajú nainštalovať. Môže to tiež byť konflikt medzi softvérovými balíčkami, ktoré sa nedajú nainštalovať spoločne. Podrobnosti: Nasledujúce balíčky majú nevyplnené závislosti:

flashplugin-installer: Závisí: libnspr4-0d, ale nenainštaluje sa

Ďakujem vopred, dodávam, že som práve opustil okná a vlastne neviem, ako používať lubuntu.

Čo sú nesplnené „závislosti“?

Ak chceme nainštalovať balík alebo program v Ubuntu a v Gnu / Linux, nepotrebujeme iba balík, ale potrebujeme aj doplnkové súbory a balíčky, od ktorých závisí program, ktorý chceme nainštalovať. Mnohokrát sa tieto balíčky v našom systéme nenachádzajú, takže sa nám zobrazuje táto chyba. Aby sme to vyriešili, musíme väčšinou inštalovať balíčky, od ktorých program závisí, ale ako sa to tu deje, niekedy systém trvá na tom, aby urobil chybu, alebo inštaláciu nerobíme správne. Väčšinou to nie je kvôli tomu, ale máme poškodený balík z nejakej inej inštalácie, a preto nám dáva chybu závislosti.

Riešenie chyby nevyplnených závislostí

Najpraktickejšie na vyriešenie tohto problému je otvoriť terminál a napísať nasledujúci text

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get aktualizácie

sudo apt-get -f inštalovať

Prvé príkazy spôsobia, že systém vyčistí pamäť balíkov a efektívnu inštaláciu a vyčistí systém od osamotených balíkov, to znamená od balíkov, ktoré naraz používala aplikácia a už ich nepoužíva žiadny program. Tretí príkaz aktualizuje systém Apt a posledný príkaz rieši všetky narušené závislosti, ktoré v systéme existujú.

Potom je možné inštaláciu vykonať správne. V tomto konkrétnom prípade by som odporučil otvoriť terminál a napísať nasledujúce

sudo apt-get install lubuntu-limited-extras

Týmto sa nainštaluje rad programov, ktoré sú pre začínajúcich používateľov klasifikované ako nevyhnutné doplnky. Medzi nimi by bola aj parcela, ktorá by mala blesk v našom systéme. Ak to nefunguje ani pri použití blesku, je najpriamejšie a najbezpečnejšie napísať do terminálu

sudo apt-get install flashplugin-installer

S týmto, ak je inštalácia Lubuntu správna, bude stačiť vyriešiť problém Lukasa, čitateľa, ktorý nám napísal. Na záver vám pripomíname, že ak máte akékoľvek otázky alebo požiadavky, neváhajte nás kontaktovať. Pokiaľ je to v našich silách, vyriešime to.

Viac informácií - Inštalácia balíkov DEB rýchlo a ľahko, Synaptic, manažér systému Debianite v Ubuntu,


Obsah článku je v súlade s našimi zásadami redakčná etika. Ak chcete nahlásiť chybu, kliknite na ikonu tu.

60 komentáre, nechajte svoj

Zanechajte svoj komentár

Vaša e-mailová adresa nebude zverejnená.

*

*

  1. Zodpovedný za údaje: Miguel Ángel Gatón
  2. Účel údajov: Kontrolný SPAM, správa komentárov.
  3. Legitimácia: Váš súhlas
  4. Oznamovanie údajov: Údaje nebudú poskytnuté tretím stranám, iba ak to vyplýva zo zákona.
  5. Ukladanie dát: Databáza hostená spoločnosťou Occentus Networks (EU)
  6. Práva: Svoje údaje môžete kedykoľvek obmedziť, obnoviť a vymazať.

  1.   15400 dijo

    Ďakujem, dostal som túto chybu a spolu s ňou zmizla. S pozdravom!

    1.    PEDRO dijo

      ďakujem fungovalo to veľmi dobre

      1.    Fabian dijo

        Ďakujem veľmi pekne.

  2.   kherson dijo

    dobre, dúfam, že mi môžeš pomôcť, užívateľ desktopu "stredná úroveň" mám xubuntu 13.10 32b, chcem vedieť, či s týmito príkazmi Ak to chceme vyriešiť, najpraktickejšie je otvoriť terminál a napísať nasledujúci text

    sudo apt-get autoremove

    sudo apt-get autoclean

    sudo apt-get aktualizácie

    sudo apt-get -f inštalovať
    môže vyčistiť úložiská tých, ktoré už nepoužívam, a ponechať mi systém bez porúch.

  3.   carlos dijo

    Mal som ubuntu 13.11 a vyriešil som to

    sudo apt-get autoclean a potom sudo install -f a potom reštart ma vystrašil, keď som to zapol, všetko vyriešené = D
    Dúfam, že vám bude slúžiť salu2

  4.   xinai dijo

    Ďakujem !

  5.   Nový linerobot dijo

    Veľmi dobrý partner, tu je skript, ktorý urobí všetko za vás, od partnera ide o program čističa systému, ktorý tiež odstráni tento typ problému, iba ak pretrváva apt-get install -f http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ vrelo odporúčam pozdravy kolegovia 🙂

  6.   hector munoz dijo

    Chcem si nainštalovať program, ktorý je pre nás užitočný, elektronika sa volá piklab, ale vždy, keď sa pokúsim, objaví sa chyba s tými závislosťami na deseria, pomôž mi ďakujem

    1.    david259 dijo

      http://ubuntuforums.org/showthread.php?t=123481 skúsili ste to pre piklab 🙂 dúfam, že to pre vás bude fungovať

  7.   pedro dijo

    nainštalujte si openoffice namiesto libreoffice a teraz mám problém s nesplnenými závislosťami, ktoré mi nedovolia nič nainštalovať. Nejaké riešenie? Vďaka

    1.    FenixPlays_YT dijo

      Ó, priateľu, to isté sa mi stane vždy, keď chcem niečo nainštalovať buď cez správcu balíkov, alebo mi obchod urobí chybu nevyplnených závislostí a povie mi, že mám 1 pokazený balík a neviem, ako to opraviť; (

  8.   Jose Carlos RG dijo

    Je to dobré vysvetlenie pre začínajúcich používateľov. Zdravím vás.

  9.   felipe dijo

    Vďaka za informácie. Zdravím vás

  10.   Dreicomp dijo

    Stále mám ten istý problém, myslím si, že je to závislosť, ktorá sa nazýva samotná ha

  11.   Alvaro dijo

    Dobrý deň, dobre, mal som podobnú chybu pri inštalácii javy na serveri Ubuntu 14.04.
    Postupoval som podľa tohto procesu:

    sudo apt-get nainštalovať predvolené-jre

    A dostal som niečo dlhšie, ale podobné tomuto, toto vyjde po prvej chybe pri ďalšom pokuse.

    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    Možno budete chcieť spustiť program „apt-get -f install“, ktorý to opraví:
    Nasledujúce balíčky majú nesplnené závislosti:
    ca-certificates-java: Závisí: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) alebo
    java6-runtime-bezhlavý
    default-jre: Závisí: default-jre-headless (= 2: 1.7-51)
    Závisí to: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: Závisí to: libtiff5 (> = 4.0.3), ale nenainštaluje sa
    E: Závislosti neboli splnené. Skúste „apt-get -f install“ bez balíkov (alebo zadajte riešenie).

    Čo som sa teda pokúsil, je postupovať podľa uvedených krokov, ale keď zadám nasledujúci pokyn, zobrazí sa nasledujúca chyba:

    sudo apt-get autoremove

    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    Možno budete chcieť spustiť program „apt-get -f install“, ktorý to opraví.
    Nasledujúce balíčky majú nesplnené závislosti:
    ca-certificates-java: Závisí: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) alebo
    java6-runtime-bezhlavý
    libgdk-pixbuf2.0-0: Závisí to: libtiff5 (> = 4.0.3), ale nenainštalované
    E: Závislosti nie sú splnené. Skúste to znova pomocou -f.

    Som v Linuxe úplne nový, mohli by ste mi pomôcť, aby som vedel, ako to vyriešiť ?, Ďakujem

    1.    finger jazyk dijo

      Dobrý deň, zobrazuje sa mi chyba podobná Alvarovi, neviem, či nám môžete pomôcť, veľmi by som ju ocenil

  12.   mateus mateus dijo

    dakujem aj v ubuntu 15.04 to funguje

  13.   Leonardo R. dijo

    Skvelé! Mnohokrat dakujem!

  14.   Mariano dijo

    Dakujem velmi pekne mi velmi posluzilo. Chcel som nainštalovať 4k youtube mp3 pomocou terminálu a nemohol som, pretože mi urobil chybu, potom som si ho stiahol a nainštaloval a dal mi závislosť na rozbitých balíkoch. Vaše riadky problém vyriešili za mňa. Zdá sa, že v ubuntu je to veľmi bežné.

  15.   Luis dijo

    Zdravím kolegov, na ktorých sa pokúšam nainštalovať cinnemon, by mali pískať a zobrazí sa chyba. Nasledujúce balíčky majú nevyplnené závislosti a na konci sa píše .. Problémy sa nepodarilo opraviť, ponechali ste si poškodené balíčky.
    Dúfam, že mi tento problém pomôže vyriešiť

  16.   liriccombene dijo

    ďakujem Grosooo, študujeme na viedma univ de Comahue v Argentíne a bolo to riešenie

  17.   Dyango vtz dijo

    ahoj, viem, že to momentálne nie je relevantné, ale pri inštalácii sa vyskytla chyba v aplikácii, už ju mám funkčnú, ale v stavovom riadku sa mi zobrazuje táto chyba: «E: Balík wps-office: i386 musí byť byť preinštalovaný, ale súbor sa nenašiel. “ Skúšal som to už odinštalovať, aby som to mohol správne preinštalovať, ale nedovolí mi to a už mi došli nápady.

  18.   gabriel dijo

    Ďakujem moc

  19.   diov3rov3r dijo

    Vďaka; D

  20.   racer5 dijo

    Vďaka, bolo to perfektné riešenie !!

  21.   Anjel Alegre dijo

    Moja chyba je kvôli vínu

    angel @ alienware: ~ $ sudo apt-get nainštalovať víno1.7
    [sudo] heslo pre anjela:
    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    Nie je možné nainštalovať nejaký balík. To môže znamenať, že
    požiadali ste o nemožnú situáciu alebo, ak používate distribúciu
    nestabilné, že niektoré potrebné balíky neboli vytvorené alebo majú
    bol presunutý z priečinka Prichádzajúce.
    Situáciu môžu pomôcť vyriešiť nasledujúce informácie:

    Nasledujúce balíčky majú nesplnené závislosti:
    wine1.7: Závisí: wine1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

    1.    Thomas Castelli dijo

      to isté sa stáva aj mne! Neviem, ako to vyriešiť, ak mi viete, ako mi dať vedieť, že to musím vyriešiť

  22.   Juan Pablo Rivera Quinzacara dijo

    ďakujem, veľmi mi to pomohlo, už som problém nemal.

  23.   max dijo

    dobré, chcem aktualizovať ubuntu 15.10 na 16.04, ale zobrazuje sa mi táto chyba

    Pri inicializácii informácií o balíku nastal problém, ktorý sa nedá opraviť.

    Nahláste to ako chybu v balíku „update-manager“ a uveďte nasledujúce chybové hlásenie:
    E: Chyba, pkgProblemResolver :: Vyriešiť generované výpadky, môže to byť spôsobené pozastavenými balíkmi.

    ak mi môžeš pomôcť ďakujem

  24.   Jorge Rios-Gomez dijo

    Ďakujem pekne, nemohol som nainštalovať hardinfo na môj Ubuntu 16 a s tvojou pomocou všetko funguje dobre.

    Srdečne ďakujem a pozdravujem.

  25.   Filip D. dijo

    Ďakujem, úžasne mi to poslúžilo, opravujem veľa chýb, ktoré som mal

  26.   ana dijo

    Ahoj, snažil som sa, ale stále sa zobrazuje chyba s libappindicator1, napríklad takto:
    chybovať http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 nebol nájdený
    E: Nie je možné získať http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 nebol nájdený

    E: Nemôžem získať nejaké súbory, možno by som mal spustiť „apt-get update“ alebo to skúsiť znova s ​​–fix-missing?

    Skúšam možnosti, ktoré mi dáva terminál, a nič ..... Nejaké nápady?
    Vďaka!

  27.   ana dijo

    Poznámka: všetko sa začína takto:
    Nasledujúce balíčky majú narušené závislosti: google-chrome-stable: Závisí to: libappindicator1, ale nie je nainštalovaný

  28.   mily dijo

    Ahojte mam problem Chcem nainštalovať program Lightworks (Video Editor), stiahnem deb a keď ho otvorím, načíta ma, ale nedovolí mi ho nainštalovať, ako hovorí:

    Chyba: Nie je možné uspokojiť závislosť: libc6 (> = 2.17)

    Už som skúsil urobiť všetko, čo ste povedali, a nefunguje to na mňa.

  29.   allodir dijo

    Výborne, ďakujem pekne!

  30.   Sergio Cabral dijo

    Ahoj, mám Ubuntu 14.04 a pri pokuse o stiahnutie vína sa mi zobrazuje veľa chýb

    Nasledujúce balíčky majú nesplnené závislosti:
    wine1.6: Závisí: wine1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Závisí: wine1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

    Hovorí mi, že ak sa pokúsim stiahnuť víno 1.6, ktoré je potrebné na víno, rovnako mi to povie, keď sa pokúsim stiahnuť víno 1.8 cez terminál a vstúpim do správcu synaptických balíkov. Skúsim tam a oznámi mi to. toto

    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.
    E: Chyba, pkgProblemResolver :: Vyriešiť generované výpadky, mohlo to byť spôsobené zadržanými balíkmi.
    E: Nie je možné opraviť závislosti
    E: Chyba, pkgProblemResolver :: Vyriešiť generované výpadky, mohlo to byť spôsobené zadržanými balíkmi.
    E: Nie je možné opraviť závislosti

    A vyskúšal som 1000 XNUMX rôznych vecí. Čo môžem robiť? Pomoc

  31.   Sebastian dijo

    Ahoj! Ako sa máš? Môžem sa ťa spýtať otázku?

    Robím to a stále mám problémy s inštaláciou Qgis, mohli by ste mi pomôcť?

    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    Nie je možné nainštalovať nejaký balík. To môže znamenať, že
    požiadali ste o nemožnú situáciu alebo, ak používate distribúciu
    nestabilné, že niektoré požadované balíčky ešte neboli vytvorené alebo sú
    Vzali z „Prichádzajúce“.
    Situáciu môžu pomôcť vyriešiť nasledujúce informácie:

    Nasledujúce balíčky majú nesplnené závislosti:
    python-qgis: Závisí to: python3-psycopg2, ale nenainštaluje sa
    Odporúčanie: liblwgeom-dev, ale nenainštaluje sa
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

    Zdravím!

  32.   Raphael Benito dijo

    ~ $ sudo apt-get -f nainštalovať
    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    0 aktualizovaných, 0 nových bude nainštalovaných, 0 na odstránenie a 167 neaktualizovaných

    Chápem to a stále mi robí problém pri inštalácii comodo.
    Prečo? prosím pomôžte

  33.   Carlos dijo

    Dobrý deň, používam ubuntu 18.04.02 LTS, situácia je taká, že sa pokúšam nainštalovať Oracle Database 11g Express Edition, to znamená, že pri sťahovaní súboru je uvedený súbor rpm, samozrejme ho chcem previesť na .deb, ale v tejto chvíli inštalujem alien, mám nejaké problémy so závislosťou v balíkoch debhelper a dpkg-dev.
    akékoľvek riešenie, budem veľmi vďačný.

  34.   Manuel Beltran dijo

    Perfektné, všetko dobré s Peppermint 10
    Ďakujeme za zdieľanie riešenia

  35.   tunel69 dijo

    Dobre.
    Zakaždým, keď idem do terminálu, zobrazí sa mi táto chyba, keď vložím sudo, a neviem, čo mám robiť.
    E: položka 49 je nesprávne zadaná v zozname súbor /etc/apt/sources.list (analýza URI)
    E: Zoznamy fontov sa nedali prečítať.

  36.   Juanan dijo

    linux je kurva hovno. Roky sa uchyľujem k rôznym distribúciám, aby som údajne využil zastarané vybavenie a vždy ten istý príbeh, tie prekliate závislosti, ktoré neumožňujú inštalovať prakticky nič. Potom musím počuť, že Ubuntu, kubuntu, lubuntu ... dokonca to používa aj moja babička ... gule. Kedykoľvek sa nadchnem, skončím frustrovaný. Normálne, ktoré ide lepšie a viac logero ... neumožňuje nič nainštalovať.

  37.   Mariana dijo

    Ahoj, mám problém s inštaláciou Haguichi, zobrazí sa nasledujúce:

    Nasledujúce balíčky majú nesplnené závislosti:
    haguichi: Závisí to: libglib2.0-0 (> = 2.48), ale bude sa inštalovať 2.32.4-0ubuntu1 + 12.04ac5
    Závisí: libglib2.0-bin (> = 2.48)
    Závisí to: libgtk-3-0 (> = 3.18), ale bude nainštalovaný 3.4.2-0ubuntu0.9
    Závisí to: libnotify4 (> = 0.7.6), ale bude nainštalovaných 0.7.5-1
    Odporúčanie: dconf-cli, ale nedá sa nainštalovať
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

    Neviem ako to mam riesit, ak niekto vie prosim pomozte mi dakujem.

  38.   daniela dijo

    Dakujem pekne, na konci som to vyriesil, si geni @

  39.   hernan dijo

    Dobrý deň, mám ubuntu 18.04 a pri pokuse o inštaláciu npm mi dáva nasledujúcu chybu, mám nainštalovaný nodejs 14.04; Už som vyskúšal riešenie, ktoré navrhujú, ale stále poskytuje rovnakú chybu, vďaka!

    sudo apt install npm build-essential
    Čítanie zoznamu balíkov ... Hotovo
    Vytváranie stromu závislostí
    Čítajú sa informácie o stave ... Hotovo
    build-essential je už v najnovšej verzii (12.4ubuntu1).
    Nie je možné nainštalovať nejaký balík. To môže znamenať, že
    požiadali ste o nemožnú situáciu alebo, ak používate distribúciu
    nestabilné, že niektoré požadované balíčky ešte neboli vytvorené alebo sú
    Vzali z „Prichádzajúce“.
    Situáciu môžu pomôcť vyriešiť nasledujúce informácie:

    Nasledujúce balíčky majú nesplnené závislosti:
    npm: Závisí: nodejs, ale nenainštaluje sa
    Závisí to: node-abbrev (> = 1.0.4), ale nenainštaluje sa
    Závisí to: node-ansi (> = 0.3.0-2), ale nenainštaluje sa
    Závisí to: node-ansi-color-table, ale nenainštaluje sa
    Závisí to: node-archy, ale nenainštaluje sa
    Závisí to: node-block-stream, ale nenainštaluje sa
    Závisí to: node-fstream (> = 0.1.22), ale nenainštaluje sa
    Závisí to: node-fstream-ignore, ale nenainštaluje sa
    Závisí to: node-github-url-from-git, ale nenainštaluje sa
    Závisí to: node-glob (> = 3.1.21), ale nenainštaluje sa
    Závisí to: node-graceful-fs (> = 2.0.0), ale nenainštaluje sa
    Závisí to: node-inherits, ale nenainštaluje sa
    Závisí to: node-ini (> = 1.1.0), ale nenainštaluje sa
    Závisí to: node-lockfile, ale nenainštaluje sa
    Závisí to: node-lru-cache (> = 2.3.0), ale nenainštaluje sa
    Závisí to: node-minimatch (> = 0.2.11), ale nenainštaluje sa
    Závisí to: node-mkdirp (> = 0.3.3), ale nenainštaluje sa
    Závisí to: node-gyp (> = 0.10.9), ale nenainštaluje sa
    Závisí to: node-nopt (> = 3.0.1), ale nenainštaluje sa
    Závisí to: node-npmlog, ale nenainštaluje sa
    Závisí: raz uzol, ale nenainštaluje sa
    Závisí to: node-osenv, ale nenainštaluje sa
    Závisí to: čítanie uzlov, ale nenainštaluje sa
    Závisí to: node-read-package-json (> = 1.1.0), ale nenainštaluje sa
    Závisí to: node-request (> = 2.25.0), ale nenainštaluje sa
    Závisí to: opakovanie uzla, ale nenainštaluje sa
    Závisí to: node-rimraf (> = 2.2.2), ale nenainštaluje sa
    Závisí to: node-semver (> = 2.1.0), ale nenainštaluje sa
    Závisí to: node-sha, ale nenainštaluje sa
    Závisí to: node-slide, ale nenainštaluje sa
    Závisí to: node-tar (> = 0.1.18), ale nenainštaluje sa
    Závisí to: podčiarkovník uzlov, ale nenainštaluje sa
    Závisí to: node-which, ale nenainštaluje sa
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

  40.   sergio dijo

    Mnohokrat dakujem! Bol som mesiace bez toho, aby som kvôli týmto chybám nemohol nainštalovať program, unavilo ma hľadanie na fórach a dnes som našiel tento. Zdravím vás!

  41.   Javier dijo

    ahoj dobrý, som v Ubuntu trochu nový a mám nasledujúci problém, neviem, či je to správne miesto, ale ak nie, prosím, povedz ma.
    Mám nainštalovaný elementárny os 5.1.7. Snažil som sa inštalovať víno mnohými spôsobmi, nasledovať návody, bez úspechu inštalovať úložiská, snažil som sa vymazať všetko aj tak, ako si uviedol v tomto príspevku, a teraz sa ho pokúšam nainštalovať z aplikačného centra a stále mi hovorí to isté «konkrétne nevyplnené závislosti»

    W: Chyba GPG: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: Nasledujúce podpisy nebolo možné overiť, pretože verejný kľúč nie je k dispozícii: NO_PUBKEY DFA175A75104960E
    E: Úložisko „https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease“ nie je podpísané.
    W: Z takého úložiska nemôžete bezpečne aktualizovať, a preto je predvolene vypnutý.
    W: Podrobnosti o vytváraní úložísk a konfigurácii používateľov nájdete na manuálovej stránke apt-secure (8).
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease nie je (zatiaľ) k dispozícii (Nasledujúce podpisy nebolo možné overiť, pretože verejný kľúč nie je k dispozícii: NO_PUBKEY DFA175A75104960E)

    Dúfam, že mi pomôžete, vopred ďakujem.

  42.   Jorge dijo

    Dobrý deň, pri inštalácii editora pre Latex (texmaker) sa mi zobrazuje nasledujúca chyba a nemôžem ju vylúčiť:
    Nie je možné uspokojiť závislosť na libc6 (> = 2.29)

    vďaka

  43.   január dijo

    Ahoj, pri natáčaní sa vyskytla chyba pri inštalácii komunitného servera mongodb:

    „Sudo apt-get install -y mongodb-org“

    a dáva mi nasledujúcu chybu:

    Nasledujúce balíčky majú nesplnené závislosti:
    mongodb-org: Závisí to: mongodb-org-server, ale nenainštaluje sa
    E: Problémy sa nedali opraviť, ponechali ste si poškodené balíčky.

    ale nevyriešilo to nič pre mňa odstránenie zastaraných závislostí

  44.   Cristian dijo

    vynikajúce !!

  45.   Miguel López dijo

    Výborné informácie a fungovali perfektne. Ďakujem pekne

  46.   Federico dijo

    Môžete priamo prejsť do priečinkov /etc/apt/sources.list.dy s vyhľadaním ls, v ktorom im urobíte chybu, a potom ich odstrániť pomocou súboru sudo rm a zadajte ...

  47.   mario dijo

    Vďaka ! Vďaka!

  48.   Alexander cardozo dijo

    Nenechám sa dostať k tej istej chybe

  49.   Doktor Strange dijo

    Inde veľmi dobré vysvetlenie, nenašiel som také jednoduché riešenie ako vy, gratulujem, ak vás môžem pozvať na kávu, dajte odkaz do svojich publikácií.

  50.   mary dijo

    Pomoc Chcem nainštalovať steam do lubuntu
    najskôr dám „sudo apt install steam-installer“, potom mi to povie, že musím dať steam, skúsim a skončím s pokazenými balíkmi
    (po vyskúšaní vyššie uvedeného, ​​samozrejme okrem toho blesku, pretože ho mám)
    Skočí mi to:
    Nie je možné nainštalovať nejaký balík. To môže znamenať, že
    požiadali ste o nemožnú situáciu alebo, ak používate distribúciu
    nestabilné, že niektoré požadované balíčky ešte neboli vytvorené alebo sú
    Vzali z „Prichádzajúce“.
    Situáciu môžu pomôcť vyriešiť nasledujúce informácie:

    Nasledujúce balíčky majú nesplnené závislosti:
    steam: i386: Závisí: libgl1-mesa-dri: i386 (> = 17.3), ale nenainštaluje sa alebo
    libtxc-dxtn0: i386, ale nie je možné ho nainštalovať
    Závisí od: libgl1-mesa-glx: i386, ale nenainštaluje sa
    Závisí od: libgpg-error0: i386 (> = 1.10), ale nenainštaluje sa
    Závisí od: libudev1: i386, ale nenainštaluje sa
    Závisí od: libxcb-dri3-0: i386 (> = 1.11.1), ale nenainštaluje sa
    Závisí od: libxinerama1: i386 (> = 2: 1.1.1), ale nenainštaluje sa
    Závisí to: libc6: i386 (> = 2.15), ale nenainštaluje sa
    Závisí to: libstdc ++ 6: i386 (> = 4.8), ale nenainštaluje sa
    Závisí to: libx11-6: i386, ale nenainštaluje sa
    Odporúčame: libxss1: i386, ale nenainštaluje sa
    Odporúčame: ovládače mesa-vulkan: i386, ale nenainštalujú sa
    E: Problémy sa nepodarilo opraviť, ponechali ste poškodené balíky
    Čo mám robiť, prosím?

  51.   Mario Barcenilla dijo

    V poslednej dobe mám veľa problémov s Ubuntu, riešim ich vo videu na mojom SABIASCOMO kanáli, takže pri preinštalovaní Ubuntu 14.04 LTS na 32-bit PC a následnej aktualizácii ma napadla kuriozita, pretože pred aktualizáciou som nainštaloval z Centrum softvéru Ubuntu, QtCreator a ja ho pri aktualizácii odstránime, pri pokuse o jeho inštaláciu sa zobrazí chyba „Nedajú sa vyriešiť závislosti balíkov“ a v časti Podrobnosti:
    Nasledujúce balíčky majú nesplnené závislosti:

    qtcreator: Závisí: libqt5concurrent5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5designercomponents5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5help5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5printsupport5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5script5 (> = 5.0.2), ale 5.2.1 + dfsg-1ubuntu1 nie je nainštalovaný
    Závisí: libqt5svg5 (> = 5.0.2), ale 5.5.1-2build1 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5xml5 (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libgcc1 (> = 1: 4.1.1), ale 1: 4.9.3-0ubuntu4 nie je nainštalovaný
    Závisí: libqt5core5a (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5designer5 (> = 5.0.2), ale 5.5.1-3build1 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5gui5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5network5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5qml5 (> = 5.2.0 ~ beta1), ale 5.5.1-2ubuntu6 ~ ppa1404 + 2 nie je nainštalovaný
    Závisí: libqt5quick5 (> = 5.1.0), ale 5.5.1-2ubuntu6 ~ ppa1404 + 2 nie je nainštalovaný
    Závisí: libqt5sql5 (> = 5.0.2), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libqt5widgets5 (> = 5.2.0), ale 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 nie je nainštalovaný
    Závisí: libstdc ++ 6 (> = 4.6), ale 4.8.4-2ubuntu1 ~ 14.04.4 nie je nainštalovaný
    Závisí: qtbase-abi-5-2-1, ale je to virtuálny balík
    Závisí: qtdeclarative-abi-5-2-1, ale je to virtuálny balík
    Ak by bol niekto taký láskavý a informoval ma, čo môžem urobiť, bol by som mu nesmierne vďačný.

  52.   alex dijo

    A v prípade debianu 11? bol by to rovnaky postup?

  53.   Mateo dijo

    Zobrazuje sa mi chyba závislosti pre tento balík vína, pretože je údajne poškodený, už som urobil všetko, čo mi stránka povedala, a neviem, čo mi odporúčajú
    tu je inštalačný balík:
    Nie je možné nainštalovať nejaký balík. To môže znamenať, že
    požiadali ste o nemožnú situáciu alebo, ak používate distribúciu
    nestabilné, že niektoré požadované balíčky ešte neboli vytvorené alebo sú
    Vzali z „Prichádzajúce“.
    Situáciu môžu pomôcť vyriešiť nasledujúce informácie:

    Nasledujúce balíčky majú nesplnené závislosti:
    winehq-stable: Závisí: wine-stable (= 7.0.0.0 ~ bionic-1)
    E: Problémy sa nepodarilo opraviť, ponechali ste poškodené balíky

    Neviem čo mám robiť môžete mi prosím pomôcť

  54.   Júl dijo

    Vynikajúce, umožnilo mi to nainštalovať ďalšie programy, vďaka