Cómo solucionar los problemas entre VirtualBox y Ubuntu 17.10

El famoso bug de Intel está provocando grandes daños a los usuarios de ordenadores. Curiosamente no por el hardware sino por las actualizaciones y parches que prometen solucionar este bug y resultan, a veces, ser más perjudiciales que el propio bug.

En Ubuntu 17.10, varios usuarios, han tenido problemas con estos parches de seguridad y la versión. Muchos usuarios, tras actualizar, perdían el funcionamiento de ciertos programas como VirtualBox. Suelen ser programas que interactúan con el kernel como Virtualbox.

Si, además, tenemos instalado las herramientas de servidor de VirtualBox, el problema puede ser muy grave e incluso perder el escritorio. Para solucionar esto, hemos de desinstalar Virtualbox, volver a instalarlo y sin hacerlo funcionar e instalar el pack de seguridad de Virtualbox. Es algo muy sencillo si escribimos lo siguiente en la terminal:

sudo apt remove --purge virtualbox*

Esto es para desinstalar VirtualBox. Luego hemos de volver a instalarlo con los siguientes comandos:

<span data-mce-type="bookmark" style="display: inline-block; width: 0px; overflow: hidden; line-height: 0;" class="mce_SELRES_start"></span>sudo sh -c 'echo "deb http://download.virtualbox.org/virtualbox/debian xenial contrib" &gt;&gt; /etc/apt/sources.list'

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -

sudo apt install virtualbox-5.2

Y con esto tendremos la última versión de VirtualBox en Ubuntu 17.10. Ahora toca instalar el paquete de seguridad que corrige este problema. Para ello hemos de ir a la web oficial de descargas y cuando lo tengamos, abrimos el paquete directamente con Virtualbox. Esto actualizará la versión que tengamos del programa a la versión 5.2.4, una versión estable que corrige todos los problemas que existe entre los parches de Meltdown y Spectre y VirtualBox.

Como podéis ver, la solución es bastante sencilla, pero hay que saber que realmente es Virtualbox quien provoca este fallo. Aunque hemos de decir que el programa no tiene la culpa en este caso sino más bien la solución, solución que ha sido criticada por muchos expertos como el propio Linus Torvalds, pero es la única que tenemos hasta que salga el kernel 4.16…

Fuente – UbuntuLeón


2 comentarios

  1.   Alberto Barbero dijo

    Aquí se invita a hacerse con la versión 5.2.4… ¿Significa esto que las nuevas versiones 5.2.6 de Virtualbox y del Extension Pack no son estables? Y, en su caso, ¿implica que, si te dan problemas, podrías reinstalar las anteriores sin cargarte todos los programas que ya tienes instalados en Virtualbox 5.2.6?

  2.   Juan dijo

    Yo tuve que regresar del kernel 4.13 porque no es compatible con la última version beta de virtualbox… esperemos que pronto lo sea ya que los de AMD sin el soporte DAL estamos jodidos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *