Amalga oshirilmagan bog'liqliklar

Ubuntu va lotinlarda bajarilmagan paketga bog'liqliklarni qanday hal qilish mumkin

Sizda muammolar bormi? bajarilmagan bog'liqliklar? Siz yagona emassiz.

Men sizga o'quvchining muammosi bilan berilgan mavzuni keltiraman, u bizning Ulanish va Debian-dagi juda keng tarqalgan muammo bo'lgan qisman echimini topadigan bizning aloqa bo'limimizdan foydalanib bizga o'z muammosini yubordi. o'rnatish uchun paketning bog'liqligini hal qilish. So'rov quyidagicha o'qilgan:

salom, men lubuntu 13.10-da fleshkani o'rnatishda muammolarga duch kelmoqdaman, sony vcpm120al netbukim bor, 2gb ram va taxminan 250gb qattiq disk, plaginni yuklab olish orqali yoki lubuntu dasturiy ta'minot markaziga o'rnatmoqchi bo'lganimda, u meni tashlaydi Xato, u sukut bo'yicha o'rnatilmagan, chunki u kelishi kerak edi
paketni o'rnatishga harakat qilsam, menga ushbu paketga bog'liqliklarni hal qilib bo'lmaydi

Ushbu xato etishmayotgan yoki o'rnatib bo'lmaydigan qo'shimcha dasturiy ta'minot paketlari tufayli bo'lishi mumkin. Bu, shuningdek, birgalikda o'rnatib bo'lmaydigan dasturiy ta'minot paketlari o'rtasidagi ziddiyat bo'lishi mumkin va batafsil ravishda quyidagi paketlar bajarilmagan bog'liqliklarga ega:

flashplugin-installer: bog'liq: libnspr4-0d, lekin u o'rnatilmaydi

Oldindan rahmat, men derazalarni tark etganimni va lubuntu-dan qanday foydalanishni bilmasligimni qo'shaman.

Bajarilmagan "bog'liqliklar" nima?

Ubuntu va Gnu / Linux-da paket yoki dastur o'rnatmoqchi bo'lsak, biz nafaqat paketga, balki biz o'rnatmoqchi bo'lgan dasturga bog'liq bo'lgan qo'shimcha fayllar va paketlarga ham ehtiyoj sezamiz. Ko'p marta ushbu paketlar bizning tizimimizda mavjud emas, shuning uchun bizda bu xato bo'ladi. Buni hal qilish uchun odatda dasturga bog'liq bo'lgan paketlarni o'rnatishimiz kerak, ammo bu erda bo'lgani kabi, ba'zida tizim xato qilishni talab qiladi yoki biz o'rnatishni to'g'ri bajarmayapmiz. Ko'pincha bu bunga bog'liq emas, lekin bizda boshqa bir o'rnatishning buzilgan to'plami bor va shuning uchun bu bizga bog'liqlik xatosini keltirib chiqaradi.

Bajarilmagan bog'liqliklar xatosini hal qilish

Buni hal qilish uchun eng amaliy narsa terminalni ochish va quyidagilarni yozishdir

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get yangilanishi

sudo apt-get -f o'rnatish

Birinchi buyruqlar tizimni paketlarni va o'rnatishni xotirasini tozalashga olib keladi, ham samarali, ham yetim bo'lmagan paketlar tizimini, ya'ni bir vaqtning o'zida dastur tomonidan ishlatilgan va endi hech qanday dastur tomonidan ishlatilmaydigan paketlarni tozalaydi. Uchinchi buyruq Apt tizimini yangilaydi va oxirgi buyruq tizimdagi mavjud bo'lgan bog'liqlikni hal qiladi.

Shundan so'ng, o'rnatish to'g'ri bajarilishi mumkin. Bunday holda, men terminalni ochishni va quyidagilarni yozishni maslahat beraman

sudo apt-get install lubuntu-хязгаарlangan-qo'shimchalar

Bu yangi boshlanuvchilar uchun kerakli qo'shimcha sifatida tasniflangan bir qator dasturlarni o'rnatadi. Ular orasida bizning tizimimizda chiroq paydo bo'lishi uchun posilka bo'lishi mumkin. Agar bu fleshka ega bo'lish uchun ham ishlamasa, eng to'g'ridan-to'g'ri va xavfsiz narsa terminalda yozishdir

sudo apt-get install flashplugin-installer

Bu bilan, agar Lubuntu o'rnatilishi to'g'ri bo'lsa, bizga yozgan o'quvchi Lukasning muammosini hal qilish kifoya. Va nihoyat sizga biron bir savol yoki so'rovingiz bo'lsa, ikkilanmasdan biz bilan bog'laning. Agar bu bizning kuchimizda bo'lsa, biz uni hal qilamiz.

Qo'shimcha ma'lumot - DEB paketlarini tez va oson o'rnatish, Synaptic, Ubuntu-dagi Debianit menejeri,


61 ta sharh, o'zingizni qoldiring

Fikringizni qoldiring

Sizning email manzilingiz chop qilinmaydi. Kerakli joylar bilan belgilangan *

*

*

  1. Ma'lumotlar uchun javobgardir: Migel Anxel Gaton
  2. Ma'lumotlarning maqsadi: SPAMni boshqarish, izohlarni boshqarish.
  3. Qonuniylashtirish: Sizning roziligingiz
  4. Ma'lumotlar haqida ma'lumot: qonuniy majburiyatlar bundan mustasno, ma'lumotlar uchinchi shaxslarga etkazilmaydi.
  5. Ma'lumotlarni saqlash: Occentus Networks (EU) tomonidan joylashtirilgan ma'lumotlar bazasi
  6. Huquqlar: istalgan vaqtda siz ma'lumotlaringizni cheklashingiz, tiklashingiz va o'chirishingiz mumkin.

  1.   15400 dijo

    Rahmat, men bu xatoni oldim va shu bilan u yo'qoldi. hurmat bilan!

    1.    PEDRO dijo

      rahmat juda yaxshi ishladi

      1.    Fabian dijo

        Sizga juda katta rahmat.

  2.   xerson dijo

    Yaxshi, men sizga yordam bera olasiz deb umid qilaman, ish stoli foydalanuvchisi "o'rta daraja" Menda xubuntu 13.10 32b, men buni bilishni xohlayman Bu buyruqlar bilan hal qilish uchun eng amaliy narsa terminalni ochish va quyidagilarni yozishdir

    sudo apt-get autoremove

    sudo apt-get autoclean

    sudo apt-get yangilanishi

    sudo apt-get -f o'rnatish
    u men endi foydalanmayotgan omborlarni tozalab, tizimni nosozliklarsiz qoldirishi mumkin.

  3.   Karlos dijo

    Menda ubuntu 13.11 bor edi va men buni hal qildim

    sudo apt-get autoclean, keyin sudo install -f va keyin qayta ishga tushirish men hamma narsani hal qilganimda qo'rqitdim = D
    Umid qilamanki bu sizga xizmat qiladi salu2

  4.   xinai dijo

    Rahmat !

  5.   Yangi Linerobotik dijo

    Juda yaxshi sherik, mana bu siz uchun hamma narsani bajaradigan skript, sherikdan bu tizimni tozalash dasturi, agar u faqat apt-get install -f davom etsa, ushbu turdagi muammolarni hal qiladi. http://glatelier.org/2009/03/02/limpiando-ubuntu-comandos-y-programas/ hamkasblar uchun juda tavsiya etilgan salomlar 🙂

  6.   hektor munoz dijo

    Bizga elektronika uchun foydali bo'lgan dasturni o'rnatmoqchiman piklab deb nomlanadi, lekin har safar sinab ko'rganimda deseriyaga bog'liqlik bilan bog'liq xatolarga yo'l qo'yaman, rahmat

    1.    david259 dijo

      http://ubuntuforums.org/showthread.php?t=123481 Siz buni piklab uchun sinab ko'rdingiz, umid qilamanki bu sizga mos keladi

  7.   Pedro dijo

    libreoffice o'rniga openoffice dasturini o'rnating va endi bajarilmagan bog'liqliklar muammosi bor, bu menga hech narsa o'rnatishga imkon bermaydi. Har qanday echim bormi? Rahmat

    1.    FenixPlays_YT dijo

      Eh do'stim, xuddi shu narsa men bilan yoki menejer orqali yoki do'kon orqali nimadir o'rnatishni xohlaganimda sodir bo'ladi, menga bajarilmagan bog'liqliklar xatosini beradi va menga 1 ta buzilgan paket borligini va uni qanday tuzatishni bilmayman; (

  8.   Xose Karlos RG dijo

    Ajam foydalanuvchilar uchun yaxshi tushuntirish. Salom.

  9.   Felipe dijo

    Ma'lumot uchun rahmat. Salom

  10.   Dreikomp dijo

    Men hali ham o'sha muammoga duch kelmoqdaman, deb o'ylayman, bu uning o'ziga bog'liqlik deb ataladi

  11.   Alvaro dijo

    Assalomu alaykum, men java-ni ubuntu 14.04 serveriga o'rnatishda xatoga yo'l qo'ydim.
    Men quyidagi jarayonni kuzatdim:

    sudo apt-get install default-jre

    Va men yana biron bir narsani oldim, ammo shunga o'xshash narsa, bu yana urinib ko'rishda birinchi xatodan keyin paydo bo'ladi.

    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    Tuzatish uchun "apt-get -f install" -ni ishga tushirishni xohlashingiz mumkin:
    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    ca-sertifikatlar-java: Bog'liq: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) yoki
    java6-ish vaqti-boshsiz
    default-jre: bog'liq: default-jre-headless (= 2: 1.7-51)
    Bog'liq: openjdk-7-jre (> = 7 ~ u3-2.1.1)
    libgdk-pixbuf2.0-0: bog'liq: libtiff5 (> = 4.0.3), lekin o'rnatilmaydi
    E: bog'liqliklar qondirilmadi. Paketlarsiz "apt-get -f install" ni sinab ko'ring (yoki echimni ko'rsating).

    Shunday qilib, men ushbu bosqichlarni bajarishga harakat qildim, ammo quyidagi ko'rsatmaga kirganimda men quyidagi xatolarga yo'l qo'yaman:

    sudo apt-get autoremove

    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    Tuzatish uchun "apt-get -f install" -ni ishga tushirishni xohlashingiz mumkin.
    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    ca-sertifikatlar-java: Bog'liq: openjdk-7-jre-headless (> = 7 ~ u3-2.1.1 ~ pre1-1) yoki
    java6-ish vaqti-boshsiz
    libgdk-pixbuf2.0-0: bog'liq: libtiff5 (> = 4.0.3), lekin o'rnatilmagan
    E: bog'liqliklar bajarilmagan. -F dan foydalanib qayta urinib ko'ring.

    Men Linux uchun juda yangi boshlovchiman, buni qanday hal qilishni bilish uchun menga yordam bera olasizmi? Rahmat

    1.    miltillaydi dijo

      Salom, men Alvaroning xatosiga o'xshash xatoga yo'l qo'ydim, bizga yordam bera olasizmi, bilmayman, buni juda qadrlardim

  12.   mateus mateus dijo

    Ubuntu 15.04 da ham u ishlaydi

  13.   Leonardo R. dijo

    Ajoyib! Katta rahmat!

  14.   Mariano dijo

    Katta rahmat, bu menga katta yordam berdi. Men 4k youtube mp3-ni terminal orqali o'rnatmoqchi edim, chunki bu xatoga yo'l qo'ydi, chunki men uni o'rnatish uchun yuklab qo'ydim va bu menga buzilgan paketlarga bog'liqlikni berdi. Sizning chiziqlaringiz men uchun muammoni hal qildi. Bu ubuntuda juda keng tarqalgan ko'rinadi.

  15.   Luis dijo

    Salom, hamkasblarim xirillashi kerak bo'lsa, men kinemon o'rnatmoqchi bo'lganimda, hamkasblarim xato qilmoqda. Quyidagi paketlar bajarilmagan bog'liqliklarga ega va oxirida shunday deyiladi .. Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.
    Umid qilaman va bu muammoni tuzatishda menga yordam beradi

  16.   lrikkomben dijo

    rahmat Grosooo biz viedma univ de Comahue Argentina-da o'qiymiz va bu hal bo'ldi

  17.   Dyango vtz dijo

    salom, men bilaman, bu hozircha dolzarb emas, lekin o'rnatishda dasturda xatolik bor, menda u allaqachon ishlagan, lekin vaziyat satrida men shunday xatoga yo'l qo'ydim: «E: wps-office to'plami: i386 kerak qayta o'rnatilsin, lekin unga fayl topilmadi. " To'g'ri o'rnatish uchun men allaqachon uni o'chirishga urinib ko'rganman, lekin bu menga ruxsat bermaydi va fikrlarim tugadi.

  18.   Gabriel dijo

    Muchas gracias

  19.   diov3rov3r dijo

    Rahmat; D.

  20.   racer5 dijo

    Rahmat, bu mukammal echim edi !!

  21.   Anxel Alegre dijo

    Mening xatom sharob tufayli

    angel @ alienware: ~ $ sudo apt-get install wine1.7
    [sudo] farishta uchun parol:
    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    Bir nechta to'plamni o'rnatolmaysiz. Bu shuni anglatishi mumkin
    siz imkonsiz vaziyatni so'radingiz yoki tarqatishdan foydalanayotgan bo'lsangiz
    beqaror, ba'zi kerakli paketlar yaratilmagan yoki mavjud emas
    Kiruvchi qismdan ko'chirildi.
    Vaziyatni hal qilishda quyidagi ma'lumotlar yordam beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    wine1.7: bog'liq: wine1.7-i386 (= 1: 1.7.55-0ubuntu1)
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

    1.    Tomas Kastelli dijo

      menga ham shunday bo'ladi! Qanday qilib hal qilishni bilmayman, agar buni qanday hal qilishim kerakligini menga xabar berishni bilsangiz

  22.   Xuan Pablo Rivera Kvinzakara dijo

    rahmat, bu menga katta yordam berdi, endi muammoga duch kelmadim.

  23.   max dijo

    yaxshi ubuntu 15.10 ni 16.04 ga yangilamoqchiman, lekin men bu xatoni qabul qilaman

    Paket ma'lumotlari ishga tushirilganda tuzatib bo'lmaydigan muammo yuzaga keldi.

    Iltimos, buni "update-manager" paketidagi xato haqida xabar bering va quyidagi xato xabarini kiriting:
    E: Xato, pkgProblemResolver :: Yaratilgan uzilishlarni hal qiling, buning sababi paketlar bo'lishi mumkin.

    agar menga yordam bera olsangiz rahmat

  24.   Xorxe Rios Gomes dijo

    Katta rahmat, men Ubuntu 16-ga hardinfo-ni o'rnatolmadim va sizning yordamingiz bilan hammasi yaxshi ishlaydi.

    Yurakdan va salomlardan katta rahmat.

  25.   Filipp D. dijo

    Rahmat, bu menga ajoyib tarzda xizmat qildi, men ko'plab xatolarni tuzatdim

  26.   Ana dijo

    Salom, men sinab ko'rdim, lekin libappindicator1 bilan xatoga yo'l qo'yaman, shunga o'xshash:
    Xato http://co.archive.ubuntu.com/ubuntu/ utopic-updates / main libappindicator1 amd64 12.10.1 + 13.10.20130920-0ubuntu4.2
    404 topilmadi
    E: olish imkonsiz http://co.archive.ubuntu.com/ubuntu/pool/main/liba/libappindicator/libappindicator1_12.10.1+13.10.20130920-0ubuntu4.2_amd64.deb 404 topilmadi

    E: Bir nechta fayllarni ololmadim, ehtimol "apt-get update" ni ishga tushirishim kerak yoki -fix-missing bilan qayta urinib ko'rsam kerakmi?

    Men terminal beradigan variantlarni sinab ko'raman va hech narsa…. Har qanday fikr bormi?
    Gracias!

  27.   Ana dijo

    Izoh: barchasi quyidagicha boshlanadi:
    Quyidagi paketlarda bog'liqliklar buzilgan: google-chrome-barqaror: bog'liq: libappindicator1, ammo o'rnatilmagan

  28.   Mily dijo

    Salom, menda muammo bor. Lightworks (Video Editor) ni o'rnatmoqchiman, debyni yuklab olaman va ochganimda u menga yuklaydi, lekin aytilganidek o'rnatishga ruxsat bermaydi:

    Xato: bog'liqlikni qondira olmaydi: libc6 (> = 2.17)

    Siz aytganlarning hammasini bajarishga harakat qilib ko'rganman va bu menga yaramaydi.

  29.   allodir dijo

    Zo'r, katta rahmat!

  30.   Serxio Kabral dijo

    Salom, menda Ubuntu 14.04 bor, men sharobni yuklab olishga urinayotganda juda ko'p xatolarga yo'l qo'yaman

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    wine1.6: bog'liq: wine1.6-amd64 (= 1: 1.6.2-0ubuntu4)
    Bog'liq: vino1.6-i386 (= 1: 1.6.2-0ubuntu4)
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

    Bu menga sharobni iste'mol qilish uchun zarur bo'lgan sharob 1.6 ni yuklab olishga harakat qilsam, u ham xuddi shu narsani aytadi, agar men terminal orqali sharob 1.8 ni yuklab olishga harakat qilsam va sinaptik paket menejeriga kirsam, u erda harakat qilaman va bu menga aytadi bu

    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.
    E: Xato, pkgProblemResolver :: Yaratilgan uzilishlarni hal qilish, bunga paketlar sabab bo'lishi mumkin.
    E: bog'liqliklarni tuzatib bo'lmadi
    E: Xato, pkgProblemResolver :: Yaratilgan uzilishlarni hal qilish, bunga paketlar sabab bo'lishi mumkin.
    E: bog'liqliklarni tuzatib bo'lmadi

    Va men 1000 xil narsani sinab ko'rdim, nima qilishim mumkin? Yordam bering

  31.   Sebastian dijo

    Salom! Qalaysiz? Sizdan bir savolni so `rasam maylimi?

    Men buni qilaman va Qgisni o'rnatishda hali ham muammolarga duch kelmoqdaman, yordam bera olasizmi?

    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    Bir nechta to'plamni o'rnatolmaysiz. Bu shuni anglatishi mumkin
    siz imkonsiz vaziyatni so'radingiz yoki tarqatishdan foydalanayotgan bo'lsangiz
    beqaror, ba'zi kerakli paketlar hali yaratilmagan yoki mavjud emas
    Ular "Kiruvchi" dan olingan.
    Vaziyatni hal qilishda quyidagi ma'lumotlar yordam beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    python-qgis: bog'liq: python3-psycopg2, lekin u o'rnatilmaydi
    Tavsiya eting: liblwgeom-dev, lekin u o'rnatilmaydi
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

    Rahmat!

  32.   Rafael Benedikt dijo

    ~ $ sudo apt-get -f install
    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    0 yangilangan, 0 yangi o'rnatiladi, 0 o'chiriladi va 167 yangilanmagan

    Men buni tushunaman va comodo-ni o'rnatishda menga muammo tug'diradi.
    Nima uchun? Iltimos yordam bering

  33.   Karlos dijo

    Assalomu alaykum, men ubuntu 18.04.02 LTS dan foydalanmoqdaman, vaziyat shundaki, men oracle ma'lumotlar bazasini 11g ekspres nashrini o'rnatmoqchiman, ya'ni faylni yuklab olayotganda ushbu fayl rpm, men uni aylantirmoqchiman. deb, lekin begona dasturni o'rnatishda debhelper va dpkg-dev paketlarida bog'liqlik muammolari paydo bo'ldi.
    har qanday echim, men juda minnatdorman.

  34.   Manuel Beltran dijo

    Yalpiz 10 bilan bu erda juda yaxshi
    Yechimni baham ko'rganingiz uchun tashakkur

  35.   Tunnel 69 dijo

    Yaxshi.
    Har safar terminalga borganimda sudo qo'yganimda bu xatoga yo'l qo'yaman va nima qilishni bilmayman.
    E: ro'yxat fayli /etc/apt/sources.list (noto'g'ri URI tahlil qilish) da 49-raqam noto'g'ri ko'rsatilgan.
    E: shriftlar ro'yxati o'qib bo'lmadi.

  36.   Xuanan dijo

    Linux - bu bema'ni narsa. Bir necha yillar davomida men eskirgan uskunalardan foydalanish va har doim bir xil hikoyani ishlatish uchun turli xil taqsimotlarga murojaat qilmoqdaman. Keyin Ubuntu, kubuntu, lubuntu ... hatto buvim ham uni ishlatishini ... to'plardan eshitish kerak. Qachonki hayajonlansam, ko'nglim tugaydi. Oddiyki, u yanada yaxshilanadi va logero ... bu hech narsa o'rnatishga imkon bermaydi.

  37.   Mariana dijo

    Salom, men Xaguichini o'rnatishda muammoga duch keldim, quyidagilarni qabul qilaman:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    haguichi: Bunga bog'liq: libglib2.0-0 (> = 2.48), lekin 2.32.4-0ubuntu1 + 12.04ac5 o'rnatiladi
    Bog'liq: libglib2.0-bin (> = 2.48)
    Bunga bog'liq: libgtk-3-0 (> = 3.18), ammo 3.4.2-0ubuntu0.9 o'rnatiladi
    Bunga bog'liq: libnotify4 (> = 0.7.6), ammo 0.7.5-1 o'rnatiladi
    Tavsiya eting: dconf-cli, lekin o'rnatib bo'lmaydi
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

    Buni qanday hal qilishni bilmayman, agar kimdir bilsa, menga yordam bering, rahmat.

  38.   Daniela dijo

    Katta rahmat, oxirida men buni hal qildim, siz geni @

  39.   hernan dijo

    Salom, menda ubuntu 18.04 bor va u npm-ni o'rnatishda menga quyidagi xatoni beradi, menda nodejs 14.04 o'rnatilgan; Men ular taklif qilgan echimni allaqachon sinab ko'rdim, lekin u bir xil xatolarni keltirib chiqarmoqda, rahmat!

    sudo apt install npm build-essential
    Paketlar ro'yxati o'qilmoqda ... Bajarildi
    Qaramlik daraxtini yaratish
    Vaziyat to'g'risidagi ma'lumotni o'qish ... Bajarildi
    build-essential allaqachon so'nggi versiyasida (12.4ubuntu1).
    Bir nechta to'plamni o'rnatolmaysiz. Bu shuni anglatishi mumkin
    siz imkonsiz vaziyatni so'radingiz yoki tarqatishdan foydalanayotgan bo'lsangiz
    beqaror, ba'zi kerakli paketlar hali yaratilmagan yoki mavjud emas
    Ular "Kiruvchi" dan olingan.
    Vaziyatni hal qilishda quyidagi ma'lumotlar yordam beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    npm: bog'liq: nodejs, lekin u o'rnatilmaydi
    Bunga bog'liq: tugun-qisqartma (> = 1.0.4), lekin u o'rnatilmaydi
    Bog'liq: node-ansi (> = 0.3.0-2), lekin u o'rnatilmaydi
    Bog'liq: tugun-ansi-rang-jadval, lekin u o'rnatilmaydi
    Bog'liq: node-archy, lekin u o'rnatilmaydi
    Bunga bog'liq: tugun-blok-oqim, lekin u o'rnatilmaydi
    Bunga bog'liq: node-fstream (> = 0.1.22), lekin u o'rnatilmaydi
    Bunga bog'liq: node-fstream-ignore, lekin u o'rnatilmaydi
    Bunga bog'liq: node-github-url-from-git, lekin u o'rnatilmaydi
    Bunga bog'liq: node-glob (> = 3.1.21), lekin u o'rnatilmaydi
    Bunga bog'liq: node-graceful-fs (> = 2.0.0), lekin u o'rnatilmaydi
    Bog'liq: tugunni meros qilib oladi, lekin u o'rnatilmaydi
    Bunga bog'liq: node-ini (> = 1.1.0), lekin u o'rnatilmaydi
    Bunga bog'liq: node-lockfile, lekin u o'rnatilmaydi
    Bunga bog'liq: node-lru-cache (> = 2.3.0), lekin u o'rnatilmaydi
    Bunga bog'liq: node-minimatch (> = 0.2.11), lekin u o'rnatilmaydi
    Bunga bog'liq: node-mkdirp (> = 0.3.3), lekin u o'rnatilmaydi
    Bunga bog'liq: node-gyp (> = 0.10.9), lekin u o'rnatilmaydi
    Bunga bog'liq: node-nopt (> = 3.0.1), lekin u o'rnatilmaydi
    Bunga bog'liq: node-npmlog, lekin u o'rnatilmaydi
    Bog'liq: bir marta tugun, lekin u o'rnatilmaydi
    Bog'liq: node-osenv, lekin u o'rnatilmaydi
    Bunga bog'liq: tugunni o'qish, lekin u o'rnatilmaydi
    Bunga bog'liq: node-read-pack-json (> = 1.1.0), lekin u o'rnatilmaydi
    Bunga bog'liq: node-request (> = 2.25.0), lekin u o'rnatilmaydi
    Bunga bog'liq: tugunni qayta urinish, lekin u o'rnatilmaydi
    Bunga bog'liq: node-rimraf (> = 2.2.2), lekin u o'rnatilmaydi
    Bunga bog'liq: tugun-semver (> = 2.1.0), lekin u o'rnatilmaydi
    Bunga bog'liq: node-sha, lekin u o'rnatilmaydi
    Bunga bog'liq: tugun-slayd, lekin u o'rnatilmaydi
    Bunga bog'liq: node-tar (> = 0.1.18), lekin u o'rnatilmaydi
    Bog'liq: tugun-pastki chiziq, lekin u o'rnatilmaydi
    Bog'liq: lekin uni o'rnatmaydigan tugun
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

  40.   Serxio dijo

    Katta rahmat! Ushbu xatolar tufayli bir necha oy dastur o'rnatolmadim, forumlarni qidirishdan charchadim va bugun buni topdim. Salom!

  41.   Xaver dijo

    Assalomu alaykum, men Ubuntu bilan biroz yangi boshlovchiman va menda shunday muammo bor, u to'g'ri joymi yoki yo'qligini bilmayman, iltimos, menga ko'rsatma bering.
    Menda elementar os 5.1.7 o'rnatilgan, men ko'p jihatdan sharobni o'rnatishga harakat qildim, o'quv qo'llanmalariga rioya qilib, omborlarni o'rnatdim, muvaffaqiyatsiz tugatdim, hattoki ushbu postga qo'yganingiz kabi hamma narsani o'chirishga harakat qildim va endi uni dastur markazidan o'rnatishga harakat qilaman va menga aynan shu narsani "bajarilmagan bog'liqliklar" ni aytib berishda davom etmoqda

    V: GPG xatosi: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease: ochiq imzo mavjud emasligi sababli quyidagi imzolarni tekshirib bo'lmadi: NO_PUBKEY DFA175A75104960E
    E: "https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease" ombori imzolanmagan.
    V: Siz bunday havzadan xavfsiz ravishda yangilanolmaysiz va shuning uchun u sukut bo'yicha o'chirilgan.
    V: omborlarni yaratish va foydalanuvchilarni sozlash bo'yicha tafsilotlar uchun apt-safe (8) man sahifasiga qarang.
    E: https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ InRelease mavjud emas (hozircha) (Quyidagi imzolarni tekshirib bo'lmadi, chunki ochiq kalit mavjud emas: NO_PUBKEY DFA175A75104960E)

    Menga yordam berishingizga umid qilaman, oldindan rahmat.

  42.   Jorge dijo

    Salom, Latex (texmaker) uchun muharrirni o'rnatishda menga quyidagi xatolik yuz beradi va men uni bartaraf eta olmayman:
    Libc6 bog'liqligini qondira olmadi (> = 2.29)

    gracias

  43.   ian dijo

    Salom, men otish paytida mongodb jamoa serverini o'rnatishda xatolik bor:

    "Sudo apt-get install -y mongodb-org"

    va bu menga quyidagi xatoni beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    mongodb-org: bog'liq: mongodb-org-server, lekin u o'rnatilmaydi
    E: Muammolarni tuzatib bo'lmadi, siz buzilgan paketlarni saqlab qoldingiz.

    ammo men uchun eskirgan bog'liqliklarni olib tashlash uchun hech narsa hal qilinmadi

  44.   kristian dijo

    zo'r !!

  45.   Migel Lopes dijo

    Zo'r ma'lumot va u juda yaxshi ishladi. Katta rahmat

  46.   Federico dijo

    Siz to'g'ridan-to'g'ri /etc/apt/sources.list.dy papkalariga ls qidiruvi bilan kirishingiz mumkin, unda qaysi birida xato yuz beradi va keyin sudo rm fayl nomi bilan o'chirib tashlang va kiriting ...

  47.   Mario dijo

    Rahmat! Rahmat!

  48.   Aleksandr kardozo dijo

    Xuddi shu xatoni takrorlashimga yo'l qo'ymayman

  49.   doktor g'alati dijo

    Boshqa joyda juda yaxshi tushuntirish, men siz kabi oddiy yechim topa olmadim, tabriklar, agar sizni qahvaga taklif qila olsam, havolani nashrlaringizga qo'ying.

  50.   Mary dijo

    Lubuntu -da bug 'o'rnatishni xohlayman
    Avval "sudo apt install steam-installer" ni qo'ydim, keyin menga bug 'qo'yish kerakligini aytadi, men sinab ko'rdim va buzilgan paketlar bilan tugayman.
    (yuqorida aytilganlarni sinab ko'rganimdan keyin, albatta, bu chirog'i, chunki menda bor)
    U menga yuguradi:
    Bir nechta to'plamni o'rnatolmaysiz. Bu shuni anglatishi mumkin
    siz imkonsiz vaziyatni so'radingiz yoki tarqatishdan foydalanayotgan bo'lsangiz
    beqaror, ba'zi kerakli paketlar hali yaratilmagan yoki mavjud emas
    Ular "Kiruvchi" dan olingan.
    Vaziyatni hal qilishda quyidagi ma'lumotlar yordam beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    steam: i386: bog'liq: libgl1-mesa-dry: i386 (> = 17.3) lekin u o'rnatilmaydi yoki
    libtxc-dxtn0: i386, lekin o'rnatib bo'lmaydi
    Bog'liq: libgl1-mesa-glx: i386, lekin u o'rnatilmaydi
    Bunga bog'liq: libgpg-error0: i386 (> = 1.10), lekin u o'rnatilmaydi
    Bog'liq: libudev1: i386, lekin u o'rnatilmaydi
    Bog'liq: libxcb-dry3-0: i386 (> = 1.11.1), lekin u o'rnatilmaydi
    Bunga bog'liq: libxinerama1: i386 (> = 2: 1.1.1), lekin u o'rnatilmaydi
    Bunga bog'liq: libc6: i386 (> = 2.15), lekin u o'rnatilmaydi
    Bunga bog'liq: libstdc ++ 6: i386 (> = 4.8), lekin u o'rnatilmaydi
    Bunga bog'liq: libx11-6: i386, lekin u o'rnatilmaydi
    Tavsiya etiladi: libxss1: i386, lekin o'rnatilmaydi
    Tavsiya etiladi: mesa-vulkan-drivers: i386, lekin o'rnatilmaydi
    E: Muammolarni tuzatib bo'lmadi, sizda buzilgan paketlar saqlanib qolgan
    Iltimos, nima qilaman?

  51.   Mario Barsenilla dijo

    So'nggi paytlarda Ubuntu bilan juda ko'p muammolarga duch keldim, men ularni SABIASCOMO kanalimdagi videoda ko'rib chiqaman, shuning uchun Ubuntu 14.04 LTS-ni 32-bitli shaxsiy kompyuterga qayta o'rnatayotganda va keyin uni yangilaganimda, menda qiziqish paydo bo'ldi, chunki yangilashdan oldin men o'zimdan o'rnatdim. Ubuntu dasturiy ta'minoti markazi QtCreator va men uni yangilashda olib tashlayman, uni o'rnatmoqchi bo'lganimda "Paketga bog'liqliklarni hal qilib bo'lmaydi" degan xato paydo bo'ladi va Tafsilotlarda quyidagilar:
    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:

    qtcreator: Bog'liq: libqt5concurrent5 (> = 5.0.2), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5designercomponents5 (> = 5.0.2), lekin 5.5.1-3build1 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5help5 (> = 5.0.2), lekin 5.5.1-3build1 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5printsupport5 (> = 5.0.2), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5script5 (> = 5.0.2), lekin 5.2.1 + dfsg-1ubuntu1 o'rnatilmagan
    Bog'liq: libqt5svg5 (> = 5.0.2), lekin 5.5.1-2build1 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5xml5 (> = 5.2.0), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libgcc1 (> = 1: 4.1.1), lekin 1: 4.9.3-0ubuntu4 o'rnatilmagan
    Bog'liq: libqt5core5a (> = 5.2.0), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5designer5 (> = 5.0.2), lekin 5.5.1-3build1 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5gui5 (> = 5.0.2), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5network5 (> = 5.0.2), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5qml5 (> = 5.2.0 ~ beta1), lekin 5.5.1-2ubuntu6 ~ ppa1404 + 2 o'rnatilmagan
    Bog'liq: libqt5quick5 (> = 5.1.0), lekin 5.5.1-2ubuntu6 ~ ppa1404 + 2 o'rnatilmagan
    Bog'liq: libqt5sql5 (> = 5.0.2), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libqt5widgets5 (> = 5.2.0), lekin 5.5.1 + dfsg-16ubuntu7.5 ~ ppa1404 + 1 o'rnatilmagan
    Bog'liq: libstdc ++ 6 (> = 4.6), lekin 4.8.4-2ubuntu1 ~ 14.04.4 o'rnatilmagan
    Bog'liq: qtbase-abi-5-2-1, lekin bu virtual paket
    Bog'liq: qtdeclarative-abi-5-2-1, lekin bu virtual paket
    Agar kimdir menga nima qilishim mumkinligini aytsa, men juda minnatdor bo'lardim.

  52.   Alex dijo

    Va debian 11 holatida? xuddi shunday tartib bo'ladimi?

  53.   Mateo dijo

    Men ushbu vino to‘plamiga bog‘liqlik xatosi oldim, chunki u buzilgan, men sahifada aytgan hamma narsani qildim va ular menga nima qilishni tavsiya qilishlarini bilmayman.
    bu erda o'rnatish paketi:
    Bir nechta to'plamni o'rnatolmaysiz. Bu shuni anglatishi mumkin
    siz imkonsiz vaziyatni so'radingiz yoki tarqatishdan foydalanayotgan bo'lsangiz
    beqaror, ba'zi kerakli paketlar hali yaratilmagan yoki mavjud emas
    Ular "Kiruvchi" dan olingan.
    Vaziyatni hal qilishda quyidagi ma'lumotlar yordam beradi:

    Quyidagi paketlar bajarilmagan bog'liqliklarga ega:
    winehq-barqaror: bog'liq: sharobga barqaror (= 7.0.0.0 ~ bionik-1)
    E: Muammolarni tuzatib bo'lmadi, sizda buzilgan paketlar saqlanib qolgan

    Men nima qilishni bilmayman, iltimos, menga yordam bering

  54.   Julio dijo

    Bu menga boshqa dasturlarni o'rnatishga imkon berdi, rahmat

  55.   streggonne dijo

    ajoyib hissa