发布了GIMP 2.99.4,这是GIMP 3.0的第二个预览版

最近 宣布发布新的GIMP 2.99.4版本 的版本是 列为GIMP 3.0的第二个预发行版本 并继续发展GIMP 3.0未来稳定分支的功能,并在该分支中过渡到GTK3。

添加了对Wayland和HiDPI的标准支持,代码库得到了大幅清理,提出并实现了用于渲染缓存插件开发的新API,并增加了对原始颜色空间中多层选择和编辑的支持。

GIMP 2.99.4主要新功能

与以前的试用版相比,添加了以下更改:

已经完成工作以提高新的紧凑型滑块演示文稿的可用性 用于配置过滤器和工具参数。 例如,通过键盘手动输入值的问题已解决; 以前,单击数字会导致值发生更改,现在,它仅设置输入焦点,而像以前一样,单击数字范围之外的区域会导致值的调整。 此外,解决了基于上下文更改游标的问题。

固定标准热键路口 (Shift +单击和Ctrl +单击),用于选择多个层(多层选择),这可能会导致错误地掩盖或删除一层。 为了避免交叉,在按住Alt键的同时会触发使用Shift,Ctrl或Shift-Ctrl的特殊控制器,例如,代替Ctrl +单击以启用/禁用图层蒙版,现在应按Alt + Ctrl +点击。

“输入设备”对话框已清除, 其中仅保留当前连接到计算机的设备的参数。 虚拟设备和XTEST被隐藏。 代替所有可能的手写笔轴,仅显示控制器实际支持的轴。 现在,轴的名称也对应于驱动程序给定的名称(例如,可以显示“ X Abs。”,而不是“ X”轴)。 如果在数位板上支持压力获取轴,则设备在编辑曲线时会自动激活压力统计模式。

Se 修改了默认设置 适用什么 当检测到新设备连接时。 首次连接设备时,默认情况下会启用它们在某些工具中的使用。

添加了新的实验性油漆选择工具,使您可以逐渐选择具有粗笔触的区域。 该工具基于使用选择性分割算法(graphcut)来仅选择感兴趣的区域。

添加 新的API要求进行插件开发 与对话框生成和元数据处理有关,大大减少了生成对话框所需的代码量。 PNG,JPEG,TIFF和FLI插件已被转移到新的API中。 例如,在JPEG插件中使用新的API可将代码大小减少600行。

为插件提供了多线程配置。 配置器中提供的参数(用于确定使用的线程数)以前仅在主进程中使用,现在可用于插件,这些插件可以通过gimp_get_num_processors()API确定配置中设置的多线程参数。

如何在Ubuntu及其衍生产品上安装GIMP?

花边 这是一个非常流行的应用程序,因此可以在存储库中找到 几乎所有Linux发行版。 但是,众所周知,Ubuntu存储库中通常不会很快提供应用程序更新,因此这可能需要几天的时间。

尽管一切都没有丢失, Gimp开发人员通过Flatpak向我们提供了其应用程序的安装。

从Flatpak安装Gimp的第一个要求是您的系统支持它。

已经确定已安装Flatpak 在我们的系统中,现在是 我们可以安装Gimp 从Flatpak,我们这样做 执行以下命令:

flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref

安装后,如果在菜单中没有看到它,则可以使用以下命令运行它:

flatpak run org.gimp.GIMP

现在 如果您已经在Flatpak上安装了Gimp,并且想更新到这一新版本 版本,他们只需要运行以下命令:

flatpak update

本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

发表评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   苏索

    遗憾的是,没有一家强大的公司为其提供支持或对其进行补贴。

    必须认识到Photoshop需要多年的研究,因此今天是这样,它甚至在开发中包括Raw AI。

    但是,一步一步。