如何从以前的版本升级到Ubuntu 17.04

上周四,我们所有人都收到了Ubuntu 17.04,这是Ubuntu的最新稳定版本,这是一个非LTS版本,如果我们使用的版本不是Yakkety Yak,则可能无法覆盖所有用户。

接下来我们解释 将旧的Ubuntu版本更新为Ubuntu 17.04需采取什么步骤。 步骤,如果不执行,我们可能没有 最新版本的Ubuntu.

从Ubuntu LTS迁移到Ubuntu 17.04之前,我们必须进行一些更改

Ubuntu的更新管理器运行得很好,但是只能从一个版本升级到另一个版本,或者从LTS版本升级到普通版本。 也就是说, 如果我们有Ubuntu 16.10,那么肯定会有更新消息,但是如果我们有其他版本,例如Ubuntu LTS或Ubuntu 15.10,则更新系统会有所不同。

第一 我们必须去软件和更新。 在此窗口中,我们有一个标签«更新»然后在底部选择选项«对于任何新版本«。 此选项将检查是否有新版本,而不仅仅是LTS版本。 更改后,我们按关闭按钮,然后转到终端。

现在,在终端中,我们必须编写以下内容:

sudo do-release-upgrade -d

该终端命令将搜索最新版本并为我们安装。 该过程将逐个版本进行。 也就是说,如果我们具有Ubuntu 16.04,我们将转到Ubuntu 16.10,然后转到Ubuntu 17.04。 如果拥有Ubuntu 15.10,我们将首先迁移到Ubuntu 16.04,Ubuntu 16.10和Ubuntu 17.04。 因此,最后一条命令我们必须重复几次。

版本更新下载量很大 因此我们将需要较大的带宽和足够的时间来执行该过程。 在任何情况下,等待都是值得的,因为我们将拥有Ubuntu的最新版本,其中包括其新闻和更改以及其一些缺点。


23条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   克里斯蒂安(Cristian Emil Spatacian)

    有人尝试过? 某些视频卡仍存在16.04之类的错误,或者已修复。 在16.04中,我无法使用Radeon r6,因为我无法使用fglrx?

    1.    卡洛斯·努诺·罗查(Carlos Nuno Rocha)
      1.    爱德华多·卡马戈

        您能解释一下方法吗,我不太了解,

        我有16.04,但无法正常工作,

        我尝试播放dota 2,但停留在演示文稿中的鼠标移动了,但没有其他作用

  2.   何塞·恩里克·蒙特罗索·巴雷罗

    对我来说,它源于pm Linux mint。 味道的问题...

  3.   约瑟夫·梅拉

    我的Ubuntu和Mint犯了严重错误。
    我正在下载Ubuntu 17:04,因为我喜欢有一个可启动的笔式驱动器来应对可能发生的情况。
    但是我不愿意将其安装为主系统。
    不仅对图形不利,而且对wifi和其他硬件也不利。
    可能是我在LINUX上经历过的最糟糕的经历。

  4.   奥斯卡

    将文件用于分页而不是交换卷有效吗?

  5.   奥斯卡·奎萨达·莱昂

    它在联想y510p上对我来说工作正常,但休眠选项无效。

  6.   银时

    关于交换文件,交换卷将起作用还是将被维护?

  7.   马科斯

    我利用这次最新的举动,从Ubuntu切换到Ubuntu Gnome。 我当时想回去...一切对我来说都更好,从美学上讲,一切都更加美丽,但是我不知道为什么WiFi会引起问题。 但是现在我看到它在Ubuntu中也带来了问题。

  8.   阿尔维达斯·尤尔库斯(Alvydas Jurkus)

    从16.04到16.10以及从16.10到17.04的错误以及许多不值得的错误,我已经重新安装了16.04 clean。 只是新的cernel和uuku的其他功能几乎相同,您更新了新的cernel,效果非常好

  9.   加布里埃尔·扎佩(Gabriel Zapet)

    您好…我是这方面的初学者..我想尝试一个干净的Ubuntu17版本,但我真的不知道该选择哪个,我看到有一个AMD版本,另一个我记不清了。 ..但是我不明白我应该选择哪一个……用于英特尔处理器,或者这根本不影响选举吗? 如果我没记错的话..您只选择了32到64位之间,然后32消失了。 我输了

    1.    Power2000

      amd 64位版本称为amd64(而不是AMD),因此请不要将AMD品牌与64位文件系统的名称混淆= amd64

  10.   埃利斯

    亲爱的查询,如果我想先更新到.16.04,然后再更新到10,则我有Ubuntu 17.04 LTS,问题是何时可以更新下一个LTS版本,或者总结一下,我可以从LTS版本更新到非LTS版本。 LTS版本,然后从此没有LTS到可用的LTS

    1.    彭德维德

      我只是为您总结一下,是的。

  11.   托马斯·史瓦茨(Thomas Schiwatsch)

    下午好,尝试从Ubuntu 16.04运行命令,它会检查版本以及是否有新版本。 最后,它为我提供了没有新版本的UBUNTU的信息。 我需要附加另一个存储库吗? 你好

  12.   妈妈

    嗯...他们说的是“中文”,我根本听不懂!!! pffff某处可供人类阅读? 计算机世界真是太好了! 他们来自另一个星球。 我只想知道为什么我不能用安装得很好的非常简单的hp打印机进行打印……它将无法打印,我已经很沮丧!

  13.   妈妈

    我仍然很沮丧,没有人回答我...我有个电脑孩子,他不给我球...我必须上色彩理论课,为此我买了这台非常简单的打印机,即可打印色彩,仅此而已! 它对我不起作用,我做了所有事情,我听从建议,安装,卸载,重新启动等,等等,等等,什么都没有。 检查hplip,妙招等他们告诉我的所有内容,将其保留为默认值,并根据建议进行配置,什么也没有,它已经死了,它只能移动墨盒,传递空白纸张,不打印,它是开着的,正确安装的等等,等等,仍然是死的,有光,但是死了。 我要做什么??? 你是

  14.   妈妈

    我是同一位沮丧的母亲,我的ubuntu版本为14.04,我认为,我的互联网连接良好且速度很快,个人电脑状况良好,一切正常,墨粉兄弟打印机对我来说效果很好,没有问题。 请帮忙

  15.   禁忌

    我刚刚从Chubut 16.04升级到16.10,它无法识别我的键盘。 我在另一个论坛上看到,这已经发生在几个人身上,我找不到解决方案。 有人有想法吗

    1.   

      键盘也发生在我身上,事实证明这是xorg的问题,无法识别硬件输入(在这种情况下为键盘和鼠标)。 请按照以下步骤操作:
      https://askubuntu.com/questions/908918/updated-from-16-04-to-16-10-the-keyboard-and-mouse-no-longer-works-after-gettin
      并且如果使用apt-get时在下载时无法识别网址,则必须输入此其他命令,以便resolv.conf文件可以正常工作:
      sudo dpkg重新配置resolvconf
      当询问时,请回答“是”以允许动态更新。

  16.  

    键盘也发生在我身上,事实证明这是xorg的问题,无法识别硬件输入(在这种情况下为键盘和鼠标)。 请按照以下步骤操作:
    https://askubuntu.com/questions/908918/updated-from-16-04-to-16-10-the-keyboard-and-mouse-no-longer-works-after-gettin
    并且如果使用apt-get时在下载时无法识别网址,则必须输入此其他命令,以便resolv.conf文件可以正常工作:
    sudo dpkg重新配置resolvconf
    当询问时,请回答“是”以允许动态更新。

  17.   贡萨洛

    我已经尝试按照您所说的安装新版本,但它不会让我失望。 它是15.04版,我已经完成了所有步骤和检查。

    xxx @ xxx-Lenovo-Z50-70:〜$ cat / etc / issue
    Ubuntu 15.04 \ n \ l
    -----------------
    xxx @ xxx-Lenovo-Z50-70:〜$ sudo do-release-upgrade -d
    检查新版本的Ubuntu
    找不到新版本
    xxx @ xxx-Lenovo-Z50-70:〜$

  18.   ise77

    您好,将我的ubundu更新为17.04,现在我的打印机出现问题,在文档的打印状态下,我停止了操作,无法进行打印。 我进入了打印机上的系统配置,似乎一切都很好,我已经卸载并重新安装了打印软件,但没有任何反应,有人发生过同样的事情吗?