Koala, et godt værktøj for udviklere

Koala skærmbillede

Virkelig i Ubuntu og i Gnu / Linux er der få værktøjer til udviklere, men de få, der findes, er overvældende godt. Vi har sagen om Netbeans, Sublime Text, Beslag, Eclipse og mange andre, dog indtil videre brugen af forprocessorer det var ret begrænset. Selvom det er rigtigt, at vi har mange redaktører, der kan oprette filer til forprocessorer, er der ikke mange værktøjer, der giver os mulighed for at se ændringerne i realtid, det vil sige for at være i stand til prækompilering disse filer for senere at dumpe det i css-filen. Koala det er et af de få værktøjer, der giver os mulighed for at bruge præprocessorer og se, hvad vi skaber i realtid.

Hvilke værktøjer er der til forbehandling?

Hvis du ved, hvordan du bruger præprocessorer, kender du allerede nogle meget nyttige værktøjer til at arbejde med preprocessorer. Det bedste af alt er Kodesæt, skam er, at det kun fungerer for Mac OS. Codekit er ikke kun den bedste, men det er også paradigmet for resten af ​​værktøjerne. I øjeblikket er der frigivet et værktøj til Windows, der kan overskygge Kodesæt, hedder Prepros, men dette værktøj skiller sig kun ud, fordi det går, hvor det ikke går Kodesæt. Hvad angår Gnu / Linux og Ubuntu-verdenen, er det værktøj, der ligner dem mest Koala, et ret kraftigt program, der ligner Codekit og Prepros, med hensyn til grænseflade.

Hvad tilbyder Koala?

Koala giver os muligheden for at bruge præprocessorer, less, Sass, CofeeScript og Compass Framework. Koala er på flere sprog, inklusive spansk, og det giver os mulighed for at minificere vores kode, både css og javascript. Projektet af Koala er i Github, hvor vi ud over at finde installationsfilerne finder en god guide til at kunne installere Koala, rette eksisterende problemer og konfigurere vores projekter. Projektet af Koala er Open Source, så vi behøver ikke betale nogen licens, selvom det er godt at donere, da projektet udføres uselvisk, men internettet, tiden eller test de er normalt ikke gratis.

Koala installation

At være i stand til at installere Koala og at det fungerer i vores Ubuntu, skal vi først åbne terminalen og skrive følgende:

sudo apt-get installer rubin

Dette installerer Ruby på vores computer, det er ikke vigtigt for Koala at arbejde, men for Sass at arbejde, så det anbefales at installere det først. Når det er installeret, vil vi den officielle hjemmeside og vi downloader pakken, der svarer til vores version af Ubuntu (32-bit eller 64-bit). Når vi har installeret det, åbner vi det, og det kan ske, at det ikke åbner; synes at være, at der er problemer med nogle Gnu / Linux-systemer, i mit tilfælde har jeg for eksempel Ubuntu Gnome 13.10 og jeg kunne ikke åbne det første gang, for at løse det åbner vi terminalen og går til

cd / lib / i386-linux-gnu, hvis du har 32 bits

cd / lib / x86_64-linux-gnu, hvis du har 64 bits

En gang der skrev vi

sudo ln -s libudev.so.1 libudev.so.0

Det fortæller os måske ikke, at filen ikke findes, så installerer vi filen libudev0 og så gentager vi den sidste handling. Efter dette vil vi have Koala fungerer perfekt og klar til at bruge forprocessorerne. Tilbyder nogen andre?


Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

6 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort.

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Marlon sagde han

    Tak ven, fejlen var meget hjælpsom.

  2.   Oscar sagde han

    Jeg har 4 timer på at prøve at installere Koala gennem instruktionerne på det officielle websted, og selvom det viste det for mig i menuen på min ubuntu, kunne det ikke udføres ordentligt, det åbnede ikke Koala-grænsefladen med disse MINIMUM og SIMPLE trin jeg kan allerede køre Koala som det skal. Tak!

  3.   Fabian sagde han

    Jeg skal downloade det og prøve, det lyder som en meget god applikation

  4.   Arbejde sagde han

    Dette indlæg har været for længe siden, og vi er allerede på 18.4 liter, så Koala åbner (fordi det fortsætter med den samme fejl, åbner det ikke), skal du installere:

    $ sudo apt -y installer libgconf2-4

    Som forklaret af Dusha Kucher i et indlæg om denne fejl. Jeg installerede det, og det fungerede.

  5.   Jorge Sierra sagde han

    Jeg vil ikke køre programmet på debian 10, jeg kører sudo ln -s libudev.so.1 libudev.so.0, og jeg får, at det ikke lykkedes at oprette symbolsk link 'libudev.so.0' filen allerede eksisterer .

  6.   Sergio sagde han

    Hej venner, jeg havde det samme problem, jeg installerede Koala ved at downloade det fra det officielle websted (64-bit deb), og det åbnede ikke programmet, jeg installerede fra pakkehåndteringen eller Synaptic (da det i terminalen fortalte mig at pakken ikke eksisterede) libgconf2-4 og voila, nu hvis Koala arbejder på Ubuntu 20.04 bits.