Transmission 4.0: نسخه جدید با بسیاری از ویژگی های مفید جدید

Transmission 4.0: نسخه جدید با بسیاری از ویژگی های مفید جدید

Transmission 4.0: نسخه جدید با بسیاری از ویژگی های مفید جدید

در پست امروز خود و همانطور که عنوان می گوید، به اخبار مربوط به "انتقال 4.0". که جدیدترین نسخه از بزرگ است سرویس گیرنده بیت تورنت رایگان و باز کنید برای گنو/لینوکس برای انجام این کار، گزارش توسعه آن را ادامه دهید، درست مانند آخرین بار (تقریباً 3 سال پیش) که اخبار مربوط به آن را مرور کردیم. انتقال 3.0.

و درست همانطور که در آن مناسبت، این جدید و آخرین نسخه منتشر شده، این یک به روز رسانی عالی است، پر از اخبار بسیار مهم، برای گفتن این نرم افزار کراس پلت فرم رایگان و متن باز همانطور که در زیر مشاهده خواهد شد.

در مورد انتقال 3.0

اما، قبل از شروع این پست در مورد انتشار اخیر آخرین نسخه "انتقال 4.0"، توصیه می کنیم پس از آن پست قبلی مرتبط با آن را بررسی کنید:

در مورد انتقال 3.0
مقاله مرتبط:
انتقال 3.0 ، نسخه جدیدی از این سرویس گیرنده تورنت ساده است

Transmission 4.0: اکنون با پشتیبانی از BitTorrent v2

Transmission 4.0: اکنون با پشتیبانی از BitTorrent v2

اخبار جاری در Transmission 4.0

مطابق اعلامیه رسمی از انتشار "انتقال 4.0"، این نسخه جدید در میان بسیاری از ویژگی های جدید شامل موارد زیر است که ما آنها را مهم یا شایسته برجسته می دانیم:

  1. با توجه به کارایی استفاده از منابع، کد به طور گسترده پروفایل شده و بهبود یافته است تا استفاده ناکارآمد کد و حافظه را برطرف کند. بنابراین اکنون می توانید تا 50٪ کمتر از چرخه های CPU و 70٪ تخصیص حافظه کمتر از Transmission 3.00 استفاده کنید.
  2. با توجه به مشارکت جامعه در توسعه، کد بهبود یافته است به طوری که برنامه نسبت به گذشته بسیار بیشتر به گزارش های باگ و ارسال کد پاسخ می دهد. علاوه بر این، اکنون گروه جدیدی از همکاران داوطلب بسیار فعال وجود دارد.
  3. در مورد نوسازی کد، تمام پایه کد از C به C++ منتقل شده است. که به نوبه خود منجر به حذف هزاران خط کد سفارشی و ارتقای خطوط دیگر به C++ شده است. بنابراین دستیابی به کد هسته 18٪ کاهش می یابد. همچنین، کلاینت GTK به GTK4/GTKMM منتقل شده است.
  4. با توجه به ویژگی های جدید گنجانده شده است، شایان ذکر است که: سازگاری با استفاده از تورنت های BitTorrent v2 و تورنت های ترکیبی و پیکربندی ردیاب های "پیش فرض" که می توانند برای تبلیغ همه تورنت های عمومی استفاده شوند. همچنین اینکه اکنون بذرهای تازه اضافه شده می توانند بلافاصله شروع به کار کنند و قطعات را بررسی کنند، شما خواسته اید. این، به جای نیاز به تأیید کامل قبل از شروع بذر.

در نهایت و برای کسب اطلاعات بیشتر در مورد نرم افزار مذکور و به دست آوردن فایل های نصبی آن، طبق معمول، هر دو مورد نیاز است وب سایت رسمی به عنوان او مخزن GitHub.

مقاله مرتبط:
نحوه استفاده از انتقال ، یکی از بهترین سرویس گیرنده ها برای بارگیری و اشتراک گذاری تورنت ها

بنر چکیده برای پست

خلاصه

خلاصه اینکه ، "انتقال 4.0" می آید تا این بزرگ را بدهد مشتری BitTorrent یک بازسازی کاملاً قابل توجه و همه به لطف شما چندین پیشرفت، تغییرات و اصلاحات عمده ساخته شده است. به این ترتیب، مدیریت دانلود فایل ها از طریق اینترنت را هم به صورت کاربردی و هم از نظر بصری بهبود می بخشد. و اگر کاربر همیشگی آن هستید و این ویژگی های جدید را عالی یافته اید، خوشحال کننده خواهد بود تجربه و برداشت خود را بدانید دست اول، از طریق نظرات.

همچنین، به یاد داشته باشید، از ابتدای ما دیدن کنید «محل»، علاوه بر کانال رسمی از تلگرام برای اخبار بیشتر، آموزش ها و به روز رسانی لینوکس. غرب گروه، برای اطلاعات بیشتر در مورد موضوع امروز.


5 نظر ، نظر خود را بگذارید

نظر خود را بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخشهای موردنیاز علامتگذاری شدهاند با *

*

*

  1. مسئول داده ها: میگل آنخل گاتون
  2. هدف از داده ها: کنترل هرزنامه ، مدیریت نظرات.
  3. مشروعیت: رضایت شما
  4. ارتباط داده ها: داده ها به اشخاص ثالث منتقل نمی شوند مگر با تعهد قانونی.
  5. ذخیره سازی داده ها: پایگاه داده به میزبانی شبکه های Occentus (EU)
  6. حقوق: در هر زمان می توانید اطلاعات خود را محدود ، بازیابی و حذف کنید.

  1.   روبرتو dijo

    خیلی جالبه ، خیلی ممنون
    اکنون فقط به یک نفر نیاز داریم که به ما متخصص کمتری بگوید چگونه می توانیم این نسخه جدید را نصب کنیم.
    من tar.xz را دانلود کرده ام و آن را از حالت فشرده خارج کرده ام و نمی دانم چگونه ادامه دهم. چند راه حلی که پیدا کردم برای من کار نمی کند.

    1.    خوزه آلبرت dijo

      با احترام، رابرت. بابت نظراتتون ممنونم. دستورالعمل نحوه کامپایل و نصب برنامه در فایل readme.md و وب سایت GitHub آن موجود است. مطمئن شوید که نسخه قبلی را نصب نکرده اید:

      $ tar xf transmission-4.00.tar.xz
      انتقال سی دی $-4.00
      $ mkdir ساخت
      $ ساخت سی دی
      $ # برای ساخت باینری بهینه شده از -DCMAKE_BUILD_TYPE=RelWithDebInfo استفاده کنید.
      $ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
      $ ساخت
      $ sudo نصب کنید

      و اگر از GitHub باشد موارد زیر است:

      ### برای اولین بار نصب کنید

      $ git کلون https://github.com/transmission/transmission انتقال
      انتقال $cd
      به روز رسانی زیر ماژول $ git --init --recursive
      $ mkdir ساخت
      $ ساخت سی دی
      $ # برای ساخت باینری بهینه شده از -DCMAKE_BUILD_TYPE=RelWithDebInfo استفاده کنید.
      $ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
      $ ساخت
      $ sudo نصب کنید

      ### برای به فعلیت رساندن

      $ سی دی انتقال/ساخت
      $ تمیز کردن
      زیر ماژول $ git foreach --بازگردانی git clean -xfd
      $ git pull --rebase --prune
      به روز رسانی زیر ماژول git $ -- بازگشتی
      $ # برای ساخت باینری بهینه شده از -DCMAKE_BUILD_TYPE=RelWithDebInfo استفاده کنید.
      $ cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..
      $ ساخت
      $ sudo نصب کنید

      https://github.com/transmission/transmission

      1.    روبرتو dijo

        سلام خوزه آلبرت، از اطلاعات شما بسیار متشکرم،
        من دستورالعملی را که به من می گویید انجام داده بودم، اما وقتی وارد خط شدم:

        cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo ..

        این خطای زیر را به من می دهد:

        شناسه کامپایلر C GNU 10.2.1 است
        - شناسه کامپایلر CXX GNU 10.2.1 است
        - شناسایی اطلاعات ABI کامپایلر C
        - شناسایی اطلاعات کامپایلر C ABI - انجام شد
        - بررسی کنید که کامپایلر C کار می کند: /usr/bin/cc - رد شد
        -تشخیص ویژگی های کامپایل C
        - تشخیص ویژگی های کامپایل C - انجام شد
        - شناسایی اطلاعات کامپایلر CXX ABI
        - شناسایی اطلاعات کامپایلر CXX ABI - انجام شد
        - بررسی کنید که کامپایلر CXX در حال کار باشد: /usr/bin/c++ - نادیده گرفته شده است
        -تشخیص ویژگی های کامپایل CXX
        - تشخیص ویژگی های کامپایل CXX - انجام شد
        -به دنبال pthread.h
        -به دنبال pthread.h - یافت شد
        - انجام تست CMAKE_HAVE_LIBC_PTHREAD
        - انجام تست CMAKE_HAVE_LIBC_PTHREAD - ناموفق
        - به دنبال pthread_create در pthreads هستید
        - به دنبال pthread_create در pthreads هستید - یافت نشد
        - به دنبال pthread_create در pthread هستید
        - در جستجوی pthread_create در pthread - یافت شد
        - موضوعات یافت شده: درست است
        خطای CMake در /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:165 (پیام):
        CURL پیدا نشد (فقدان: CURL_LIBRARY CURL_INCLUDE_DIR) (الزامی است
        حداقل نسخه "7.28.0")
        Call Stack (اولین تماس اخیر):
        /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:458 (_FPHSA_FAILURE_MESSAGE)
        /usr/share/cmake-3.18/Modules/FindCURL.cmake:169 (find_package_handle_standard_args)
        CMakeLists.txt: 203 (find_package)

        - پیکربندی ناقص ، خطا رخ داده است!
        همچنین به "/home/capgros/Downloads/transmission-4.0.0/build/CMakeFiles/CMakeOutput.log" مراجعه کنید.
        همچنین به "/home/capgros/Downloads/transmission-4.0.0/build/CMakeFiles/CMakeError.log" مراجعه کنید.

        من متوجه شدم که خطا می گوید CURL را پیدا نکرده است، اما من آن را نصب کرده ام:

        ~/Downloads/transmission-4.0.0/build$ dpkg -l | grep curl

        ابزار خط فرمان ii curl 7.74.0-1.3+deb11u5 amd64 برای انتقال داده با نحو URL
        ii libcurl3-gnutls:amd64 7.74.0-1.3+deb11u5 amd64 با استفاده آسان کتابخانه انتقال URL سمت مشتری (طعم GnuTLS)
        ii libcurl4:amd64 7.74.0-1.3+deb11u5 amd64 با کاربری آسان کتابخانه انتقال URL سمت سرویس گیرنده (طعم OpenSSL)
        ii python3-pycurl 7.43.0.6-5 amd64 اتصال پایتون به libcurl (Python 3)

        من به گزارش های خطا نگاه کردم، اما چیزی از آنها متوجه نشدم، اگر می دانید چگونه می توانم آن را برطرف کنم، به من بگویید.
        من دبیان 11 دارم

        1.    خوزه آلبرت dijo

          با احترام، رابرت. بله، ظاهراً می گوید که سیستم عامل شما یک کتابخانه CURL، مساوی یا بزرگتر از نسخه 7.28 ندارد. این را اجرا کنید تا ببینید آیا آن کتابخانه را نصب می کند یا خیر، و امیدواریم آن نسخه یا بالاتر را داشته باشید:

          sudo apt update && sudo apt upgrade && sudo apt install curl && sudo apt-get install libcurl4-openssl-dev

          یا در صورت استفاده از CentOS: sudo yum libcurl-devel را نصب کنید

          1.    روبرتو dijo

            سلام آلبرت من کتابخونه هایی که بهم میگی نصب کردم تو نت سرچ کردم و راه حل هایی که پیدا کردم اصلا واضح نیست و برای دانشم خیلی پیچیده است.
            فعلاً به نسخه 3 پایبندم.
            بسیار متشکرم.