Installez le noyau 4.14.13 pour combattre Meltdown

Linux Kernel

Avec récents problèmes de sécurité généré ces dernières semaines avec concernant les attaques Meltdown et Spectre, les grandes sociétés de logiciels ont déployé beaucoup de travail pour trouver et résoudre ce problème.

En attendant Sous Linux, nous avons déjà les premiers correctifs qui résolvent ces graves failles de sécurité, nous devons donc nous donner la tâche de mettre à jour le noyau de notre système à protéger.

En cette nouvelle version Maintenance du noyau Linux Le plus remarquable de ce Ce sont les correctifs qui arrêtent les attaques Meltdown et Spectre, d'autre part, ils ont travaillé pour éviter les problèmes de débordement de mémoire, ainsi que l'allocation de mémoire.

Comment installer la version de maintenance du noyau Linux 4.14.13 sur Ubuntu 17.10?

Sans plus la seule chose que je puisse dire est que cette version est extrêmement importante pour l'avoir dans notre système, car c'est la solution aux problèmes de sécurité qui se posent actuellement.

Il est important de mentionner que le processus décrit ici n'est pas seulement valable pour Ubuntu, on peut aussi le faire en Linux Mint, OS élémentaire, OS Zorin et tout autre système dérivé d'Ubuntu.

Pour les versions 32 bits, Nous ouvrons un terminal et exécutons ce qui suit:

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413_4.14.13-041413.201801101001_all.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413-generic_4.14.13-041413.201801101001_i386.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_i386.deb

Déjà fait cela, jeNous installons les packages avant de les télécharger avec ce qui suit:

sudo dpkg -i linux-headers-4.14.13*.deb linux-image-4.14.13*.deb

Maintenant pour les systèmes 64 bits, nous téléchargeons ces packages:

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413_4.14.13-041413.201801101001_all.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

wget -c www.kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

Y nous avons finalement installé avec la commande suivante:

sudo dpkg -i linux-headers-4.14.13*.deb linux-image-4.14.13*.deb

Enfin Nous n'aurons plus qu'à redémarrer l'ordinateur pour que les modifications prennent effet et quand nous sommes dans Grub, nous devons nous assurer que le système démarre avec le nouveau noyau.

Maintenant, si vous êtes novice, vous pouvez éviter de le faire manuellement, vous pouvez utiliser cet outil qui peut vous aider à le faire pour vous, le le lien est ceci.


Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont marqués avec *

*

*

  1. Responsable des données: Miguel Ángel Gatón
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   giovanni gapp dit

    Et l'erreur bios pour le moment où ils le réparent ou vont-ils simplement nous dire qu'il n'y a pas de solution et se laver les mains?

    1.    David Yeshaël dit

      L'erreur a déjà été corrigée

      1.    Hector Moreau dit

        Bonjour David.

        Vous mentionnez que l'erreur a déjà été corrigée, mais ils sont censés permettre le téléchargement le 11/01, mais à ce jour rien. Aucune explication n'est donnée non plus, ni dans ubunlog, même pas en OGM ! Ubuntu !, ni sur la page officielle d'Ubuntu.

  2.   Josep Pujadas-Jubany dit

    Cette version du noyau accroche tous les ordinateurs portables de notre Institut. Nous avons dû désactiver les mises à jour Lubuntu 16.04 LTS 64 bits.
    Chez moi, sur mon bureau, ça marche. Mais l'ordinateur se bloque lorsque j'ouvre mon ancien Windows XP virtualisé avec VirtualBox. Plus d'informations sur:
    https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1742626

    1.    Josep Pujadas-Jubany dit

      Horreur!
      À l'époque, je faisais référence à 4.13.0-26 (le dernier officiel) pour le 16.04 LTS HWE. Et maintenant je vois que l'article dit 4.14.13.
      Pardon!
      https://insights.ubuntu.com/2018/01/12/meltdown-and-spectre-status-update/

  3.   Saito dit

    Je suis avec Kubuntu 16.04.3 et le noyau 4.13.0-26, tout est patché et fonctionne parfaitement (pas d'erreur ni de bogue majeur), cependant je dois dire que j'ai les mêmes problèmes que tout le monde avec VirtualBox: bien qu'il ne meure pas pour moi le système, simplement la consommation du processeur s'élève à plus de 75% et après quelques minutes, seul VirtualBox cesse de fonctionner et pas toujours.

  4.   Ingemar dit

    Je reçois ce message: bash: erreur syntaxique près de l'élément inattendu `newline ', ce qui précède lors de la saisie du premier package correspondant aux systèmes 64 bits Comment corriger cela pour installer les packages dans Ubuntu 17.10? Les salutations!

  5.   Gonzalo dit

    Ils devront sûrement mettre à jour VirtualBox pour accueillir cette mise à jour du noyau

  6.   Hector Moreau dit

    Que se passe-t-il avec Canonical et Ubuntu?

    Comme ubuntu 17.10 ne peut pas être utilisé, il est retourné à ubuntu 16.04.03. Mais après l'installation et la mise à jour, entre autres, le noyau a été mis à jour de 4.10 à 4.13. Lorsque j'ai redémarré le PC, je n'ai pas pu rechercher les programmes, car le démarrage d'Ubuntu s'est écrasé et lorsque j'ai cliqué dessus, l'écran a redémarré et il n'y avait aucun moyen de travailler normalement. En d'autres termes, le dock entier s'est écrasé, cela ne pouvait fonctionner que par terminal.

    Mon ordinateur portable est un HP Pavilion DV5-2247la. Processeur Intel Core i5-480M de 2,66 GHz, cache L3 de 3 Mo, 2 modules DIMM DDR3 de 8 Go, carte graphique Intel HD avec jusqu'à 1696 Mo de mémoire graphique totale, disque dur de 640 Go (5400 tr / min).

    1.    Josep Pujadas-Jubany dit

      Si vous utilisez 16.04 LTS HWE (16.04.03), le dernier noyau officiel est 4.13.0-31. Dans mon travail, cela fonctionne bien sur des équipes de plus de 2 ans. Dans les plus récents, nous avons des problèmes d'attribution d'IRQ.

      https://bugs.launchpad.net/ubuntu/+source/linux-signed/+bug/1742626
      https://bugzilla.kernel.org/show_bug.cgi?id=194945#c84

      Dans le menu grub, les options avancées que vous pouvez commencer avec 4.10. Et puis vous pouvez installer grub-customizer pour définir le démarrage sur 4.10.

      http://ubuntuhandbook.org/index.php/2016/04/install-grub-customizer-ubuntu-16-04-lts/

      Nous avons des équipes avec 4.10 (c'est la première mesure que nous prenons) et depuis hier des équipes avec 4.14.15, http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.15/

      «Que se passe-t-il avec Canonical et Ubuntu?

      Ce n'est pas leur problème. C'est un problème général qui affecte tous les systèmes d'exploitation. Notre fournisseur de matériel m'a dit il y a quelques jours qu'il avait beaucoup de machines non Linux qui ne démarrent pas après la mise à jour.

      Bonne chance!

  7.   Pierre Aribaut dit

    Salut, le noyau 4.14.13 peut-il être utilisé avec Linux Mint 18.3?

    1.    Josep Pujadas-Jubany dit

      Je devrais partir. C'est un Ubuntu Xenial (16.04), https://linuxmint.com/download_all.php