Canonical állítások A Snap csomagokat könnyebb használni

Krita Snap-ban

Néhány órával ezelőtt tudtuk, hogyan beszélt Martin Wimpress a beépítéséről csomagokat csatolhat az Ubuntu MATE-re, kezdve magával a MATE asztallal. Láttuk azt is, hogyan hozhat létre egyszerű csomagot tökéletesen működő számológéppel.

De nem csak ez az, amit a csomagok tehetnek. Michael Hall megerősíteni akarta a snap csomagok fontosságát, és nem engedte, hogy azok feleslegesek maradjanak, ahogyan ő maga tette átalakítás a deb csomagokból a snap csomagokba ez senkit sem hagy közömbösnek.

Az általunk hivatkozott szoftver nem több és nem kevesebb, mint Chalk 3.0. Hall be akarta mutatni a snap csomagok teljes potenciálját és a Krita 3.0 verziójáról konvertált, ami egyszerű módon és teljesen működőképes eredménnyel történt.

Hall létrehozott egy Krita csomagot, hogy bemutassa erejét

Hall biztosította, hogy a snap nem csak a számológépek számára készült, és hogy a felhasználók a kedvenc programjaik legújabb verzióit csak néhány órával a snap csomagok létrehozása óta való nyilvános közzétételük után kaphatják meg, és frissítése nem tart olyan sokáig, mint a deb csomagok, a jelenlegi csomagrendszert, amelyet pontosan a Debiantől örököltek.

A csomagcsomagok eredménye nagyon jó, kétségtelen, de ennek az új csomagrendszernek a problémája nem a minőségében, hanem a mennyiségében van, az új csomagolási rendszert használó fejlesztők számában. Jelenleg, bár a Snap-ot az Ubuntu Core-ban használják, kevés olyan csomag van, amelynek a snap verziója van, és ez szerintem sajnos sokáig megmarad. Mit gondolsz? Gondolod, hogy a snap végre a szokásos Ubuntu csomag lesz? Kipróbált már telepítést snapon keresztül?


A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

5 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Ricardo dijo

    Úgy gondolom, hogy a jövőben ez lesz az Ubuntu szabványos csomagja (és természetesen annak származékaiban), amely együtt fog állni a deb csomagokkal, háttérbe szorítva őket.

    Kipróbáltam a Telegram snap-ot az Ubuntu áruházból, de van néhány hátrányom, ami nem tetszik. Nincs 100% -ban integrálva az Ubuntuban azzal, ami elveszett 1- az állapotjelző ikon a felső sávban és az olvasatlan üzenetek száma, amelyek nem jelennek meg az egységindító ikonban, és 2 - a hivatkozások nem nyithatók meg az általad küldött webhelyen üzenetben. A megoldás a link másolása, a böngésző megnyitása és beillesztése. Biztosan a jövőben meg tudják oldani ezeket a problémákat, ezért most telepítem a Telegram weboldal verzióját.

    Néhány programot is telepítettem a következőn keresztül: https://uappexplorer.com/apps?type=snappy egy számológép, jegyzetek és egy óra.

    Szeretem kipróbálni a snap csomagokat, egyszerűbb és "erősebb", de még mindig javítaniuk kell az integrációt az Ubuntuval (távirat), és különösen a terminál egyik alkalmazásával vagy paranccsal, hogy frissítsék az összes telepített snapot, és ne kelljen egyenként haladniuk. a neved.

  2.   Jose L. Torres dijo

    Mi van a biztonsági hibával odakinn? Amikor megoldják, akkor beszélni fogunk ezekről a csomagokról, köszönöm.

  3.   Zsidó dijo

    José L. Torres, milyen biztonsági hibája van a Snapnak? :-VAGY

  4.   supersx dijo

    Kike, hogy az emberek bulvárcímet olvasnak, és nem veszik a fáradságot, hogy elolvassák a részleteket. Röviden, valaki kijött (nem emlékszik a névre, sajnálom), mondván, hogy nem biztonságosak. Ha elolvassa a részleteket, kiderül, hogy a snaps biztonság része a Sandbox rendszer, amely Mir-től függ. Tehát, ha nem telepít olyan számítógépre, amely még mindig X11-et használ, akkor az alkalmazások nem rendelkeznek Sandboxing-védelemmel. valamint egyik sem telepítve DEB vagy RPM használatával.
    Szenzációhajhász.

    1.    Zsidó dijo

      Köszönöm a supersx választ, vele megvizsgáltam egy kicsit, és ahogy olvastam, nem a snap, hanem az X11 hibája, tehát ugyanezen három szabály szerint ugyanaz történne egy hagyományos .deb esetén is.
      Tetszik a snap ötlete, minden, amire szükséged van egyetlen csomagban, homokozó rendszer a rendszer biztonságához ... szóval remélem, hogy pillanatok alatt ez lesz az alapértelmezett csomag az Ubuntuban.