Hogyan telepítsem a Wine-t az Ubuntu 18.04 LTS-re?

Bor

Bor egy népszerű ingyenes és nyílt forráskódú szoftver amely lehetővé teszi a felhasználók számára a Windows-alkalmazások futtatását Linuxon és más Unix-szerű operációs rendszereken. Hogy kicsit technikásabb legyek, Wine ez egy kompatibilitási réteg; lefordítja a rendszerhívásokat Windows-ról Linux-ra és néhány Windows könyvtárat használ .dll fájlok formájában.

A Linuxról migráló emberek számára valószínűleg szükségük van valamilyen Windows szoftverre vagy játékra, amely nem érhető el, vagy amelynek nincs megfelelője a Linuxban. A Wine lehetővé teszi a Windows programok és játékok futtatását a Linux asztalon.

Bor ez az egyik legjobb módszer a Windows-alkalmazások futtatására Linuxon. Ezen kívül a Bor közösség nagyon részletes alkalmazás-adatbázisa van, AppDB-nek találjuk több mint 25,000 XNUMX programot és játékot tartalmaz, a Wine-val való kompatibilitásuk szerint rangsorolva:

  • Platina alkalmazások- Zökkenőmentesen telepíti és futtatja a használatra kész Wine telepítést
  • Arany alkalmazások- hibátlanul működik néhány speciális beállítással, például a DLL felülírásaival, más beállításokkal vagy harmadik fél szoftverével
  • Ezüst alkalmazások- Kisebb problémákkal futnak, amelyek nem befolyásolják a tipikus használatot, például egy játék futtatható egyjátékosban, de többjátékosban nem.
  • Bronz alkalmazások- Ezek az alkalmazások működnek, de észrevehető problémáik vannak, még rendszeres használatuk esetén is. Lehet, hogy lassabbak, mint kellene, UI problémákkal küzdenek, vagy hiányozhatnak a sajátosságaik.
  • Junk apps- A közösség bebizonyította, hogy ezek az alkalmazások nem használhatók a Borral. Lehet, hogy nem telepítik, nem indulnak el, vagy annyi hibával indulhatnak, hogy lehetetlen használni.

A Wine telepítése előtt el kell döntenünk, hogy a legújabb stabil verziót vagy a fejlesztői verziót akarjuk-e.

A stabil verzió kevesebb hibát tartalmaz és nagyobb a stabilitás, de kevesebb Windows alkalmazást támogat. A fejlesztői verzió jobb kompatibilitást kínál, de több megoldatlan hibát tartalmaz.

Ha a stabil Wine sorozat legújabb verziójára vágyik, akkor most a 3.0 verziót használjuk.

A Wine telepítése az Ubuntu 18.04-re

 

Telepítéséhez a rendszerünkbe terminált kell nyitniuk nyomja meg a 'CTRL + ALT + T' billentyűt vagy az asztalról és futtatásához futtassa a következő parancsokat.

Az első lépés a 32 bites architektúra engedélyezése lesz, még akkor is, ha a rendszerünk 64 bites, ennek a lépésnek a végrehajtása sok problémát takarít meg, amelyek általában felmerülnek, erre a terminálra írunk:

sudo dpkg --add-architecture i386

Most be kell importálnunk a kulcsokat és hozzá kell adnunk a rendszerhez ezzel a paranccsal:

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key

Most kész a következő adattárat fogjuk hozzáadni a rendszerhezJelenleg nincs tárház az Ubuntu 18.04 LTS számára, de használhatjuk az előző verzió tökéletesen működő tárházát, ehhez a terminálba írjuk:

sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ artful main'

Végül, Csak be kell írnunk a következő parancsot a Wine számítógépre történő telepítéséhez, ez a Wine 3.0 stabil verziójának telepítése:

sudo apt-get install --install-recommends winehq-stable

Most a Borfejlesztési ághoz is hozzáférünk, amely sokkal több funkciót és fejlesztést tartalmaz, mint a 3.0, a fejlesztői verzió problémája, hogy fennáll annak a veszélye, hogy a végrehajtás során hibákat észlelünk.

Kapcsolódó cikk:
A függőségek nem teljesülnek

De ha telepíteni akarja, amely jelenleg folyamatban van, a Wine 3.7 verzió telepítésre kerül csak futnia kell:

sudo apt-get install --install-recommends winehq-devel

Kész a telepítés Csak futtatnia kell ezt a parancsot a sikeres telepítés ellenőrzéséhez és tudja, milyen verziót telepített:

wine --version

Ahol ez a stabil verzió volt, a következő választ kapja:

wine-3.0

Hogyan lehet eltávolítani a Wine alkalmazást az Ubuntu 18.04 LTS-ből?

Ha bármilyen okból el akarja távolítani a Wine rendszert a rendszeréből, sCsak a következő parancsokat kell futtatnia.

Távolítsa el a stabil verziót:

sudo apt purge winehq-stable

sudo apt-get remove wine-stable

sudo apt-get autoremove

Távolítsa el a fejlesztői verziót:

sudo apt purge winehq-devel

sudo apt-get remove wine-devel

sudo apt-get autoremove

A cikk tartalma betartja a szerkesztői etika. A hiba bejelentéséhez kattintson a gombra itt.

40 hozzászólás, hagyd a tiedet

Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: Miguel Ángel Gatón
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   Jorge Ariel Utello dijo

    Az egyetlen olyan alkalmazás, amelyet a Windows-tól szeretnék, vagy támogatja a bort ...

  2.   Jézus dijo

    a második lépésben szintaktikai hibát kapok a váratlan "newline" elem közelében, hogyan tudom megoldani? Köszönöm

  3.   július dijo

    Pontosítás, a «sudo apt-add-repository parancs https://dl.winehq.org/wine-builds/ubuntu/»Nem használható 18.04-ben, mivel a címen nincs Bionic mappa, ezért a sudo« apt-add-repository 'deb parancs https://dl.winehq.org/wine-builds/ubuntu/ ravasz fő '»amely helyettesíti.
    Kipróbáltam az első parancsot, és ez egy állandó tárhelyhibát eredményezett, amelyet manuálisan kellett eltávolítanom a Szoftver és frissítések közül

    1.    Daniel Perez dijo

      Ugyanez történt velem, mint július, és ezt kaptam az Ubuntu 18.04-ben:

      daniel @ daniel-X45C: ~ $ sudo apt-get update

      Ign: 1 http://dl.google.com/linux/chrome/deb stabil InRelease
      Des: 2 http://dl.google.com/linux/chrome/deb stabil kioldás [1 189 B]
      Des: 3 http://dl.google.com/linux/chrome/deb stabil Release.gpg [819 B]
      Des: 4 http://security.ubuntu.com/ubuntu bionikus biztonsági InRelease [83.2 kB]
      Obj: 5 http://mx.archive.ubuntu.com/ubuntu bionikus InRelease
      Ign: 6 https://dl.winehq.org/wine-builds/ubuntu bionikus InRelease
      Des: 7 http://mx.archive.ubuntu.com/ubuntu bionikus frissítések InRelease [83.2 kB]
      Des: 8 https://dl.winehq.org/wine-builds/ubuntu ravasz InRelease [4 701 B]
      Des: 9 http://dl.google.com/linux/chrome/deb stabil / main amd64 csomagok [1 370 B]
      Err: 10 https://dl.winehq.org/wine-builds/ubuntu bionikus kibocsátás
      404 nem található [IP: 151.101.196.69 443]
      Err: 8 https://dl.winehq.org/wine-builds/ubuntu ravasz InRelease
      A következő aláírásokat nem sikerült ellenőrizni, mert nyilvános kulcsuk nem érhető el: NO_PUBKEY 818A435C5FCBF54A
      Obj: 11 http://mx.archive.ubuntu.com/ubuntu bionikus-backports InRelease
      Des: 12 http://security.ubuntu.com/ubuntu bionic-security / main amd64 DEP-11 metaadatok [204 B]
      Des: 13 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main i386 csomagok [58.8 kB]
      Des: 14 http://security.ubuntu.com/ubuntu bionikus biztonság / univerzum amd64 DEP-11 metaadatok [2 456 B]
      Des: 15 http://security.ubuntu.com/ubuntu bionikus biztonság / univerzum DEP-11 64 × 64 ikonok [29 B]
      Des: 16 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main amd64 csomagok [59.3 kB]
      Des: 17 http://mx.archive.ubuntu.com/ubuntu bionikus frissítések / fő fordítás-hu [21.6 kB]
      Des: 18 http://mx.archive.ubuntu.com/ubuntu bionic-updates / main amd64 DEP-11 metaadatok [9 092 B]
      Des: 19 http://mx.archive.ubuntu.com/ubuntu bionikus frissítések / fő DEP-11 64 × 64 ikonok [8 689 B]
      Des: 20 http://mx.archive.ubuntu.com/ubuntu bionic-updates / universe i386 csomagok [28.2 kB]
      Des: 21 http://mx.archive.ubuntu.com/ubuntu bionic-updates / universe amd64 csomagok [28.2 kB]
      Des: 22 http://mx.archive.ubuntu.com/ubuntu bionikus frissítések / univerzum amd64 DEP-11 metaadatok [5 716 B]
      Des: 23 http://mx.archive.ubuntu.com/ubuntu bionikus frissítések / univerzum DEP-11 64 × 64 ikonok [14.8 kB]
      Csomaglista olvasása ... Kész
      E: A "https://dl.winehq.org/wine-builds/ubuntu bionic Release" tárolóban nincs közzétételi fájl.
      N: Az ilyen tárolóból nem lehet frissíteni biztonságosan, ezért alapértelmezés szerint le van tiltva.
      N: Az adattárak létrehozásával és a felhasználók beállításával kapcsolatban lásd az apt-secure (8) kézikönyvet.
      W: GPG hiba: https://dl.winehq.org/wine-builds/ubuntu ügyes InRelease: A következő aláírásokat nem sikerült ellenőrizni, mert nyilvános kulcsuk nem érhető el: NO_PUBKEY 818A435C5FCBF54A
      E: A "https://dl.winehq.org/wine-builds/ubuntu artful InRelease" adattár nincs aláírva.
      N: Az ilyen tárolóból nem lehet frissíteni biztonságosan, ezért alapértelmezés szerint le van tiltva.
      N: Az adattárak létrehozásával és a felhasználók beállításával kapcsolatban lásd az apt-secure (8) kézikönyvet.
      daniel @ daniel-X45C: ~ $

  4.   eláraszt dijo

    Úgy érted, hogy a második adattár működik? Ugyanez történt velem is, kézzel kellett eltávolítanom az adattárat, mert ez nem engedte meg a frissítéseket, az egyetlen dolog, amit nem tehettem, az volt, hogy eltávolítottam a WineHQ csomagok szolgáltatóját a Szoftver és frissítések "Hitelesítés" részben. hogyan tudom eltávolítani?

  5.   Aioros dijo

    Köszönöm az adatokat, az igazság nagyon sokat segített nekem

  6.   David mansilla dijo

    Helló, követtem az összes lépést, és a Wine nem jelenik meg a telepített programok listájában, bár ha a $ wine –verziót teszem
    akkor igen úgy tűnik

    bor-3.13
    Tehát nem tudom mi a probléma, először a stabil verziót próbáltam ki, aztán ezt, és nem látom

  7.   pipo dijo

    nézd meg, hogy a kali linuxhoz kerestem segítséget, nem az ubuntuhoz>: v atte el pipo: v

  8.   Alfonso dijo

    Grace elvtárs @, de a nekem szükséges Windos programhoz a .NET Framework programot kéri

    van még egy ász az ujján, 😉

    Köszönöm.

  9.   guillermo velazquez vargas dijo

    Köszönöm a hozzájárulást, új vagyok a linuxban, kérem, segítsen, nézze meg, telepítse a bort, ahogy említi, és telepítve volt .. csak, mivel a terminálon keresztül történt, nem jött létre közvetlen hozzáférés, már megtaláltam a locate-tal de közvetlen hozzáférést akarok, segítsen nekem szívességgel

  10.   Diego dijo

    Nagyon köszönöm, nagyon sokat segített nekem. Üdvözlet Uruguay-ból

  11.   GIGY dijo

    HELLO: NAGYON KÖSZÖNÖM, AMI ÖSSZESEN SZOLGÁLT, KÖSZÖNÖM, HOGY NEKEM TELEPÍTETTEM.

  12.   Matias dijo

    Helló, jó megkérdezni, történt-e vele valaki, hogy amikor egy win2 szoftvert futtatunk, és fájlt akarunk húzni, akkor ez nem lehetséges, elmagyarázom: Már telepítve van a program, ez egy zenelejátszó (radioboss ) borral, a zenék vannak a lemezeken, és meg akarom találni, húzzam és dobjam a lejátszóra, és ez nem engedi. Ha valaki tudja a megoldást, köszönöm.

    És üdvözlet Mendozából, Argentínából.

  13.   Manuel Beltran dijo

    amikor egy Windows programot akarok borba telepíteni, a következő üzenetet kapom;

    végzetes hiba
    a telepítés idő előtt véget ért egy hiba miatt

    Van valami, amit rosszul tettem a bor telepítésekor, vagy mi lesz a hiba?

  14.   Hóvirágok322 dijo

    Ez segített nekem köszönetet mondani

  15.   Jose Vega dijo

    jó estét

    Megtettem az egész eljárást, de amikor megadod a kódot az eredmény telepítéséhez:

    * a következő csomagok hibás függőségekkel rendelkeznek:
    borhq-stabil: függ: borstabil (= 5.0.0 bionos)
    E: A problémákat nem sikerült kijavítani, a meghibásodott csomagokat megtartotta.

    1.    Diego dijo

      José, hogy megy ez? Nekem is ugyanaz a problémám volt. Sikerült kijavítani?

  16.   samfurtado dijo

    MIT ÉRTEM EL YEHHHHHHHH YOLO # XD 🙂 😉

    1.    JeniaPS dijo

      Hogyan csináltad végre?

  17.   Tamás dijo

    Az összes folyamat végrehajtása után az utolsó parancssor így szól:

    bor: nem található L »C: \\ windows \\ system32 \\ PROGRAM.exe»

    És a Wine nem jelenik meg telepítve. Melyik lehet?

  18.   Kenshyura dijo

    sudo dpkg –add-architektúra i386
    sudo apt frissítés
    sudo apt-add-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionikus fő '
    wget -nv https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key -O Release.key
    sudo apt-key add - <Release.key
    sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./ ”
    sudo apt-get update
    sudo apt install –install-javasolja a winehq-stabil programot

    fix a LUBUNTU 18.04 LTS-hez
    FORRÁS: https://askubuntu.com/questions/1205550/cant-install-wine-on-ubuntu-actually-lubuntu-18-04

  19.   paul dijo

    Csomaglista olvasása ... Kész
    Függőségfa létrehozása
    Az állapotinformációk olvasása ... Kész
    Nem telepíthet néhány csomagot. Ez azt jelentheti
    lehetetlen helyzetet kért, vagy ha a terjesztést használja
    instabil, hogy néhány szükséges csomagot még nem hoztak létre vagy vannak
    A "Bejövő" -ből vettek.
    A következő információk segíthetnek a helyzet megoldásában:

    A következő csomagok teljesítetlen függőségekkel rendelkeznek:
    borhq-stabil: függ: borstabil (= 5.0.0 ~ bionos)
    E: A problémákat nem sikerült kijavítani, a meghibásodott csomagokat megtartotta.
    miért kapom ezt?

    1.    daniel dijo

      Ugyanez történik velem is, sikerült megoldani?

    2.    Pablo dijo

      Pontosan ugyanez történt velem, hagyom neked a javítást

      Ha nem rendelkezik aptitude-val, telepítse a sudo apt-get aptitude, majd a sudo apt-get update programmal

      végül telepítsen bort:

      sudo aptitude telepítés winehq-stable

      majd futtassa ezt az útmutatót

      https://help.ubuntu.com/community/Wine - winecfg

  20.   női ing dijo

    Szia, van ubuntu társam 18.04 és nem tudom telepíteni a bort, ezt kapom:

    shimmy @ shimmy-Aspire-A315-33: ~ $ sudo apt-key add winehq.key
    OK
    shimmy @ shimmy-Aspire-A315-33: ~ $ sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionikus fő '
    Obj: 1 http://es.archive.ubuntu.com/ubuntu bionikus InRelease
    Obj: 2 http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu bionikus InRelease
    Obj: 3 http://es.archive.ubuntu.com/ubuntu bionikus frissítések InRelease
    Ign: 4 https://dl.winehq.org/wine-builds/ubuntu nagyszerű InRelease
    Obj: 5 https://brave-browser-apt-release.s3.brave.com bionikus InRelease
    Obj: 6 https://dl.winehq.org/wine-builds/ubuntu eoan InRelease
    Obj: 7 http://es.archive.ubuntu.com/ubuntu bionikus-backports InRelease
    Obj: 8 http://security.ubuntu.com/ubuntu bionikus biztonsági InRelease
    Obj: 9 https://dl.winehq.org/wine-builds/ubuntu bionikus InRelease
    Obj: 10 https://dl.winehq.org/wine-builds/ubuntu ravasz InRelease
    Obj: 11 http://ppa.launchpad.net/lah7/ubuntu-mate-colours/ubuntu bionikus InRelease
    Err: 12 https://dl.winehq.org/wine-builds/ubuntu nagyszerű kiadás
    404 nem található [IP: 151.101.134.217 443]
    Obj: 13 http://repository.spotify.com stabil InRelease
    Csomaglista olvasása ... Kész
    E: A "https://dl.winehq.org/wine-builds/ubuntu great Release" tárolóban nincs közzétételi fájl.
    N: Az ilyen tárolóból nem lehet frissíteni biztonságosan, ezért alapértelmezés szerint le van tiltva.
    N: Az adattárak létrehozásával és a felhasználók beállításával kapcsolatban lásd az apt-secure (8) kézikönyvet.

    Hogyan oldjam meg?
    Köszönöm!

    1.    muflus dijo

      Szia! megoldottad ??
      ugyanez történik velem is ...

  21.   CoffeeRobot dijo

    Milyen parancs szükséges a bor megnyitásához a terminálból? Korábban használtam, de már nem emlékszem rá, és nincs regisztrálva a terminálon. ha valaki ismeri a parancsot, tudna nekem segíteni?

  22.   megszűnik dijo

    yusmar @ yusmar-Intel-alapú osztálytárs-PC: ~ $ sudo apt-get install –install-javasolja a winehq-stabil
    Csomaglista olvasása ... Kész
    Függőségfa létrehozása
    Az állapotinformációk olvasása ... Kész
    Nem telepíthet néhány csomagot. Ez azt jelentheti
    lehetetlen helyzetet kért, vagy ha a terjesztést használja
    instabil, hogy néhány szükséges csomagot még nem hoztak létre vagy vannak
    A "Bejövő" -ből vettek.
    A következő információk segíthetnek a helyzet megoldásában:

    A következő csomagok teljesítetlen függőségekkel rendelkeznek:
    borhq-stabil: függ: borstabil (= 5.0.1 ~ bionos)
    E: A problémákat nem sikerült kijavítani, a meghibásodott csomagokat megtartotta.

    Hogyan tudom kijavítani?

    1.    Roberto dijo

      Helló, háromszor próbáltam, és mindig megemlítettem, E: Nem sikerült megoldani a problémákat, megtartottad a törött csomagokat. Telepítettem a Synaptic-ot, hogy el tudjam távolítani őket, de nem teszi megfelelően. Ha tudsz valamit a probléma leküzdésében, meg fogom értékelni.

  23.   JSTB dijo

    Gond van a Wine ubuntu szoftverből történő telepítésével? mentség a tudatlanságról, új vagyok a linuxban.

  24.   Salgado.hivatalos dijo

    Köszönöm <3
    2020-ban alkalmaztam a módszerét, és ez nekem tökéletesen bevált

  25.   Aranysárga dijo

    Mindent ugyanúgy tettem, és kihagytam a hibát, és ugyanazt folytattam, és sok mindent letöltenek nekem.
    Remélem, hogy egyáltalán nem rosszindulatú.

    1.    Lykos dijo

      Használja az lts verziót? Abban az esetben, ha a legyeket a 18.10-re telepítette, menjen a 18.04 lts-re, hosszú távú támogatással rendelkezik.
      A bor sok drámát adott nekem, amikor 18.10-kor voltam, 18.04-re mentem, és ez egy drágakő

  26.   Lucas Levaggi dijo

    de ezt a pillantást kapom az E-re: a dpkg végrehajtása megszakadt, a probléma kijavításához manuálisan kell végrehajtani a "sudo dpkg –configure -a" parancsot

  27.   JOSE dijo

    KÖSZÖNJÜK

  28.   szellemjátékos dijo

    Nagyon tetszett, telepítettem és emiatt fnaf-ot játszok, tesó, köszi

  29.   enzyipro dijo

    Ezt kapom A következő csomagok nem teljesített függőségekkel rendelkeznek:
    borhq-stabil: függ: borstabil (= 6.0.0 ~ bionic-1)
    E: A problémákat nem sikerült kijavítani, a meghibásodott csomagokat megtartotta.

  30.   Pablo dijo

    Helló, végre telepíthettem a Wine-t a Linux Ubuntu 18.04-re

    Azt tapasztaltam, hogy a hiba a bionic-tól stb. Függ, amikor megpróbáltam telepíteni, ezért az aptitude segítségével kellett telepítenem a paranccsal

    sudo aptitude telepítés winehq-stable

    és nekem bevált 😀

    majd kövesse az útmutató lépéseit

    https://help.ubuntu.com/community/Wine

    Amikor a terminálon futottam a winecfg-vel, megkönnyebbültem, hogy végre élvezhettem.

    Egyébként csak hozzá akartam járulni ehhez a tudáshoz, üdvözlethez

  31.   Juan Pablo dijo

    6.0 bort kapok, az app bárban pedig nem

  32.   RafaCG dijo

    Igaz, hogy a Wine nem tökéletes, de segít abban, hogy itt futtassam azokat a programokat, amelyekkel a Windows rendszeren dolgozom, a Linuxon.