Katoolin,在Ubuntu上安装所有Kali Linux工具

Katoolin

Katoolin主菜单

Katoolin已经 用Python开发 并且可以在Ubuntu或Linux Mint的Github上免费获得。 除了安装Kali linux工具外,Katoolin还允许安装其存储库,菜单以及Unity用户的经典菜单。

许多用户正在寻找安装Kali Linux工具的最佳方法,每个人都需要一种简单的方法,而不必安装发行版即可使用它们。 我认为,作为每天使用的操作系统,它有很多不足之处。 碰巧我碰到了 Katoolin.

许多人下载了Kali linux,甚至没有使用一半的工具,那么为什么不只安装我们需要的工具呢? Katoolin是一个安装脚本 Hecho Por 雄狮。 这按类别列出了工具,并允许我们以简单的方式选择要在系统中安装的工具。 不出所料,这将使我们避免不得不一一编译,因为这是一件很费力的工作。

什么是Kali Linux?

对于那些尚不了解的人,Kali Linux是基于Debian GNU / Linux的发行版,主要为 审计和总体计算机安全。 此发行版由Offensive Security Ltd.维护。该团队通过重写BackTrack开发了该发行版。 我们可以认为它是Kali Linux的前身。

Kali Linux的伟大资产是它带来了 预装了600多个程序 包含: NMAP (端口扫描程序),Wireshark(嗅探器),Ripper开膛手(密码破解程序)和Aircrack-ng套件(用于无线网络安全性测试的软件)等等。

Kali Linux可以通过Live CD,live-usb使用,也可以作为主要操作系统安装,尽管正如我已经说过的那样,这是非常不可取的。

安装Katoolin

要从我们的团队从GitHub安装Katoolin,我们只需要打开终端并向其中添加以下脚本:

sudo su
git clone https://github.com/LionSec/katoolin.git && cp katoolin/katoolin.py /usr/bin/katoolin
chmod +x /usr/bin/katoolin
sudo katoolin

安装完成后,我们将使用以下命令启动脚本:

sudo katoolin

启动该应用程序后,将显示5个选项的列表。 但是要在我们的Ubuntu上安装Kali Linux工具,我们将仅使用前两个。

  1. 添加Kali Linux存储库并更新存储库列表。
  2. 请参阅工具类别。
  3. 安装“ classicmenu指示器”。
  4. 安装Kali linux菜单。
  5. 它将向我们展示在脚本执行过程中可以使用的命令。

安装Kali Linux工具

为了安装Kali linux工具,您必须首先添加它们的存储库。 在进行存储库更新之前,建议先查看sources.list,以避免重复,否则会导致更新时出现问题。

Katoolin存储库中的选项

Katoolin存储库选项

当我们确认没有存储库重复时,我们将从选项“ 1”开始。 在此选项内,还有其他一些选项使我们可以将Kali Linux存储库添加到Sourcers.list中。 在下一个屏幕上,我们将再次选择选项1。

我们将通过选择选项2来更新系统的存储库,以继续安装,这仅用几句话即可完成“ sudo apt-get更新”。 我们将在控制台中看到如何更新存储库。

如果一切顺利,我们将写“ back”返回上一屏幕。 在其中,我们将选择选项“ 2”以向我们显示可用工具的类别。

在这里,我们可以通过按“ 0”来安装所有类别中包含的所有工具。 或者,我们可以选择一个类别,然后选择我们要安装的工具。

Katoolin的类别

Katoolin的类别

在一个类别中,我们可以按“ 0”来安装所选类别中包含的所有工具。 我们还可以写出我们想要安装的工具的编号。

操作完成后,我们只需要退出脚本即可。 现在我们可以看到我们已经有了 Ubuntu中的Kali Linux工具.


19条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   楚斯·马德

    我回到17.04进行安装,但是起初我遇到了一些问题。 后来我有了更多的东西,我回到了16.04 LTS(我认为这会更可靠),这是什么意思,首先发生的是搜索引擎,图标以及启动器中的图标消失了。 然后他一直说“对不起,Ubuntu遇到了内部错误”,然后出现内部错误。 系统完全崩溃了,很长一段时间后,我不得不离开它成为不可能。 Linux是一个不稳定的操作系统,您始终必须在浏览器中始终寻找具有更新的解决方案。 有很多发行版,许多版本,当某些东西起作用时,他们将其删除并放置了不起作用的东西。 这是一场灾难。 您一直在为系统工作,而不是像原来那样工作。 我们将看看我是否能够保持稳定。 或重新安装它。

    1.    丹尼尔萨利纳斯

      我了解所有操作系统均已更新

      1.    巧克力

        面向已实现linux内核的最终用户的系统通常非常稳定可靠,但是正是用户通过做一些他们在互联网上阅读的愚蠢事情而使其变得不稳定(如güinbug$)

    2.    宫崎骏

      也许是安装错误,或者您移动了本不应该拥有的东西,图标或搜索引擎并没有消失。 我在Ubuntu上使用了将近3年,它从未给我带来严重的错误,出现的小错误是任何其他操作系统所提供的,只有在Windows等其他操作系统中,有时它们甚至没有警告您:另一方面,我认为如果您想使用Linux,是的,您应该花一些时间来学习如何使用Linux,但是我认为这样做很值得。

    3.    罗德里戈·埃雷迪亚(Rodrigo Heredia)

      我从12.04开始更新,今天有16.04,并且没有稳定性问题,并且对处理器进行了超频。

    4.    约西努

      您不喜欢它或它运行不正常的事实并不意味着它是一个糟糕的操作系统,并且说到lts是最大的问题,我拥有xubuntu 16.04,因为它出来了并且计算机直接飞向了我而且我从没有遇到过“唯一”问题,而且我知道一个Linux用户从2012年开始在他的PC上安装了xubuntu,他的Linux版本也为14.04,而且从2012年以来从来没有说过,他没有一个单一的问题,我想您宁可不知道,您也弄糟了。

  2.   犬风

    希望这些博客的作者将不再放置使最终用户相信发行版是完全不同的操作系统的标题。

    可以在任何Liñux发行版上安装任何Liñux工具。

    如果您知道自己在做什么,甚至可以在Fedora中安装apt和pacman并在不造成任何麻烦的情况下使用它,或者在Slackware或OpenSuSE中将“ Deepin”用于“ AppStore”。

    但是最后,除非手动编译失败,否则手动编译总是比预编译的更好。

    因为我什至可以共享一个在Slackware 0.74中编译的DOSBox 11.0,它可以在任何发行版中工作,所以只要它具有图形环境,即使它是极简主义,它也可以处于“实时”模式。

    1.    达米安·阿莫多(Damian Amoedo)

      如果有人认为发行版是完全不同的操作系统,那么他们就不会阅读本文的其余部分。 第一个重大错误。

      显然,任何用户都可以耐心在任何Linux发行版上安装工具(在某些情况下,他们可能会叛逆)。 但是请不要忘记“并非每个人都是天生的。” 并非所有用户都具有执行此操作的知识,因此具有此类预编译应用程序的脚本可以让更多的非专业人士测试他们可以利用的某些应用程序。 如果他们喜欢他们,他们将永远有时间学习。 取得一切都是时间问题,尽管并非所有人都有。 在形成意见之前先阅读全文,这是一个很好的起点。

      我必须承认,如果有什么我同意你的观点。 实际上,手动编译应用程序是安装的最佳解决方案,但这已经是每个人的口味了。

      问候。

  3.   elphist0n

    早上好,我有一个问题。
    为什么不建议使用Kali作为主要操作系统?

    1.    达米安·阿莫多(Damian Amoedo)

      我说的是不明智的,因为就我的口味而言,并且在计算机上将其用作主要操作系统后,它似乎有点不稳定。 但这是个人的欣赏,请尝试并得出自己的结论。 你好。

  4.   附件

    问题是存储库,添加存储库会将操作系统更新为Kali并产生冲突,只是不添加存储库即可正常运行,我只是在Ubuntu 17.04中对其进行了测试

    1.    灵光

      简便:一旦不再使用Kali工具,通过在nano /etc/apt/sources.list中的相应行上注释来停用存储库,这样,在进行apt-get更新时系统不会发生冲突。

      问候。

  5.   富丽堂皇的

    当执行第二次安装命令时,我得到以下信息:bash:意外元素';&'附近的语法错误

    1.    达米安·阿莫多(Damien Amoedo)

      你好。 尝试输入: git clone https://github.com/LionSec/katoolin.git && cp katoolin/katoolin.py /usr/bin/katoolin

  6.   米格尔

    A>如果您没有安装git,则缺少apt install git。

  7.   奥斯卡

    你好,

    添加和更新存储库后,我尝试安装工具,这给了我很多错误:

    正在阅读包装清单...完成
    创建依赖树
    正在读取状态信息...完成
    gqrx软件包不可用,但是其他一些软件包参考
    到了。 这可能意味着包装件丢失,陈旧或仅
    可从其他来源获得
    但是,以下软件包将其替换:
    gqrx-sdr:i386 gqrx-sdr

    E:找不到acccheck软件包
    E:找不到自动程序包
    E:找不到dnmap软件包
    E:找不到幻影诱饵程序包
    E:找不到麦芽糖包装
    E:找不到miranda程序包
    E:找不到sslcaudit程序包
    E:找不到wol-e软件包
    E:找不到hexorbase软件包
    E:无法找到powerfuzzer软件包
    E:找不到幻影诱饵程序包
    E:找不到giskismet软件包
    E:“ gqrx”软件包没有候选安装
    E:找不到wifitap程序包
    E:找不到blindelephant程序包
    E:找不到起火包
    E:找不到fimap软件包
    E:无法找到采集卡包
    E:找不到麦芽糖包装
    E:无法找到powerfuzzer软件包
    E:找不到proxystrike程序包
    E:找不到ua-tester软件包
    E:找不到vega软件包
    E:无法找到http-tunnel数据包
    E:找不到相交数据包
    E:无法找到u3-pwn软件包
    E:无法找到magictree软件包
    E:找不到麦芽糖包装
    E:找不到iphone-backup-analyzer软件包
    E:找不到pdgmail软件包
    E:找不到acccheck软件包
    E:找不到crddump程序包
    E:找不到findmyhash软件包
    E:找不到hexorbase软件包
    E:找不到keimpx软件包
    E:找不到麦芽糖包装
    E:找不到jad软件包

    关于如何继续的任何提示? 我曾尝试更新软件包,清理,重新生成source.list ...,但均未成功。

    谢谢。

  8.   匿名的

    它存储在哪里?

  9.   梅西亚斯·托雷斯

    欧盟 ESTOU 3 天离开 TestE DO KALI LINUX ALL 和 ESTALAÇÃO 的几个版本 NO SYSTEM NÃO ACHA 一个 VERÇÃO,它有一个 OPÇÃO DE STALL 现场直播系统,所以它不会等待,那是你很强壮此处用于测试 E SE GOSTARMOS FAZER ESTALÇAO DIRETO DO SISTEMA NA MACHINA、DEVE TER UMA FACILITAÇÃO DE ESTALAÇÃO DO SISTEMA 的 ESTALAR 或 KALI LINUX 系统

  10.   John

    这让我非常有用