Github anuncia el IDE de Atom

Atom IDE

Atom IDE

En colaboración con Facebook el equipo de GitHub, se complacen en anunciar el lanzamiento de Atom-IDE el cual es un conjunto de paquetes opcionales para llevar la funcionalidad de tipo IDE a Atom.

Todas estas totalmente opcionales como lo pueden ser autocompletar el contexto, diagnósticos, formateo de documentos, además de una serie de características de navegación de código así como otras funciones útiles.

Este entorno de desarrollado integrado es potencialmente establece un curso completamente nuevo para lo que ya es un editor de texto popular y extensible. Esta versión inicial incluye paquetes para TypeScript, Flow, JavaScript, Java, C # y PHP.

TypeScript y JavaScript (ide-typescript)

El paquete ide-typescript aprovecha el servidor Microsoft TypeScript envuelto en un protocolo de servidor de idiomas. Si bien está dirigido a TypeScript también funciona muy bien con JavaScript que le proporciona el autocompletado, esquemas de documentos, diagnósticos y errores, etc.

Flujo (ide-flowtype)

Nuestros buenos amigos en Facebook han publicado ide-flowtype para llevar el poder del sistema de anotación de tipo Flow a Atom.

C # (ide-csharp)

Aprovechando el paquete node-omnisharp podemos incorporar muchas características similares a IDE en Atom for C # a través de ide-csharp .

Java (ide-java)

Para esto será necesario tener instalado el runtime de Java 8 instalado para poder disfrutar de mucho más.

PHP (ide-php)

El ide-php utiliza un servidor de lenguaje PHP de FelixFBecker para proporcionar soporte para el lenguaje de scripting PHP.  Es necesario tener el runtime de PHP 7 instalado.

Muchas de las funciones habilitadas en el IDE de Atom son servidas desde el  Protocolo de servidor de idioma (LSP). Esto es un mecanismo a través del cual el IDE puede utilizar un “servidor fuera de proceso” para proporcionar un rico análisis, refactorización y características interactivas para un lenguaje de programación dado.

Atom

Atom

¿Cómo usar el IDE de Atom?

Para ello se recomienda usar Atom Beta 1.21 ya que incluye la supervisión de archivos y el control de procesos necesarios para garantizar que los servidores de idioma subyacentes se estén ejecutando correctamente.

Tendremos que instalar dos paquetes:

  1. la interfaz de usuario de Atom IDE.
  2. un paquete que admita el idioma que desea utilizar.

Esto aparecer el cuadro de diálogo de paquetes de instalación de Atom en Vista de configuración: instalar paquetes y temas.
Buscaremos e instalaremos el paquete atom-ide-ui para introducir la interfaz de usuario IDE. Aquí será donde instalaremos el soporte de idioma IDE que necesita (por ejemplo, ide-typescript).


Categorías

Software

David Yeshael

Soy Estudiante de Ingeniería en Computación en la Universidad Autónoma Metropolitana (México), me considero aun un usuario medio en Linux , tengo... Ver perfil ›

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *