UBPorts lanza la OTA-4 para los Ubuntu Phone y con ello la llegada de Xenial Xerus

El líder del proyecto de UBPorts, Marius Gripsgård, ha anunciado el pasado 26 de agosto la liberación de la OTA-4, la última gran actualización de Ubuntu Phone y Ubuntu Touch que representa un avance de versión respecto a la base del sistema operativo.

La OTA-4 es una versión nueva que se basará en Xenial Xerus en lugar de Vivid Vervet, la versión que era la base de Ubuntu Touch hasta el momento. Esto supone que la nueva versión corre de forma más rápida y fluida en los mismos dispositivos y además más dispositivos compatibles con esta nueva versión.

La OTA-4 representa un punto de inflexión respecto a anteriores versiones ya que por un lado introduce todo el software de Xenial, por otro lado corrige bugs y limpia el sistema de scopes que ya no son mantenidos y que representan un problema de seguridad para el sistema operativo.

Pero lo más llamativo de la nueva OTA-4 es la llegada de paquetes deb al sistema operativo. Por el momento es algo experimental, pero el equipo de UBPorts ha introducido un sistema de contenedores que en un futuro no muy lejano permitirá instalar cualquier paquete deb.

Lamentablemente el sistema de actualizaciones no es compatible con esta OTA-4, es decir, que si tenemos la OTA-3 o anteriores, hemos de utilizar el UBPorts Installer para instalar la OTA-4. Una vez que lo ejecutemos, entonces hemos de seleccionar el canal “16.04/stable” para la instalación de la nueva OTA-4. Este proceso no es tan sencillo pues antes de eso tendremos que realizar una copia de seguridad de nuestros datos ya que el proceso borrará por completo el dispositivo.

La OTA-4 es un gran avance dentro del proyecto, algo que está teniendo sus frutos con la llegada de nuevos dispositivos con esta versión de Ubuntu Phone. Esperemos que además haga que el ritmo de actualizaciones sea más rápido de lo actual.


Categorías

Ubuntu, Ubuntu Phone

Historiador e informático. Mi actual meta es conciliar estos dos mundos desde el momento en el que vivo. Ah y estoy enamorado del mundo GNU/Linux. Abierto a cualquier pregunta. Preguntar no es ofender.

2 comentarios

  1.   Elcondonrotodegnu dijo

    Gracias por el articulo, pero he encontrado dos errores:

    “Lamentablemente el sistema de actualizaciones no es compatible con esta OTA-4, es decir, que si tenemos la OTA-3 o anteriores, hemos de utilizar el UBPorts Installer para instalar la OTA-4”

    O esperar a la OTA-5, se pasara de OTA-3 a OTA-5.

    “Este proceso no es tan sencillo pues antes de eso tendremos que realizar una copia de seguridad de nuestros datos ya que el proceso borrará por completo el dispositivo.”

    Creo que si no marcas la opción “wipe” no te borra nada, de todas formas la copia de seguridad es recomendable siempre.

  2.   Joaquín García dijo

    Hola Elcondonrotodegnu, lo primero gracias por comentar. Sobre las correcciones que haces, las agradezco mucho y tienes razón pero no estoy de acuerdo con ellas. Primero por que creo que es muy arriesgado esperar para pasar de la OTA-3 a la OTA-5, dejas demasiados bugs por el camino sin olvidar rendimiento. Y sobre el tema del wipe, si que lo conozco pero no he tenido gratas experiencias con ello en Android, el sistema se ralentizaba mucho. Prefiero hacer copia de seguridad como dices e instalar de nuevo ( con las versiones de Ubuntu también lo hago). Aún así gracias por comentar, seguro que a algún usuario les son de ayuda.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.